[1.7.10] TolkienCraft II - Adventure Awaits! - v2.9.5[QUESTS][ADVENTURE][NORMAL MODE]

Discussion in 'Public Packs' started by GreatOrator, Aug 24, 2014.

  1. Wiremash

    Wiremash New Member

    But vals, I thought it was possible to store entities inside spatial storage cells? :p I stored my buddy in it by accident once. "Why is my screen suddenly all black?"



    Here are my testings on my singleplayer test world
     
    Last edited: Jan 21, 2015
  2. Wiremash

    Wiremash New Member

    B4 is the latest version, stick with it. Lowering the render distance usually does the most significant fps drop, try lowering it to 4?

    (doublepost....doublepost... how do I merge quotes after pressing "Post reply"?)
     
    Vals NoisyToys and GreatOrator like this.
  3. cbruh

    cbruh New Member

    Okay thanks , I'm gonna try it out now /: hopefully it works
     
    Vals NoisyToys and GreatOrator like this.
  4. Wiremash

    Wiremash New Member

    I have a faster way of moving entities



    (The last bit might startle val) :p
     
  5. cbruh

    cbruh New Member

    @Wiremash thanks everything seems to be working I change all my settings to fast and lower it to 4
     
    Vals NoisyToys and GreatOrator like this.
  6. Wiremash

    Wiremash New Member

    No problem :D If you'd like, you can slowly increase your settings till it lags again, then lower it back.
     
    Vals NoisyToys, GreatOrator and cbruh like this.
  7. cbruh

    cbruh New Member

    Yea I tried tht but my fps are kinda bad highest i gotten was a 25 nd they drop every now and then also it lags when I press E so idk if I'm gonna b able to really play this mod pack Im gonna mess around with it and see what I can do
     
    Vals NoisyToys and GreatOrator like this.
  8. Wiremash

    Wiremash New Member

    Yeah I'm having lag when opening inventory/interacting with stuff too, not sure what causes it but you can read the previous few pages
     
    Vals NoisyToys and GreatOrator like this.
  9. Orma

    Orma New Member

    I get that lag when i open inventory/menu's etc aswell. But it usually flows fine after i restart MC.

    And if you want, kill the FTB launcher after you started MC. The launcher does bad things and eats atleast 3 times as much memory as any other launcher not to mention it eats a ton of CPU when you launched MC.
     
  10. Arikast

    Arikast New Member

    If you continue to have problems I have had pretty good luck with B1. B4 was giving me quite a few issues so I played around with different versions till I found one that worked pretty well. I've had the disappearing blocks happen to me once while I was recording but it hasn't popped up again since then.
     
    Vals NoisyToys and GreatOrator like this.
  11. unseennote

    unseennote New Member

    I can't even play, darn world won't even load completely before it decides to kick me off the local world, so it looks like I can't play til' I get my new PC...
     
    Vals NoisyToys and GreatOrator like this.
  12. Wiremash

    Wiremash New Member

    I'll try that, but I'm not sure about the memory thing. My framerate is low, I get lag spikes but my memory usage stays at 20% for some reason, it's like its not using the memory
     
    Vals NoisyToys and GreatOrator like this.
  13. GreatOrator

    GreatOrator New Member

    That is an optifine issue unfortunately and the result typically of the version of optifine not matching the version of forge (2.3.14 moved to 1286)
    The pack does not have randommobs installed, so that is either referring to the optifine function (which, sorry, will not troubleshoot issues with optifine), or extra mods I didn't put in so can't/won't troubleshoot either.
    Java is great at using memory, the more you give it, the more it will use. :)
     
  14. Vals NoisyToys

    Vals NoisyToys New Member

    It is possible, yes. Which is why I warned the players to evacuate the pylon enclosure. :p
    As for villagers: possibly for vanilla, however the Minecraft Comes Alive ones just vanished that were in the village at the time of storage. I assume this is due to the mod not knowing about AE and visa versa (although your video shows it working fine with them - maybe it's a server thing).

    I didn't leave the villagers there in the first place because if the event had actually occurred the first day, I'd have only had time to grab the villagers before all heck broke loose. I didn't know there was a village there until the time of the first try at the event. However, since that first try at the summoning had issues, it gave me a chance to slave away off camera and make all the things used in "Project: Rescue!" before the event was unleashed on the server. :) So although this video shows it happening really close in time, this actually was done over the course of about a week.

    The idea for the village rescue itself came from my stream chat, although I think they weren't serious at the time. I took it and ran with it! :p
     
    eDilettante, GreatOrator and Wiremash like this.
  15. Vals NoisyToys

    Vals NoisyToys New Member

    Cool. I haven't done anything with Ars, though. :p

    You kidnapper! And you left Valentine behind! My cat! Augh!
     
  16. Wiremash

    Wiremash New Member

    I've returned you back to the city :p
    (And stole the cat)
     
  17. Vals NoisyToys

    Vals NoisyToys New Member

    Revenge will be had! Return my beloved Valentine! *gears up for war*
     
    Wiremash, eDilettante and GreatOrator like this.
  18. Ginko

    Ginko New Member

    I only ever play on weekends :3 but if the server is full i'm fine with that c:

    Also thought I'd post my specs here for reference. I'm using an asus gaming labtop.

    Intel Core i7-3610QM @ 2.3GHZ
    Nvidia GeForce GTX 670M (3GB)
    8GB Ram
    64 bit install of windows 7

    FTB Config
    [​IMG]

    I'm using FastCraft, and these java arguments both in environment variables and in the FTB Launcher
    -Dforge.forceNoStencil=true -XX:+UseLargePages -XX:+AggressiveOpts -XX:+UseFastAccessorMethods -XX:+OptimizeStringConcat -XX:+UseBiasedLocking -Xincgc -XX:MaxGCPauseMillis=10 -XX:SoftRefLRUPolicyMSPerMB=10000 -XX:+CMSParallelRemarkEnabled -XX:parallelGCThreads=10 -Djava.net.preferIPv4Stack=true"

    in game settings
    [​IMG]

    I run the game, singleplayer pretty well on these settings.

    I average ~160 fps

    Proof
    [​IMG]

    With little to no perceptible lag when I interact with things. Although, the maps do lag me for half a second.

    I also changed my viewdist to 8 and maxed my settings. There was a ~10fps (average) drop but that's it.

    more proof
    [​IMG]

    Hopefully this helps people. Tbh, I think a lot of the problem may be in not running a 64bit system. Something about wordsize. I also recall 32 bit systems having a 4 gig max on usable memory (even if you have 4+ gigs of ram the OS and CPU can't handle it), although i'm not sure about this.
     
  19. unseennote

    unseennote New Member

    It would be referring to Optifine, but I did turn the function off, so I'm unsure as to why it's making any change... Which version do you use?

    Turned off RandomMobs, stopped making RandomMobs messages., but still get the same results when trying to load the game.

    [00:10:42] [Netty Client IO #0/ERROR] [FML/]: HandshakeMessageHandler exception
    java.lang.RuntimeException: Timeout waiting for client thread to catch up!
    at cpw.mods.fml.client.FMLClientHandler.waitForPlayClient(FMLClientHandler.java:850) ~[FMLClientHandler.class:?]
    at cpw.mods.fml.common.FMLCommonHandler.waitForPlayClient(FMLCommonHandler.java:585) ~[FMLCommonHandler.class:?]
    at cpw.mods.fml.common.network.handshake.NetworkDispatcher.clientListenForServerHandshake(NetworkDispatcher.java:154) ~[NetworkDispatcher.class:?]
    at cpw.mods.fml.common.network.handshake.FMLHandshakeClientState$1.accept(FMLHandshakeClientState.java:33) ~[FMLHandshakeClientState$1.class:?]
    at cpw.mods.fml.common.network.handshake.FMLHandshakeClientState$1.accept(FMLHandshakeClientState.java:27) ~[FMLHandshakeClientState$1.class:?]
    at cpw.mods.fml.common.network.handshake.HandshakeMessageHandler.userEventTriggered(HandshakeMessageHandler.java:40) ~[HandshakeMessageHandler.class:?]
    at io.netty.channel.DefaultChannelHandlerContext.invokeUserEventTriggered(DefaultChannelHandlerContext.java:308) [DefaultChannelHandlerContext.class:?]
    at io.netty.channel.DefaultChannelHandlerContext.fireUserEventTriggered(DefaultChannelHandlerContext.java:294) [DefaultChannelHandlerContext.class:?]
    at io.netty.channel.ChannelInboundHandlerAdapter.userEventTriggered(ChannelInboundHandlerAdapter.java:108) [ChannelInboundHandlerAdapter.class:?]
    at io.netty.channel.DefaultChannelHandlerContext.invokeUserEventTriggered(DefaultChannelHandlerContext.java:308) [DefaultChannelHandlerContext.class:?]
    at io.netty.channel.DefaultChannelHandlerContext.fireUserEventTriggered(DefaultChannelHandlerContext.java:294) [DefaultChannelHandlerContext.class:?]
    at io.netty.channel.ChannelInboundHandlerAdapter.userEventTriggered(ChannelInboundHandlerAdapter.java:108) [ChannelInboundHandlerAdapter.class:?]
    at io.netty.channel.DefaultChannelHandlerContext.invokeUserEventTriggered(DefaultChannelHandlerContext.java:308) [DefaultChannelHandlerContext.class:?]
    at io.netty.channel.DefaultChannelHandlerContext.fireUserEventTriggered(DefaultChannelHandlerContext.java:294) [DefaultChannelHandlerContext.class:?]
    at io.netty.channel.DefaultChannelPipeline.fireUserEventTriggered(DefaultChannelPipeline.java:779) [DefaultChannelPipeline.class:?]
    at cpw.mods.fml.common.network.handshake.NetworkDispatcher.handlerAdded(NetworkDispatcher.java:132) [NetworkDispatcher.class:?]
    at io.netty.channel.DefaultChannelPipeline.callHandlerAdded0(DefaultChannelPipeline.java:484) [DefaultChannelPipeline.class:?]
    at io.netty.channel.DefaultChannelPipeline.callHandlerAdded(DefaultChannelPipeline.java:479) [DefaultChannelPipeline.class:?]
    at io.netty.channel.DefaultChannelPipeline.addBefore0(DefaultChannelPipeline.java:178) [DefaultChannelPipeline.class:?]
    at io.netty.channel.DefaultChannelPipeline.addBefore(DefaultChannelPipeline.java:163) [DefaultChannelPipeline.class:?]
    at io.netty.channel.DefaultChannelPipeline.addBefore(DefaultChannelPipeline.java:153) [DefaultChannelPipeline.class:?]
    at cpw.mods.fml.common.network.handshake.NetworkDispatcher.insertIntoChannel(NetworkDispatcher.java:119) [NetworkDispatcher.class:?]
    at cpw.mods.fml.common.network.handshake.NetworkDispatcher.clientToServerHandshake(NetworkDispatcher.java:124) [NetworkDispatcher.class:?]
    at cpw.mods.fml.common.network.internal.FMLNetworkHandler.fmlClientHandshake(FMLNetworkHandler.java:66) [FMLNetworkHandler.class:?]
    at net.minecraft.client.network.NetHandlerLoginClient.func_147390_a(NetHandlerLoginClient.java:107) [biz.class:?]
    at net.minecraft.network.login.server.S02PacketLoginSuccess.func_148833_a(SourceFile:39) [js.class:?]
    at net.minecraft.network.login.server.S02PacketLoginSuccess.func_148833_a(SourceFile:11) [js.class:?]
    at net.minecraft.network.NetworkManager.channelRead0(NetworkManager.java:113) [ej.class:?]
    at net.minecraft.network.NetworkManager.channelRead0(NetworkManager.java:317) [ej.class:?]
    at io.netty.channel.SimpleChannelInboundHandler.channelRead(SimpleChannelInboundHandler.java:98) [SimpleChannelInboundHandler.class:?]
    at io.netty.channel.DefaultChannelHandlerContext.invokeChannelRead(DefaultChannelHandlerContext.java:337) [DefaultChannelHandlerContext.class:?]
    at io.netty.channel.DefaultChannelHandlerContext.fireChannelRead(DefaultChannelHandlerContext.java:323) [DefaultChannelHandlerContext.class:?]
    at io.netty.channel.DefaultChannelPipeline.fireChannelRead(DefaultChannelPipeline.java:785) [DefaultChannelPipeline.class:?]
    at io.netty.channel.local.LocalChannel.finishPeerRead(LocalChannel.java:313) [LocalChannel.class:?]
    at io.netty.channel.local.LocalChannel.access$400(LocalChannel.java:43) [LocalChannel.class:?]
    at io.netty.channel.local.LocalChannel$6.run(LocalChannel.java:299) [LocalChannel$6.class:?]
    at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:354) [SingleThreadEventExecutor.class:?]
    at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:348) [NioEventLoop.class:?]
    at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:101) [SingleThreadEventExecutor$2.class:?]
    at java.lang.Thread.run(Unknown Source) [?:1.7.0_25]
    [00:10:51] [Server thread/DEBUG] [PerfectSpawnCore/]: Transforming noppes.npcs.NoppesUtilPlayer
     
    eDilettante likes this.
  20. GreatOrator

    GreatOrator New Member

    I am using B4 for optifine. Now there will be a delay normally when world first loads because of the way journeymap starts. On a brand new world I have had this take up to 5 minutes and yes, I have reported this to the dev.
     
    Vals NoisyToys and eDilettante like this.

Share This Page