[1.7.10] TolkienCraft II - Adventure Awaits! - v2.9.5[QUESTS][ADVENTURE][NORMAL MODE]

Discussion in 'Public Packs' started by GreatOrator, Aug 24, 2014.

  1. Teraphina

    Teraphina New Member

    omg wiremash i want your kitty
     
    Vals NoisyToys and GreatOrator like this.
  2. Wiremash

    Wiremash New Member

    These are my specs before adding the JVM arguments, I didn't have them earlier
    [​IMG]

    After adding the JVM arguments in the FTB advanced options area

    [​IMG]

    Picture was from pretty much the same location, my framerate for some reason doesn't seem to go significantly above 30 (Highest I've had was 33 fps) The framerate is set to unlimited. After adding the JVM arguments, nothing really changed in terms of framerate, interacting with anything (Including pressing esc) still causes a lag spike. However the memory usage has went down. I don't think this is really related to modpack but I hope anyone experienced with this can help. The buddy who plays with me on my server experiences 120+ framerates on a lower-end computer with similar settings, except he has higher render distance, which mine is currently set at 4. I'm not quite sure what causes this, thanks for any help in advance.

    I'm not very experienced with java so I feel that it's just "not using" the memory I've allocated to it, despite it lagging. My framerate is usually lower when I go outside of my underground section about 17 fps I have no idea why it's not using the memory either. I have a NVIDIA GTX 850M graphics card if that matters.
     
    Vals NoisyToys and GreatOrator like this.
  3. Ginko

    Ginko New Member

    I meant this modpack :3
     
    Vals NoisyToys and GreatOrator like this.
  4. GreatOrator

    GreatOrator New Member

    The day you find the answer to why they get those framerates is the day I dance for joy...been trying to figure out that myself...lol

    As for another server with TolkienCraft II, yes I have seen some, try looking through the server advertisements here at FTB.
     
    Vals NoisyToys likes this.
  5. Wiremash

    Wiremash New Member

    Ohhh xD I didn't even think of that

    My server's more of a mini server, not a dedicated one (It's on when I want to play or my buddy wants to play)
     
    GreatOrator and Vals NoisyToys like this.
  6. Ginko

    Ginko New Member

    Be my buddy ;w;!
     
    GreatOrator and Vals NoisyToys like this.
  7. Putzaroo

    Putzaroo New Member


    Stop using the ftb launcher and switch to multimc and see what you get then.
     
    GreatOrator and Vals NoisyToys like this.
  8. unseennote

    unseennote New Member

    Okay, so I tried to start a new world, it get's to 80% loaded, and then the game kicks me out of it, so I can't play at all.
    [22:18:16] [Server thread/INFO]: unseennote left the game
    [22:18:17] [Server thread/INFO]: Stopping singleplayer server as player logged out
    I did add Fastcraft and Optifine.
    I see a lot of stuff about RandomMobs, also a lot of "The overworld is not loaded!". I tried to load it a second time, and it got to the same point, but instead of sending me back to the main menu, it just crashed.

    I have 3GB of RAM allocated to FTB, unsure as to why it keeps booting me off before the world has loaded.
     
    Last edited: Jan 21, 2015
    GreatOrator likes this.
  9. Ginko

    Ginko New Member

    You could also try adding them to the Windows Environment Variables directly. Go to Control Panel, System and Security, System, Advanced System Settings, Environment Variables,

    Make a new variable

    call it JAVA_OPTS,
    and paste this mythical string into the other field, "-Dforge.forceNoStencil=true -XX:+UseLargePages -XX:+AggressiveOpts -XX:+UseFastAccessorMethods -XX:+OptimizeStringConcat -XX:+UseBiasedLocking -Xincgc -XX:MaxGCPauseMillis=10 -XX:SoftRefLRUPolicyMSPerMB=10000 -XX:+CMSParallelRemarkEnabled -XX:parallelGCThreads=10 -Djava.net.preferIPv4Stack=true" I assume this is the one u use c:

    Worked for me, may work for you c:
     
    GreatOrator likes this.
  10. Wiremash

    Wiremash New Member

    Doesn't seem to make any difference, does it matter that I'm using a laptop? Because a lower-speced desktop computer magically has 120 fps o.e
     
    GreatOrator and Vals NoisyToys like this.
  11. Wiremash

    Wiremash New Member

    But I don't know if I can keep the server on all the time D:

    (Anyone knows how to merge quotes in edit mode? I keep accidentally double posting)
     
    GreatOrator and Vals NoisyToys like this.
  12. unseennote

    unseennote New Member

    They've infused their computers with dark magic, or made a deal with the devil or something...
     
  13. cbruh

    cbruh New Member

    so the world finally loaded but most blocks arent visible anyone else has that problem ? :/ please help 2015-01-20_23.39.15.png 2015-01-20_23.39.15.png
     
    GreatOrator likes this.
  14. cbruh

    cbruh New Member

    also im only gettin like 10 fps its horrible
     
    GreatOrator likes this.
  15. unseennote

    unseennote New Member

    I can't even get the world to load, even turned off RandomMobs, no change.
     
    GreatOrator likes this.
  16. Vals NoisyToys

    Vals NoisyToys New Member

    A village is in danger! Valentine and her friends leap to the rescue on the official Tolkiencraft II server.

     
  17. Wiremash

    Wiremash New Member

    You're getting 2fps, the minimap shows fps for some reason.
    Looks like your computer is lagging quite badly. Try launching with 4GB of ram, reduce render distance to 4. Add optifine and fastcraft and lower the graphics quality (by changing everything to fast etc.)
     
    Vals NoisyToys and GreatOrator like this.
  18. cbruh

    cbruh New Member

    Fastcraft and optifine are already on
    Nd I do have 4gbs of ram, in gonna try the rendering and lowering graphics , however what about the invisible blocks ?
     
    Vals NoisyToys and GreatOrator like this.
  19. Wiremash

    Wiremash New Member

    That's a half-loaded chunk, it seems due to the world not loading properly (likely due to lag)

    I have these little tiny things I do not sure if it significantly improves framerate but you can try minimising all background apps, close those unused ones.
     
    Vals NoisyToys, GreatOrator and cbruh like this.
  20. cbruh

    cbruh New Member

    Is there anything I can do about that ?
    I have optifine B4 on it should I change it for A4 or w.e it's called ? Also Im gonna try lowering my rendering, I haven't had this kind of problem with any other mod /:
     
    Vals NoisyToys and GreatOrator like this.

Share This Page