A Rotarycraft Thread (Meanders a little)

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here
  • FTB will be shutting down this forum by the end of July. To participate in our community discussions, please join our Discord! https://ftb.team/discord

Reika

RotaryCraft Dev
FTB Mod Dev
Sep 3, 2013
5,079
5,331
550
Toronto, Canada
sites.google.com
@Reika, agree with everything you've said except this:
Accidental silliness? You cannot pick and choose which physics we must assume you've handled. There's a million common-sense items you will have to omit from your excellent mod, and we cannot magically infer the list of ones you implemented. Nothin' but love other than that :)
This is true, but I do not see what point you are trying to make.


Hey Reika, loving rotarycraft especially how messy an exploding gas turbine is :)

I have a question and thought I'd ask it here rather than start a new dialogue, is it possible to pipe jetfuel into gas turbines?

I've tried with fuel lines, TE ducts and Ender IO conduit and nothing wants to put the jet fuel in, buckets is the only way I've got to work so far.
The fuel must be piped in the bottom, or through an ECU (which also must be below the engine).
Fluiducts work, Fluid export buses work, my pipes work, BC pipes work. I do not use EnderIO so I cannot comment on them.
 
  • Like
Reactions: Ako_the_Builder

Yusunoha

New Member
Jul 29, 2019
6,440
-4
0
Hey Reika, loving rotarycraft especially how messy an exploding gas turbine is :)

I have a question and thought I'd ask it here rather than start a new dialogue, is it possible to pipe jetfuel into gas turbines?

I've tried with fuel lines, TE ducts and Ender IO conduit and nothing wants to put the jet fuel in, buckets is the only way I've got to work so far.
The fuel must be piped in the bottom, or through an ECU (which also must be below the engine).
Fluiducts work, Fluid export buses work, my pipes work, BC pipes work. I do not use EnderIO so I cannot comment on them.

bit late to the party, but yes, you need to fill the turbines from the bottom. I also had a bit of trouble figuring this out when doing this build I did
http://forum.feed-the-beast.com/threads/rotary-extractor-going-to-slow-for-you.39538/
 
  • Like
Reactions: Ako_the_Builder

Yusunoha

New Member
Jul 29, 2019
6,440
-4
0

uTLlvvJ.gif
 
  • Like
Reactions: ThatOneSlowking

Eyamaz

New Member
Jul 29, 2019
2,373
0
0
I hope people like going from 20 FPS to 200 for complex setups. :D
It is no longer laggy to accumulate lots of my TEs in one place. This may also mean solar plants are no longer FPS killers. :)

Oh? That's awesome.
 

Ako_the_Builder

New Member
Jul 29, 2019
789
0
0
The fuel must be piped in the bottom, or through an ECU (which also must be below the engine).
Fluiducts work, Fluid export buses work, my pipes work, BC pipes work. I do not use EnderIO so I cannot comment on them.

Through the ecu is sweet, had no Idea I could put stuff through that :) Love the videos you've added to the thread, good showcase of what is possible :)
 
  • Like
Reactions: jokermatt999

Yusunoha

New Member
Jul 29, 2019
6,440
-4
0
I just put out v15. Among its many changes are MASSIVE performance boosts for Rotary/ReactorCraft and Taint/Instability-Fighting Rainbow trees for Dye Trees.
https://sites.google.com/site/reikasminecraft/home
I hope people like going from 20 FPS to 200 for complex setups. :D
It is no longer laggy to accumulate lots of my TEs in one place. This may also mean solar plants are no longer FPS killers. :)

wV4umnO.gif


I just keep taking my sunglasses off, I can't seem to stop...
 

Pyure

Not Totally Useless
Aug 14, 2013
8,334
7,191
383
Waterloo, Ontario
I hope people like going from 20 FPS to 200 for complex setups.
I watched a vid last night of someone assembling one of your reactors. My main takeaway with the giant spinning turbines and the scores of steam blocks jostling around was that it couldn't be wonderful for fps. Is that one of the setups improved by latest changes? (Alternately I could be wrong and it might not've impacted fps at all)

At work or I'd provide more specifics about video.
 

Morberis

New Member
Jul 29, 2019
77
0
0
Ha, this seems to be a general rotarycraft thread now so I have a question for anyone. I'd heard reports of AC engines being a bit glitchy, is that still true? The reason I'm asking is that I built a 2 clock as specified on the minecraft wiki and my AC Engine worked fine for a minute, actually probably a half hour. And then suddenly it stopped making noise so I hooked it up to a dynameter and found that instead of putting out the 131kw like it was before it was alternating between 2.5kw and 25kw. Same clock signal, and from what I saw the tesla rating of my rotor core hadn't gone down yet and was still sitting at 171microteslas.

For those interested I built a subtraction N clock.

Edit: And suddenly it starts working again. I have no words. All I did was put in a dynameter and watch it and after another 10 minutes or so it started working.
 
Last edited:

Reika

RotaryCraft Dev
FTB Mod Dev
Sep 3, 2013
5,079
5,331
550
Toronto, Canada
sites.google.com
Ha, this seems to be a general rotarycraft thread now so I have a question for anyone. I'd heard reports of AC engines being a bit glitchy, is that still true? The reason I'm asking is that I built a 2 clock as specified on the minecraft wiki and my AC Engine worked fine for a minute, actually probably a half hour. And then suddenly it stopped making noise so I hooked it up to a dynameter and found that instead of putting out the 131kw like it was before it was alternating between 2.5kw and 25kw. Same clock signal, and from what I saw the tesla rating of my rotor core hadn't gone down yet and was still sitting at 171microteslas.

For those interested I built a subtraction N clock.

Edit: And suddenly it starts working again. I have no words. All I did was put in a dynameter and watch it and after another 10 minutes or so it started working.
99% of "bugged" complaints come from poor redstone design. I have no issues with them.

Also, v15 has a bug where clientside code is not running properly, and thus things appear to malfunction (though in fact work properly). I will make v15b tonight to fix this.
 

Morberis

New Member
Jul 29, 2019
77
0
0
It is possible that my clock is incorrect, but here is how I have it setup. I'm using the 14b version included with the latest monster pack.
5hvz.jpg

qy4t.jpg


For anyone looking to use AC engines you should also use flywheels, because at least with this setup the power is a little bumpy. As you can see I do not have flywheels so I get some sparking at the junction, but if I put a dynameter in place of the beveled gear I do get the appropriate 260kw.

And yeah it's a little messy and needs to be cleaned up
 

Reika

RotaryCraft Dev
FTB Mod Dev
Sep 3, 2013
5,079
5,331
550
Toronto, Canada
sites.google.com
It is possible that my clock is incorrect, but here is how I have it setup. I'm using the 14b version included with the latest monster pack.


For anyone looking to use AC engines you should also use flywheels, because at least with this setup the power is a little bumpy. As you can see I do not have flywheels so I get some sparking at the junction, but if I put a dynameter in place of the beveled gear I do get the appropriate 260kw.

And yeah it's a little messy and needs to be cleaned up

Your problem is the repeater. Repeaters elongate and delay pulses.
 
  • Like
Reactions: gallowglass

Physicist

New Member
Jul 29, 2019
351
0
0
99% of "bugged" complaints come from poor redstone design.
I dunno:
And suddenly it starts working again. I have no words.
Sounds to me like someone might have had an extra magnetized shaft in inventory, then walked away and came back without it.[DOUBLEPOST=1390947140][/DOUBLEPOST]
Your problem is the repeater. Repeaters elongate and delay pulses.
Looking at his clock, it's roughly identical to mine, unless going through that block adds a tick. You need that repeater to turn that clock (1tick on/1tick off) into a 2-clock.