1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

A Rotarycraft Thread (Meanders a little)

Discussion in 'General FTB chat' started by Physicist, Jan 25, 2014.

  1. Physicist

    Physicist New Member

    Edit: So having played a few more hours of Monster and focusing on Rotarycraft, I'm seeing that it's got some issues. I really like the unique gameplay it offers, but I am an equal opportunity bug finder.

    I had a bucket of Rotarycraft Lubricant and right-clicked to put the lube in a Buildcraft tank.

    The 1000mb of lube appeared in the tank correctly, but the bucket disappeared as though I had used a glass bottle or wax capsule.
     
    Last edited: Jan 26, 2014
  2. Physicist

    Physicist New Member

    New issue: The surface of a Mystcraft writing desk looks like the side of a Minefactory Reloaded auto-spawner.
     
  3. Yusunoha

    Yusunoha New Member

    known bug for quite a while now. problem is with Mystcraft, so you'll have to wait for xcomp to fix this
     
  4. SaintLucifer

    SaintLucifer New Member

    Is interesting how Mystcraft textures works fine on DW but not on Monster tho.
     
  5. Mevansuto

    Mevansuto New Member

    It's the Random Things mod. It's because it changes the crafting table. If DW20 added Random Things it'd look like that.
     
  6. lumien

    lumien New Member

    Yey i "intended" to fix this, since Mystcraft wanted to change their writing desk to a 3d model anyway though i didn't bother since its just a visual bug.
     
  7. Mevansuto

    Mevansuto New Member

    No love for visuals? :'(

    Does this affect any other mods?
     
  8. lumien

    lumien New Member

    It only affects mods that directly use the texture of the Crafting Table.
    And i like visuals (Even though i'm not really good at making nice things). I actually fixed this already but then accidentally put it back in :p Whoops.
    I don't know of any other mod that gets broken by this.
     
  9. Mevansuto

    Mevansuto New Member

    Thanks.
     
  10. Physicist

    Physicist New Member

    A new problem: Using the IC2 drill does not behave just like a pick on several of Reika's blocks, probably more: Pumice (takes longer to break than with a stone pick), Reservoir (completely destroys the reservoir, rather than dropping with contents).
     
  11. Physicist

    Physicist New Member

    And now a problem with the AC electric engine: It doesn't always run, and sometimes provides a small amount of power without any redstone or magnetized shaft (yes, I know how to redstone it properly).
     
  12. Physicist

    Physicist New Member

    And an Aqueous Accumulator pushing water directly into Rotarycraft Liquid Pipes caused a flood of NPE errors to spill directly into my in-game chat.
     
  13. Physicist

    Physicist New Member

    And placing an Empty reservoir next to a 64-bucket Creosote reservoir appears to have worked correctly, but caused a message to the effect of "A mod tried to access invalid inventory slot 6 of reservoir".

    Splitting the two apart and using buckets to empty the last drop of Creosote from a reservoir caused my client to disconnect from the LAN game my wife was hosting (forge log: http://pastebin.com/wdyTitWB).
     
  14. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    What kind of clock do you have?

    Are you holding a magnetized shaft nearby?

    This is because a drill is not a pick, and the IC2 api changes every 30 minutes.

    Not a bug.
     
    ThatOneSlowking likes this.
  15. Physicist

    Physicist New Member

    It's a comparator clock: subtraction mode with a repeater (to add a tick) pushing directly into it's side.
    Wait, holding a magnetized shaft in your inventory screws with the engine? If so, could I ask for a notation about that in the RotaryCraft handbook? I saw others with similar issues commenting on a wiki somewhere while I searched for this information. It worked fine when I tested to understand the engine, but then when I went to do testing on the speed of magnetization and demagnetization of multiple shafts with varying magnetization torques and speeds, things stopped working when I creative-pick-block-cloned a stack of partially magnetized shafts from what I had charged so far.

    Incidentally, this is not clear regarding the magnetization and demagnetization, and it's what I was experimenting to discover when I ran into troubles: Energy cost to magnetize is [greaterthan? equalto?] energy output of the resultant AC engine?
    Between 1.5 and 1.6 FTB, I spent a long time playing GT and IC2 without other industrial mods, so I feel really awkward and cringe every time I have to use a pick on a machine that doesn't have a proper tool. Is there a wrench from another mod that works on your blocks?
    To be clear: Any pick, but no other tools or magic drops the reservoir block and preserves contents, right? Or... are you saying the portable-tank-like behavior is unintended?
     
  16. Physicist

    Physicist New Member

    Found something new: I had a Reservoir completely full of Ars Magicka 2 Liquid Essence. I had two buckets stacked together on my hotbar. I used the bucket(s) on the reservoir once, and suddenly I had two buckets stacked full of Liquid Essence. After separating them, I did indeed still have two buckets full of the liquid.

    However, upon looking at the reservoir, I observed that instead of being at the expected 62 buckets full, it had somehow depleted to 60 buckets.
     
  17. Mevansuto

    Mevansuto New Member

    Aren't there bug reporting threads already? And wouldn't it be easier for Reika if you reported the bugs to them directly?
     
    kaovalin and RedBoss like this.
  18. Physicist

    Physicist New Member

    At first I was more just asking if anyone else knew about buckets disappearing on using a RC fluid on a BC tank, then I meandered to Mystcraft, which is a known issue with specific packs, then I hit a slough of single-author things.

    I did actually link this thread to Reika on the Rotarycraft thread to bring it to his attention.

    I do suppose this thread belongs more in another subforum than General Chat, though.
     
  19. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    Comparator clocks are not fully off-on; they generate a 1-14 signal strength alternation. You need a 0-any.

    This (like the ideas of parallel multiplication, heat transfer, boiling point of water, and common sense) falls under "expected prerequisite knowledge". In this case, the fact that moving a magnetic field around a conductor generates a current.

    Check that you have both a good fast AC clock and magnetized cores.
    90% of the people who use the AC engine fail to grasp this, and either use clocks that are absurdly slow (eg ExtraUtils), not fully AC (eg comparator), do not magnetize the core, or fail to give AC to the magnetizer.

    No. The magnetizer requires much less than the AC engine emits.

    Pickaxes are the only tools that will work on my machines. IC2 Drills and TiC hammers have been excluded for realism reasons (especially the hammer). Pickaxes are included because they are the only method in vanilla to harvest iron-type blocks, and because I personally hate the IC2 mechanic of needing a wrench.
    I would allow the "shift-right-click" mechanic with the BC or TE wrenches, but the RC screwdriver is registered as the same, and as such I would have to special-case the code everywhere (which is messy) to avoid breaking its own shift-right-click mechanic.
     
    ThatOneSlowking likes this.
  20. Loufmier

    Loufmier New Member

    i don't really get the realism reason for excluding TiC hammer, but it works like a nice safety mechanism.
     

Share This Page