Thermal Expansion 3.0!!! No More Beta! Thanks KL!

Discussion in 'Mod Discussion' started by RedBoss, Oct 27, 2013.

  1. MigukNamja

    MigukNamja Forum Addict


    Are you going into the "gear" menu (right side, bottom tab) in the Pulverizer and changing the color of the sides ? If you want classic "top in, bottom out" behavior, click on the gear tab and do the following:

    1. For each of the five configurable faces, left-click until it is blank. This is simply to have a known starting point where no face has input or output
    2. Click on the top face (at the top) until it is blue.
    3. Exit the GUI and look at the Pulverizer. The top face should have a blue square on it.
    4. Go back into the GUI and click on the bottom face (bottom middle) until it is orange *and* both the primary and secondary (bonus) output slot in the main part of the Pulverizer GUI are also orange
    5. Exit the GUI and look at the Pulverizer. The bottom face should have an orange square on it.

    You now have a Pulverizer configured for classic "top in, bottom out" interaction. You should now be able to put/push/place items in the top and get/pull/receive items from the bottom face.

    Side note : In the gear GUI, the rear face of the Pulverizer is represented by the bottom-right face.
  2. Firnagzen

    Firnagzen Active Member

    Yes, I am.

    What I did was as such: Put down a turtle. Put down a pulverizer on top of it. Place chests around and on top of the pulverizer. In each chest, I placed a stack of items, cobble, stone, wood, etc.

    Using a script run on the turtle, I wrapped the pulverizer as a peripheral, and attempted to use the .pullItemIntoSlot method to pull items from each chest into each slot available.

    With all the faces of the pulverizer blanked out, no items were pulled into the pulverizer.

    With any one of the faces configured to blue, items could be pulled into the pulverizer from that side only, and could be pulled to every slot (including the capacitor slot) except the actual input slot of the pulverizer. This behaviour is repeatable with all the faces that can be configured to blue.

    In the case of an Induction Smelter, the only slot that can be accessed by the turtle is the second input slot, the one that is purple. This is regardless of face configuration.

    At this point, I facepalmed and gave up. There is clearly an issue here with the interaction of TE3 and OpenPeripheral; I just don't know which. I thought I'd ask here first.
  3. MigukNamja

    MigukNamja Forum Addict

    Has OpenPeripheral been updated for TE3 ?

    If not, has TE3 changed its input/output API from TE2 ?
  4. King Lemming

    King Lemming Thermal Expansion Dev FTB Mod Dev

    This is on OpenPeripherial's side, and it's kind of worrying tbh. If they were actually using ISided access, then everything would work fine. They are obviously directly hacking the blocks instead and have done so incorrectly here.

    I'll go have a chat with them, but I do not appreciate this sort of stuff.
  5. Golrith

    Golrith Over-Achiever

    Posting in this topic as a lot of intelligent people visit here :D

    I've got a similar problem to what was mentioned on page 48, liquids are not registered correctly. Liquids are all contained within Forge, so there are no IDs (as far as I understand). So some combination of mods in my pack are getting the liquids all muddled up. Is there any way I can track down the culprit?

    For me I'm finding that Conduits need Acid instead of Redstone, Impulse Ducts need Poison instead of Glowstone, and Acid Bottles (not sure which mod they are from) need Liquid Meat.
  6. Jadedcat

    Jadedcat Gamepack Creator Retired Staff

    In the direwolf 20 pack on the launcher is a mod called "sort fix" try adding that and see if it helps.
  7. Golrith

    Golrith Over-Achiever

    Thanks Jaded. Discovered that client only, all is fine. Log onto the server, recipe is mixed up. Considering that the server is a clone of my client installation, this has got me confused.
  8. Golrith

    Golrith Over-Achiever

    OK. Seems to be a server side display glitch only. Can craft conduits with liquid redstone just fine, just NEI tells me Acid is required.

    What does that sort fix do?
  9. MigukNamja

    MigukNamja Forum Addict

    @Golrith - Where did your world come from ?

    Does this issue occur with a brand-new world, created by the server ?
  10. VapourDrive

    VapourDrive Hammer Wielder Forum Moderator Mod Developer Trusted User

    I believe the issue (as actually discovered by KL) is that if the OS of the server is different from that running the client, the liquid registry doesn't happen in the same order between client and server, ensuring that all of the mod names start with a capital letter in both server and client. Linux and windows differ in sorting based on caps. (If anyone knows better, please correct me)
    jokermatt999 likes this.
  11. King Lemming

    King Lemming Thermal Expansion Dev FTB Mod Dev

    Just figured I'd drop a note here and let everyone know that b9 is out, along with b0 of Redstone Arsenal. Technically Redstone Arsenal is probably not a "beta" as such, but since the CoFH Library is still not finalized, we're calling it beta.

    Anyways, go forth and enjoy!
    un worry and PierceSG like this.
  12. PierceSG

    PierceSG Popular Member

    What does the redstone arsenal do?! Someone do a spotlight! :p
    I just noticed that the new ducts are not working with Mekanism's machines at all.
    Do I need to update Mekanism? I'm using build #640 now.

    Nevermind me, I've just noticed I need to install a servo to upgrade the ducts. :)
    Mind if I ask, if I didn't install the upgrades, would a redstone signal work?
    Last edited: Dec 14, 2013
  13. Golrith

    Golrith Over-Achiever

    Ah, that might be the case. I'll try updating the server mods.
  14. Firnagzen

    Firnagzen Active Member

    Thank you, and sorry for the trouble!
  15. Golrith

    Golrith Over-Achiever

    I've updated to latest version, converted all my ducts/conduits and started to replace them in the world, but I get a crash on Item Ducts (Opaque). Leadstone Conduits and Liquidducts are fine.

    12:21:14 [SEVERE] Encountered an unexpected exception NoSuchFieldError
    12:21:14 java.lang.NoSuchFieldError: itemsToAdd
    12:21:14 at thermalexpansion.part.conduit.item.ConduitItem.<init>(
    12:21:14 at thermalexpansion.part.conduit.ItemConduitPart.newPart(
    12:21:14 at
    12:21:14 at thermalexpansion.part.PartItemBase.func_77648_a(
    12:21:14 at net.minecraft.item.ItemStack.func_77943_a(
    12:21:14 at net.minecraft.item.ItemInWorldManager.func_73078_a(
    12:21:14 at
    12:21:14 at
    12:21:14 at
    12:21:14 at
    12:21:14 at
    12:21:14 at net.minecraft.server.dedicated.DedicatedServerListenThread.func_71747_b(SourceFile:30)
    12:21:14 at net.minecraft.server.MinecraftServer.func_71190_q(
    12:21:14 at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(
    12:21:14 at net.minecraft.server.MinecraftServer.func_71217_p(
    12:21:14 at
    12:21:14 at

    Separate note, ensuring all the mod names start with capitals on the server has solved the mixed up liquids.
    Last edited: Dec 14, 2013
  16. Skyqula

    Skyqula Well-Known Member

    Awesome update! Those redstone tools are much better then I expected. Even unbreaking works on them <3 And covers working? Totally awesome!
  17. Jadedcat

    Jadedcat Gamepack Creator Retired Staff

    This is exactly what the SortFix mod.. fixes. Install on both Server and Client to fix the sync issue. We will be shipping it with all packs as we update them.
  18. PierceSG

    PierceSG Popular Member

    Anyone knows how the tools/weapons works and what they do?
  19. Algester

    Algester Active Member

    they kill the mine the chop with redstone flux power... you need an energetic infuser to charge them not to mention shear sheep with wrenches
  20. Golrith

    Golrith Over-Achiever

    Unfortunately it didn't work for me. But renaming all the mod files on the server so they start with Capitals fixed things.

    Now just got to work out why the Item Ducts crash the server when placed, but Liquiducts and Conduits don't.
    Edit, after some testing. Client side everything is fine. On my server, crash on any Itemduct being placed.
    Last edited: Dec 14, 2013

Share This Page