On the 31st October 2019, the partnership between FTB and Twitch will be ending

Discussion in 'Feed the Beast News' started by Feed the Beast, Oct 8, 2019.

  1. JRSofty

    JRSofty New Member

    Your Legacy Launcher does not support Java 11 (I get a warning that I must install Java 6).

    What's the current status on the new launcher?

    Will the new launcher import the modpacks and games I've already started on Twitch, or will I need to move those manually?
     
  2. grandrolf

    grandrolf Popular Member Trusted User

  3. JRSofty

    JRSofty New Member

    Yes I'm quite aware of Minecraft and Minecraft Launcher's requirements for Java and it works just fine with my installation of Java. However!! My comment about the Java 6 error isn't Minecraft's Launcher throwing the error, but the legacy launcher of FTB. This means if I want to play an FTB modpack I still need to use Twitch, unless they have the new launcher beta ready. I do hope they continue with using the primary Minecraft launcher in the future. However, since it is now 11 November (12 days since end of contract with Twitch) and we've not heard anything new, I'm curious as to know the status.
     
  4. Matsiv

    Matsiv New Member

    I understand the change and that it's out of your hands. That said, there is a bit of an issue that is rather pertinent. The FTB launcher cannot sustain the amount of memory Twitch can. As such, I am a bit concerned about this change, as it will greatly inhibit my ability to enjoy the works you all put out. Why there is such a difference, I don't know, but when using the FTB launcher, it has a max of 998 MB, whereas the Twitch one is over two thousand. If this is fixed in future updates, that would be spectacular, but until then, I worry for the future of the launcher.
     
  5. grandrolf

    grandrolf Popular Member Trusted User

    Twitch comes bundled with java, the FTB launcher does not.

    FTB launcher uses the java that you have installed on your system - and if you can't allocate enough ram, make sure to install and use Java 8 64-bit.

    If you still have issues, head over to support and submit a ticket together with your log.

    (instructions on how to get full log can be found here: https://support.ftb.world/ )
     
  6. cyber01

    cyber01 New Member

    My question is, if the agreement with Twitch ended on October 31, then why are FTB assemblies still available in Curse (Twitch)? I think they should be available only through the FTB launcher and nowhere else
     
  7. GamerwithnoGame

    GamerwithnoGame Forum Addict

    I mean, that would MASSIVELY fuck a bunch of people over, so I'm extremely glad that isn't the case.
     
  8. Seviiro

    Seviiro New Member

    I am so glad for this change if I'm honest, I really disliked having to use the Twitch launcher with a passion.
     
  9. funtime_foxy455

    funtime_foxy455 New Member

    so
    so can you elaborate on the account thing? does this mean we can do our own accounts that arnt from the actual Minecraft account or can we use those? please elaborate.
     
  10. matheryn

    matheryn New Member

    so its now the 17th im curious as to when the new launcher will be out or atleast when the old launcher will be updated to allow 1.14 modpacks?
     
  11. Magzie

    Magzie Well-Known Member

    From Twitter:
    ProgWML6

    @Zachthegeek


    Version 1.5.0 of the
    @FTB_Team
    Launcher has been released with some bug fixes, repo changes, and support for 1.14.4 forge. big thanks to
    @modmuss50
    for his help improving support for some newer java versions on the launcher itself and chasing last minute bugs
    7:53 PM · Oct 31, 2019
     
  12. Smooz2015

    Smooz2015 New Member

    I downloaded the legacy launcher. Created a profile using my minecraft.net credentials, which does point to the paid account. When I attempt to launch, I get the invalid username or password. I have tried with both my username and both fail.

    What am I supposed to use?

    Lawrence
     
  13. Rick Carter

    Rick Carter New Member

    So, where do we get this new launcher? The link on the main page still downloads an older one without 1.14 support.
     
  14. Magzie

    Magzie Well-Known Member

    According to FTB Twitter the old launcher was updated to allow 1.14 packs. I believe the launcher should be 1.5.0 or so. If you are having problems still with the old launcher playing 1.14 pack you could check the version your launcher is at and ensure it updated.
     
  15. Rick Carter

    Rick Carter New Member

    Well, the version that downloads is the version I have installed, v1.5.0. It only supports up to 1.12.2 according to the filters section, and there are no 1.14 packs (such as unstable).
     
  16. loster31345

    loster31345 New Member

    Thank you!!!
    but does this mean that ftb is gonna make a new launcher now?
    I saw that the website is gonna get become new^^
     
  17. asb3pe

    asb3pe New Member

    So we're basically in the same boat we always were in...

    FTB Launcher can't run v1.14.4 modpacks, and neither can the MultiMC launcher run v1.14.4, so...

    The only place we can play v1.14.4 modpacks is on Twitch... except for whatever reason (who cares, not me), the Twitch launcher won't work at all for ANY modpack. It just hangs and I have to ALT-CTRL-DEL to shut the Twitch Minecraft Launcher down. Doesn't matter if I use the "native" launcher or the "JAR" launcher settings in Twitch, neither one works. I've deleted the Twitch app and re-installed it from scratch, no change.

    These days, I'm playing vanilla minecraft on Hypixel Skyblock, it's been at least as much fun as modded minecraft, without all the launcher BS and all the behind-the-scenes politicking by the various Modded Minecraft factions that are constantly in-fighting with one another.

    Oh the joy of Minecraft. Thanks Notch, hope you are enjoying your billions!!
     
  18. Hambeau

    Hambeau Over-Achiever

    Actually, the MOJANG launcher autoloads Java 1.0.8_51 (IIRC) unless it detects a local installation of Java, in which case it uses that.

    I noticed the FtB launcher is assuming a 32 bit version of Java is loaded, hence the memory limit (a 32-bit CPU only has a 4GB address space, windows chops that to 3GB)

    I loaded a 64 bit java version and fixed the issue.
     
    GamerwithnoGame likes this.
  19. Gamebuster

    Gamebuster Active Member

    This is great news! I've always hated having to wait 4 minutes for twitch to load the mods section in order to play a pack. Plus hopefully this will help bring back the forums, I've always liked seeing the forum threads for packs, so we can see if they're actually good or not.
     
  20. Rudi Hansen

    Rudi Hansen New Member

    So when is the launcher going to support minecraft 1.14.4 mods like FTB Unstable 1.14??
    I just downloaded the launcher, and there is still only the 1.12 mods supported.
    For now twitch still works but that might end anyday
     

Share This Page