1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Detected leaking worlds in memory.

Discussion in '[Archived] Tech Support' started by Yusunoha, Feb 19, 2013.

Thread Status:
Not open for further replies.
  1. Darkmega

    Darkmega New Member

    Next time it explodes in my face I'll drop it here. cause haven't had a game for a bit, just looking around for hints on whats going on, but that direwolf video back a bit with chickenbones talking about the caches and stuff seems legit.
     
  2. Booker The Geek

    Booker The Geek Well-Known Member

    Nice. Glad the stuttering went away

    um... Java is still outdated... :(

    Otherwise, lets see here.....

    oh. Is btg for me? :p I got to admit, I like.

    • Line #952 tells us:
    • But line # tells us:
      • 17:33:39 [SEVERE] [ForgeModLoader] The world 9a93359 (btg1) has leaked.
    That is... Odd.....

    Let me think about this for a bit?[DOUBLEPOST=1362460939][/DOUBLEPOST]
    If you MUST have those mods, you can always try fix #2 from the post in my signature.
     
  3. Darkmega

    Darkmega New Member

    [​IMG]

    I've got a jar of wiiiisps!

    *ahem* but serious now, that whole time it hasn't crashed yet. it's odd, cause you see, my game begins to lag when I start loading to many textures from NEI... cause sometimes I shift through the pages looking for things and I get random lag bursts, and then sometimes I go to check a recipe and it freezes for probably a second then comes up. If that lag had already been piling up, sometimes that lag becomes a crash if it's an item with many recipes that I can cycle through. but it doesn't happen consistently. Such as, i looked up recipes and uses for obsidian one time while just putting up with the gradual lag, it froze and blew up in my face. But when I got back in, I tried again, circled through the recipes, nothing happened.

    Ideas?

    I do notice in the console which is up in the background in debug mode that everytime I pause it saves the nether (which should be nonexistent for this flat world) and the world itself.
    theres also a whole derpload of treecapitator talking to itself asking the game if I'm using an axe to break some things occasionally, but otherwise it's still going...
     
  4. Darkmega

    Darkmega New Member

    well, sorry but first try, "pastebin is under heavy load" got me. So, gonna do this the old fashion way.

    theres a direct txt paste for you of what my console had (set to debug mod in the dropdown tabs). that should work well enough... right? and it was a permgen Space out of memory crash. it began right after I posted, ironically, doing exactly what I said it usually happened by... by scrolling/searching stuff in NEI for a bit. It lag bursted as I got back in, then like usual, lagged out till it blew up in my face and the internal server crashed... BUT... somehow I was still in the game. Just nothing would do anything. it was like one of those connection timed out moments where nothing moves. only you could actually break and place blocks but the sounds went all shit so I just ended it.

    When it was stable my task manager said it was a 1.3 gig, when it began it's lag out, it went to 1.4 and so on until it blew up at 1.6.... Even if I had 3 gigs assigned to it via the launcher... >_>

    edit:

    and another (crashderp 2). this time didn't feel as long as the other lasted, but i did look through centrifuge recipes for various combs while listening to my wisps twinkle, then I began making a cube of creepers and started getting lag and then the game blew up in my face again, this time going to the dirt screen with "saving chunks" error when I was gonna take a screenshot of the cube of creepers to send to a friend since he called the wisp jar cute (which they are, when they're not lasering you all the way back to your base cause you forgot your bow/offensive wand).

    this time I also had the non-ultra optifine (if it makes a difference) since I noticed the thread saying not to use ultra optifine and so I oblidged.
     

    Attached Files:

  5. ShireensPlay

    ShireensPlay New Member

    I get 70FPS with Optifine when I don't record and when I do I get 15 maybe... I use Quicktime Player but it never makes me lag. the latest videos I've record have been so laggy I can just about move.

    Any suggestions; I can't use Frap because I'm on a MacBook Pro and I can't afford ScreenFlow.
     
  6. Darkmega

    Darkmega New Member

    tasty... if I could have my game not crash I was actually feeling in the mood to record my own MC finally (tried it once, had gradual lag issues too but I couldn't be bothered trying to figure them out back then), but all this memory leaking and herpderping around is gradually killing the mood. >_>

    For macs I've got no clue.... unless Gameclaw works for macs? but I think you gotta buy that one...
     
  7. ShireensPlay

    ShireensPlay New Member

    I fixed my world Leaks (I think) and lag by following Bookers instructions and also deleting ChickenChunks. I hope it works for you and thank you for the suggestions.
     
  8. Darkmega

    Darkmega New Member

    I've tried it already before even bothering coming here since I managed to draw a line between world loading the chickenchunks just by looking at it but yeah, based on the time it took to lag out between versions ironically it actually caused more problems than it solved, cause it still lagged out just as fast (or even a little bit faster o.o) eventually after doing too many things.

    You're welcome.
     
  9. ShireensPlay

    ShireensPlay New Member

    Well, hopefully the modders will fix this soon because it's beyond ridiculous. They know the bug is there and yet they haven't posted anything about it; I know it takes a long time to create and edit bugs. But if they don't fix it FTB is gonna lose players and people like me who record won't want to anymore; I almost gave up last week.
     
  10. Darkmega

    Darkmega New Member

    It is a pain, since I'm scared to use my server cause it might lag out and kaboom when we're doing something "important" but can't do much about it but hope and just filter out things that could be doing it and try to replicate it best as you can so the people who can can actually look at the code and try to fix it once knowing where to begin... if it's other mods fault for the so called "Disloading worlds but something is forcing them to reload themselves" (or something about keeping stuff loaded when they're not meant to cause the worlds are meant to disappear and reappear) someone might want to get onto the mystcraft and twilight forest guys as a start if thats one of the roots...
     
  11. ShireensPlay

    ShireensPlay New Member

    Totally agree
     
  12. TsunamiMike

    TsunamiMike New Member


    Instructions I was referring to were the "new world in creative, play, don't go to Nether, etc." directions :). Took care of Java this morning at about 4am. Uninstalled all other versions, including 1.7.0_15, then downloaded 1.7.0_17 64 bit. Installed this morning, will try later this evening. I am reviewing your "other" directions to see what the next step is there :p.

    Thanks for the help, and let me know if you need me to run another test.
     
  13. Booker The Geek

    Booker The Geek Well-Known Member

    Ok, lets try some things out here...
    1. Open the FTB Launcher.
    2. Under the options tab, go to advanced, and type this into the Java parameters:
    • MAKE SURE IT IS EXACTLY AS WRITTEN! You will get errors if there are any extra spaces/letters/special chars.... Please double check.
    Less then 2GB of ram
    Code:
    -Xms256m -XX:PermSize=128M -XX:MaxPermSize=256m
    More then 2GB or ram
    Code:
    -Xms512m -XX:PermSize=128M -XX:MaxPermSize=512m
    • So what this does is:
      1. -Xms: set initial Java heap size.
      2. -Xmx: set maximum Java heap size. (Not in code, this is set by the slider.)
      3. -XX: PermSize: Size of the Permanent Generation.
      4. -XX:MaxPermSize: Maximum Size of the Permanent Generation.
    So... Try these, and re-post to pastebin if it don't work.

    Why you ask?
    So the idea I have come to is that with so many mods, Java is running out of memory.

    • "What? but i gave it two gigs of ram in the launcher"
    Well, Java actually uses Two different memory settings. The slider in the launcher only touches one of them. This will change the other way that Java uses memory.

    • "Why is that happening now oh wise man?"
    Basically, (Not pointing fingers), It is because most of the people who are creating these wonderful amazing mods we like to play with are sorta kinda new to java programing. (SOME of the people, KINDA SORTA new. :DI love you all ) These problems will go away as the people get better at programming. No, there is nothing right now that we can do to solve a lot of these issues. (You could always help out the mod programmers and the FTB launcher guys if you really want to by DONATING to them. This will allow them to have more incentive/free-time to become better at Java.)

    {edit} Realized that the numbers were exactly the same.... oops
    {edit} Changed Parameters.
    {edit} Added the warning at the top.
    {edit} Clarified some instructions
    {edit} Removed space from Java Parameters, Thanks Phil_Aus
    {edit} Need to add INSIDE of FTB, TYVM Furious1964
     
  14. Darkmega

    Darkmega New Member

    I haven't tried what you said yet, but this evening I played from 10:30 till 12:30 or so and nothing began lagging. I was playing a legit world on hardcore mode it just played as normal as usual... this thing is a real tease... but ok, I'll throw that stuff into where it's meant to go and see if anything happens when I go back to my lag prone flatlands in a short period of time.

    and btw:
    nah really, didn't notice. lol (sarcasm ftw, no offense meant)
     
  15. Booker The Geek

    Booker The Geek Well-Known Member

    LOL... :D:p
     
  16. TsunamiMike

    TsunamiMike New Member

    I will try the >2g option this evening or next. When I tried to use the perm size value (before correcting my Java version issue) it gave me an error. Now that I have fixed the Java version, perhaps I will have better results.

    I will keep you posted :)

    Ah yes, BTG was for you :p
     
  17. ShireensPlay

    ShireensPlay New Member

    Ok... Something weird just happened.

    I was in the Nether and an Embittered Bee killed me. I respawned in my base and FTB completely froze and crashed, I've been in and out of the nether multiple times but this is the first it has crashed.
     
  18. Booker The Geek

    Booker The Geek Well-Known Member

    crashlog?
     
  19. Daddy_Cecil

    Daddy_Cecil New Member

    Probably a stupid question, but whenever I put in the <2GB thingy into the Java parameters, the game won't start up. I am on a Mac running Lion... I really want to play FTB!
     
  20. Booker The Geek

    Booker The Geek Well-Known Member

    Try each one by itself and tell me which one is causing the crash please.
     
Thread Status:
Not open for further replies.

Share This Page