1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Detected leaking worlds in memory.

Discussion in '[Archived] Tech Support' started by Yusunoha, Feb 19, 2013.

Thread Status:
Not open for further replies.
  1. RetroGamer1224

    RetroGamer1224 New Member

    Okay I followed the advice Booker gave and I had little stutter or slowdown on my SSP world. I did have a world leak in a dimension though..which is funny because on my SSP i haven't even been to the nether so yeah. I had to re enable the mods to play with my friend on his server and I got the stutter and slowness. Then it just crashed. I am not upset thought as I got a few things done and can affirm that those three mods cause a majority of problems but something else can cause world leaks. From the console it is Thaumcraft unloading aura nodes
     
  2. othala

    othala New Member

    Any news about a real fix for these mods and memory leak ? :S
     
  3. Booker The Geek

    Booker The Geek Well-Known Member

    Another idea....

    If you can, jump into creative and place a chunk loader in each diminsion that is not unloading.... (I.E. the end, the nether, Twilight Forest, and any mystcraft ages that have been made...)
     
  4. othala

    othala New Member

    there is a way to jump to the end until I never discover it ? with ops privileges. Have you an idea ?
     
  5. TsunamiMike

    TsunamiMike New Member

    BTG,

    I will try to get this today. I am still on a business trip, so my ability to get to my PC and do this is somewhat limited.

    Thanks,
     
  6. ShireensPlay

    ShireensPlay New Member

    I followed what booker said and it has helped immensely... I can now record my FTB Let's Play and also my FPS has gone back up to 70; it went down to 18.

    Thank you Booker :D
     
  7. othala

    othala New Member

    Actually we have any ETA for a fix and an precise idea of the defectiv mod ?
     
  8. ShireensPlay

    ShireensPlay New Member

    Nope. I also removed ChickenChunks and TwilightForest
     
  9. Booker The Geek

    Booker The Geek Well-Known Member

    :)

    I just force updated my DW20 pack, and while I still get leaking worlds,i am not getting any lag. :D I so happy!
     
    Ashzification likes this.
  10. TsunamiMike

    TsunamiMike New Member

    http://pastebin.com/0istjMpd

    BTG,

    That is pastebin #1, before going to the nether. New world created had seed 'btg1'. No lag, no leaking worlds, but it is saving the nether, even though I haven't been there.
     
  11. Ashzification

    Ashzification New Member

    TsunamiMike, why are you using java 6 on windows?
     
  12. Booker The Geek

    Booker The Geek Well-Known Member

    Please read this post HERE
     
  13. TsunamiMike

    TsunamiMike New Member

    Ash,

    Not sure. I definitely updated to 1.7.0_15 when the problems began on the suggestion of someone else. It is possible that I may have both versions on the computer.

    Here is the additional part of the pastebin after going to the Nether, killing a bunch of stuff, and coming back. Note that while I don't have a leaking world, there are signs that something isn't keeping up:

    2013-03-04 17:16:14 [INFO] [STDOUT] Sending serverside check to: Tanuden

    2013-03-04 17:16:14 [WARNING] [Minecraft] Can't keep up! Did the system time change, or is the server overloaded?

    2013-03-04 17:16:14 [INFO] [Minecraft] Saving and pausing game...

    2013-03-04 17:16:14 [INFO] [Minecraft] Saving chunks for level 'btg1'/Overworld

    2013-03-04 17:16:15 [INFO] [STDOUT] Loading World: local/btg1

    2013-03-04 17:16:15 [INFO] [Minecraft] Saving chunks for level 'btg1'/Nether

    2013-03-04 17:16:34 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:16:41 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:16:44 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:16:46 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:16:49 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:17:41 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:17:44 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:17:45 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:17:48 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:17:48 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:17:49 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:17:50 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:17:52 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:18:07 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:18:32 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:18:33 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:18:37 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:18:39 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:19:18 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:19:20 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:20:19 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:20:25 [INFO] [STDOUT] Sending serverside check to: Tanuden

    2013-03-04 17:20:25 [WARNING] [Minecraft] Can't keep up! Did the system time change, or is the server overloaded?

    2013-03-04 17:20:25 [INFO] [Minecraft] Saving and pausing game...

    2013-03-04 17:20:25 [INFO] [Minecraft] Saving chunks for level 'btg1'/Overworld

    2013-03-04 17:20:25 [INFO] [STDOUT] Loading World: local/btg1

    2013-03-04 17:20:25 [INFO] [Minecraft] Saving chunks for level 'btg1'/Nether

    2013-03-04 17:20:44 [INFO] [STDOUT] Fetching addPacket for removed entity

    2013-03-04 17:23:43 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:23:46 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:24:14 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:24:16 [INFO] [STDOUT] Processing Shard

    2013-03-04 17:26:20 [INFO] [Minecraft] Saving and pausing game...

    2013-03-04 17:26:20 [INFO] [Minecraft] Saving chunks for level 'btg1'/Overworld

    2013-03-04 17:26:20 [INFO] [Minecraft] Saving chunks for level 'btg1'/Nether
     
  14. Skythe

    Skythe New Member

    I also have this issue. its highly annoying. The simple semi-fix that worked was removing Wireless redstone and Any chicken chunks i had in my world. My minecrafts still gets memory leaks but i can play for much longer before it crashes.
     
  15. Booker The Geek

    Booker The Geek Well-Known Member

    Glad that it worked for you :)

    PLEASE post your entire logs (both the console and crash-report) to pastebin, as it makes it much easier to help you.
     
    Ashzification likes this.
  16. TsunamiMike

    TsunamiMike New Member

    http://pastebin.com/kW2MS20r

    Ok BTG, there is the final, complete log of the entire test you requested. While this last log shows a leaking world, my performance the entire time was pretty good. No stuttering for sure.

    I followed your instructions to the letter except that I didn't have to disable Mystcraft as it isn't installed in Mindcrack. Test world for the second part of the test is btg2.

    Hope that helps :)
     
  17. Skythe

    Skythe New Member

    Sadly theres no real crashlog that any of us can give since none of the mods have proper console log support to type out the issue yet.
     
  18. Booker The Geek

    Booker The Geek Well-Known Member

    I believe the latest version of Java is 1.7.0_17....
    You can get it HERE
    Also, Follow the first three step on the linked page in my sig.
     
  19. Darkmega

    Darkmega New Member

    well, new here on the forums (but not to mods glitching out and FTB/technic in general) but in previous versions if this has been persisting for ages on end I've never had a problem, but a few days ago it started up just like everyone else. I turn on for 10 minutes at best and get lag. Then gradually more lag, until about 10 minutes more and I'm down to freeze frames and then it either crashes with a permgen error of some kind or a general out of memory crash.

    and you know what the moment was when it all started? When I tried to use buildcraft engines to extract stuff from barrels to and from a cargo manager connected to a wood farming cart I had going in my flatlands test world. Even the 5 turtle strong mob grinder I had already built using a nooby startup melee loop didn't cause terrible lag until of course the 10 or so brain jars ate all the EXP and the turtles got loaded full of loot and began leaving crap all over the place which is predictable.

    Ever since said barrel lag out I've been getting the lag crashes. I've tried updating forge to the latest, optifine ultra 5, removing chickenchunks, updating chickenchunks and other possible world loading mods and still nothing. Sometimes I might get a fair game of half an hour before it starts acting up again but thats about it. All the time it's memory overloads or permgen space or something glitch.

    Before that test that began my hunt for mod updates and attempted fixes I was I was able to have games of 3-4 hours long on my server with a buddy using my same pack ("my same pack" since it's mindcrack but with a few other additions I can't go without) ... Hell even the server crashed itself at one point when I tried to use barrels to store surplus materials so lets just say it's being a real douchenozzel and it seems to cause major problems when theres a certain mix of stuff going on. What that mix is though, I'm stumped.
     
  20. Booker The Geek

    Booker The Geek Well-Known Member

    Could you post your console log and/or crash log to pastebin? I'll take a crack at helping you out.
     
Thread Status:
Not open for further replies.

Share This Page