1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Detected leaking worlds in memory.

Discussion in '[Archived] Tech Support' started by Yusunoha, Feb 19, 2013.

Thread Status:
Not open for further replies.
  1. Ashzification

    Ashzification New Member

    Ok, so, remove thaumcraft and problem solved for you.
    Otherwise, if you wish to continue this discussion, please post a new thread describing your issue, and provide your complete client-side console log on pastebin.com
     
  2. othala

    othala New Member

    Removing Thaumcraft is not a solution, I can remove all mods and play to vanilla ... my issue ? It's the same of all FTB players : memory leak
     
    RedBoss likes this.
  3. Ashzification

    Ashzification New Member

    If you wish to continue this discussion about your exact problem and ways to work around it, open your own thread and I will help you there.
     
    Booker The Geek likes this.
  4. othala

    othala New Member

    This thread is the main thread for this major issue so I use it as I want :)
     
  5. Ashzification

    Ashzification New Member

    Since you do not wish to open your own thread to receive personalized help regarding this issue, then please don't complain that the problem is not solved.
     
  6. othala

    othala New Member

    I don't need any personalized help about this isssue because it's a general / major modpack issue.

    The problem is clearly not solved and as I'm still have right to speak here.
     
  7. Ashzification

    Ashzification New Member

    I cannot agree with this, because not everyone is effected by the world leaking issues.
    I've only experienced it once, on one world. When I reinstalled my launcher, changed my perm gen space and chunk loaded as Booker suggested, I never had another problem on that world. I have not had this problem on any other world since.
     
  8. S0L0SAM

    S0L0SAM New Member

    I was having this problem. I installed mcpc plus jar and havent had it since. I was getting it on every server boot and ive rebooted twice since with no problems.

    Maybe coincidence, dont know.
     
  9. ShireensPlay

    ShireensPlay New Member

    Mods that cause world leaks (I had problems with these):
    • Mystcraft (I don't use it)
    • Twilight Forest
    • Wirless Redstone
     
  10. Ashzification

    Ashzification New Member

    Can I also make a knowledgebase article about this?
     
    Booker The Geek likes this.
  11. Whist34

    Whist34 New Member

    I am using FTB DW20 5.2.0 and I followed your instructions for version 1 to get rid of leaking memory.

    It is rather odd. During testing I got the same error you did.

    -- My testing history --
    I should have checked the forums first, but decided to debug myself. I eventually found that CBE's version of wireless redstone was not gracefully unloading the Redstone Ether and was keeping it loaded in memory even after the world had been closed. I discovered this while trying to find a good world for my server. After 30 worlds my forge log was reporting around 34 worlds leaking and java was taking up 5g of system memory (normally 2g on my system). I also noticed that I could not delete worlds that I had just created and wanted to get rid of. The log reports showed that the redstone ether dimension was still in use. This issue ceased when I removed the CBE wireless redstone mods (granted, it may have been another mod interaction, but I could not find any other installed mod that uses the redstone ether).

    After disabling CBE-wirelessredstone I found that the redstone ether was no longer persisting (obviously) and I could now delete old worlds, however, a memory leak still existed for consecutively created worlds. It is an odd issue and many people probably do not even notice that it exists, because unless you are looking for it and creating multiple worlds then you won't find it (these are not myst dimensions). The first world has no memory leak, but follow-up worlds report the last world as leaking memory. (I seem to remember reading that this may just be a forge reporting thing and not really be a memory leak, something to do with the way worlds are unloaded, but I'm too tired to go digging around for that thread again.)

    So then I further tested without CBE-wirelessredstone and found that if I deleted a world (W01) that had just been created then created a new world (W02) with a new name then Thaumcraft reported errors of not finding aurra node data in the world (W01) that was just deleted. Obviously the files no longer existed, but why was Thaumcraft trying to access them in the first place? I created a new world, why would Thaumcraft need to look to the old one for aura nodes?

    I then disabled Thaumcraft. Still... leaking consecutive worlds but at least nothing was reported actively trying to access them. Finally I added ChickenChunks to my disable list. Now I have disabled ChickenChunks, mystcraft, PortalGun, Thaumcraft, ThaumicBees, TwilightForest, and all three CBE-wirelessredstone. I have now made 4 consecutive worlds with no leak reports.
    -- End history --


    I would like to know if you finished thinking about the problem you mentioned =) If so, would you please let me know what you discovered?

    I have not tried your second fix. I will, eventually; I love all of these mods and intend to use them on my server (memory leak in consecutive worlds should not be a problem). I will, however, investigate an alternative to CBE-Wirelessredstone. The original wirelessredstone mod has a version available for 1.4.7 (which is the Minecraft version we are all using on FTB at the moment).


    Thank you

    (P.S. No logs are posted because I am not trying to have something debugged... yet. Just requesting follow-up info for something BTG posted.)
     
  12. Elysium

    Elysium New Member

    This is not a client issue, it is a host issue (I.E. any computer/serverbox that hosts a world) will experience this issue. You will NOT experience this issue in your client log when you launch the game, or join someone elses world. Only when you create a server or maybe even single player. You can change all the launch parameters you want, it is NOT going to make leaking worlds dissapear. Again, this has NOTHING to do with the client.
     
  13. Booker The Geek

    Booker The Geek Well-Known Member

    YES!... I don't mind if you do. :D
    (I helped out a knowledge base articall.... Hell yeah!)

    I believe, (As in I think but am not sure) That server and client now both run when playing single player. I remember reading something about it when mods were required to be both server and client compatable in the same download?


    What was I thinking about?
     
  14. Booker The Geek

    Booker The Geek Well-Known Member

    One would think so, but i perfer to be better safe then sorry. I will test it out and if no problems occure I'll modify the post though.
     
  15. Hottheadliberty

    Hottheadliberty New Member

    just in case this might help someone else i was having the world leak issue and i decidd to try the chunkloader solution, i went to all my mystcraft worlds and put CL's in them then i placed one in the overworld. then i restarted the game. but i still had the problem with the lag spikes every 5 seconds. so i tried the solution with disabling the wireless redstone mods. i followed the procedure exactly but still had the problem. then i decided to try adding a CL to the twilight forest even though i had not gone there yet. as soon as the Twilight forest loaded the lag spikes were gone so plopped down a CL and went back to the over world and no lag spikes.

    so in short you have to place Chunk loaders in every dimension even if you have not been to it yet. i hope this helps sombody else

    Edit: started a new world today and no matter how many chunkloaders i place nothing works!
    any ideas?
     
  16. Booker The Geek

    Booker The Geek Well-Known Member

    ... Did you read Fix #2? :D
     
  17. Hottheadliberty

    Hottheadliberty New Member

    yes i did but it does not specify that you needed to put one in the twilight forest even if you have never been there before. regardless i hope they track down this bug soon
     
  18. Ashzification

    Ashzification New Member

    It's not technically a bug. The leaking memory spam in your console is meant to grab the developers attention. It's a problem with more than one mod as well.
     
  19. Hottheadliberty

    Hottheadliberty New Member

    well it may be poor phrasing on my part but i consider anything that causes my game to not run correctly a "bug". i honestly don't care if the console tells me to go to hell just so long as i stop getting the 4 second lag spike every 5-6 seconds.

    after reading what i wrote it sounds like i have an attitude but i promise you thats not the case i just can think of any better wording to say that. :)
     
  20. DragoncraftGaming

    DragoncraftGaming New Member

    Thanks for the help BTG! I removed wireless redstone and mystcraft and my world leaks are gone without reappearing for one full day!
    ~EDIT~ The time I was awake during that specific day.
     
Thread Status:
Not open for further replies.

Share This Page