Detected leaking worlds in memory.

Status
Not open for further replies.

RuRo

New Member
Jul 29, 2019
10
0
0
Dunno, if this is still up to date.
But Disabling Grav. Gun and Portal Gun fixed leaking for me, it seems that there is something wrong with the hope it will be fixed.
 

Darkmega

New Member
Jul 29, 2019
18
0
0
Alright all, listen up. I want ya'll to try the 2 gig ram advanced settings booker threw out BUT ALSO update all of chickenbones mods that are currently in the pack (core, wireless redstone, NEI and it's plugins, enderchest and chickenchunks) to the latest versions then tell me if stuff lags out in the same time it used to be. Cause last night I had my stuff updated I managed to play hardcore for a few hours without it derping out, then just now I went back to my play around world (this time with the advanced settings as back-up help since thats where I've had the most hiccups) and dicked around with nuking stuff in warded containment holes, making jars of wisps and just generally playing around with whatever came to mind and it was still working fairly well when I stopped just now (after an hour or so. Would go for longer but it's getting close to my "school tomorrow" bed time ("no school tomorrow bed time" is almost non-existent if you were gonna ask to make conversation ;)).

So guys, give that a shot and lets see if that either mitigates it to the point people can atleast get an hour or more out depending on their comps, or whether it stops the gradual lag outs completely or if perhaps my glitch is just my computer and minecraft conspiring to be a pair of douchenozzels. Cause twice in a row of not blowing up in my face after a reasonable time couldn't just be a coincidence.

Although I did notice that by the end I was using half the allocated ram (nearly 1 out of my 2) but it wasn't gradually stacking itself up from what I could tell and was probably cause of mobs, aura nodes, loaded sprites of what I had been using, wisps and my turtles all doing their thing... aswell as maybe some scrap items in a nearby nuke and scattershot mining laser crater. :p
 

TsunamiMike

New Member
Jul 29, 2019
17
0
0
I will try the >2g option this evening or next. When I tried to use the perm size value (before correcting my Java version issue) it gave me an error. Now that I have fixed the Java version, perhaps I will have better results.

I will keep you posted :)

Ah yes, BTG was for you :p
BTG et al,

Tried the java parameters last night and it worked great. I may have had a leak (can't remember, there was wine involved), however it did not affect performance. I will try again in the next couple days, and if you need a log let me know.

Regarding the other suggestion of manually updating the pack, I will try that it it becomes an issue. So far the parameters are working on their own, with the only mod to Mindcrack being the disabling of Xycraft.
 

Darkmega

New Member
Jul 29, 2019
18
0
0
given that everythings been quiet since thursday is everyone savvy now? :O mines been working like a charm after the updated chickenbones stuff and advanced settings for safety. How's everyone else?
 

DZCreeper

New Member
Jul 29, 2019
1,469
0
1
I say someone in this thread saying the console was a bit spammy when using TreeCapitator, there is a debug option which defaults to true, change that in the config.
 

Work_work

New Member
Jul 29, 2019
41
0
0
Just found this page today, I updated my java, used the >2g settings and the current Direwolf20 pack, disabled wireless redstone, mystcraft, twilight forest, gravitygun and portalgun, havent had any issues yet. *knock on wood*
 

Work_work

New Member
Jul 29, 2019
41
0
0
I had problems with 5.2 before I disabled these settings, I will try out my old world after work and see.
 

miralize

New Member
Jul 29, 2019
8
0
0
I tried editing the java perms that were on Page 7 of this thread, but now I get the following


Exception in thread "main" java.lang.NoClassDefFoundError:
Caused by: java.lang.ClassNotFoundException:
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
 

Phil_Aus

New Member
Jul 29, 2019
1
0
0
Hey miralize, I had the same error. I tried a few things but found that I had included a leading space at the start of the java perms, exactly as BTG has it displayed. Without the space it works.
Been back into my Direwolf20 world for some hours with no lag issues and no crashes. Thanks BTG.
 

Booker The Geek

Well-Known Member
Feb 26, 2013
1,664
222
78
Pacific North West, USA
Hey miralize, I had the same error. I tried a few things but found that I had included a leading space at the start of the java perms, exactly as BTG has it displayed. Without the space it works.
Been back into my Direwolf20 world for some hours with no lag issues and no crashes. Thanks BTG.
Fixed the leading space, thanks for the info.
 
  • Like
Reactions: Ashzification

maxpowa

New Member
Jul 29, 2019
74
0
0
Code:
-Xms512m
You shouldn't have to do this, the launcher automatically adds the
Code:
-Xms256m
parameter which is quite sufficient for an initial heap size.

I do agree with using these though:
Code:
-XX:PermSize
-XX:MaxPermSize
 

othala

New Member
Jul 29, 2019
18
0
0
I try to understand. I put on each world : Nether , Ender , Twilight , Overworld a chunkloader and world leak message gone. Why I dont need to put it on very Mystcraft world ?

Is Thaumcraft mod leaking or Mystcraft ? Is a chunkload on each world is not to RAM usage intensive ?

Actually we are in Direwolf20 5.0.1 and we want to plan to upgrade to 5.2 I dont want to have major issue.

And finaly is it true this leak was already present but not showing in the console ?
 

othala

New Member
Jul 29, 2019
18
0
0
Anyone seems anoying with this mem leak ??? That's crazy , there is any real fix from modder or from FTB team ? 2 releases and any fix ....
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
Anyone seems anoying with this mem leak ??? That's crazy , there is any real fix from modder or from FTB team ? 2 releases and any fix ....
1. It's been more than 2 releases.
2. It's a problem with a handful of specific mods, which need to be fixed by their authors
3. I understand your native language may not be English, but could you please at least try to make a complete sentence. It's very hard to understand what you're trying to say.

And finally 4. All of these suggestions have been brought to you by other members of the community, because at this time, there is no official fix for this problem. (that has been stated here at some point I believe, so just reiterating)
 

othala

New Member
Jul 29, 2019
18
0
0
More than 2 release ? So why I haven't got these lag / issue on 5.0.1 ? Which mod is the problem ? Anyone here tell what is exactly the buggy mod. Why modpack autors release new version with the same severe bug ? Actually all workaround is to play without many usefull mod.....or ... in 5.0.1
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
More than 2 release ? So why I haven't got these lag / issue on 5.0.1 ? Which mod is the problem ? Anyone here tell what is exactly the buggy mod. Why modpack autors release new version with the same severe bug ? Actually all workaround is to play without many usefull mod.....or ... in 5.0.1
Because the issue got worse as more mods got updated and became more prevalent as more people were using the modpacks. Mystcraft seems to be one of the main culprits, since there are so many worlds loading and unloading.

Again, there is more than one mod involved here.
 

othala

New Member
Jul 29, 2019
18
0
0
As I see for me Mystcraft seems not the troublemaker , Thaumcraft load and forget to unload node on some world ...
 
Status
Not open for further replies.