1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Detected leaking worlds in memory.

Discussion in '[Archived] Tech Support' started by Yusunoha, Feb 19, 2013.

Thread Status:
Not open for further replies.
  1. RuRo

    RuRo New Member

    Dunno, if this is still up to date.
    But Disabling Grav. Gun and Portal Gun fixed leaking for me, it seems that there is something wrong with the hope it will be fixed.
     
  2. Darkmega

    Darkmega New Member

    Alright all, listen up. I want ya'll to try the 2 gig ram advanced settings booker threw out BUT ALSO update all of chickenbones mods that are currently in the pack (core, wireless redstone, NEI and it's plugins, enderchest and chickenchunks) to the latest versions then tell me if stuff lags out in the same time it used to be. Cause last night I had my stuff updated I managed to play hardcore for a few hours without it derping out, then just now I went back to my play around world (this time with the advanced settings as back-up help since thats where I've had the most hiccups) and dicked around with nuking stuff in warded containment holes, making jars of wisps and just generally playing around with whatever came to mind and it was still working fairly well when I stopped just now (after an hour or so. Would go for longer but it's getting close to my "school tomorrow" bed time ("no school tomorrow bed time" is almost non-existent if you were gonna ask to make conversation ;)).

    So guys, give that a shot and lets see if that either mitigates it to the point people can atleast get an hour or more out depending on their comps, or whether it stops the gradual lag outs completely or if perhaps my glitch is just my computer and minecraft conspiring to be a pair of douchenozzels. Cause twice in a row of not blowing up in my face after a reasonable time couldn't just be a coincidence.

    Although I did notice that by the end I was using half the allocated ram (nearly 1 out of my 2) but it wasn't gradually stacking itself up from what I could tell and was probably cause of mobs, aura nodes, loaded sprites of what I had been using, wisps and my turtles all doing their thing... aswell as maybe some scrap items in a nearby nuke and scattershot mining laser crater. :p
     
  3. TsunamiMike

    TsunamiMike New Member

    BTG et al,

    Tried the java parameters last night and it worked great. I may have had a leak (can't remember, there was wine involved), however it did not affect performance. I will try again in the next couple days, and if you need a log let me know.

    Regarding the other suggestion of manually updating the pack, I will try that it it becomes an issue. So far the parameters are working on their own, with the only mod to Mindcrack being the disabling of Xycraft.
     
  4. Booker The Geek

    Booker The Geek Well-Known Member

    Glad you got it working Glad to be of help.

    Now all I need to do Is make a map with my name as a seed and see what I can make... :D
     
  5. Darkmega

    Darkmega New Member

    given that everythings been quiet since thursday is everyone savvy now? :O mines been working like a charm after the updated chickenbones stuff and advanced settings for safety. How's everyone else?
     
  6. DZCreeper

    DZCreeper New Member

    I say someone in this thread saying the console was a bit spammy when using TreeCapitator, there is a debug option which defaults to true, change that in the config.
     
  7. Work_work

    Work_work New Member

    Just found this page today, I updated my java, used the >2g settings and the current Direwolf20 pack, disabled wireless redstone, mystcraft, twilight forest, gravitygun and portalgun, havent had any issues yet. *knock on wood*
     
  8. RetroGamer1224

    RetroGamer1224 New Member

    I may be wrong but since the update a lot of things may have been fixed. Try it before you disable all those mods
     
  9. Work_work

    Work_work New Member

    I had problems with 5.2 before I disabled these settings, I will try out my old world after work and see.
     
  10. miralize

    miralize New Member

    I tried editing the java perms that were on Page 7 of this thread, but now I get the following


     
  11. Phil_Aus

    Phil_Aus New Member

    Hey miralize, I had the same error. I tried a few things but found that I had included a leading space at the start of the java perms, exactly as BTG has it displayed. Without the space it works.
    Been back into my Direwolf20 world for some hours with no lag issues and no crashes. Thanks BTG.
     
  12. Booker The Geek

    Booker The Geek Well-Known Member

    Fixed the leading space, thanks for the info.
     
    Ashzification likes this.
  13. maxpowa

    maxpowa New Member

    Code:
    -Xms512m
    You shouldn't have to do this, the launcher automatically adds the
    Code:
    -Xms256m
    parameter which is quite sufficient for an initial heap size.

    I do agree with using these though:
    Code:
    -XX:PermSize
    -XX:MaxPermSize
    
     
  14. ShireensPlay

    ShireensPlay New Member

    My world leaks have come back... I've updated the launcher and I can't play anything... It crashed everytime I tried to open any of my worlds...

    Here is the pastebin: http://pastebin.com/vZ8zjnCF
     
  15. othala

    othala New Member

    I try to understand. I put on each world : Nether , Ender , Twilight , Overworld a chunkloader and world leak message gone. Why I dont need to put it on very Mystcraft world ?

    Is Thaumcraft mod leaking or Mystcraft ? Is a chunkload on each world is not to RAM usage intensive ?

    Actually we are in Direwolf20 5.0.1 and we want to plan to upgrade to 5.2 I dont want to have major issue.

    And finaly is it true this leak was already present but not showing in the console ?
     
  16. othala

    othala New Member

    Anyone seems anoying with this mem leak ??? That's crazy , there is any real fix from modder or from FTB team ? 2 releases and any fix ....
     
  17. Ashzification

    Ashzification New Member

    1. It's been more than 2 releases.
    2. It's a problem with a handful of specific mods, which need to be fixed by their authors
    3. I understand your native language may not be English, but could you please at least try to make a complete sentence. It's very hard to understand what you're trying to say.

    And finally 4. All of these suggestions have been brought to you by other members of the community, because at this time, there is no official fix for this problem. (that has been stated here at some point I believe, so just reiterating)
     
  18. othala

    othala New Member

    More than 2 release ? So why I haven't got these lag / issue on 5.0.1 ? Which mod is the problem ? Anyone here tell what is exactly the buggy mod. Why modpack autors release new version with the same severe bug ? Actually all workaround is to play without many usefull mod.....or ... in 5.0.1
     
  19. Ashzification

    Ashzification New Member

    Because the issue got worse as more mods got updated and became more prevalent as more people were using the modpacks. Mystcraft seems to be one of the main culprits, since there are so many worlds loading and unloading.

    Again, there is more than one mod involved here.
     
  20. othala

    othala New Member

    As I see for me Mystcraft seems not the troublemaker , Thaumcraft load and forget to unload node on some world ...
     
Thread Status:
Not open for further replies.

Share This Page