1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Detected leaking worlds in memory.

Discussion in '[Archived] Tech Support' started by Yusunoha, Feb 19, 2013.

Thread Status:
Not open for further replies.
  1. ExEvolution

    ExEvolution New Member

  2. Bigdavie

    Bigdavie New Member

    This does appear to be working with me, 30mins running and no issues.
     
  3. Booker The Geek

    Booker The Geek Well-Known Member

    Glad It did. :D
     
  4. Merp Masta

    Merp Masta New Member

    Hello, I was wondering if you could help me disable wireless redstone. I'm a noob I know :p I've tried just deleting the .jar and the .cfg files but this did not solve it.
    Thanks :D
     
  5. Booker The Geek

    Booker The Geek Well-Known Member

    No worries!

    1. Launch FTB
    2. Go into the options tab
    3. Click force update
    4. Make sure "Reopen launcher after exiting minecraft" (Not required, just makes life easier.)
    5. Launch the RECOMMENDED version of your favorite modpack
    6. When you get to the minecraft load screen, (i.e. load a game, start a new one, join online...) DO not start playing yet, just "quit minecraft".
    7. You should be back at the launcher.
    8. Make sure the "Modpacks" tab is selected.
    9. Click "Edit Mod Pack". Should be directly under "Modpacks" tab.
    10. Under "Enabled Mods", scroll down untill you see the following.
      • wirelessredstoneaddons
      • wirelessredstonecore
      • wirelessredstoneredpower
    11. Select one and hit "Disable>>"
    12. Repeat step #11 for the other two.
    13. Close the window
    You should be good at this point to launch the game. I would recommend NOT to use your saved worlds IF you have any wirelessredstone items in your world. Otherwise it should, SHOULD, work. Best bet is to start a new world and see if it solves your problem. If it does, feel free to then try any of your older saved games.

    You did backup your saved games, right?
     
    ShireensPlay and Ashzification like this.
  6. Ashzification

    Ashzification New Member

    Also, at roughly 10:00 in the newest DW20 SMP video, this issue is explained very well:
     
    Mutabulis likes this.
  7. Zexmaxwell001

    Zexmaxwell001 New Member

    So I was watching a DW20 video and they talk about this exact problem everyone is having.


    11m50s is the important part.

    In short, the error message is not for us(server admins), but for the developers. so no matter what you do, you may "fix" the problem, but the problem is not really fixed because it has to be recoded by the modder.

    EDIT: ROFL! Double post FTW!
     
    Mutabulis and Ashzification like this.
  8. tabs

    tabs New Member

    Saying this message is for developers is all well and good, but to be honest most of us end users only care about it because our performance has tanked. The message and the performance are related as it is certainly a memory leak issue.

    I would happily ignore this message that isn't meant for me if my gameplay wasn't suffering so badly.
     
  9. Zexmaxwell001

    Zexmaxwell001 New Member

    If you hate the performance of your server, then start removing mods or don't have a modded server. The devs need to recode their work so it wont hurt the performance that is why the message is in.

    That being said. their is nothing the server admins can do about it. Its like the "server can't keep up" spam. You can read all sorts of tips and tricks to get rid of it but they are all myths.
     
  10. tabs

    tabs New Member

    Are you seriously suggesting I simply don't use FTB rather than mention a bug? If not, what was the point of your post?
     
  11. Zexmaxwell001

    Zexmaxwell001 New Member

    If that's how you read it. yes, or take the time to figure out what mod or machines is taking the most hit on your server.

    This is just the nature of modding.

    I removed IC2 and RP2 because it had nothing but problems from day one. but now that I heard that they fixed a few things with IC2, I might put it back in.
     
  12. tabs

    tabs New Member

    I've followed these instructions, which removed two of the four leaking worlds and slowed the rising memory.

    Removing twilight forest stops the other two world leaks. This was done on a fresh 5.1.1 save without even making a twilight portal.

    After 10 minutes of running around with no reported leaks (they usually appear after a few seconds of starting a new world) I cheated in a couple of mystcraft books and used them. This caused the world leaks again.

    Even if you quit the game and rejoin it later (single player, so basically a server restart) mystcraft will be leaking if you've made an age at some point previously in that world.

    It appears then that to mitigate the problem significantly we should be disabling twilight, mystcraft, and wireless redstone.

    You are essentially telling me nothing relevant to my post. That's why I asked you what you were saying. Of course I am testing and removing mods. The point of my post was that it's unfair to ask people to ignore the console messages when the only reason they mention them is because their performance is suffering. That performance is a direct result of the problems these console messages are highlighting. It would be silly not to mention the messages when we are reporting bugs.

    The mod dev seemed to think that people were up in arms because "oh noes! red text in my console!" when the real issue is that the game is rendered unplayable after a while because of memory leaks. He's quite right that we shouldn't care too much about the messages, in isolation.
     
  13. tabs

    tabs New Member

    Sadly, loading up an old save using the new mod list still suffers from the memory leak issue. This save hadn't had any mystcraft worlds ages yet. I've tried removing all dimensions apart from the overworld, and deleting all redstone ether folders. Still gives me 2-5 world leaks and rising memory.

    It's possible that these are the leaks that are being fixed but not reported as such. I'll keep it running for a few hours and see if it crashes. I'd rather keep this save than have to start over.
     
  14. RetroGamer1224

    RetroGamer1224 New Member

    I have a strong feeling that come 1.5 a lot of things will be cleaned up. I am not too worried about it as I can wait for things to happen. As a side question is a GL error anything to worry about?
     
  15. tabs

    tabs New Member

    Server still performing fine after a couple of hours on DW 5.1.1 - even though there are occasional (much less frequent) leak warnings which I can now happily ignore. Basically follow the steps Booker the Geek outlined, but remove Twilight Forest and Mystcraft too. I also deleted all DIM folders that were not DIM1 or DIM-1, and deleted all redstone ether folders - however I don't know if that was necessary. It certainly didn't harm the world.
     
  16. Booker The Geek

    Booker The Geek Well-Known Member

    I am glad it worked!

    I will look into The mystcraft and twilight forest thing and see if I can recreate it. Either/or, I will be sure to edit my post with the new information, since this post is the one that everybody is getting refered to rather then rewriting everything. Plus as the most replies/views while dealing with the topic, it comes out first on a search.
     
  17. TsunamiMike

    TsunamiMike New Member

    Like everyone else, I have been following the "leaking world's threads" with interest. I have the same or similar issues.

    I tried the "permsize" parameter in the Launcher and received an error message "Unable to load module" or something to that affect, and had to remove the parameter to play. Mindcrack 8.1.1 with Xycraft disabled.

    In my console, I periodically see Nether chunks being saved right before the hard crash. The odd part, which fits what other people have stated above, is that I don't have any chunkloaders, automation, etc. running in the Nether. I went there weeks ago to get a t5 blaze spawner, and haven't been back since. However, the game periodically saves chunks there, and if I have been to Twilight then it is saving chunks in three worlds, even if I am no longer in Twilight, putting everything further behind until the big crash. Exiting often, before the leak, seems to help.

    One other odd tidbit. It seems right clicking on a coke oven triggers an instant crash with leaking worlds. I can replicate this fairly easily. If anyone needs a pastebin, just ask and the next time I play I will get a crash and post it.

    All in all it is a minor inconvenience once you learn to work with it. The worlds save often enough so I only lose a few seconds here or there.
     
  18. tabs

    tabs New Member

    Server has been up for 7 hours now, and still only just over 2 gigs RAM used. I'd say this was a success. I've even been using mystcraft link books just for the nether.
     
  19. Booker The Geek

    Booker The Geek Well-Known Member

    I was wondering, Could you attempt something for me?

    1. Disable all wirelessredstone addons.
    2. Disable mystcraft
    3. Disable twilight forests
    4. Leave everything else enabled
    5. Start a new world, in creative.
    6. Build, play etc... DO NOT go to the nether or the end.
      • Do you still get leaking worlds?
    7. Go to the nether, do / build / kill something
    8. Go back to the overworld
    9. Repeat step #5
      • Now do you get leaking worlds?

    I have been having not the same issue, but almost. Seems we will have to wait for the modpacks to update. :)
     
  20. V001

    V001 New Member

    Ive had this error message since updating to Mindcrack v8.1.1 just a few days ago. I had no problems with it until today. Everywhere an Enderchest was located looked like this [​IMG]

    I had ender chest linked via colour coding running from quarries to sorting rooms log in this afternoon and each area a chest was located looked like this
    [​IMG]

    each quarry looked like this
    [​IMG]
     
Thread Status:
Not open for further replies.

Share This Page