[1.7.10] The Ferret Business [WIP][BQ + HQM, 500+ Quests][v 0.2.6]

Discussion in 'Public Packs' started by Caigan, Feb 17, 2015.

  1. I have a problem with the pack. I added some mods and it ran on 40-60 fps with but now the best i get with low graphic settings is 15 fps. Can somebody help me please?
     
  2. RedFawx

    RedFawx Guest

    Afternoon. I've been having an issue with randomly crashing. I don't know why, it's not effecting other people. We can't seem to fix it. Can anyone help me out? I've attached the crash log here. Thanks, I really appreciate it!
     

    Attached Files:

  3. Trisscar

    Trisscar New Member

    Could you throw the log into this please; https://pastebin.com/
    and then post the url of the submitted result here? DLing files is a bit dangerous, even if you think they're safe. Also please specify whether this is a server and what mods have been installed (different from what comes with the pack), updated or otherwise changed.

    @Darkzonegermany Adding mods to packs makes them more unstable. If you remove them (one at a time if you want to find the culprit) does the issue go away?
     
    An0nymuS and Everlasting2 like this.
  4. RedFawx

    RedFawx Guest

    Sure thing.

    https://pastebin.com/W1GqRmVc Here is the error in paste bin.

    As for the other question, this is a server. However, the error is happening client side. It isn't effecting any other player but myself. No mods have been changed from the instillation from FTB on client, or server side. This is on 0.2.2. Thanks for taking the time to help by the way.
     
  5. Trisscar

    Trisscar New Member

    Thank you. And no worries, this is a fun time for me. ;)
    Alright..... Oooh geez, Java itself crashed apparently. Time for tier 1 tech questions then.
    What's your OS/Java version, and what bit size are they (32 or 64)?
    What amount of RAM are you letting Minecraft use?
    Is this happening in or near a specific chunk, or after a certain amount of time?
    System specs (Total RAM, video card model) please?
    Is the server ever turned off, and is the box hosting it as well? What OS/Java/bit-size is it running if it's a personal computer and not a public server style deal?

    There's a thing here that I found while looking around, I don't suggest you try this till we've gone through the usual crash fixes, but if you happen to be comfortable with coding;
    Example 5-2, where a JavaThread fails while in the _thread_in_vm state (meaning that it is executing in Java VM code).

    Example 5-2 Example for a Crash


    # An unexpected error has been detected by HotSpot Virtual Machine:
    #
    # EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x08083d77, pid=3700, tid=2896
    #
    # Java VM: Java HotSpot(TM) Client VM (1.5-internal mixed mode)
    # Problematic frame:
    # V [jvm.dll+0x83d77]

    --------------- T H R E A D ---------------

    Current thread (0x00036960): JavaThread "main" [_thread_in_vm, id=2896]
    :
    Stack: [0x00040000,0x00080000), sp=0x0007f9f8, free space=254k
    Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
    V [jvm.dll+0x83d77]
    C [App.dll+0x1047] <========= C/native frame
    j Test.foo()V+0
    j Test.main([Ljava/lang/String;)V+0
    v ~StubRoutines::call_stub
    V [jvm.dll+0x80f13]
    V [jvm.dll+0xd3842]
    V [jvm.dll+0x80de4]
    V [jvm.dll+0x87cd2]
    C [java.exe+0x14c0]
    C [java.exe+0x64cd]
    C [kernel32.dll+0x214c7]
    :


    In this case, although the problematic frame is a VM frame, the thread stack shows that a native routine in App.dll has called into the VM (probably with JNI).

    The first step to solving a crash in a native library is to investigate the source of the native library where the crash occurred.

    • If the native library is provided by your application, then investigate the source code of your native library. A significant number of issues with JNI code can be identified by running the application with the -Xcheck:jni option added to the command line. See The -Xcheck:jni Option.

    • If the native library has been provided by another vendor and is used by your application, then file a bug report against this third-party application and provide the fatal error log information.

    • If the native library where the crash occurred is part of the Java Runtime Environment (JRE) (for example awt.dll, net.dll, and so forth), then it is possible that you have encountered a library or API bug. If so, gather as much data as possible and submit a bug or report, indicating the library name. You can find JRE libraries in the jre/lib or jre/bin directories of the JRE distribution. See Submit a Bug Report.
    You can troubleshoot a crash in a native application library by attaching the native debugger to the core file or crash dump, if it is available. Depending on the OS, the native debugger is dbx, gdb, or windbg. See Native Operating System Tools.
    https://docs.oracle.com/javase/8/docs/technotes/guides/troubleshoot/clopts002.html#CHDDEGBI
     
    Last edited: Jul 10, 2017
  6. RedFawx

    RedFawx Guest

    Wonderful. Where here come your answers.

    Windows 8.1/Java 1.8.0.131 (64 bit)
    Minecraft RAM usage differs for each mod I play, however Ferret Business takes 4 gigs.
    The specific error has happened before on two different servers. It happened much sooner the first time, and that was off someones personal computer, so I don't think that it's based on time. It seemed to happen as I ran back towards where me and my friends had been building our base, but it also might just have been random. I honestly couldn't tell you because each time I log in, I instantly crash.
    My laptop has 12 gigs of ram with a NVIDIA GTX860M video card.

    The server we were running this on is a server that I pay monthly for from a friend that runs a business. This is the only mod that I've had errors with (We've played MANY FTB modpacks on this server with no issues). The server specs are: Debian OS/16 GB ram/ Intel Xeon E3 1230 Dual Quad/64 bit java


    I'll avoid any drastic measures for now... I'll wait until you think of anything else first! :3
     
    Last edited: Jul 11, 2017
  7. Trisscar

    Trisscar New Member

    Humm, alright that's all fine as far as I'm aware.
    "As soon as I log in I instantly crash" as in load into the world right? Also the "two different servers" are you guys starting a new world on the same server hardware yes?
    ....Huh. Debian is a Linux distro, so it's possible that Win8 is being an unmitigated ass and predatory as hell, or in other words something between the OS's was mistranslated. Though it could also be a variant of that Nvidia bug from a little while back that was crashing people for no good reason.
    If it's only affecting you, then it's most likely your hardware or software, so that narrows things down immensely. Add to the list of things to try that are annoying or long; Updating drivers.
    Speaking of, had you updated anything before playing this pack? System updates would count, as would driver updates and other sundry software related ones.
    A bunch of server ping threads were blocked, which could easily mean that your antivirus or malware protection or firewall is being silly, buuuuttt could also just be a symptom. Add to "should probably check on and possibly disable only while testing" list. ;)
    Some of those blocked threads were logistics pipes related. One solution might be taking any that are being used in the area you crashed down and attempting to log in then. Same goes for iron chests, though if yall are willing to go this far you should do these separately to see which might be causing the issue.
    Would also suggest temporarily disabling journeymap, since that can cause issues sometimes due to what it's doing every time it loads a part of the map or writes it.
    Also fastcraft may need temp disabling. One of the tricks it uses might be causing nonsense to happen. Both this and journeymap should be just your end things, and shouldn't block you from entering the server.
    (Finds this while reading, starts laughing:
    jvm_args:-XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump)
    So if you look at line 89 in the pastebin, it says it was trying to render ToolInv. You guys doing anything weird with Tinker's tables or drying racks or anything else tool based? Like making something stack that might not usually be stacked, or shoving things into a table or something via pipes or ducts?
    If someone who has mod powers can figure out how to move your current spawn/login spot to somewhere far away, that might at least get you into the game, long enough to figure out if it's something that you're trying to render that's causing issues, or something else. This might also require unloading of all other chunks not being used for your new spawn.
    Remind me, is FeBu running any of those inventory/hotbar mods that add new slots for things (besides Botania and Tinkers)? Because if you picked up something or attempted to "equip" it, accidentally or not, that might cause permacrash. You may have to have mod power delete your inventory and all armor and equipment on all tabs to find out though.

    I'd suggest doing all this in any order you see fit, Java crashing and little to no available documentation on similar crashes may mean this'll be a bit of a long haul, sorry. XD
     
  8. RedFawx

    RedFawx Guest

    So here's something we've noticed. We think it might be Decocraft. Whenever someone pulls out a decocraft item I crash. We think that the random crashing was due to monsters dieing and dropping the decocraft clay items. How do I get around this without disabling it, as my friend says some quest items we get are decocraft items.
     
  9. Dylan Jones

    Dylan Jones New Member

    Just wanted to say I've been having a lot of fun with this pack over the past 2 weeks with a few friends!
     
  10. Nortalian

    Nortalian Guest

    I have not been able to get into the pack for about two months now. Looking back on the crash reports that i've had in the past, it looks like this issue first appeared on the first of June. I didn't realize how big of a problem it would be then but I will post the first and most recent crash reports. The most recent being from, as of posting this, today (July 17, 2017). This is not including the 15 other times I have crashed in this same way over the past month and a half.
     

    Attached Files:

  11. Mel_M

    Mel_M Guest

    Will this pack still work if we remove Decocraft? It's causing a lot of crashing for us. Since some of the reward bags contain Decocraft items, will it cause issues, other than not getting the rewards?
     
  12. An0nymuS

    An0nymuS New Member

    IIRC there are a bunch of quests for decocraft items and I believe some reward bags contain Decocraft things, so you might be able to run it, but quest progression might be broken and you might get a lot of crashes.
     
  13. Trisscar

    Trisscar New Member

    @RedFawx Hardcore Questing will probably be fine if you remove Deco, last I checked it'll just replace the reward items with a bedrock icon and have them not reward you with anything if it has issues finding the item. Quest progression may also be broken, in which case you'd probably want to use the OP Quest Book to complete them all first.

    Reward bags might be a different issue however. Best I can say at this point is: Either wait for it to maybe crash and do this, or do this now;
    Go into the relevant mod config files and find the list of rewards each bag can give, and remove all Decocraft items from them. Have both the server owner and probably all players attempting to connect do this, though the player thing might not be needed depending on how things are coded.

    Also sorry for not replying, I usually get email notifications for if someone has answered a post of mine, but it didn't trigger this time so I didn't realize till I went looking manually.
     
    Everlasting2 likes this.
  14. Kira Wroth

    Kira Wroth Guest

    I'm having trouble downloading this modpack on Twitch/Curse launcher, says it could not find child addon 225921 (Enhanced Portals 3)
     
  15. UnbracedZeus

    UnbracedZeus Guest

    Trying to get into Draconic Evolution (have rank in all 3 reputation tracks), but some of the required quests are nowhere to be found in the QUEST book. I was able to work around that (after scratching my head for weeks) by clicking thru the item submission station to find the one I needed, but then I have no clue as how to use the things. Was this intentional, or is it due to WIP status?
     
  16. TheLogan

    TheLogan New Member

    How come there's no bonus to refining products?
    I've tried to find good ways of earning vouchers, carrots are crap at 5 vouchers per carrot, for some reason potatoes are set at 50 per potato, so that's what seems most reasonable, sugar coal also sells for 50, but you need to plant the sugarcane, harvest the sugar cane, refine into sugar and then bake the sugar, and you're rewarded with the same amount as for potatoes, it seems silly. If you refine potatoes into baked potatoes, they also still just sell for 50, and the same goes for pretty much everything.
     
  17. hector212121

    hector212121 New Member

    With sugar, you can pulverize it for extra.

    Also, the best way by FAR(though it takes much hunting to obtain) is fireblossoms. Comb deserts for villages; greenhouses have a fair chance of having them.

    Also, baking potatoes DOES have a refining bonus. Trivection upgrade doubles food.

    It becomes ridiculous when baking bread, then baking bread into toast. Your SAG mill(without a grindstone) turns wheat into 2 flour, which turns into 4 bread, then 8 toast, which generates 30 rf/t in a culinary gen.

    @Caigan Don't forget about Clockwork Phase--it's clearly planned since it's in the icons.

    I might just add it myself to my own install with that reasoning.
     
  18. Not trying to be a mean or a jerk here but is there anyway the complete pack can be hosted somewhere else besides on the now twitch app? I've spent a day and a half already trying to download it or import it with no success and it's all issues with the twitch app itself so if that is possible it would be greatly appreciated otherwise I suppose playing this pack won't be possible for me for the time being.
     
  19. Everlasting2

    Everlasting2 Well-Known Member

    i think the legacy ftb client can still download it
     
  20. Thanks, I will give it a try.
     

Share This Page