1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Those little things that irk you about Minecraft

Discussion in 'General FTB chat' started by Ripley, Oct 25, 2013.

  1. Ripley

    Ripley Well-Known Member

    There is always that detail that annoys you, it's not really a big deal but by Jove you wish it could change!

    Here are 2 examples:
    -ComputerCraft edit program:
    Apparently non qwerty keyboards are a thing that does not exist.
    You see on non qwerty keyboards you have to use Alt-Gr to write characters like [ or { which are used quite a lot when coding.
    Of course Alt-Gr brings the save/exit menu so you have to do some weird combo to write those characters.
    A simple fix is to extract the computercraft.zip, edit the edit program and change the menu key to something other than Ctrl. Repack and put the modified Computercraft.zip back to where it belongs but still I wish they would just put an option in the configs...

    -Mystcraft and biomes:
    Ever tried mystcraft without a biome extension like ExtraBiomesXL or BoP?
    You instantly find interesting pages like blocks, terrain, biome controllers not just some biomes, more biomes and yet more biomes. I wish the chance for biome pages could be configured to be a flat chance instead of the more biome page you have the more you have a chance to find a biome page.

    Please note this is not a thread to troll that mod you don't like/think is OP. It's for those little quirks that annoy you in that mod you LOVE :p.
     
    Last edited by a moderator: Nov 29, 2013
  2. Zarkov

    Zarkov Well-Known Member

    You need to breed bees that poison you to get material for a suit that protects against bee poison.
     
  3. Yusunoha

    Yusunoha Never Leaves Wiki Staff ModMyMC Editor

    I hate it when mods make you craft items/blocks with rarely used items, and you end up not using them anymore because they're basically useless. like nuggets, almost no recipes uses them, but the once that do only require a few of them, but you can't get yourself to throw away the ones you don't use, just for that one chance you might need them again
     
  4. Steel

    Steel Well-Known Member


    Could you elaborate on what you mean about having to use Alt-Gr to write special characters on non-qwerty keyboards? I use dvorak, and I don't even know what Alt-Gr means.
     
  5. Ripley

    Ripley Well-Known Member

    It's the Alt on the right of space:
    [​IMG]

    It permits to use those bottom right symbols under 1,2, etc
    Apparently it's considered a combination of Ctrl+Tab or something like that so it triggers the menu from ComputerCraft.
     
  6. Zarkov

    Zarkov Well-Known Member

    Key bindings in Modular Power Suits. For me, they always reset every time I start Minecraft. I can't remember them ever working properly.

    I wonder how many times I've mapped Night Vision to "n" and Flight Control to "f" by now...
     
    AndyMASH, xTordX, E_DM_B and 3 others like this.
  7. xSINZx

    xSINZx Member

    notepad++
    No way am I going to type out an entire LUA program into CC. Copy/Paste rules.
     
  8. Ripley

    Ripley Well-Known Member

    Direwolf has the same problem, I remember seeing him remap flight in nearly every episode at one point :p.
     
  9. Geometry

    Geometry Well-Known Member

    I have the same problem as well, but I just fix it by pressing K which opens the key bind GUI. Still annoying to press it every time I start Minecraft, but it's better to press 1 key than opening the whole GUI and rebinding them :)
     
    Hunter Pierce and MigukNamja like this.
  10. Gerald Huppertz

    Gerald Huppertz Well-Known Member

    This one makes sense to me. Just like you need to milk snake venom to make an antidote, or culture a flu virus to make a vaccine. You need to breed the poisonous bees to learn how the poison works before you can make protection for it.
     
  11. Zjarek_S

    Zjarek_S Active Member

    It is region specific and doesn't necessarily mean that you use non-qwerty keyboard. In Poland personal computing started with imported stuff and keyboard was usually US one and it is this way to this day with notable exception of macs, but they never were popular. However we use alt-gr (usually just called right alt) to write special characters like ć(c)ś(s)ą(a)ż(z)ź(x) and they aren't usually even marked on keyboard. In windows it is basically ctrl-alt on those keyboard settings and it sometimes causes problems, for example I had to change ATI driver settings, because it used ctrl-alt-c global shortcut and that way I couldn't write ć.
     
  12. b0bst3r

    b0bst3r Popular Member

    WHY OH WHY is there no STONE stairs.... come on Mojang get it together!!!
     
  13. AlanEsh

    AlanEsh Well-Known Member

    TiCo's seared brick/glass tank (for holding lava) is rendered like a Lego, as if stacking them would allow them to join like standard Tanks do when stacked. But they don't! This makes my smeltery setup messier than it should be :)
     
    Reddis, kaovalin, ApSciLiara and 4 others like this.
  14. kittle

    kittle Active Member

    Ditto on the CC edtor.
    but try as I might, i cannot get copy+paste to work.

    I also wish the forestry fermenter would take ANY sapling
     
    angelnc likes this.
  15. Pokefenn

    Pokefenn Over-Achiever Mod Developer

    Only MFR uses vines in recipes....
     
    ApSciLiara and RedBoss like this.
  16. Celestialphoenix

    Celestialphoenix Too Much Free Time

    That snarky message on the MC start screen telling you to use the new launcher.

    Re-authenticating your account to use the new launcher after using the FTB one. (yes- every time after using a 3rd party/old launcher)

    The stupidly over complex convoluted 'jump through loops' method of setting up a modded profile in the new launcher compared with the old one or FTB.

    Boats not responding to WSAD.

    Accidently hitting the crafting arrow in the vanilla grid- then waiting while NEI loads 1000+ recipes.

    The item held in your mouse vanishes after hitting said crafting arrow. You have to close the GUI and drop everything to get it back.

    Rain noise.

    Charcoal and Coal use the same texture.
     
    TunaSammich and angelnc like this.
  17. MigukNamja

    MigukNamja Forum Addict

    If I hold the CTRL key while typing the 'edit <filename>' command in the CC shell while keeping CTRL held, I can then CTRL+V to paste. But, I can only paste once person edit session. Have to save and close and re-open if I was to paste again.

    But, it's far easier to use pastebin.[DOUBLEPOST=1382723330][/DOUBLEPOST]

    Yeah, I just plop down an Ender Tank fed with lava beside by smeltery lava tank and call it done. I haven't tried an Ender Tank underneath, though...That might work and would look cleaner.[DOUBLEPOST=1382723435][/DOUBLEPOST]

    LOL, yeah. The best-looking "stairs" I usually make for my base are a series of stone slab half-heights. The problem is the staircase is then twice (i.e. rising half as fast) as long as a comprable cobble or wooden stairs-based staircase.
     
  18. MigukNamja

    MigukNamja Forum Addict


    Same. The only time I have to re-map is when there's a conflict. Every time I make a new client or add mods that want to take the F key (and there's lots of them !), I move everything/everyone off of F. That way, F is available for MPS. Otherwise, if another mod wants to also use F, MPS will make me re-map F every time.
     
  19. AlanEsh

    AlanEsh Well-Known Member

    But ... a tower of linked tanks fed by a pipe at the top looks cool! it just doesn't work... and there's no reason it shouldn't, except to annoy me.

    Can't you saw stone into slabs and then columns to make your own natural stairs? I do it with other materials, even dirt, haven't tried with plain stone.
     
  20. xbony2

    xbony2 WikiWorker Wiki Staff FTB Mod Dev

    When I have to use something WIP to progress, and I only have to use it that one time for that one thing *gregtech-cough-cough-cough*

    Zan's minimap has problems with waypoints in other dimensions (as of the 1.4 version) which is a pain when I try to teleport "home" in the nether and get lost.
     

Share This Page