1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Is Rotarycraft stupidly difficult or am I the stupid one?

Discussion in 'General FTB chat' started by Dragonchampion, Aug 7, 2014.

  1. Peppe

    Peppe Well-Known Member

    @Reika

    Thanks for being so active! Checked out your main thread on the MC forums and look forward to 1.7 testing when it opens up.
     
  2. Dragonchampion

    Dragonchampion Active Member

    Erps. I'll fix that now. That's my author's prejudice kicking in... I always write my females with vowels at the end so I often make the mistake of calling guys with the same naming format girls. Sorry, Reika!
     
  3. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    Which is as soon as my access transformers start working.
     
  4. dalekslayer96

    dalekslayer96 Well-Known Member

    The usual. A little debate, a little off-topic, a little flaming, etc.
     
  5. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    Here is the file. It probably does not load, but I have spent four days trying to figure out why java's manifest reader thinks it is an empty file, yes a hacked copy of the reader works fine.
    http://www.mediafire.com/download/q1kq3eq9k9ylbg4/Reika-1.0.jar

    As I am out of ideas, it may be a java version/OS thing. Maybe one of you can run it. Note that it contains all my mods, and is not suitable for play.

    Also, I just realized that the jar above does not contain the textures, sounds, or other resources, so is likely to crash anyways, or at least be very broken.
     
    Last edited: Aug 16, 2014
  6. Peppe

    Peppe Well-Known Member

    I imagine same error you are seeing:
    cpw.mods.fml.common.LoaderException: java.lang.IllegalAccessError: tried to access field net.minecraft.client.Minecraft.field_110451_am from class Reika.DragonAPI.DragonAPIInit

    Looking at other AT files your config looks right to me. Anyway to check if forge is even loading it?

    Any of the authors for these mods easy to talk to or readable source to follow their AT setup?
    Aroma1997Core-1.7.10-1.0.2.7.jar
    InventoryTweaks-1.58-147.jar
    CoFHCore-[1.7.10]3.0.0B3-26
    CoFHLib-[1.7.10]1.0.0B3-20
    RedstoneArsenal-[1.7.10]1.1.0B3-8.jar
    SimplyJetpacks-MC1.7.10-1.0.1.jar
    ThermalExpansion-[1.7.10]4.0.0B3-11.jar
    ThermalFoundation-[1.7.10]1.0.0B1-6.jar
    neiaddons-mc1710-1.12.0.1.jar
    NotEnoughItems-1.7.10-1.0.2.15-universal.jar
    TConstruct_mc1.7.10_1.6.0d36.jar

    Found AT cfg files in all those mods for 1.7.10.
     
  7. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    It is not, as the manifest is not reading correctly.
     
  8. Peppe

    Peppe Well-Known Member

    Never done anything in forge and Java is not my main language.

    Just read this and poked at a few of the mods with ATs:
    http://www.minecraftforge.net/wiki/Using_Access_Transformers

    The other at.cfg using mods don't have a line like this in their manifest.mf in meta-inf:
    FMLAT: DragonAPI_at.cfg

    your meta-inf folder has the DragonAPI_at.cfg along with it being in the root of the zip (where it is for other mods).

    Not sure if that would cause issues.
     
  9. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    The manifest is what is read by cpw's code on game launch to detemine if I have an AT and where it is. Other mods do in fact have this.
     
  10. Peppe

    Peppe Well-Known Member

    I was trying to say no other mod in the list I made above of 1.7.10 mods using an *_at.cfg file has the:
    FMLAT: *_at.cfg line in the manifest.mf file.

    Some are empty or have a line or two to indicate they are core mods, but none have FMLAT declaration.

    And non have their config in the meta-inf folder, all of them have it in the root where you also have a copy. I do not know if forge would be troubled by having it in two locations.

    Like I said i don't use Java much and don't know the template for implementing this, but I see differences between your mod and the others I listed. Maybe they mean nothing or maybe they indicate a step in the build process is missing/different enough to break it.
     
  11. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    It is possible to load an access transformer via a core plugin, so that is likely what the other mods are doing. I have no idea how to do this.
    Having the file in multiple locations is not the problem; Forge never even searches for the file.

    Basically, here is how it works. Forge loads, and scans the manifest file of the jar. It searches for the "FMLAT" property inside the manifest, which should return "DragonAPI_at.cfg". However, the return value is in fact null, and this is the root of the problem.
     
  12. Calech

    Calech Active Member

    Well, I'm really rusty on my Java, but I'm keen for RoC and ReC to get to 1.7, so I poked around a bit on the Forge site... Don't know if this helps but the changelog on the Forge build has a line;

    Would it work if you moved the _at.cfg file to the META-INF folder? I'm guessing that the coremod versions can go elsewhere because of how they work but these ones might need to be local to the manifest file, for whatever reason.

    (Never mind - it is already in there! Having read your thread on the Forge forums in full, it looks like you've already figured out the problem, it's just finding a solution that's causing problems :( )

    Besides your own thread on their forums it looks like the only other posts there pre-date that announcement, so it seems there's little information about it.
     
    Last edited: Aug 16, 2014
  13. dothrom

    dothrom Well-Known Member

    Had an electricraft question, so i thought I'd ask. How does one make "coolant" to fill the superconduting wires with? I know it has to go through the filler, but I just can't find the fluid/item that's supposed to be used.
     
  14. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    I put it in both. Also, again the problem is not that it cannot find the file when looking for it. The problem is when forge reads my manifest file, getProperty("FMLAT") returns null, as if that line was not in my manifest file at all.

    The refrigeration unit manufactures liquid nitrogen.
     
    dothrom likes this.
  15. dothrom

    dothrom Well-Known Member

    oooooo. tyvm Reika.
    in hindsight i should have thought of that. but got frustrated when it wasn't coming up in NEI
     
  16. Calech

    Calech Active Member

    Yeah, I noticed that I failed my Reading skill check on that one... oops.

    The usual process I go through when debugging someone else's code is to try to make it crash, then work back from there. I've been playing around with the manifest file and dropping the .jar into the FTB Unstable pack mods folder (which is not exactly the safest test environment), and I've noticed that if I stick an extra newline in between the manifest version and the FMLAT entry, it crashes really, really fast - so it crashes with an 'invalid manifest' error, same as happened to you. However, it can read the manifest file just fine, because if I declare FMLCorePlugin: this.should.crash.java it tells me that it can't load that file (obviously). So there's something odd with how it's reading that specific tag in the file.

    Okay... so I've poked and prodded it a bit more. If I take out the extra periods between the class declarations and the data items eg.

    public net.minecraft.client.renderer.entity.RenderSlime field_77092_a #scaleAmount

    with no . between RenderSlime and field_etc,

    the error changes. It instead goes to

    java.lang.NumberFormatException: For input string: "Reika-1"
    at java.lang.NumberFormatException.forInputString(Unknown Source)
    at java.lang.Integer.parseInt(Unknown Source)
    at java.lang.Integer.parseInt(Unknown Source)
    at Reika.DragonAPI.Auxiliary.CommandableUpdateChecker$ModVersion.getFromString(CommandableUpdateChecker.java:347)
    at Reika.DragonAPI.Auxiliary.CommandableUpdateChecker.getVersionFromFileName(CommandableUpdateChecker.java:147)
    at Reika.DragonAPI.Auxiliary.CommandableUpdateChecker.registerMod(CommandableUpdateChecker.java:97)
    at Reika.DragonAPI.Base.DragonAPIMod.basicSetup(DragonAPIMod.java:62)
    at Reika.DragonAPI.DragonAPIInit.preload(DragonAPIInit.java:164)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    etc. Which indicates that I've broken something just by playing with the access transformer file - so it is being read somewhere, if that helps? It got further than it did before, 'replacing 618 ore types', so I must have broken something else on the way?
     
  17. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    No, you actually fixed the problem, though I just now fixed it another way.

    Here is the download. It does contain all the resources and textures, and once again is all my mods wrapped together.



    It is very alpha, and I have tested little. Provide me with bug reports and this copy is not to be used in modpacks and you risk world corruption by using it in play worlds.

    Also, most of the new ChromatiCraft content is currently only available in creative. You can open a half-done GUI by pressing LSHIFT+L-Alt if you are in creative to access some of the abilities, and some of the tools are available in the creative mode inventory.

    Download:
    http://www.minecraftforum.net/forum...h-worldgen-civilization-and-more?comment=1074
     
    Last edited: Aug 17, 2014
  18. Dragonchampion

    Dragonchampion Active Member

    A little update: AFter weeks of practice and hard work, I know the mod pretty well now... and now it's hard to use anything else. The Grinder and Extractor are so cheap and easy to set up that it makes all other ore processing look crappy in comparison. xD
     
    PierceSG and Padfoote like this.
  19. Pyure

    Pyure Not Totally Useless

    Awesome man :)

    Once you get up to gas turbines, its time to start looking at building your first fission reactors for ultimate power. Those are very fun projects.
     
    PierceSG and Padfoote like this.
  20. dothrom

    dothrom Well-Known Member

    Question about fission reactors. What's usually the best way to reliably sustain them? Since I don't see a way to turn them "off" just lower output/reactions/fuel burn.
    I know there's bees that produce uranium for IC2 (wich can be used for RoC), but if I recall, there's at least one other material that gets consumed making the fuel pellets.

    I didn't list boring machines or quarries, because mining is inconsistent.
     

Share This Page