1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Is Rotarycraft stupidly difficult or am I the stupid one?

Discussion in 'General FTB chat' started by Dragonchampion, Aug 7, 2014.

  1. Dragonchampion

    Dragonchampion Active Member

    So I am trying my hardest to figure things out. I have googled dozens of tutorial pages and help guides, and hell, I even play Kerbal Space Program and know my delta/vs and other rocket science. But for some reason Rotarycraft eludes me, even with 2 google search pages of tutorials and tips.

    Everything seems to be wrong, or out of date, or just plain impossible. Magnetostatics seem to have been used a lot but are no longer viable. I can't seem to find any efficient method of running a Bedrock Breaker, no matter what. I have tried using gearboxes, a hydrokinetic engine, all of this in survival. I have wasted dozens of steel gearboxes, using a diamond gearbox, and still can't figure out how to do this legit, thanks to the massive amount of diamond needed for just ONE gearbox, and the fact Monster has an insane amount of ores and thus decreases diamond spawn (I found 2 diamonds after doing a method that would get me dozens in vanilla; branch/grid mining. I spent an hour on this.)

    I used those diamonds to make a twilight portal and beelined for a hollow hill to get the diamonds for a single gearbox, thus giving me my 2:1 diamond gearbox. However, even after using it, it seemed that the reddit page was wrong and a hydrokenetic engine + a diamond 2:1 gearbox does NOT power a bedrock breaker. I have gone into creative and gone nuts, trying shaft Junctions with the basic coils, I have tried performance engines, I have tried AC engines... nothing, and I mean NOTHING works.

    There are no /up to date/ guides or tips on how to run a Bedrock Breaker, there are no good ways to do it, thanks to Magnetostatic engines hardly doing anything now, I can't seem to get the torque or power needed for the Breaker (holy shit, 8192? AND 2 MW power? HOW?! The Coils worked for torque with an 8:1 gearbox, but even on max output for the COil it was only giving 1 MW)

    And then there's the matter of the Extractor. A jet Engine works for it I found, but that is extremely expensive. It's infuriating. I went to Rotarycraft and told myself to learn it when I made this world, forcing myself to learn about the shafts, the engines, and everything else because I was told it was /fun/. This isn't fun. This is just tedious and infuriating.

    TL;DR: HELP. ROTARYCRAFT IS HARD.
     
  2. Padfoote

    Padfoote Brick Thrower Team Member Forum Moderator

    Most if not all guides are out of date because Reika pushes updates so fast. Your best bet is to read the handbook for the engine outputs and machine requirements. For the bedrock breaker, you need 8192 Nm and 2MW (as you've said). There's no engine that can get that, so you need to use shaft junctions and gearboxes to hit that requirement.

    Magnetostatics are now tiered. They come at T0, and require an upgrade to go up a tier. They're setup so that in order to get the upgrade, you have to understand that tier of RotaryCraft (ethanol production, magnetizing, bedrock, etc).

    Extractors are also pretty easy to run. I have an AC Electric Engine hooked into two diamond gearboxes (can't remember the ratio though) to run mine. Slow, but it works.
     
  3. Dragonchampion

    Dragonchampion Active Member

    I know how to make ethanol, and magnetizing looks easy. (Stick a shaft into the magnetizer. Done. I think?) Bedrock is the tier I am stuck at, and desperately need the help. So far the ONLY thing I have managed to do to get it running is cheat in a Mekanism Energy Cube and a tier 5 magnetostatic. But that's not viable in survival, and it's also using another mod to cover for it! As for the shaft junctions, I tried using it, as stated above, to merge two fully basic Coils. Yet, it didn't work. All that happened is it turned it to only 1 MW for some reason; which is the same as only one coil...
     
  4. madnewmy

    madnewmy Well-Known Member

    It's stupidly difficult because reika made it so you don't skip tier and do what you are doing...
    You can find a guide in my sig, but I can tell you ;)

    4 hydro outputting into the next with 64+ water fall and a 4:1 gearbox on SPEED
    a microturbine with 2x16:1 and a 2:1 gearbox on TORQUE
    a tier 4 magnetostatic with 4:1 gearbox on TORQUE
    a tier 5 magnetostatic
    a gas turbine with an 8:1 gearbox on TORQUE
    a reactorcraft turbine hooked directly (because hell yea)
     
    dalekslayer96 and Pyure like this.
  5. Padfoote

    Padfoote Brick Thrower Team Member Forum Moderator

    It sounds like the shaft junction wasn't setup correctly, since two coils should've been enough.
     
  6. Dragonchampion

    Dragonchampion Active Member

    @Padfoote I just set down the shaft junction and connected the two Coils to it, and on the output of the shaft junction I put the 8:1 Diamond Gearshaft, since I couldn't afford a second gearshaft.

    @madnewmy I read that guide! it's actually the one I have been trying to use. I quote, directly from your guide: "You can run a Bedrock breaker off a single engine using a 2:1 Gearbox." From all of your discussions I had assumed a Hydrokinetic, but that doesn't work at all. I also haven't tried Reactorcraft yet... I was going to treat it as an alternate to Atomic Science, which, thanks to Caclavia merging it into Resonant Induction, no longer works with Monster 1.1.2. I was forcing myself to learn all this, because I wanted to essentially use the mods which were meant to be alternate paths to the mods I use a lot, Mekanism and Atomic Science vs Rotarycraft and Reactorcraft.
     
  7. Padfoote

    Padfoote Brick Thrower Team Member Forum Moderator

    That should've been plenty. Did you give both coils a redstone signal, and were both configured for 1024x1024? It sounds like only one coil was outputting correctly.
     
  8. Dragonchampion

    Dragonchampion Active Member

    I made sure, yes. But it still didn't work correctly.
     
  9. madnewmy

    madnewmy Well-Known Member

    oh yea it's not updated... I rewrote a good amount of it but *kofkof @Padfoote kofkof* didn't look over it yet :p
    The part you see is for v14-19 mostly... I updated for v23-24 and it now says:

    Next step is too get the bedrock breaker going. You have three main options for this: four Hydrokinetic Engine with an 4:1 gearbox on speed (2Mw), a tier 4 magnetostatic with 4:1 gearbox on torque (8Mw) or an gas turbine with an 8:1 gearbox on torque (65Mw). Note the the breaker dosen't have a much faster speed with increasing speed. It's recommended to have a few running at the same time.

    and I already need to update it for v25...
     
  10. Padfoote

    Padfoote Brick Thrower Team Member Forum Moderator

    Can you post a picture of the setup?
     
  11. Dragonchampion

    Dragonchampion Active Member

  12. madnewmy

    madnewmy Well-Known Member

    Yup one of the coil is either empty or not outputting

    Edit: or they are not at max output
    Edit2: Can you show us what you set the coils too?
     
    Padfoote likes this.
  13. Dragonchampion

    Dragonchampion Active Member

    The coils I maxed out for both speed and torque.
     
  14. PierceSG

    PierceSG Popular Member

    I want Rotarycraft and it's addons for 1.7.10 so bad. :confused:
     
  15. madnewmy

    madnewmy Well-Known Member

    1024x1024 for each?

    he is working on it... I think
     
    Padfoote likes this.
  16. Dragonchampion

    Dragonchampion Active Member

    Excuse me, but I am trying to figure out Rotarycraft. Please don't hijack my thread.

    Anyways, I discovered the problem; it seems that one of the coils reset. However, now is the problem with sustainability. Hydrokinetics, as stated before, are incredibly expensive, costing a /stack/ of steel EACH. In order to sustain a bedrock breaker, I need an /entire/ 4 hydrokinetics. I'm in survival, I don't have a Mechanical Miner. I can't possibly gather that much! Especially with my grinder setup being slow as molasses... And I need more energy to power a damn Extractor to get more stupid ores. To get more energy I need bedrock. It's all so frustrating!

    I might just have to switch back to Mekanism. It, at least, gives the x5 ores, but I lose the ability to refine Mimichite...
     
  17. madnewmy

    madnewmy Well-Known Member

    boring machine is the answer to all ore needs :D
     
    Padfoote likes this.
  18. Dragonchampion

    Dragonchampion Active Member

    I skipped the borer, because I felt it was like all other miners; it mines a tiny strip, having to be moved after 5 or so blocks... did I misunderstand the wiki page for the Borer?
     
  19. Padfoote

    Padfoote Brick Thrower Team Member Forum Moderator

    You misunderstood it. It mines horizontally until you remove it. The bore head will chunkload itself, and continue on forever.
     
    PierceSG likes this.
  20. psp

    psp Well-Known Member

    You misunderstood it, it will mine in the direction you place it forever, if give the power requirements.


    lel beat to it
     
    Padfoote likes this.

Share This Page