Mod Feedback ChromatiCraft questions and suggestions

Dorque

New Member
Jul 29, 2019
1,022
0
0
Everything looks correct, and the NBT confirms that all the flags are set...o_O

Double check that the runes are not supposed to be one block further out.
No luck. Pushing them one further out zeroes out the struct flag too. I also tried adjusting the y-levels, just to check.

For now, I'm going to go with "mod interaction" - we never run a completely standard pack. This one's based on DW20 but it definitely has some changes; might be the best move for now is to wait for the V4 release and see what happens. At least I can stop banging my head against the wall ;)
 

Dorque

New Member
Jul 29, 2019
1,022
0
0
No luck. Pushing them one further out zeroes out the struct flag too. I also tried adjusting the y-levels, just to check.

For now, I'm going to go with "mod interaction" - we never run a completely standard pack. This one's based on DW20 but it definitely has some changes; might be the best move for now is to wait for the V4 release and see what happens. At least I can stop banging my head against the wall ;)
Update; I got the pylon compass to build, which wasn't happening with the old altar, so there must have been something wrong there. The Heat Lily still won't go; something about putting the runes in place of the structure (which is what the Lexicon shows right now) makes the structure, um, not exist, according to the debug data (assuming I'm reading your flags right).

I'll keep experimenting.
 

Dorque

New Member
Jul 29, 2019
1,022
0
0
So I could make the first two crystal groups, but installing the runes for the last two again broke the structure; is the problem I'm facing that some of these recipes actually require a Casting Temple?
 

Dorque

New Member
Jul 29, 2019
1,022
0
0
In v3 (I think), but definitely in v4, you can replace crystalline stone with runes.
In the case of the last two crystal groups - Orange and White if I recall - it wasn't even a matter of replacing crystalline stone; they were just added on top of existing ones, along the outside edges. When I placed them though the structure flag still zeroed.

I'm about to try it with a Temple.
 

Dorque

New Member
Jul 29, 2019
1,022
0
0
2015-01-27_03.26.34.png 2015-01-27_03.26.59.png 2015-01-27_03.29.31.png 2015-01-27_03.29.35.png

Well, now, how about that?

So here's the takeaway tonight:

In v3 at least, any recipe intended to be made in a Casting Temple, if its runes are placed instead in a Casting Room (and there's no way to discern which is required from the Lexicon at this point) will actually break the Casting Room (as in, zeroes out the Struct flag).
 

Reika

RotaryCraft Dev
FTB Mod Dev
Sep 3, 2013
5,079
5,331
550
Toronto, Canada
sites.google.com
View attachment 14404 View attachment 14405 View attachment 14406 View attachment 14407

Well, now, how about that?

So here's the takeaway tonight:

In v3 at least, any recipe intended to be made in a Casting Temple, if its runes are placed instead in a Casting Room (and there's no way to discern which is required from the Lexicon at this point) will actually break the Casting Room (as in, zeroes out the Struct flag).
Heat lilies and anything else using the internal 3x3 are not intended to be made in a casting temple (though they certainly can be).
 

Dorque

New Member
Jul 29, 2019
1,022
0
0
Heat lilies and anything else using the internal 3x3 are not intended to be made in a casting temple (though they certainly can be).
Ok, well, I'm officially declaring that your problem. I just do the testing, you're the developer. ;) Heat Lilies, Orange and White Crystal Groups aren't working in the Room. I'm also finding myself unable to place anything outside the 3x3 grid in the Temple (i.e. the groups required to make a cluster.) and yes, debug shows Tier 2 and the Struct2 flag.

As a totally random aside, making an Aura Cleansing Potion to assist with searching for Tahara crystals (because Warp) is not nearly as clever an idea as I had first thought.
 

Dorque

New Member
Jul 29, 2019
1,022
0
0
It gets better in v4, where the Aura cleaner actually removes warp.
Which is a beautiful thing, make no mistake, but my biggest concern is with the black screen effect.

That's what I get for doing one single research with an insignificant amount of warp (I swear, the goat knew what it was getting into.)
 

Someone Else 37

Forum Addict
Feb 10, 2013
1,880
1,442
168
I am replacing the scramble text with this:

How does it look?

No, you will not be able to substitution-cipher it, as the letters used change based on context.
I'll support that, as long as I can still search the items in NEI so I don't have to mess around with progression in my test worlds. If I have to go through the whole progression thing just to be able to type "tree berries" into NEI and get a useful result, I'll be just a little annoyed.

In Lexicon recipe ingredient lists and other GUIs, I say go for it.
 

Reika

RotaryCraft Dev
FTB Mod Dev
Sep 3, 2013
5,079
5,331
550
Toronto, Canada
sites.google.com
I'll support that, as long as I can still search the items in NEI so I don't have to mess around with progression in my test worlds. If I have to go through the whole progression thing just to be able to type "tree berries" into NEI and get a useful result, I'll be just a little annoyed.

In Lexicon recipe ingredient lists and other GUIs, I say go for it.
One, there are commands for progression. Two, there are creative mode tabs.
 

Someone Else 37

Forum Addict
Feb 10, 2013
1,880
1,442
168
One, there are commands for progression. Two, there are creative mode tabs.
One, cool! I hope they're documented somewhere.
Two, I've found that NEI doesn't like vanilla Creative mode (it's annoying how the item panel only shows up in the Survival Inventory tab, and I've never had much luck with the search tab), so I've used Creative+ since it was introduced. But point taken.

Also, the current scramble text works fine with NEI. If I type tree berries, I get tree berries with illegible names. So it works fine as of v3d- I just hope your rune update doesn't break that.