{Alpha} Unstable Pack: Bug Reports

Discussion in 'Modpack Bugs' started by Jadedcat, Mar 8, 2014.

  1. Pallitax

    Pallitax Guest

    First: the "stuck in bed bug" (problem in the Modpack "all the mods", too) is really bad. Perhaps a problem of Quark, is reported there (because of the re-coloring possibility of the bed in this mod) but absolutely not sure if quark is the problem at all. There are older reports that this was happening in vanilla, too but they might be misleading. Second: Roots has a bug in the build-in version (no mana bar with the staff, they are not working), which is fixed in the newer version of quark, which is not part of the modpack in the moment. Perhpas time to refresh the mod-versions.... Third: a bug with the "Reservoir" block from enderio (refilling an empty bucket with water gets you 1000 buckets full of water) which is caused by IC2 as the enderio developer stated. Is reported both in enderio and IC2. The bed-bug is the main problem during normal gameplay. You have to kill the game and restart or simply only do "/t time set day" instead of sleeping to avoid this. Once even the bed was gone after restarting the game! (it was freshly build a moment before trying to sleep and it was a vanilla bed) . Happens 10-30% of the time using the bed, i feel it is happening more often after teleporting or leaving the nether and so on. Chunk loading problem?
     
    Last edited: Jul 28, 2016
  2. Pallitax

    Pallitax Guest

    additional info about the "stuck in bed" bug: https://github.com/maruohon/enderutilities/issues/22
    i am pretty sure, this is the same problem, but i has nothing to to with the charged porter, i think, but with teleporting itself. if you only play SP there is now chance to recognize that you are invisible to other players in thsi state. If you are invisible and try to sleep you get the "stuck in bed" bug. Must have to do soemthing with chunk loading not fast enough. Hope it helps.
     
  3. TantalusSama

    TantalusSama Guest

    [FTB Unstable 4.2.5]
    I don't know if it is intentional (or not implemented yet) but i am missing the hole RFTools Dimensions Stuff (except the Teleport Pads)

    Beside that, is Solar Flux (reborn) working for anybody? I have alot of Crafting Recipes but the only placeabel Objects are the cables.


    Are there some Missing Blocks or is it just me, cause on google i can't find anything fitting.
     
  4. DeathOfTime

    DeathOfTime New Member

    [4.2.5] all doors newly placed after the update would glitch or disappear when the area was loaded. Not for sure if it was related but the contents of my drawers and compacting drawers would also disappear.

    Was reading on the forge site that the door issue might be fixed in a later version of forge. Trying out version 12.18.1.2044. had to disable a mod as the game would crash on load and list it as a possible cause. Got a crash near sunset on my first day of a new save that was made after updating forge. Not for sure if that is forge, the pack, or my fault.

    Anyways, updating forge might not work. If you are experiencing the door and drawer issue and want a temp fix rolling back to a previous version might be it. As always back up your stuff and expect serious losses. This is unstable after all. (still fun to play in)

    Edit:
    Forgot I had the crash issue in another 1.10 pack. I am going to try giving the game more RAM. I have been able to run infinity and such fine off of 3GB. And this pack up until now.

    Wasn't a memory issue. Still only getting 12 FPS. the uncustomized pack I was getting 90. Which is the highest I have seen in minecraft in awhile. 12 FPS isn't actually all that bad for this PC. Turned out it crashes when I try to break the stencil table on that version of forge. Not all that important since this pack doesn't use it. Going to wait and see what the next pack update brings.
     
    Last edited: Aug 1, 2016
  5. DeathOfTime

    DeathOfTime New Member

    FTB Unstable 1.10 v4.2.5 uses a version of forge(2027) that introduces issues. (doors not saving, drawers losing contents). Updating past those issues cause other problems with the pack (charset crashing the game at launch, tinkers' stencil table crash on punching). It might work to roll back to forge version 2026 if you are having issues. I need to test a lot further(finally play the hella out of this pack, again)

    As usual backup your stuff, and pray. Whatever you decide to do.
     
  6. signupsucks

    signupsucks New Member

    The most recent Forge update, 2046, fixes the issue with certain blocks crashing when you attempt to break them (tinker's smelter basin and crafting table among others) and previous forge updates fixed the issues with doors and some other blocks disappearing (I had similar issues with storage drawers when they weren't facing north).

    If anyone is unfamiliar, see Strill's post here for instructions on manually updating forge.

    But yeah, as mentioned by DoT, updating forge will break Charset. I had to remove it completely because charset is apparently discontinued (see post by asiekierka). He mentions that its available to be forked but I didn't research further to see if someone else picked it up. I'm not entirely sure what charset even offered so it's no loss to me, but maybe other people used it.
     
    DeathOfTime likes this.
  7. DeathOfTime

    DeathOfTime New Member

    Yesterdays update to Unstable seems to be working fine. I haven't gotten very far in testing it out though. It is using 2046 and charset is even still there and working. If I was checking it properly. It looks to be the same version of charset.
     
  8. signupsucks

    signupsucks New Member

    Hmm, I didn't get a prompt when I ran the pack today about there being a newer version of unstable. Ah, I had set the launcher to 4.2.5 instead of Recommended.

    Also strange that charset is working again, but perhaps it is related forge-2046. I had seen a previous comment that the issue with breaking blocks causing crash was a result of a change AlgorithmX made in forge previously, which he then fixed in 2046, so it was possibly the same issue that broke charset entirely.
     
    DeathOfTime likes this.
  9. Lord_Gaav

    Lord_Gaav Guest

    Using the latest pack, and forge 2046 on both client and server, I still get a breaking block crash when trying to remove IC2 copper wires. The client crashes with the following stacktrace, the server doesn't crash. After reconnecting, the wires looks disconnected from the surrounding wires, but is not removed.

    Code:
    ---- Minecraft Crash Report ----
    
    WARNING: coremods are present:
      IC2core (industrialcraft-2-2.6.15-ex110.jar)
      LoadingPlugin (Quark-beta-49.jar)
      LoadingPlugin (CustomMainMenu-MC1.9.4-2.0.1.jar)
      EnderCorePlugin (EnderCore-1.10.2-0.4.1.46-beta.jar)
      LoadingPlugin (ResourceLoader-MC1.9.4-1.5.1.jar)
      FMLPlugin (InventoryTweaks-1.61-58.jar)
      TransformerLoader (OpenComputers-MC1.10.2-1.6.0.3-rc.1.jar)
      LoadingPlugin (RandomThings-MC1.10.2-3.7.5.jar)
      CoreMod (Aroma1997Core-1.9.4-1.1.0.3.jar)
      ShetiPhian-ASM (shetiphiancore-1.10.0-3.3.0.jar)
    Contact their authors BEFORE contacting forge
    
    // Oh - I know what I did wrong!
    
    Time: 06/08/16 13:18
    Description: Unexpected error
    
    java.lang.NullPointerException: Unexpected error
        at net.minecraft.client.renderer.block.model.BakedQuadRetextured.func_178217_e(BakedQuadRetextured.java:26)
        at net.minecraft.client.renderer.block.model.BakedQuadRetextured.<init>(BakedQuadRetextured.java:17)
        at net.minecraft.client.renderer.block.model.SimpleBakedModel$Builder.func_188644_a(SourceFile:114)
        at net.minecraft.client.renderer.block.model.SimpleBakedModel$Builder.<init>(SourceFile:100)
        at net.minecraftforge.client.ForgeHooksClient.getDamageModel(ForgeHooksClient.java:668)
        at net.minecraft.client.renderer.BlockRendererDispatcher.func_175020_a(BlockRendererDispatcher.java:47)
        at net.minecraft.client.renderer.RenderGlobal.func_174981_a(RenderGlobal.java:1907)
        at net.minecraft.client.renderer.EntityRenderer.func_175068_a(EntityRenderer.java:1343)
        at net.minecraft.client.renderer.EntityRenderer.func_78471_a(EntityRenderer.java:1229)
        at net.minecraft.client.renderer.EntityRenderer.func_181560_a(EntityRenderer.java:1038)
        at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:1076)
        at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:371)
        at net.minecraft.client.main.Main.main(SourceFile:124)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:483)
        at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
        at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    
    
    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------
    
    -- Head --
    Thread: Client thread
    Stacktrace:
        at net.minecraft.client.renderer.block.model.BakedQuadRetextured.func_178217_e(BakedQuadRetextured.java:26)
        at net.minecraft.client.renderer.block.model.BakedQuadRetextured.<init>(BakedQuadRetextured.java:17)
        at net.minecraft.client.renderer.block.model.SimpleBakedModel$Builder.func_188644_a(SourceFile:114)
        at net.minecraft.client.renderer.block.model.SimpleBakedModel$Builder.<init>(SourceFile:100)
        at net.minecraftforge.client.ForgeHooksClient.getDamageModel(ForgeHooksClient.java:668)
        at net.minecraft.client.renderer.BlockRendererDispatcher.func_175020_a(BlockRendererDispatcher.java:47)
        at net.minecraft.client.renderer.RenderGlobal.func_174981_a(RenderGlobal.java:1907)
        at net.minecraft.client.renderer.EntityRenderer.func_175068_a(EntityRenderer.java:1343)
        at net.minecraft.client.renderer.EntityRenderer.func_78471_a(EntityRenderer.java:1229)
    
     
  10. Lord_Gaav

    Lord_Gaav Guest

  11. Pallitax

    Pallitax Guest

    in my case 30% of a building made out of granite bricks were missing. Possibly a part made in creative, not sure if these bricks were from Botanaia. The Endoflame had the wrong texture (runic altar) breakiung them and replacing them with endoflames in crative made acrash but was not repeatable. Everyting works well after that. Simply relaced the missing blocks. First tests of the world seemed to be fine.
     
  12. Pallitax

    Pallitax Guest

    Seems to be a bug in ic2 which is fixed in the latest build (from 6. August http://jenkins.ic2.player.to/job/IC2_110/changes) , perhaps a quickfix from the Devs ? Otherwies we have to wait until next week.
    Discussion in the IC2 forum here: http://forum.industrial-craft.net/index.php?page=Thread&threadID=13096
     
    DeathOfTime likes this.
  13. TantalusSama

    TantalusSama Guest

    i tried now dozens of times to update/install the 4.2.6 Version of Unstable, but every time, after at least 10 mins i get a timeout for botania.

    I have deinstalled and cleaned all curse files, all packs, new install folders ... still same result, stops installing at botania and take about 8 mins only for the Pack Data.
    My Internet connectivity is fine, 1.5 to 2.5 MB/s is normal and working, except for unstable, other packs including botania work just fine (not 1.10.x)
     
  14. jikuja

    jikuja Launcher Dev Launcher Developer

    Zajo and DeathOfTime like this.
  15. Pallitax

    Pallitax Guest

    i have the same driver but a different graphic card and played 3-4 hours without problem. If you have installed optifine perhaps try without, else try with older verion of the pack to find out if it is the pack or the card. I cannot read your log in the thread.
     
  16. Zajo

    Zajo New Member

    I reported that bug on FTB Support (Driver crash). It didn't crash in previous versions of the pack. I did a clean reinstall of the driver and it was still crashing after ~90 minutes. Before reinstall it was crashing after 10 minutes. I tried vanilla Minecraft 1.10 and it didn't crash.

    Edit: It didn't crash today
     
    Last edited: Aug 7, 2016
  17. TantalusSama

    TantalusSama Guest

    I don't know how, but my Java (JRE 8u101) was missing and replaced with an older Version of Java 7. That said, now the installation works fine.

    Still there is no Silver Ore and Copper Ore spawning. Solar Flux Reborn has no placable Solar Panels. I dont know if there are more missing blocks, but there is no error, nothing.
     
  18. Pallitax

    Pallitax Guest

    In my SP world i do find enough copper, but almost (?) no silver, i remember to get silver powder as an additional product when pulverising lead. But copper is definitly there. I even think there are 2 sorts (dont remeber the mods in the moment)
    My world was "Quark realistic", my mine is in extreme hills position. Only out of curiosity: If you generate a new world with the setting quark realisistic, do you find copper there? i definitly find it in ground niveau or slightly beneath it.
    EDIT: I looked for it: IC2 and Forestry are making 2 types of Copper in this mod, either can be used, no difference
     
    Last edited: Aug 8, 2016
  19. Zajo

    Zajo New Member

    In my world copper is generating normally, but I can't find any silver ore.
     
  20. Pallitax

    Pallitax Guest

Share This Page