[1.7.10] TolkienCraft II - Adventure Awaits! - v2.9.5[QUESTS][ADVENTURE][NORMAL MODE]

Discussion in 'Public Packs' started by GreatOrator, Aug 24, 2014.

  1. Orma

    Orma New Member

    Zomg more towns :O. Any % on completion?

    And will they include HQM quests or just customNPC quests?
     
    Last edited: Jan 27, 2015
  2. Danteleet

    Danteleet New Member

    Hi !

    I've been trying to play this modpack since yesterday, and while it seems to run quite well overall, I'm having trouble with GUI lag, like some others have experienced.

    What this means is : Whenever i try to open my inventory, a chest, a furnace.. anything with a GUI, I have a spike that lasts anywhere from .5 to 3 seconds, and makes me stutter afterwards. Also, if i press ESC to bring up the options menu, i get extremely laggy, but if I get into a submenu such as the video or keybind settings, it's completely smooth again.

    When not in a GUI, everything is alright, I get a constant 60FPS in the starting town.

    I am currently using Fastcraft, and some JVM arguments that I found while mining this thread, but to no avail. I am not using Optifine due to missing textures, but even with it activated I still get the same issues.
    Nothing in the video settings changes the GUI spikes.
    Hiding NEI doesn't help either.

    My specs are :
    Windows 8 pro 64 bits
    i7 4790K (4GHz)
    Nvidia GTX 770
    8GB ram
    Running the game on an SSD drive

    FTBLauncher : http://i.imgur.com/F1JBMSz.png
    Advanced : http://i.imgur.com/tWYgI8M.png
    Using Java 8 Update 31 64bits

    I tried downloading other modpacks (namely, direwolf20 1.7.10, Material Energy 1.7.10, The Dark Trilogy 1.7.10, Agrarian Skies) and was not able to replicate the issue with these.

    Any suggestions are welcome. I am currently in the process of installing ubuntu to see if it's anything with win8, but this will take a while with my slow internet.

    Edit : To prove that I actually tried, i also replicated the steps described in this post :


    To no avail. My specs are obviously way higher, and I'm getting 80-100 fps in town with it (without VSYNC, which i prefer ON anyways, but that's not the subject) but Ginko talks about "little to no perceptible interaction lag", while mine is definitely perceptible and prevents me from wanting to play further.
     
    Last edited: Jan 27, 2015
  3. Orma

    Orma New Member

    Do you get that freezing all the time or does it show up after awhile?
     
    GreatOrator likes this.
  4. Danteleet

    Danteleet New Member

    I get it as soon as the game is started, and it doesn't ever fade away as the game smooths up.
     
    GreatOrator likes this.
  5. GreatOrator

    GreatOrator New Member

    Both! :)

    I have been trying to replicate, but have yet to see this in my test world. Considering what supposedly is causing the lag the only mod I can think of that might be the cause would bee the inventory tweaks mod since it directly affects the inventory or NEI
     
    Vals NoisyToys and eDilettante like this.
  6. Danteleet

    Danteleet New Member

    Is there anything i can do to help you identify the source of this lag and help you replicate it ?
     
    Vals NoisyToys and GreatOrator like this.
  7. GreatOrator

    GreatOrator New Member

    Short of eliminating mods in your install until you find the cause, not much unfortunately.
     
    Vals NoisyToys likes this.
  8. Danteleet

    Danteleet New Member

    Wow, well I did just that, removing any mod that seemed UI related.

    Turns out, the LaunchGUI mod was causing the lag. I have removed only this one and now everything is silky smooth.

    Now is it a required mod that i can make work some other way, or can I live without it ?
     
  9. GreatOrator

    GreatOrator New Member

    LaunchGUI is a mod that you can live without...it is the one that sends the one-time announcement and checks for new versions. I use it as another step to make sure I don't get some of the more common questions. I will have to report to the mod dev on that. Thank you for your help!

    EDIT: Reported to the mod dev, let's see what he says.
     
  10. Wiremash

    Wiremash New Member

    Finally a solution to my pain :D

    For some reason my framerate has just killed itself though
     
    Last edited: Jan 27, 2015
    Vals NoisyToys and GreatOrator like this.
  11. spar1819

    spar1819 New Member

    Everytime I try to launch the modpack i get this.

    Exception in thread "main" [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: java.lang.NoClassDefFoundError: scala/collection/Seq
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at java.lang.Class.forName0(Native Method)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at java.lang.Class.forName(Unknown Source)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at cpw.mods.fml.relauncher.CoreModManager.loadCoreMod(CoreModManager.java:417)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at cpw.mods.fml.relauncher.CoreModManager.discoverCoreMods(CoreModManager.java:346)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at cpw.mods.fml.relauncher.CoreModManager.handleLaunch(CoreModManager.java:214)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at cpw.mods.fml.relauncher.FMLLaunchHandler.setupHome(FMLLaunchHandler.java:90)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at cpw.mods.fml.relauncher.FMLLaunchHandler.setupClient(FMLLaunchHandler.java:67)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at cpw.mods.fml.relauncher.FMLLaunchHandler.configureForClientLaunch(FMLLaunchHandler.java:34)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at cpw.mods.fml.common.launcher.FMLTweaker.injectIntoClassLoader(FMLTweaker.java:126)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at net.minecraft.launchwrapper.Launch.launch(Launch.java:115)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: Caused by: java.lang.ClassNotFoundException: scala.collection.Seq
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at java.lang.ClassLoader.loadClass(Unknown Source)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at java.lang.ClassLoader.loadClass(Unknown Source)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: ... 11 more
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: Caused by: java.lang.NullPointerException
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182)
    [05:10:29] [main/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: ... 13 more
    please help.
     
    GreatOrator likes this.
  12. GreatOrator

    GreatOrator New Member

    Try re loading the pack...that looks like a forge mismatch possibly (though full crash log would be more helpful, and in a spoiler)
     
    eDilettante likes this.
  13. Sidreal

    Sidreal New Member

    Hi GreatOrator, I'd never heard of this pack till I saw it in FTB. Absolutely loving it, killed the troll, got some generators as a reward, and I got teleported by the ancient to somewhere I can build a base and I ran into my first real problem. I was roaming around looking for a good spot to set up shop and my world stopped loading in. I ended up having to kill minecraft as the in game effect looked like when a chunk doesn't load in right so I was planning to log out and log in to fix it but it wouldn't shut the server down either. Long story short I stripped out the soartex texture pack to make sure it wasn't that and just used vanilla textures and same thing happens whenever I approach whatever chunk is causing the problem . I investigated the console and found the following line repeated (no lie) hundreds of times.

    [Server thread/INFO] [STDERR]: [atomicstryker.ruins.common.RuinTemplateRule:doSpecialBlock:566]: Ruins Mod could not determine what to spawn for [minecraft:preserveBlock] in Ruin template: Tree_Chandelier_Sky_1v7v10.tml

    Any ideas of what I can do other than remove the fun of the Ruins mod? Thanks in advance your majesty.

    Edit: to clarify when I say the world stopped loading in I mean MC stopped generating all chunks once it hit the offending chunk.
     
    Last edited: Jan 28, 2015
  14. GreatOrator

    GreatOrator New Member

    well, temporarily you can disable the ruins mod since it does not actually add any blocks so the chunks will load, then re-enable. I may just remove that template from ruins if I get any more reports since this is the first. Glad you are enjoying the pack!
     
    Vals NoisyToys and eDilettante like this.
  15. punk_hiji

    punk_hiji New Member

    GreatOrator likes this.
  16. punk_hiji

    punk_hiji New Member

    so does anyone know how to keep chunks loaded in this modpack?
     
    GreatOrator likes this.
  17. Orma

    Orma New Member

    Railcraft anchor's

    They are powered by ender pearls, each pearl loads a 3x3(chunks) area for 12 hours. But it turns off when you go offline.
     
    GreatOrator and eDilettante like this.
  18. punk_hiji

    punk_hiji New Member

    okay thanks for the info
     
    GreatOrator and eDilettante like this.
  19. eDilettante

    eDilettante New Member

    Also dimensional anchors are available, they don't require ender pearls and you can set how many chunks they keep loaded.
     
  20. birdiegirl4444

    birdiegirl4444 New Member

    Hi all, In the Flaxbeard's Steam Power quests, the items needed for the first quest require a crucible and mold to make the brass. the second quest is for a crucible and a mold. the reward for the second quest is the molds that are required for the parts for the first quest. is this intended? it seems that these are in the wrong order. you make the molds for the 1st quest, and then you get the molds again. now you have two of the same thing. Thanks
     
    Vals NoisyToys and GreatOrator like this.

Share This Page