[1.7.10] TolkienCraft II - Adventure Awaits! - v2.9.5[QUESTS][ADVENTURE][NORMAL MODE]

Discussion in 'Public Packs' started by GreatOrator, Aug 24, 2014.

  1. GreatOrator

    GreatOrator New Member

    Short answer, the memory/fps issue is covered in the FAQ as far as selling, yes only certain npc's and certain item.

    Dislocators make for very easy transport and there is a certain npc that loves to give them out frequently in the mage tower. also, with the supplies in the library, you could easily make a mini transport hub to move around as well.

    Glad to see you worked that out, but there are also keybinds (I ionclude a keyboard layout for it in the minecraft folder) to navigate.
     
    eDilettante likes this.
  2. eDilettante

    eDilettante New Member

    I'd also try with less RAM allocated, I often find that giving more than 4GB actually creates more problems than it solves, I run this pack at 3.5GB and don't have any issues, even with resource packs loaded.

    The default keybind is 'L' to open up the NPC quest tab.

    While I'm here, @GreatOrator, having now watched dozens of playthroughs on YouTube it seems the most common problem is that despite it being mentioned in the first HQM quest, people are just not familiar with the NPCQuesting mod and even though they see that it exists they don't understand that it's actually a whole separate system. With the number of modpacks now using HQM most people are familiar with how that works, but very few packs use NPCQuests (I'd never seen it before this pack) - perhaps the first HQM quest should actually be something that explicitly forces you to open the NPC Quest journal, and read BOTH tabs of the quest to complete it - at least that way the player is aware of the NPC Quest system, how to get to it and how it works (and that it even exists), before they progress too far with the HQM quests and then have to backtrack and repeat a bunch of quests when (if) they finally stumble upon the NPC Quests. I only mention this because at least 90% of the playthroughs seem to have completely missed the NPC side of the questing for at least the first video (or ten...)
     
  3. GreatOrator

    GreatOrator New Member

    I actually plan to add some flavor text with the first quest explicitly telling players to open the custom NPC quest window...lol
     
  4. Sidreal

    Sidreal New Member

    Evening Great Orator, I tried disabling the ruins mod but it didn't help :( I did a little testing to try and figure it out to no avail, all I learned is that the earlier error message had nothing to do with it as it happens whenever one of those floating trees is around but has not effect other than spamming the FTB Launcher log it just tricked me since they seemed to coincide. The side effects of the world not rendering are a bit more.. problematic than I thought though. I ended up dying and respawned in draconis. 6K blocks from where I died. Figured oh well I'll just fly there, I have bat form for a reason. I hit a different spot where the world stopped rendering and just kept going. Turns out the chunk generation once it stops never comes back on without restarting minecraft and it prevents saving my location when I hit escape (inventory seems unaffected thankfully). The automated server backup though worked when I was only 600 blocks out so if I dodge around the spot where I know it chokes I should be able to get my stuff back. I'd post a crash log but I don't have one since the game doesn't CTD. Is there anything I can do/provide that might assist in tracking this down? I managed to get to a point where I'm just a few blocks away from where it chokes the renderer and I have attached the last minute before I forced the oddity. I've also attached a few screen shots to highlight what it actually looks like, as I said if there is anything else I can provide just let me know and I shall do my best to make it happen as in it's present state I'm afraid to spend much time doing anything since it may not get saved :(. It also occurs to me since I haven't said it out right, Other than a texture pack I have made no additions, subtractions, or mod config edits. The pack is fantastic as it is.

    2015-01-29_19.58.50.png
     

    Attached Files:

  5. wrongcoder

    wrongcoder New Member

    Hard to say based on provided information. A series of thread dumps taken every, say, 10 seconds, while flying into the problem area, then sitting there for a minute or so, might be useful. I'm not necessarily volunteering to look at the output but that'd be a good first set of data to start with.

    Pretty good looking instructions for that here: http://helpx.adobe.com/experience-manager/kb/TakeThreadDump.html You want the Java process that's using all the CPU, not the launcher window that might call itself Minecraft.jar.

    Last time I had a server hang like that, it looked like Logistics Pipes was sharing a HashMap between threads, which is a no-no, but I never got around to investigating any further.

    Never do this. Unless you're submitting a patch that includes a failing/fixed automated test, and even then, never do this. I know, I'm guilty of it all the time, too, and you probably didn't remove anything relevant this time, but still, never do this. :)
     
    eDilettante and GreatOrator like this.
  6. Sidreal

    Sidreal New Member

    My bad. My initial attempt at uploading was failing so I wanted to trim the size down. It was the same line repeated over and over so it seemed a good candidate. That said I am duly chastised (and I appreciate the nice way you did it :) ) I'll look at getting Jstack installed and see what kind of thread dumps I can get but for the moment sleep calls. Stupid work...
     
    eDilettante and GreatOrator like this.
  7. GreatOrator

    GreatOrator New Member

    So looked at the file you provided, and you're right, there is nothing that stands out. Have you tried the latest version of fastcraft (or fastcraft at all) as the only time I had issues like this in testing was chunk gen outpaced memory and processor power and would hang. Once I started using fastcraft I have not seen it since.
     
    Vals NoisyToys and eDilettante like this.
  8. Sidreal

    Sidreal New Member

    I had not tried FastCraft (hadn't heard of it to be honest) but I just installed an tested it with no change. That said I tried a few variations on graphic settings ranging from minimal to maximum and nothing seemed to help. That said with FastCraft I did notice an improvement in speed when I had everything cranked up :D. On a whim I changed my texture pack and the strangest thing happened. It tried to build the chunks that were within render range of where it hit whatever chunk is making it cry. Tried it when I was farther away and same thing BUT it's like it's stuck trying to render one chunk and won't move on until it succeeds. This seems to me to be, at least superficially, like an infinite loop so I'm going to leave the game running when I head to work in a moment, hit escape, and just let it go for the day and see what happens, maybe it just needs more time the I'm giving it(taking a backup of my world first though... just in case). Also going to give it high priority in my task manager, which as an interesting aside is definitely doing something (hovering between 9 and 12% CPU even with escape hit). I'll post results when I get home. Thanks again for all the help thus far:).

    Addendum: This also seems limited to my over world poked around middlearth for a while and it didn't seem to happen at all so I may just build my base there and set something up in Draconis as a Hub so I can still go to the nether and various other dimensions without to much trouble, I wonder if I should make it look like a mini mount doom "secret" volcano lair Sauron needs a roommate right? Might be a long trip to get out of the shire though, to many hobbits wandering in like they own the place.
     
  9. GreatOrator

    GreatOrator New Member

    Hmmm, may just ultimately be a minecraft bug at this point rather that a bug with the pack (I have had weird things happen randomly unfortunately) Middle-Earth is fine, I would just warn you that the content update you will want to stay at least 1000 chunks away from the marker of mount doom in the lotr map because of the content update coming.
     
    eDilettante and Vals NoisyToys like this.
  10. cyanidearsenic

    cyanidearsenic New Member

    Oh, wow, you know, I looked through the folders and, looking at the file I remember opening it, but I completely forgot it was there!
    Really? I always just assumed more RAM would make it run easier. I'll definitely try that, thank you.

    Thank you both for replying to quickly.
     
  11. Orma

    Orma New Member

    I got my FTB launcher set at 3.5GB .. Wont let me pull it up higher even tho i got 16GB ram :D.

    But MC still uses around 4-6gb while playing. And i have 0 problems. Only thing i have added are the arguments. And my PC is oooold.
     
  12. GreatOrator

    GreatOrator New Member

    Nice to know! though the memory limit may be due to the version of java on your pc (32 bit versus 64 bit)

    EDIT: Folks, the next update will be delayed a bit...while in the test environment buildcraft causes a crash without optifine installed and having a heck of a time figuring out why.
     
    Last edited: Jan 30, 2015
    eDilettante and Vals NoisyToys like this.
  13. Orma

    Orma New Member

    Its running with 64bit java .. But my computer hates the FTB launcher. I HAVE to use the jar file to launch FTB or my entire computer pretty much performs suicide by choking itself.

    Its some wierd ass coding with the .exe that my computer hates. Also just trying to delete the .exe makes my computer kill itself. ._.
     
    Arikast, eDilettante and GreatOrator like this.
  14. asiekierka

    asiekierka Over-Achiever Mod Developer

    Report the crash on GitHub
     
  15. GreatOrator

    GreatOrator New Member

    I will, I like to verify as best I can who is the cause of the crash before reporting. But thank you very much for paying attention! :)

    Posted to your github!
     
    Vals NoisyToys and eDilettante like this.
  16. GreatOrator

    GreatOrator New Member

    Ok folks Update submitted!
    • Update - 2.3.15
      • New Mods added
        • ClothingCraft
        • CosmeticArmor
        • TolkienTweaks (This is for future content)
      • Configs tweaked
        • Hopefully found and fixed the combustion issue
        • Turned back on warp in thaumcraft until Tinker makes it possible to open his pages without it
      • Mods Updated
        • BDLib
        • Forge
        • Applied Energistics
        • Binnie's Mod
        • Biomes O Plenty
        • Blood Magic
        • Botania
        • Carpenters Blocks
        • CustomNPC's
          • This should fix the crash some of you are getting, let me know if you see any other issues.
        • Extra Cells
        • Forestry
        • Gendustry
        • Infernal Mobs
        • ThaumCraft
        • Thaumic Energistics
        • Thaumic Exploration
        • The Camping Mod
          • This should fix the lantern Crash
        • Traveller's Gear
        • Unique Artifacts
        • Damage Indicators
        • NEI Integration
        • TiC Tooltips
        • Wawla
    • This will be the last update until the content update so I can focus on one update rather than two (unless there is some major crash issue)
     
  17. ZephyrWindSpirit

    ZephyrWindSpirit New Member

    This won't require another map download, right?
     
    Vals NoisyToys and GreatOrator like this.
  18. GreatOrator

    GreatOrator New Member

    Nope, this is simply mod updates. Only reason you would need to re-download the map would be if you get any weirdness with customNPC's (There is a new map download just in case) you'll just follow normal update process otherwise.
     
    Vals NoisyToys and eDilettante like this.
  19. Sidreal

    Sidreal New Member

    Hi Boss just got home and I was greeted by something rather interesting. A pop up from Custom NPC's letting me know about doing them in tandem with HQM (how that interrupted the escape screen I have no idea). I checked the launcher log and found a couple surprises. I Left the game on with escape hit at 06:00 and got home at 16:32 I've attached the surprisingly short log however at 08:51, 10:12, 12:06, and 14:39 There were some things thrown that weren't server backup messages which was all I had expected to see but Java killed my inner child so what do I know :p.

    Now all I need to do is set up a small hub and get to Middle Earth for base building no where near Mordor... Probably take me most of the night just to get out of the shire.. common morph earn your keep and find me somewhere nice.
     

    Attached Files:

    eDilettante and GreatOrator like this.
  20. Orma

    Orma New Member

    Sidreal - You can teleport to any of the locations in the shire, there is also one really close to the edge of another region.
     

Share This Page