MPS Support Thread

INCSlayer

Well-Known Member
Nov 17, 2012
185
48
53
i have flight control on the helmet do i have to put it inot hover mode? , but i guess i will put the jumpjets on the boots, next time i was think i might be the weight that was making me so slow. some times i just put on the regualer jetpack to get around faster.
to enable the flight control you have to set a keybinding for it from the mps keybinding menu which defaults to k on your keyboard
 

Vaygrim

New Member
Jul 29, 2019
533
0
0
I set my jetpack and flight control to the same keybind, so it gets turned on every time I start flying. Makes control a lot simpler.
 

im4u2nv000

New Member
Jul 29, 2019
4
0
0
ok have a running error with the unleashed 1.0.3

and no I do not have optifine

2013-07-28 12:09:17 [WARNING] [MMMPS-CLIENT] Loading shaders failed!
2013-07-28 12:09:17 [INFO] [STDERR] java.lang.ExceptionInInitializerError
2013-07-28 12:09:17 [INFO] [STDERR] at net.machinemuse.utils.render.MuseShaders.hBlurProgram(MuseShaders.scala)
2013-07-28 12:09:17 [INFO] [STDERR] at net.machinemuse.powersuits.client.ClientProxy.registerRenderers(ClientProxy.java:91)
2013-07-28 12:09:17 [INFO] [STDERR] at net.machinemuse.powersuits.common.ModularPowersuits.load(ModularPowersuits.java:152)
2013-07-28 12:09:17 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2013-07-28 12:09:17 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] at java.lang.reflect.Method.invoke(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:494)
2013-07-28 12:09:17 [INFO] [STDERR] at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] at java.lang.reflect.Method.invoke(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.EventBus.post(EventBus.java:267)
2013-07-28 12:09:17 [INFO] [STDERR] at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:192)
2013-07-28 12:09:17 [INFO] [STDERR] at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:172)
2013-07-28 12:09:17 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2013-07-28 12:09:17 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] at java.lang.reflect.Method.invoke(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
2013-07-28 12:09:17 [INFO] [STDERR] at com.google.common.eventbus.EventBus.post(EventBus.java:267)
2013-07-28 12:09:17 [INFO] [STDERR] at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:103)
2013-07-28 12:09:17 [INFO] [STDERR] at cpw.mods.fml.common.Loader.initializeMods(Loader.java:691)
2013-07-28 12:09:17 [INFO] [STDERR] at cpw.mods.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:213)
2013-07-28 12:09:17 [INFO] [STDERR] at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:448)
2013-07-28 12:09:17 [INFO] [STDERR] at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)
2013-07-28 12:09:17 [INFO] [STDERR] at net.minecraft.client.Minecraft.run(Minecraft.java:733)
2013-07-28 12:09:17 [INFO] [STDERR] at java.lang.Thread.run(Unknown Source)
2013-07-28 12:09:17 [INFO] [STDERR] Caused by: java.lang.RuntimeException: Error creating shader: ERROR: 0:? : 'gl_ModelViewProjectionMatrix' : variable is not available in current GLSL version
2013-07-28 12:09:17 [INFO] [STDERR] ERROR: 0:? : 'gl_Vertex' : variable is not available in current GLSL version
2013-07-28 12:09:17 [INFO] [STDERR] ERROR: 0:? : 'gl_MultiTexCoord0' : variable is not available in current GLSL version
2013-07-28 12:09:17 [INFO] [STDERR] ERROR: 0:? : 'gl_MultiTexCoord0' : variable is not available in current GLSL version
2013-07-28 12:09:17 [INFO] [STDERR]
2013-07-28 12:09:17 [INFO] [STDERR]
2013-07-28 12:09:17 [INFO] [STDERR] at net.machinemuse.utils.render.ShaderProgram.mk(ShaderProgram.scala:72)
2013-07-28 12:09:17 [INFO] [STDERR] at net.machinemuse.utils.render.ShaderProgram.<init>(ShaderProgram.scala:18)
2013-07-28 12:09:17 [INFO] [STDERR] at net.machinemuse.utils.render.MuseShaders$.<init>(MuseShaders.scala:13)
2013-07-28 12:09:17 [INFO] [STDERR] at net.machinemuse.utils.render.MuseShaders$.<clinit>(MuseShaders.scala)
2013-07-28 12:09:17 [INFO] [STDERR] ... 34 more
 

LucasRo7

New Member
Jul 29, 2019
1
0
0
I had a crash few minutes ago in infamy modpack 1.5.2,
i'm uploading the crash report(*\Roaming\Infamy\minecraft\crash-reports)
the bug happens when minecraft has to render the armor(in inventory screen and F5 mode)
 

Attachments

ThatOneGuy

New Member
Jul 29, 2019
21
0
0
Not sure if this is the right place, considering it might be an MPSA bug, and involves Thaumcraft, but it is an exploit so ehh...

Break open the spoiler at your own peril!
Modular Powersuits 0.7.1-573
MPSA-176 (Requires MPS561+)

Using the Shears module (which isn't the Blade Launcher module) for the Power Fist and using it to break Cinderpods or Shimmerleaves in the world will drops both the preserved plant and the expected byproduct of Blaze Power/Quicksilver, One can simply keep replacing the plant and break it over and over again to farm infinite amounts of Blaze Power/Quicksilver.

Testing with vanilla shears and the Blade Launcher module confirm only the Shears module can do this.
My theory is that Muse is having the shears module "silk touch" things to grab them. If so, then silk touch enchanted shears would do the same thing.
 

haisho

New Member
Jul 29, 2019
72
0
0
Nope! Just tested Shears enchanted with Silk Touch, but it just yields the plant and no byproduct.
 

Andyb

New Member
Jul 29, 2019
1
0
0
in what seems to be any version of modular power suits for 1.5, 534 in this specific instance, i get extreme lag when i have the mod installed, i get around 1-3 fps at the most when it is installed even without any amour equipped, then when i uninstall the mod i get 40-50 fps, could post the computer specs or other stuff it that would help.
 

TurbanMasher

New Member
Jul 29, 2019
1
0
0
Im not sure if this is supposed to happen when i equip the power tool ..... the screen gets buggy and starts flashing crazy and all sorts of other weird things.
I'm getting this same thing, DW20 1.5.2 modpack. No optifine. Seems like a pretty big bug to ignore machinemuse.
 

einsteinsci

New Member
Jul 29, 2019
109
0
0
I have seen the website warning about the use of optifine. I tried disabling everything related to the custom font engine through the powersuits config, just as the warning also says, since my computer is VERY laggy without optifine. Ingame, nothing changes, I still have the fonts bug and when I roll over modules in the tinker table, the custom font still appears. Is there a way to have optifine without this bug?
 

haisho

New Member
Jul 29, 2019
72
0
0
I have seen the website warning about the use of optifine. I tried disabling everything related to the custom font engine through the powersuits config, just as the warning also says, since my computer is VERY laggy without optifine. Ingame, nothing changes, I still have the fonts bug and when I roll over modules in the tinker table, the custom font still appears. Is there a way to have optifine without this bug?
Could be that MPS uses a completely different rendering method for its UI. It would explain the incompatibility with Optifine.
My key binds seem to be erased every time I close the window. Weird.
Define close the window.

If it's just closing the keybinding UI in Minecraft, I have no idea how to fix that because I've never seen it.
If it's closing and restarting Minecraft, there are two things I can think of:

- Minecraft doesn't want to remember you made keybinds for MPS. Just reopen the keybinding UI and close it, and you should be fine.
- MPS actually erased your keybinds when you restarted Minecraft. The only instance in which I've had this occur to me is when it's using an already occupied keybind, such as using F for both toggling MPS Jetpacks and Gravisuit flight. Only solution I have for now is to change the offending keybind so that it's open.
 

mushroom taco

New Member
Jul 29, 2019
571
0
0
- MPS actually erased your keybinds when you restarted Minecraft. The only instance in which I've had this occur to me is when it's using an already occupied keybind, such as using F for both toggling MPS Jetpacks and Gravisuit flight. Only solution I have for now is to change the offending keybind so that it's open.
Ah. alright, ill try that.
 

DragonsLover

New Member
Jul 29, 2019
12
0
0
I don't know if it has been reported before, but all the items in MMMPowersuits are all messed up, having wrong icons:

http://www.mediafire.com/view/xpcbds6f20hzaxp/2013-08-02_01.14.23.png

I'm using Direwolf20_1_5 v1.1.1. Optine is installed, BUT the new font engine has been disabled. I tried disabling Optifine and the problem above persists, meaning that it's a problem related with the mod pack itself. Is there some kind of way to fix it or, if not, will you fix it please?
 

einsteinsci

New Member
Jul 29, 2019
109
0
0
Could be that MPS uses a completely different rendering method for its UI. It would explain the incompatibility with Optifine.
I can't disable the font engine, I know that's what the compatibility issue is coming from, but it isn't disabling. mmmPowersuits.cfg:

...
####################
# font
####################

font {
B:"Font Anti-Aliasing"=false
I:"Font Detail Multiplier"=4
S:"Font URI"=/mods/mmmPowersuits/fonts/cra.ttf
S:"Native Font Name (Overrides URI)"=
B:"Use Custom Font Engine"=false
}
...

Also, I can't find any recoloring module. It doesn't show up at the tinker table. Is it done using a separate interface? For now, I'm stuck with a white powersuit.
 

mushroom taco

New Member
Jul 29, 2019
571
0
0
I can't disable the font engine, I know that's what the compatibility issue is coming from, but it isn't disabling. mmmPowersuits.cfg:

...
####################
# font
####################

font {
B:"Font Anti-Aliasing"=false
I:"Font Detail Multiplier"=4
S:"Font URI"=/mods/mmmPowersuits/fonts/cra.ttf
S:"Native Font Name (Overrides URI)"=
B:"Use Custom Font Engine"=false
}
...

Also, I can't find any recoloring module. It doesn't show up at the tinker table. Is it done using a separate interface? For now, I'm stuck with a white powersuit.
Default key to change appearance is l
 

Teralius

New Member
Jul 29, 2019
3
0
0
I'm also having the problem with MPS interfaces. After using Tinker Table or "L" key interface it stays on the screen and it becomes impossible to play. No optifine installed. Font disabling didn't work too. But my friend doesn't have such bug though we have the same modpacks. Confirmed on DW20 1.5.2 pack and Unhinged 1.5.2 pack.
I hope you will look into this case, MachineMuse, because it is really great mod.
 

mushroom taco

New Member
Jul 29, 2019
571
0
0
I'm also having the problem with MPS interfaces. After using Tinker Table or "L" key interface it stays on the screen and it becomes impossible to play. No optifine installed. Font disabling didn't work too. But my friend doesn't have such bug though we have the same modpacks. Confirmed on DW20 1.5.2 pack and Unhinged 1.5.2 pack.
I hope you will look into this case, MachineMuse, because it is really great mod.
He can't look into it because you didn't post anything helpful.
When reporting a bug like this it is important to post forge logs and screenshots
 

Teralius

New Member
Jul 29, 2019
3
0
0
He can't look into it because you didn't post anything helpful.
When reporting a bug like this it is important to post forge logs and screenshots
There are no crash logs, because mc doesn't crash. It only freezes the whole screen except for little window and it looks like screenshot already posted before. I just hoped that at least quantity of people with such problem would turn MachineMuse's attention to this.
 

mushroom taco

New Member
Jul 29, 2019
571
0
0
There are no crash logs, because mc doesn't crash. It only freezes the whole screen except for little window and it looks like screenshot already posted before. I just hoped that at least quantity of people with such problem would turn MachineMuse's attention to this.
Where did I say crash logs?