MPS Support Thread

Teralius

New Member
Jul 29, 2019
3
0
0
Where did I say crash logs?
http://pastebin.com/XfLc63g3
https://www.dropbox.com/s/59me4sgwr6upgmy/Безымянный.png
The console log and screenshot.
Also, after reading this thread: https://github.com/jlmwas/MachineMusePowersuits/commit/6db8b0b31f7e8160af22c2fafa63fc3e991fb7e8
I looked into some files and found that I don't have the whole line of code in question. which is

GL11.glPushAttrib(GL11.GL_ENABLE_BIT | GL11.GL_SCISSOR_BIT);
But I don't know how to work in java(
I hope this information will be useful.
 

mushroom taco

New Member
Jul 29, 2019
571
0
0
http://pastebin.com/XfLc63g3
https://www.dropbox.com/s/59me4sgwr6upgmy/Безымянный.png
The console log and screenshot.
Also, after reading this thread: https://github.com/jlmwas/MachineMusePowersuits/commit/6db8b0b31f7e8160af22c2fafa63fc3e991fb7e8
I looked into some files and found that I don't have the whole line of code in question. which is

GL11.glPushAttrib(GL11.GL_ENABLE_BIT | GL11.GL_SCISSOR_BIT);
But I don't know how to work in java(
I hope this information will be useful.
Again, I said forge log.
It can be found in your minecraft/ftb folder (whatever you play on)
 

MisterBossFTW

New Member
Jul 29, 2019
2
0
0
Okay guys so I am having a huge issue with PowerSuits. I have also Re-Downloaded my ModPack & no luck so far. I even checked DW20's New ModPack.
When I Open The PowerSuit Tinker Table this happens (Also when I hit "K" (Default Bind Key))
Broken Interface.png
I Re-Opened The Interface & got this.
Interface Glitch.png
I also get this when I have a Power Fist in my inventory
Inv. Cut-Off.png
I have to restart my client in order to fix this & everyone knows how tedious that can be seeing there is so much in there to load
I don't know why this happens & I haven't seen anything online about it so I think it's only me but could you please help me?
 

MisterBossFTW

New Member
Jul 29, 2019
2
0
0
Wait...what? How does that help me? I'm a little new to this whole thing. Can I get some more in-depth help with this?
 

Frankyathell

New Member
Jul 29, 2019
1
0
0
Hey there,

just signed up for this thread and got the same problem as MisterBossFTW.
Tryed it with Unleashed, Direwolf, Unhinged and Amp'z Mod. It seems to be that this bug is coming with minecraft 1.5.2
I hope this is the right File that you need for analyse the Problem. Screenshots are given by MisterBossFTW already.

I also tryed it on my other Computer which has a totaly different Graphic card to eleminate driver Problems but there's the same Problem.
 

Attachments

Gottfridsson

New Member
Jul 29, 2019
3
0
0
Feature? Noticed in passing that running over ice slows me down, most likely to whatever speed vanilla mc thinks ice should be, way slower than the suit allows. Then made the mistake of replacing much used walkways with "road" blocks and they do the same... ie most likely vanilla ice speeds. would be nice if ice and similar blocks boosts speed not sets a preset speed. Not really this mod to decide/fix/amend but it is affecting power leg running. :-D

Nice mod, good job!
 

Taco-Man

New Member
Jul 29, 2019
2
0
0
Is there a way to permanently lower the protections from the armor plating/energy field? Everytime I boot up the server the settings I adjusted don't seem to work.
 

Blaster_V16

New Member
Jul 29, 2019
1
0
0
Hello, I'm having the same trouble as MisterBossFTW and FrankyAtHell. I play the DW20 mod pack on Win Vista SP2 64bit, with both 32 and 62bit java installed. I have (hopefully) attached my forge logs. If you need any other info let me know, I'm more than happy to help.
 

Attachments

daraku_dakara

New Member
Jul 29, 2019
31
0
0
the best way is to change the config for the server, and then distribute the config file to the users. To make sure that everyone has matching files.
 

hirole

New Member
Jul 29, 2019
1
0
0
2013-08-08_13.16.39.png2013-08-08_13.16.40.png2013-08-08_13.16.42.png2013-08-08_13.16.39.png2013-08-08_13.16.40.png2013-08-08_13.16.42.png I am having the same issue and noticed this in the console.
2013-08-14 16:58:19 [WARNING] [MMMPS-CLIENT] Loading shaders failed!
2013-08-14 16:58:19 [INFO] [STDERR] java.lang.ExceptionInInitializerError
2013-08-14 16:58:19 [INFO] [STDERR] at net.machinemuse.utils.render.MuseShaders.hBlurProgram(MuseShaders.scala)
2013-08-14 16:58:19 [INFO] [STDERR] at net.machinemuse.powersuits.client.ClientProxy.registerRenderers(ClientProxy.java:91)
2013-08-14 16:58:19 [INFO] [STDERR] at net.machinemuse.powersuits.common.ModularPowersuits.load(ModularPowersuits.java:152)
2013-08-14 16:58:19 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2013-08-14 16:58:19 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] at java.lang.reflect.Method.invoke(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:494)
2013-08-14 16:58:19 [INFO] [STDERR] at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] at java.lang.reflect.Method.invoke(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.EventBus.post(EventBus.java:267)
2013-08-14 16:58:19 [INFO] [STDERR] at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:192)
2013-08-14 16:58:19 [INFO] [STDERR] at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:172)
2013-08-14 16:58:19 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2013-08-14 16:58:19 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] at java.lang.reflect.Method.invoke(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
2013-08-14 16:58:19 [INFO] [STDERR] at com.google.common.eventbus.EventBus.post(EventBus.java:267)
2013-08-14 16:58:19 [INFO] [STDERR] at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:103)
2013-08-14 16:58:19 [INFO] [STDERR] at cpw.mods.fml.common.Loader.initializeMods(Loader.java:691)
2013-08-14 16:58:19 [INFO] [STDERR] at cpw.mods.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:213)
2013-08-14 16:58:19 [INFO] [STDERR] at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:448)
2013-08-14 16:58:19 [INFO] [STDERR] at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)
2013-08-14 16:58:19 [INFO] [STDERR] at net.minecraft.client.Minecraft.run(Minecraft.java:733)
2013-08-14 16:58:19 [INFO] [STDERR] at java.lang.Thread.run(Unknown Source)
2013-08-14 16:58:19 [INFO] [STDERR] Caused by: java.lang.RuntimeException: Error creating shader: 0(1) : error C0201: unsupported version 150
2013-08-14 16:58:19 [INFO] [STDERR] 0(2) : warning C7532: global type vec2 requires "#version 100" or later
2013-08-14 16:58:19 [INFO] [STDERR] 0(5) : warning C7532: global variable gl_Position requires "#version 100" or later
2013-08-14 16:58:19 [INFO] [STDERR]
2013-08-14 16:58:19 [INFO] [STDERR] at net.machinemuse.utils.render.ShaderProgram.mk(ShaderProgram.scala:72)
2013-08-14 16:58:19 [INFO] [STDERR] at net.machinemuse.utils.render.ShaderProgram.<init>(ShaderProgram.scala:18)
2013-08-14 16:58:19 [INFO] [STDERR] at net.machinemuse.utils.render.MuseShaders$.<init>(MuseShaders.scala:13)
2013-08-14 16:58:19 [INFO] [STDERR] at net.machinemuse.utils.render.MuseShaders$.<clinit>(MuseShaders.scala)
2013-08-14 16:58:19 [INFO] [STDERR] ... 34 more
 
  • Like
Reactions: sztamfater

eupraxo

New Member
Jul 29, 2019
6
0
0
Issue: Had the armor on for a while and then at some point it stopped displaying. I can use all the features (gliding, etc), but the armor isn't visible at all. I cheated myself a new set and it seems to display fine. Tried everything I could to try to replicate the issue, but I haven't been able to yet (put it on an armor stand, etc).

FTB Unleashed, standard launcher and client.
 

Omegatron

Well-Known Member
Mar 29, 2013
544
371
78
England
Issue: Had the armor on for a while and then at some point it stopped displaying. I can use all the features (gliding, etc), but the armor isn't visible at all. I cheated myself a new set and it seems to display fine. Tried everything I could to try to replicate the issue, but I haven't been able to yet (put it on an armor stand, etc).

FTB Unleashed, standard launcher and client.
Have you tried pressing L and checking if the armour is set to be visible?
 
  • Like
Reactions: Pokefenn

Magma4Lava

New Member
Jul 29, 2019
7
0
0
i have a big issue on MPS 0.7.0-534. i have the Direwolf20 1.5.2 mod pack, and i hate the crash that occurs when I put on my Power Helmet. On the previous update of the modpack, i had MPS 0.7.1-555 (or something close to it), and i found that it was much better in terms of not crashing then the previos version. could someone tell me the best version of MPS that I should get? it's for 1.5.2.[DOUBLEPOST=1377748876][/DOUBLEPOST]i have a big issue on MPS 0.7.0-534. i have the Direwolf20 1.5.2 mod pack, and i hate the crash that occurs when I put on my Power Helmet. On the previous update of the modpack, i had MPS 0.7.1-555 (or something close to it), and i found that it was much better in terms of not crashing then the previos version. could someone tell me the best version of MPS that I should get? it's for 1.5.2.
 

kurogane520

New Member
Jul 29, 2019
2
0
0
I dont know if this has been asked before but, it seems that the powertool and the powersuit drain energy from other tools first before draining its own energy.
example:

I have a chainsaw in my inventory and a mining laser. Shooting a plasma ball or flying around in a jetpack seems to drain EU from the chainsaw and mining laser up to the point where they lose all EU before draining energy from the armor or powertool itself.

is this intentional?
 

Omegatron

Well-Known Member
Mar 29, 2013
544
371
78
England
I dont know if this has been asked before but, it seems that the powertool and the powersuit drain energy from other tools first before draining its own energy.
example:

I have a chainsaw in my inventory and a mining laser. Shooting a plasma ball or flying around in a jetpack seems to drain EU from the chainsaw and mining laser up to the point where they lose all EU before draining energy from the armor or powertool itself.

is this intentional?
The powersuit and tool can draw power from all chargeable items in your inventory (I think).
 

kurogane520

New Member
Jul 29, 2019
2
0
0
The powersuit and tool can draw power from all chargeable items in your inventory (I think).
that doesn't seem like a good thing, I remember in an older version of FTB this didnt use to happen. Is there a way to make it that it doesnt draw power from other tools? or atleast draw from those tools last?