Unsupported Direwolf 20: 1.6.4 {PUBLIC BETA}

Status
Not open for further replies.

Bushido

New Member
Jul 29, 2019
78
0
1
excatly having this issues too, clicking computer monitor will show up aspect:79: , attempt blah blah blah error on screen,
really scratching my head and got no idea what's going on.

the button api is working in my another computer,since that is portal control system form dire which using in forgecraft1 1.6.4
not sure is there something change in computercraft or open peripheral mod

Yea it is weird. The aspects don't show up but the refresh button is still visible. Also the Full error is aspects:79: attempt to index ? (a nill value)
I'm guessing it is a problem with the index part of the code but i don't know why it would crash now. Here is the code if anyone can figure it out http://pastebin.com/5Hz1vg7e
 

Paulbunion

New Member
Jul 29, 2019
7
0
0
Mod Pack: Direwolf20 1.6.4 v1.0.23
Mod: BoP
Whats the bug?: Haven't found any BoP gems in my overworld gen. Been playing this map since the start of the series, and started using ender quarries as of v1.0.19. But whether I was mining by hand, or by quarry I have yet to see even 1 BoP gem drop. Currently testing in a new creative world to see if ores are similarly absent using both ender and bc quarries.
Repeatable: N/A
Known Fix:...

Edit: Confirmed in a new creative world after checking multiple biomes with both ender and bc quarries no BoP gems were found.
 
Last edited:

Deathzore

New Member
Jul 29, 2019
6
0
1
Mod Pack: Direwolf20 1.6.4 v1.0.23
Mod: BoP
Whats the bug?: Haven't found any BoP gems in my overworld gen. Been playing this map since the start of the series, and started using ender quarries as of v1.0.19. But whether I was mining by hand, or by quarry I have yet to see even 1 BoP gem drop. Currently testing in a new creative world to see if ores are similarly absent using both ender and bc quarries.
Repeatable: N/A
Known Fix:...

Edit: Confirmed in a new creative world after checking multiple biomes with both ender and bc quarries no BoP gems were found.
A temporary workaround for this would be to use a laser drill from MFR, they generate plenty of the gem ores when using the proper foci.
 

tommy3244

New Member
Jul 29, 2019
12
0
0
Mod Pack: Direwolf20
Mod & Version: Openblocks (I think)
Pastebin link to crash log: No crash, but a misbehavior
Whats the bug? When a player dies by an explosion, many of their items are gone. I assume this is due to OpenBlocks placing a grave then that grave being destroyed by the explosion which then goes on to destroy many of the item entities
Can it be repeated? Die by a creeper in survival mode
Known Fix: None

Note: Just tested, this is not a bug with vanilla.
 

Ieldra

Popular Member
Apr 25, 2014
1,810
733
129
Mod Pack: Direwolf20 1.6.4 v1.0.21
Mod: Portal Gun, possible interaction with ChickenChunks
Pastebin link to crash log: No crash.
The problem: Displaced terrain, possibly whole chunks. I first observed this when part of my base was replaced by stone or air for no apparent reason. I tried moving out this and that from the chunk, and it turned out when I placed my portals into a different chunk, that chunk would be affected by the "displaced terrain" effect. I haven't checked this yet, but it's possible that the terrain is switched between the chunks where the different ends of the portal reside.
Can it be repeated? Not reliably, unfortunately, but eventually it will happen. This may be connected to a mod pack update (this never happened in 1.0.19) or to the fact that I recently backed up my world and restored it a few times for testing purposes.
Known Fix: None
 

Ghost_Of_Sparta

New Member
Jul 29, 2019
1
0
0
Modpack: Direwolf20
Mod&Version:Thermal expansion-3.0.0.2
Pastebin:In game not a crash....

Whats the bug? When you put a fluiduct and install a Pnematic servo Liquid filter doesn't work sometimes, For example when you put Molten gold inside of the filter there would be no change not just to this liquid but every single liquid

Known fix: None
 

Internuntius

New Member
Jul 29, 2019
215
0
0
Mod Pack: Direwolf20
Mod & Version: the hole dw20 1.21
Pastebin link to crash log: The launcher creates no
Whats the bug? Whenever I start a single player game or joine on a server ... the client closes after more than 5 seconds.
Can it be repeated? yes
Known Fix: No one knows because what
 

sivina

New Member
Jul 29, 2019
21
0
1
Yea it is weird. The aspects don't show up but the refresh button is still visible. Also the Full error is aspects:79: attempt to index ? (a nill value)
I'm guessing it is a problem with the index part of the code but i don't know why it would crash now. Here is the code if anyone can figure it out http://pastebin.com/5Hz1vg7e

Finally discovered the case of this,
It is cause form thaumic tinkerer update in 1.0.22
build 138

  • Made OpenPeripheral compatibility changes Warning: Jar and Other Aspect containers computer craft API has changed, please check wiki

The Api changes break the codes i think, since i can't find the new api information about the changes, i have switch back to thaumic tinkererbuild 103 for the essential system working again:(
 

iRealWilliam

New Member
Jul 29, 2019
20
0
0
Mod Pack: Direwolf20
Mod & Version: OpenBlocks
Pastebin link to crash log: no crash
Whats the bug? Traveling by the openblocks elevator removes xp
Known Fix: None, yet =)
 

McJty

Over-Achiever
Mod Developer
May 13, 2014
2,015
2,519
228
twitter.com
Mod Pack: Direwolf20
Mod & Version: OpenBlocks
Pastebin link to crash log: no crash
Whats the bug? Traveling by the openblocks elevator removes xp
Known Fix: None, yet =)

This is actually a default setting in the openblocks config but can be disabled easily.
 

Anaerin

New Member
Jul 29, 2019
62
0
0
Mod Pack: Direwolf20 1.0.23
Mod & Version: OpenBlocks
Pastebin link to crash log: no crash
Whats the bug? Openblocks Elevators don't work after the first jump.
Known Fix: None.

Placing down two elevators works the first time you use them. But the second (and subsequent) time, nothing happens.


EDIT: Ignore me. Apparently they require XP now, and I didn't have quite enough.
 
Last edited:

Jugg3rV

New Member
Jul 29, 2019
213
0
0
Mod Pack Version: 1.0.23
Mod & Version: industrialcraft-2_2.0.354-experimental
Pastebin link to crash log: no crash
Error Message:
[IC2] EnergyNet.addTileEntity: p[email protected]662e0ec3 (p[email protected]662e0ec3) is conflicting with p[email protected]59cb589d using the same position (already added, prev. te not removed, overlapping), aborting
Whats the bug? This causes the energynet to disconnect all IC2 items. Cable won't connect, power won't flow. All items have to be removed and placed again. This happens after changing dimensions.
Known Fix / Workaround: Don't switch dimensions ;P - hopefully a update to IC2 / MFR might help
 

Henry Link

Popular Member
Dec 23, 2012
2,601
553
128
USA - East Coast
Finally discovered the case of this,
It is cause form thaumic tinkerer update in 1.0.22
build 138

  • Made OpenPeripheral compatibility changes Warning: Jar and Other Aspect containers computer craft API has changed, please check wiki

The Api changes break the codes i think, since i can't find the new api information about the changes, i have switch back to thaumic tinkererbuild 103 for the essential system working again:(

The best fix is update the code to match the API changes. Just change the scanEssentia function to what I have below should fix it. I learned a lot about how to use the modems and the open peripherals API to make the needed chagnes.

Code:
function scanEssentia()
  for i,j in ipairs(jars) do
    if peripheral.getType(j) == "tilejar" then
       pw = peripheral.wrap(j)
      asp = pw.getEssentiaType('front')
       countasp = pw.getEssentiaAmount('front')
      if countasp > 0 then
          essentia[asp] = math.floor(countasp)
      end
     end
  end
end

For those of you that want the pastebin you get can get it here:
http://pastebin.com/HQFndnaa
 
  • Like
Reactions: sivina

sivina

New Member
Jul 29, 2019
21
0
1
The best fix is update the code to match the API changes. Just change the scanEssentia function to what I have below should fix it. I learned a lot about how to use the modems and the open peripherals API to make the needed chagnes.

Code:
function scanEssentia()
  for i,j in ipairs(jars) do
    if peripheral.getType(j) == "tilejar" then
       pw = peripheral.wrap(j)
      asp = pw.getEssentiaType('front')
       countasp = pw.getEssentiaAmount('front')
      if countasp > 0 then
          essentia[asp] = math.floor(countasp)
      end
     end
  end
end

For those of you that want the pastebin you get can get it here:
http://pastebin.com/HQFndnaa

Thank you sir :)
You make my day!

Should really get your codes while i back home :)

Tapatalk を使用して私の GT-N7105 から送信
 

Bushido

New Member
Jul 29, 2019
78
0
1
The best fix is update the code to match the API changes. Just change the scanEssentia function to what I have below should fix it. I learned a lot about how to use the modems and the open peripherals API to make the needed chagnes.

Code:
function scanEssentia()
  for i,j in ipairs(jars) do
    if peripheral.getType(j) == "tilejar" then
       pw = peripheral.wrap(j)
      asp = pw.getEssentiaType('front')
       countasp = pw.getEssentiaAmount('front')
      if countasp > 0 then
          essentia[asp] = math.floor(countasp)
      end
     end
  end
end

For those of you that want the pastebin you get can get it here:
http://pastebin.com/HQFndnaa

Thanks it works, but i noticed another bug with the catalog turtle. It was repeatedly scanning the same bean over and over before the fix and now it gives an error catalog:12: attempt to call nil
here is the catalog code btw if you can figure that one out too :p
 
Last edited:

Henry Link

Popular Member
Dec 23, 2012
2,601
553
128
USA - East Coast
Thanks it works, but i noticed another bug with the catalog turtle. It was repeatedly scanning the same bean over and over before the fix and now it gives an error catalog:12: attempt to call nil
here is the catalog code btw if you can figure that one out too :p

I'll check the turtle on my server that is doing this function sometime this weekend. In the meantime can you post a pastebin of your turtle code?
 

HangingLotus

New Member
Jul 29, 2019
138
0
0
i dont know if this is intended or not but the Opis map mod is in the enabled and disabled list at the same time. something else that is rather odd is in the mods folder where the pack is stored on my pc i noticed a "Disabled" Opis file (Opis.DISABLED). this is from the update to 1.0.23. i know this is not in the right format but its not related to the pack (although if you add in one of the other map mods you end up with two maps in-game). this could also be a problem with the launcher. for the time being i deleted the opis mod from the folder as i dont want to run into additional problems.
 

DarkInsanePyro

New Member
Jul 29, 2019
2
0
0
Mod Pack: Direwolf20 1.6.4 1.0.23
Mod & Version: Unknown
Crash Log: Not Applicable
Repeatable? Same World: Yes, New World: Unknown
Known Fix:

Operating Specifications:
Memory Allocated: 5GB
Memory Used (Nominal): 3.2GB
CPU Type/Speed: AMD/~3.4GHz
CPU Usage (Nominal): 6%*
* during normal operation, full usage of core of CPU during issue

Issue:
Upon upgrading a server from 1.0.21 to 1.0.23 we have observed unstable tick rates in the server. Initially the server appears to behave normally but after approximately 30 minutes of normal gameplay the server introduces spikes of lag (tick time goes from ~25mS to ~1000mS) then rapidly drops back to normal tick timings. After a few cycles of this behavior changes. The tick duration will increase to and in excess of 1000mS and maintain it indefinitely with only slight oscillations.

Research:
Attempted to locate faulting mod via. Opis with no success. Opis tracked normal tick durations for different parts of the game (net tick time of 20mS) but final tick time of excess of 1000mS. The following categories were searched for anonomous timings with no luck:
TileEntity Timing, Chunk Timing, EventHandler Timing.
Direwolf20_1.6.4_1.0.23_LagIssue.png

It seems there is some code running away in execution duration but said code is not registered in the profiler. Has anyone experienced this when updating to this version of Direwolf20 1.6.4?
 
Last edited:

DutchGiant

New Member
Jul 29, 2019
2
0
0
Mod Pack: Direwolf20
Mod & Version: 1.0.23 - Applied Energistics (rv14-finale3)
Pastebin link to crash log: No crash
Whats the bug? Ever since the upgrade to version 1.0.23 my Quantum Network Bridge isn't working properly anymore, my ME system on the non controller side can't communicate with the controller and thus is useless.
Can it be repeated? Tried rebuilding the bridge and use newly created singularities in it - nothing worked.
Known Fix:
 
Status
Not open for further replies.