Unsupported Direwolf 20: 1.6.4 {PUBLIC BETA}

Discussion in 'Modpack Bugs' started by Jadedcat, Dec 10, 2013.

Thread Status:
Not open for further replies.
  1. Jadedcat

    Jadedcat New Member

    WARNING : This pack is a Public Beta with any luck nothing major will change in the next 3 weeks. ID's should be stable. However it is completely possible that something could go horrible wrong you may find a catastrophic bug the test team missed and you might lose a few things. Projected time to full release status - 3 weeks.


    Please note we cant fix a lot of the issues just report them here so we can fix them in future.

    Be sure to send the FTB console log not the minecraft crash report

    Please report all Launcher crashes/ failures here http://forum.feed-the-beast.com/forum/tech-support.14/

    Format:

    Mod Pack: Direwolf20
    Mod & Version:
    Pastebin link to crash log:
    Whats the bug?
    Can it be repeated?
    Known Fix:


    New rule for this thread. If you post a bug that's already known and it doesn't provide any more new useful information it will be deleted. Posts that provide no useful information may also be deleted.

    If you post a bug or problem already mentioned here: http://forum.feed-the-beast.com/threads/important-update-news-read-before-updating-any-pack.36499/

    We will delete it. Read the warning thread before posting bug reports.


    Follow the format in the first post and check to see if your bug is known before posting. If your post vanishes its already known or not a bug or didn't include enough info.

    "I has a bug"

    "xyz mod is broken"

    "it crashes" -- with no crash report

    the above do not qualify as bug reports and will be terminated on sight.



    Known Issues

    ArsMagica 2 causes many issues with several mods due to the way it changes how chunks load. If you are having odd issues with itemducts, pipes, hoppers, chests or anything else: Remove Ars Magica 2 from the game and try to duplicate it without it. If you cannot duplicate it without Ars Magica 2 report it as an Ars Magica bug.

    Logistics Pipes:

    Crashes when interacting with TE3 machines - Fixed in updated Logipipes

    Invisible item ducts, conduits and some machines - Caused by Ars Magica 2

    Major crash with the Ars Magica 2 "Mana Battery"
     
    Last edited: Feb 15, 2014
    nfen98 likes this.
  2. caweren

    caweren New Member

    Crashes on startup, have tried to redownload the client - but it doesn't help :(

    Mod Pack: Direwolf20
    Mod & Version: 1.6.4
    Pastebin link to crash log: http://pastebin.com/7EsXcBh2
    Whats the bug? Crashes on startup.
    Can it be repeated? Yes, can't evade it
    Known Fix:
     
  3. Jadedcat

    Jadedcat New Member


    Give it more Ram under the options tag. It needs at least 2 on the slider.
     
    theCreeperer likes this.
  4. tomownu21

    tomownu21 New Member

    Mod Pack: Direwolf20
    Mod & Version: Thaumcraft4.0.5b
    Pastebin link to crash log: http://pastebin.com/SQDafGCH
    Whats the bug? When ever a player clicks the research table it crashes the client.
    Can it be repeated? Yes when ever you click on the research table.
     
    jebelg01, phrozen, Turtles and 4 others like this.
  5. LimeZest

    LimeZest New Member

    Mod Pack: Direwolf20
    Mod&Version: Don't know
    Pastebin Link: http://pastebin.com/hntuyVXr
    Bug: Game seems to lock up at certain intervals, the console shows
    1. 2013-12-10 21:48:24 [WARNING] [Minecraft-Server] Can't keep up! Did the system time change, or is the server overloaded?

      Happens about 3 times/ minute

      Can it be repeated: Happened every world i've loaded and even redownloaded pack but same occurs.
     
  6. Nymall

    Nymall New Member

    Mod Pack: Direwolf20
    Mod & Version:Unknown
    Pastebin link to crash log:No Crash
    Whats the bug? - When mining ores underground, it seems to take a block update to make them appear. Everything seems to inittially be stone, but as I mine dirt/ores get revealed by the 2nd/3rd strike.
    Can it be repeated? I've tested this on two worlds with the same result.
    Known Fix:I think this is walia related. A while ago I built a pack and had some strange interaction with Thaumcraft, where silverwood trees and leaves would revert to oak after being looked at(shimmerleaf would dissapear altogether). I'll remove Walia and see if that helps.

    Edit - Removing Waila seemed to do the trick.
     
    Last edited: Dec 10, 2013
  7. Piemur1

    Piemur1 New Member

    Mod Pack: Direwolf20
    Mod & Version: 1.0.0 Mod version for MC ver 1.6.4
    Pastebin link to crash log: http://pastebin.com/85UuXHhP
    Whats the bug? - When I try to launch the Direwolf20 modpack for 1.6.4, it gives me a "Error extracitng natives: Unexpected end of ZLIB input stream" (and no that is not a spelling error, that is exactly what the error says) then the launcher closes (javaw.exe closes as well and Minecraft does not launch).
    Can it be repeated? It happens everytime I try launching the game.
    Known Fix: Not a bloody clue.
     
  8. Butterfly062

    Butterfly062 New Member

    Mod Pack: Direwolf20
    Pastebin link to crash log: http://pastebin.com/RLkBEsNz
    Whats the bug? - when i closed the launcher it caused a BSOD.
    prior to disconnecting form server and the client started to hang this corresponded to
    ########## GL ERROR ##########
    [CLIENT] [SEVERE] @ Post render
    [CLIENT] [SEVERE] 1285: Out of memory
    server: 6GB of ram running on ubuntu 12.04 lts 64bit
    client had 2.25GB for minecraft on windows 8.1 and i have a geforce GTX470 graphics card which has 1.25 GB of ram
    java version 1.7.0_21-b11
    missing texture were also reported in the log on launching the pack.
    Can it be repeated? not encountered since.
    Known Fix: increase ram in launcher?
     
  9. Mogens Høj

    Mogens Høj New Member

    Mod Pack: Direwolf20

    Mod & Version: OpenPeripheral-0.2.1-preview8

    Pastebin link to crash log: No crash occurred

    Whats the bug?
    The recipe for "Thin Wire" (ID: 1313) is broken and it's a known bug in that version of OpenPeripheral. Thin Wire is a central ingredient for a lot of the items you can create in the mod.

    Can it be repeated?
    Yes, try to craft Thin Wire from scratch. The recipe is supposed to be 2 x Iron Ingot on top and bottom of 1 x Redstone. You can't.

    Known Fix:
    Using newer snapshots of the mod fixes this bug, but may or may not be preferable overall, I don't know for sure. Link to newer builds http://www.openmods.info:8080/job/OpenPeripheral/

    EDIT: Added emphasis on why this bug seems important to me.
     
    CracksisT likes this.
  10. nick1wasd

    nick1wasd New Member

    Mod Pack: Direwolf20
    Mod & Version: Thaumcraft (what ever is in the 1.0.0. pack)
    Pastebin link to crash log: http://pastebin.com/H0mD8f9E
    Whats the bug? every single time i click the research table, i crash, i believe it's "thaumcraft.client.renderers.block.BlockTableRenderer.renderInventoryBlock(BlockTableRenderer.java:43)"
    Can it be repeated? every time i click the table
    Known Fix: nothin
     
    Turtles likes this.
  11. Vox

    Vox New Member

    Minor bug:

    Mod Pack: Direwolf20
    Mod & Version: Project Red
    Pastebin link to crash log: No crash, let me know if I can help you find info on this bug.
    Whats the bug? Placing a random assortment of project red blocks leads to massive lag spikes more than once a second after only minuets of game-play.
    Can it be repeated? Yes.
    Known Fix: Destroy blocks and replace them, seems to stop the lag.

    As a side note project red itself is really laggy compared to other mods.

    Turns out this was all a java installation problem, it wasn't properly allocating memory.
     
    Last edited: Dec 11, 2013
  12. thynamesq

    thynamesq New Member

    Mod Pack: Direwolf20
    Mod & Version:Vanilla and 1.6.4
    Pastebin link to crash log:N/A
    Whats the bug?Glowstone and enderstone have randomly spawned in a cave in the overworld, its in a Swampland biome, they are about 10-15 blocks apart. I've used Biomes o plenty as the Terrain Gen
    Can it be repeated? Only found it the one cave so far
    Known Fix:
     
  13. Jadedcat

    Jadedcat New Member

    Inside those should be magic bee hives. You're in a magical biome.
     
  14. thynamesq

    thynamesq New Member

    Ah cool, Thanks for the help
     
  15. Vox

    Vox New Member

    Mod Pack: Direwolf20
    Mod & Version: Ars Magica 2
    Pastebin link to crash log: N/A
    Whats the bug? Trying to craft witchwood stairs results in oakwood stairs instead. There is infact a witchwood stair block that is needed for crafting ars magica structures.
    Can it be repeated? Yes.
    Known Fix: Creative spawn them in.
     
    GkSanchez likes this.
  16. Summit

    Summit New Member

    Mod Pack: Direwolf20 v1.0.0 1.6.4
    Mod& Version: Portal Gun v2.0.1
    Pastebin link to crash log: No crash
    What is the bug? I found a portal gun in a dungeon chest and the PortalGunSounds.pak was not included in the mod pack. I had to grab it separately so portal gun would have sounds.
    Known Fix: Download the PortalGunSounds.pak and install it manually.
     
  17. Clos3d

    Clos3d New Member

    Mod Pack : Direwolf20 v1.0.0 1.6.4
    Mod & version: I don't know what is causing it
    Pastebin : http://pastebin.com/6Zhv3f1M
    What is the bug? It won't let me get into the game at all. It freezes where you see it get to in the pastebin. I've updated everything trying to fix
    it. Nothing works.
    Known Fix: <--Would be nice
     
  18. koolcat_23

    koolcat_23 New Member

    Mod Pack: Direwolf20
    Mod & Version: not sure.
    Pastebin link to crash log: no crash
    Whats the bug? shift clicking coal places it into the top slot of a furnace rather than the bottom. if you place an item into the top slot and then shift click the coal it will not go into the furnace.
    Can it be repeated? yes.
    Known Fix: manually place coal in furnace.
     
  19. Darhole

    Darhole New Member

    Mod Pack: Direwolf20
    Mod & Version: Thaumcraft 4.0.5b
    Pastebin link to crash log: http://pastebin.com/Rhr1pNUz
    Whats the bug? Local client crash anytime somebody tries to interact with a research table.
    Can it be repeated? Each and every time, by anybody who attempts it.
    Known Fix: None, yet =)
     
    Zuusu, Turtles and KrazyBrute like this.
  20. jmarler

    jmarler New Member

    Mod Pack: Direwolf20 1.0.0 1.6.4
    Mod & Version: MachineMuse Modular Power Suits 0.8.0-62
    Pastebin: http://pastebin.com/PjfdnQCG
    Whats the bug? During startup, the class "thaumcraft.common.Config" is attempted to be called, which should actually be "thaumcraft.common.config.Config"

    The error is at line 22 of ThaumGogglesModule.java

    This appears to cause at a minimum a visual defect when attempting to add the Thaumic goggles to the Power Armor Helmet. I'm not 100% sure if it breaks the functionality or not.

    Fix:

    Code:
    diff --git a/src/minecraft/net/machinemuse/powersuits/powermodule/misc/ThaumGogglesModule.java b/src/minecraft/net/machinemuse/powersuits/powermodule/misc/ThaumGogglesModule.java
    index d4cf27b..115e788 100644
    --- a/src/minecraft/net/machinemuse/powersuits/powermodule/misc/ThaumGogglesModule.java
    +++ b/src/minecraft/net/machinemuse/powersuits/powermodule/misc/ThaumGogglesModule.java
    @@ -19,7 +19,7 @@ public class ThaumGogglesModule extends PowerModuleBase {
        public ThaumGogglesModule(List<IModularItem> validItems) {
            super(validItems);
            try {
    -            tcItems = Class.forName("thaumcraft.common.Config");
    +            tcItems = Class.forName("thaumcraft.common.config.Config");
                Field itemGoggles = tcItems.getField("itemGoggles");
                Item goggles = (Item) itemGoggles.get(itemGoggles);
                gogglesStack = new ItemStack(goggles);
    Opened issue 442 on MachineMuses's GitHub.
     
Thread Status:
Not open for further replies.

Share This Page