Unsupported Direwolf 20: 1.6.4 {PUBLIC BETA}

Status
Not open for further replies.

littlebeast

New Member
Jul 29, 2019
4
0
0
The bricks from Tinker's Construct (the ones made with the chisel, not the seared bricks; I actually only tested endstone and sandstone, but I assume the rest behave similarly) behave oddly in a couple ways: they don't conduct redstone, and Lux Capacitors (from Powersuits) can't be placed on them. I think they're being treated like transparent blocks?
 

KrazyBrute

New Member
Jul 29, 2019
95
0
1
Mod Pack: Direwolf20 1.0.23
Mod & Version: ProjectRed:Transmission 4.2.2.19
Pastebin link to crash log: http://pastebin.com/vPYGRKi9
Whats the bug?
Whenever I try to remove this red alloy wire from the wall it causes my client to close down.
Can it be repeated?
Yes my client closes down everytime I attempt to remove the wire
Known Fix:
None:(
 

BrickVoid

Well-Known Member
Dec 2, 2012
593
57
54
Mod Pack: DireWolf20 1.0.23
Mod & Version: Identification needed of an unknown nether mod that spawns a rather hard to deal with mob.
Pastebin link to crash log: N/A
What's the bug? Whenever I enter the Nether I am attacked by a tall black column of smoke particles that I cannot get a mob type reading on when looking at it with WAILA.
Can it be repeated? Yes, spawns repeatedly in Normal mode if I switch to/from peaceful mode.
Known Fix: Currently, play Nether in Peaceful.
 

Haybale100

New Member
Jul 29, 2019
2
0
0
Mod Pack: Direwolf20 1.0.23 and 1.0.24
Mod & Version: Ender Storage(1.4.3.6)
Pastebin link to crash log: 3 pastebin links due to size limit
Part 1: http://pastebin.com/r6U0YAYC
Part 2: http://pastebin.com/JeEW6UxC
Part 3: http://pastebin.com/eivsB7aU
Whats the bug?: Server-side world becomes unusable by use of multi-dimensional Ender storage, Ender tank in the nether collecting lava from ender-thermic pump connected by opaque fluiducts on a private frequency with machines using the lava in the overworld using opaque fluiducts
Can it be repeated?: Yes in new worlds after server restart and after placing ender tank in overworld and nether on same frequency
Known Fix: Disabling/Delete Ender Storage mod from Client and Server
 

GScott

New Member
Jul 29, 2019
17
0
0
Mod Pack: Direwolf20 1.0.23/22
Mod & Version: LogisticsPipes 0.7.4.dev.172/ComputerCraft 1.5.7
Pastebin link to crash log: N/A (Game does not crash)
The bug: LogisticsPipes is not providing its peripheral API to ComputerCraft. This is because as of commit 485b444 of LogisticsPipes, LogisticsPipes was upgraded to ComputerCraft 1.6. This breaks compatibility with ComputerCraft 1.5.7, meaning that LogisticsPipes loads a dummy Proxy, and the peripheral API is no longer available.
Solution: Not super easy to fix, either downgrade LogisticsPipes (bad idea, could break more things), or update ComputerCraft to 1.6 (also could break stuff).
Evidence:
Code:
2014-05-23 18:23:00 [INFO] [LogisticsPipes|Main] Loaded CC DummyProxy
Repeatability: Consistently repeatable. Simply query the peripheral API of a Logistics pipe with ComputerCraft, it will not have the correct methods available.
This bug is actually more costly when combined with the fact that there's an existing bug with OP's integration with AE. You cannot request enchanted (or any items with NBT data) from the AE network. LP integration through an interface was the *only* workaround for that -- and now that's bugged due to LP's upgrade to CC 1.6.

This means that in pack 1.0.22+ there exists no way to for CC to interact with the two largest storage provides (AE & LP) when it comes to magical, enchanted, or non-stackable items. Since they are freezing the 1.6.4 packs soon I really hope that someone steps up to the plate and brings this mods in line even if that means downgrading Logistics Pipes, which is not a total world breaker.

-S
 

lolterispro2

New Member
Jul 29, 2019
2
0
0
mod pack: Direwolf20 1.6.4
mod and version: game crashing
pastebin crash log: http://pastebin.com/4T807dsE
bug: I died in the nether due to those pesky phantoms who are invisible and threw me in lava, outraged, I cheated my stuff in, but i cheated in tinkers construct items, which I used. They crashed my game but i got it fixed again. I did this by force updating. After I did that and realized my issue after a few times of cheating tinkers construct items. But I was stupid enough to cheat a manyullyn bow after all of that, and I used it and now my game always says shutting down internal server after like 5 seconds of being in the world. I tried reinstalling java but that didn't work, I also tried to force update many times but that didn't work either so I don't know what to do anymore. I also tried allocating more RAM and things like that.
(THIS ONLY HAPPENS IN THAT SPECIFIC WORLD)
known fix: I don't know what do do :C
(moderator help would be appreciated)
 

KrazyBrute

New Member
Jul 29, 2019
95
0
1
Mod Pack: Direwolf20 1.0.23
Mod & Version: Tinkers Construct 1.5.5.4
Pastebin link to crash log: http://pastebin.com/RZmGwrFe
Whats the bug?
Whenever I try to right click on the tool station it causes a crash.
Can it be repeated?
Yes my client closes down everytime I try to open a interface
Known Fix:
None:(
 

BrickVoid

Well-Known Member
Dec 2, 2012
593
57
54
This bug is actually more costly when combined with the fact that there's an existing bug with OP's integration with AE. You cannot request enchanted (or any items with NBT data) from the AE network. LP integration through an interface was the *only* workaround for that -- and now that's bugged due to LP's upgrade to CC 1.6.

This means that in pack 1.0.22+ there exists no way to for CC to interact with the two largest storage provides (AE & LP) when it comes to magical, enchanted, or non-stackable items. Since they are freezing the 1.6.4 packs soon I really hope that someone steps up to the plate and brings this mods in line even if that means downgrading Logistics Pipes, which is not a total world breaker.

-S
This might seem like getting to the party late, but has the modpack creator for the DireWolf20 modpack tried updating the ComputerCraft version for this modpack? ComputerCraft on it's official site is now up to 1.63 and I was thinking that perhaps this would provide a fix or workaround for this bug?

Just my observations after checking the www.computercraft.info page.

Cheers ...

BrickVoid
 

GScott

New Member
Jul 29, 2019
17
0
0
This might seem like getting to the party late, but has the modpack creator for the DireWolf20 modpack tried updating the ComputerCraft version for this modpack? ComputerCraft on it's official site is now up to 1.63 and I was thinking that perhaps this would provide a fix or workaround for this bug?

Just my observations after checking the www.computercraft.info page.

Cheers ...

BrickVoid
I tried that locally with 1.0.22 and had issues. At that time OP didn't support CC 1.6x versions. Unfortunately those two are pretty part-and-parcel for most CC controlled automation builds. Upgrading CC but having a non-functioning OP would break more worlds I think. I really need to go check OP -- it's just soooo hard to find good info on that mod. It's almost like those mod devs purposefully try to be difficult when it comes to what build supports what.
 

Fuunokami_oka

New Member
Jul 29, 2019
2
0
0
Mod Pack: Direwolf20

Mod & Version: v1.0.23

Pastebin link to crash log: None (no crash)

Whats the bug?:
  • I made a grinder, rancher, chronotyper and breeder from minefactory reloaded and I can't put upgrades in them. I've tried to put one in all 4 of them an the slot just doesn't appear. Not sure what I did wrong. :/
Can it be repeated?
  • Yes, it happens no matter the machine.
Known Fix:
  • None yet. :/
Edit: I have uploaded a picture of the GUI i receive when I open any of the machines. (Minus the slots to put wheat with breeder and holding slots for the wool/items in the rancher.)
No Upgrade Slot.PNG
 
Last edited:

Anaerin

New Member
Jul 29, 2019
62
0
0
I made a grinder, rancher, chronotyper and breeder from minefactory reloaded and I can't put upgrades in them. I've tried to put one in all 4 of them an the slot just doesn't appear. Not sure what I did wrong.
The Mob-based machines mentioned (Grinder, Rancher, Chronotyper, Breeder, Veterinary Station and Slaughterhouse) cannot have their range upgraded. Other (farm-related) MFR machines (Planter, Fertilizer, Harvester, Fruit Picker) can. So this isn't a bug.
 

HangingLotus

New Member
Jul 29, 2019
138
0
0
Mod Pack: DW20 1.0.23
Mod & Version: Open Blocks (version unknown)
Pastebin: NA as there is no crash
Whats the bug: elevators are not working at all
Known Fix: Unknown
 

Anaerin

New Member
Jul 29, 2019
62
0
0
Mod Pack: DW20 1.0.23
Mod & Version: Open Blocks (version unknown)
Pastebin: NA as there is no crash
Whats the bug: elevators are not working at all
Known Fix: Unknown
Elevators now require XP to operate. If you don't have any levels, they won't work.
 

BrickVoid

Well-Known Member
Dec 2, 2012
593
57
54
I tried that locally with 1.0.22 and had issues. At that time OP didn't support CC 1.6x versions. Unfortunately those two are pretty part-and-parcel for most CC controlled automation builds. Upgrading CC but having a non-functioning OP would break more worlds I think. I really need to go check OP -- it's just soooo hard to find good info on that mod. It's almost like those mod devs purposefully try to be difficult when it comes to what build supports what.
When you write 'OP' you mean 'LP' right, IE that's just a typo?

If so, question: Does connecting a basic logistics pipe (or any logistics pipe for that matter) directly to the AE unit holding the enchanted items work to access them? If bypassing the AE network works, it might be better to try redesigning your system so that the LP connectivity is directly tied to where the enchanted items are stored so that the CC network can directly access them.

Related question to the above: What exactly is it you want your CC system to do with the enchanted items once it receives them? Sorting books by enchantment type would be pretty useful IMHO. Not sure about enchanted items but I'd like to see any system that can process enchanted items and either recover materials from them or remove desired enchantments using a MFR auto-disenchanter to take off desirable enchantments and store them in books.

It might help, therefore, if you explain what the CC system you're feeding the items to is doing with them. :)

Cheers ...

BrickVoid
 

GScott

New Member
Jul 29, 2019
17
0
0
When you write 'OP' you mean 'LP' right, IE that's just a typo?
No, when I say OP I mean Open Peripherals. AE does not support direct CC integration and you would use Open Peripherals interface proxy to access a block's methods.

What the CC system needs to do with enchanted (NBT data) items is irrelevant especially given in mod pack 1.0.22+ it cannot even retrieve said items from an AE or LP system.
 

BrickVoid

Well-Known Member
Dec 2, 2012
593
57
54
No, when I say OP I mean Open Peripherals. AE does not support direct CC integration and you would use Open Peripherals interface proxy to access a block's methods.

What the CC system needs to do with enchanted (NBT data) items is irrelevant especially given in mod pack 1.0.22+ it cannot even retrieve said items from an AE or LP system.
It sounds like you might have to try writing a fixed version of the OP code yourself and then submitting it to whoever maintains that code base, and hope that they can ratify the fixed version and integrate it into a build release you can then download. Is there anything in a mod other than OP you could use to make a workaround for the problem at hand or is it something that only OP can handle for some obscure reason?

I still suggest that you post what exactly it is you're trying to do with the systems you're trying to get the items into, because if you do, someone here might have a method you haven't come across that could work.

Have you also looked at the code that Dire designed for the essentia jars from Thaumcraft 4.0 to see if there's anything that you might be able to adapt or modify to read through OP stubbornness?

Worst case scenario I can see is that you might have to write a customized add-on module for the mod(s) in question yourself to add functionality that should have been there. That's not necessarily a bad thing if you're willing to share anything you do come up with even if you have to get outside help to code it.

Cheers ...

BrickVoid
 

lolterispro2

New Member
Jul 29, 2019
2
0
0
I'm still having trouble with my world. I got it fixed somehow but then it started crashing again after my power strip was accidentally unplugged causing crashes and the world to stop, again only that world doesn't work.

pastebin for crash http://pastebin.com/zg6nuTXJ
 
Last edited:

BrickVoid

Well-Known Member
Dec 2, 2012
593
57
54
I'm still having trouble with my world. I got it fixed somehow but then it started crashing again after my power strip was accidentally unplugged causing crashes and the world to stop, again only that world doesn't work.

pastebin for crash http://pastebin.com/zg6nuTXJ
Have you tried loading it into MCEdit and looking for corrupted chunks in it? An abrupt loss of power usually means that data being saved may have be unrecoverable. You might also be able to use the backup files of the world save data and see if that fixes the corruption although it sounds as if your only hope is to take out corrupted chunks one by one and hope that you can recover some of the lost world that way.

Also be sure to have your hard drive scanned for errors, although it might take a while, file corruption errors can be fixed automatically by the scandisk program, if you're running Windows. That may mean data will go missing from your world, but you might be able to recover enough to make it viable to replace some of the missing items in your world and move on.

Last, but not least, invest in a decent uninterruptible power supply, for your PC, this means that even if the power is cut, if you have your computer and primary monitor plugged into it, that you will at least be able to shut the computer down and exit Minecraft properly, thus saving your world from future corruption caused by accidentally unplugging the power board.

Cheers ...

BrickVoid
 

GunnyWaffle

New Member
Jul 29, 2019
1
0
0
I hope this is the right place...

Mod Pack: Direwolf20 v1.0.23 minecraft v1.6.4
Mod & Version: Thermal Expansion 3.0.0.7
Pastebin link to crash log: No crash
Whats the bug? Impulse Item ducts have a 50-100% chance of mis-identifying their whitelists. IE: whitelisting slag and dirt allowed electrum ingots through.
Can it be repeated? Somewhat, it depends on your setup.
My setup to replicate:
- induction smelter set to export out bottom, to a red impulse duct, leading out 4 blocks.
- split off 3 impulse item ducts to the right and 5 to the left. Making a T junction
- attach a chest to each end, wrench the longer end to be dense.
- apply a servo to the shorter end, whitelist for dirt and slag
- now smelt 1 gold and 1 silver in the induction smelter
If it replicates, the electrum will traverse into the chest with the whitelist.
Known Fix: Replacing the impulse itemduct with a normal one seems to fix the problem.

I hope this is not a user error, as I have been working with itemducts for a long time and I'd hate to know that I am using them wrong. :c

PS: I can provide a world download with more details if needed.

Edit: It seems to effect extraction too, a whitelist of -silver gold iron lead tin copper ores and dirt- was pulling out ferrous ore, no matter the settings. Using a standard itemduct fixed the problem.
 
Last edited:

Mikhail5555

New Member
Jul 29, 2019
3
0
0
Mod Pack: DW20 1.0.23
Mod & Version:
  • OpenBlocks version: 1.2.7
  • Thaumcraft version: 4.1.0g
Pastebin: No access to the server logs
Whats the bug: The world crashes, after a restart is crashes on chunk load
Known Fix: Unknown
Can it be repeated? Yes:
Step 1: Place a Vacuum hopper above a 'Arcane Pedestal' (thaumcraft)
Step 2: Insert item in Vacuum Hopper
Step 3: Set the item output of the Vacuum Hopper down (to the pedestal)
Step 4: Crash
I can't provide an error log since this happened on a public server.
Sorry for my bad english, I'm not a native speaker.
 
Status
Not open for further replies.