DartPatch - MFR Planter/Harvester support for DartCraft

Discussion in 'Mod Discussion' started by Minalien, Aug 11, 2013.

  1. Jakja22

    Jakja22 New Member

    When I tried this with FTB Unleashed 1.1.3, I get this error. http://pastebin.com/uRenqMxD I'm using the 1.2 version of the patch. After removing the patch, the server loads up fine without crashing.
     
    juggy11 likes this.
  2. GuntherDW

    GuntherDW New Member

    It might be happening because of a dartcraft version change in 1.1.3 unleashed.
    It went from "DartCraft Beta 0.1.18v3.jar" to "DartCraft Beta 0.1.18.jar"

    EDIT: Doesn't look like it is, I'm testing it out to see what mod/change actually causes this.

    Removed just about any coremod and/or mod that could've messed with the path.
    The only thing that "fixed" it was to just "hard-wire" DartPatch to Dartcraft instead of using reflection.
     
  3. Faithless

    Faithless New Member

    so how again did you fix that? what did you do? :x

    i'd really love to work this with 1.1.3 :<
     
    juggy11 likes this.
  4. TheMalkore

    TheMalkore New Member

    Now I feel a bit dumb :( forgot this mod early on :)
    thanks
     
  5. dixsonchix

    dixsonchix New Member

    Cheers, pal.
     
  6. Darky212

    Darky212 New Member

    any chance to get this updated for 1.1.4 and i know its just come out but just like to ask :)
     
  7. Jadedcat

    Jadedcat New Member

    Minalien is currently moving...
     
    DZCreeper and Pokefenn like this.
  8. xdr

    xdr New Member

    Unfortunately I seem to experience the same issue as many others.

    Here is my crash log: http://pastebin.com/JLERxJ9A

    I do have some extra mods installed, but the crash occurs even with a stock 1.1.3 install. I've also tried the Dartcraft file from 1.1.2 with no success.

    Hope your move is going smoothly, thanks in advance if you get around to this.
     
  9. Imasneakypanda1

    Imasneakypanda1 New Member

    This doesn't work on my FTB Unleashed 1.1.4 server but works on Client. P.S. The server just doesn't start up.
     
  10. Siro

    Siro New Member

    And how was this accomplished?
     
  11. DarkClown384

    DarkClown384 New Member

    can anyone reupload the 1.1 patch until a 1.3 is lunched that fixes it?
     
  12. einstein9073

    einstein9073 New Member

    The most recent Dartpatch (1.2) is still crashing the server in the most recent FTB Unleashed (1.1.3).

    http://pastebin.com/ThFwbKSG

    It's definitely dartpatch:
    Code:
    Caused by: java.lang.NoClassDefFoundError: Lnet/minecraft/item/EnumRarity;
    ...
        at com.minalien.dartpatch.DartPatch.getDartItem(DartPatch.java:51)
        at com.minalien.dartpatch.DartPatch.modsLoaded(DartPatch.java:82)
     
  13. Siro

    Siro New Member

    For reference, those are the two lines that try to reflect the force nuggets from dartcraft. And at this point I've learned more about java than I ever intended to in trying to figure out why it's throwing an exception on that; and still haven't figured it out.

    (I'd be happy with just not getting nuggets out of an MFR setup if anyone had the previous version available)
     
  14. DarkClown384

    DarkClown384 New Member

    yeah, can anyone upload the older version that doesn't have the force nugets fix.
     
  15. xdr

    xdr New Member

    PierceSG and Siro like this.
  16. Hodgetts330

    Hodgetts330 New Member

  17. DarkClown384

    DarkClown384 New Member

    your using it on a sever right.
    If thats the case that just use the link and download 1.1, it was posted just two post above, until minalien fixes the crash with servers and the 1.2 version, the only downside it´s that it doesn´t produce the force nuggets in the farm, but besides that it works just fine.
     
  18. Hodgetts330

    Hodgetts330 New Member

    okay thanks
     
  19. PierceSG

    PierceSG New Member

    A question, would the 1.1 patch work in a 1.1.4 Unleashed server?
     
  20. DarkClown384

    DarkClown384 New Member

    yes, it works, I am using it.
     
    PierceSG likes this.

Share This Page