[1.7.10] TolkienCraft II - Adventure Awaits! - v2.9.5[QUESTS][ADVENTURE][NORMAL MODE]

Discussion in 'Public Packs' started by GreatOrator, Aug 24, 2014.

  1. Wiremash

    Wiremash New Member


    I have charms of dislocations (Too many) and a few enhanced ones already

    How far do I need to progress to get the infused armour? I am level 32 in ars magica with 2 sets of battlemage (made an extra in case the first one was bugged out) and made 2 silver spells. Also made an armour imbuement table, to my disappointment it didn't work due to not having any infused exp
     
    Vals NoisyToys and GreatOrator like this.
  2. wrongcoder

    wrongcoder New Member

    FWIW (cc @TheRangerX) 2.3.13 appears to be available on the launcher
     
  3. eDilettante

    eDilettante New Member

    OK, latest info I can find on the AM2 thread in the MC forums about the armor is from November, relating to the 1.7.10 version - "The Armour XP system is currently bugged. it still works in the 1.7.2 version (I think) but it is among the bugs that Mithion will hopefully fix before he makes his leave from the modding community (hopefully only temporarily leaving)." - I think the most recent update to AM2 was included in version 2.3.11 of the TCII modpack, so if you're already past that version and infusion's still not working then I guess Mithion didn't manage to get to the armor infusion in this part of the final cleanup of the mod; I think there's still one more cleanup patch to come for AM2, someone else may be have more info on this though.
     
    Last edited: Jan 5, 2015
  4. Gamingjg

    Gamingjg New Member

    Possible dumb question: When upgrading a server I just copy and paste all except the world folder, ops.json, whitelist, etc., correct?
     
    Vals NoisyToys and GreatOrator like this.
  5. GreatOrator

    GreatOrator New Member

    Well, depends on what you have done with your server. Typically all you should need to copy is the customnpc folder from the world into your server and replace the mods folder and config folder and you should be good.
     
    Vals NoisyToys and TheRangerX like this.
  6. Gamingjg

    Gamingjg New Member

    It keeps telling me this (screenshot), these mods(botany, Extratrees Extrabees, binniecore, genetics, AWWayOfTime) aren't in the server pack mods folder at all and (carpenters blocks, refinerelocation, asielib) are in the mod folder and with the same version numbers on client and server(as listed in their name, i.e. AsieLib-1.7.10-0.3.8) but still says they are wrong, also for some reason the asielib file name says 0.3.8 but the error says 0.3.3. Should I just download them separately?

    Am I crazy or just doing everything wrong? Other than Direwolf20's 1.7.10 and 1.6.4 modpacks I haven't made any other servers and I just downloaded those and was ready to go. I think you have several thing going on differently so I'm probably messing things up. Any help?

    P.S. We have done almost all quests and are in the Overworld setting up a base, we have done a lot of mining but haven't ventured to Middle Earth yet but have been to the nether.
     

    Attached Files:

    Vals NoisyToys and GreatOrator like this.
  7. eDilettante

    eDilettante New Member

    OK, I can confirm that renaming the location block and completing Magician IV did allow me to talk to Legolas, but his dialog just keeps repeating, so I think breaking the sequence of the quest chain has meant the Middle Earth quest hasn't opened correctly for me. I'll try completing it in the correct order in my next playthrough and see how that goes, but maybe worth double-checking to make sure the location block is named correctly, this was all in my V2.3.13 single-player game.
     
    Vals NoisyToys and GreatOrator like this.
  8. GreatOrator

    GreatOrator New Member

    thank you eD, I will double check that when I get home tonight. As for that error, was that from the server download that should be listed with the recent update? if so, I'll have to check the contents, either I missed something or the server download broke.
     
    eDilettante and Vals NoisyToys like this.
  9. Vals NoisyToys

    Vals NoisyToys New Member

    Posting this as a general response to people having trouble getting RF power to their machines at the start of the game. And because @GreatOrator asked me to do so. ;)

    To start out I used Buildcraft Kinesis pipes in the following configuration:

    s = solar generator (Note: solar gen gathers power by day, transmits at night. To transmit during day, put a lever beside it and use that to control when power is flowing)
    w = wooden kinesis pipe
    c = cobblestone kinesis pipe
    p = pulverizer (or other machines)

    s w c p

    Later I changed over to Extra Utilities transfer nodes, pipes etc an example of which is:

    t = transfer node (energy)
    e = energy pipe
    x = energy extraction pipe (Optional??) **note - I'm not quite sure when you need this one, I've used it very seldom. I've been told I need to connect it to the cell on the output (orange) side after the transfer node but it's always worked fine for me without using it
    g = lava generator / solar generator
    c = leadstone cell etc (set side connected to "gt" to blue (input), and side connected to "te" to orange (output)
    p = pulverizer (or other machines)
    . = nothing, a space filler so the diagram shows correctly.

    g t c t e e e e p1
    ..............e p2
    ..............e p3


    Later on yet I refined it using Ender transmitters and receivers, but I won't get into that at the moment. :p Hope this helps!
    -- Val

    ETA: fixed diagram on 2nd example.
     
    Last edited: Jan 6, 2015
    SWJoker, adeshpan, jdtm and 15 others like this.
  10. GreatOrator

    GreatOrator New Member

    Been Meaning to do this for some time now...will link to this from the main post.
    FAQ:

    Q: I’m stuck, the HQM book will not progress.

    A: Reading is your friend.

    1. A fair number neglect to read the first HQM quest text in full that (as well as the initial startup screen) tells them to do the customNPC quests hand in hand with the HQM ones. So either they don't know the customNPC quests exist at all, or they don't do them along with the HQM quests. Then they get confused when the quest method they are following 'stops' because it's waiting for triggers from the other questing method.

    2. Once started, many don't continue to read the full text of the HQM and customNPC quests and get confused and 'stuck' later in the quest line. In this modpack you NEED to read the quest text. All of it. It's there for a reason!

    3. After being at a loss of what to do next, they fail to talk to all the customNPCs in the town when they feel that they are stuck (despite the quest text telling them to do so at various points). They also don't go back and read the HQM and customNPC quest text in full (granted, the customNPC ones go away when 'completed' so you can't go back and read them again - but AFAIK once those are completed they are no longer relevant; the HQM ones you can always go back and re-read).
    4. Command Blocks need to be enabled if on a server for the NPC's to function properly.
    5. HQM is disabled on first load and must be enabled the first time and will work thereafter.
    Q: Where is the map?

    A: As of version 2.3.14 the map is no longer included with the client side version. There is a new button on the main menu specifically to take you to the map download if you need/want it.
    1. Curseforge is where the map download is now at.
    2. Download the archive, extract contents to minecraft folder of FTB instance for modpack.
    3. Start new world.

    Q: Every time I try to create a new world it takes me back to the main menu.

    A: Make sure you have the correct map version for the version of the pack you are using. Make sure you placed the map from curse in the right location ([path to FTB]>TolkienCraftII>minecraft) as the template folder in the curse download goes there. Any other reasons, I'll add here as they are found.

    Q: My CustomNPC quests keep disappearing! Why haz this broken?

    A: After extensive testing by myself and the mod dev it was found that one of two reasons are causing quests with customNPC's to disappear:
    1. Your MC client is not connecting to the Mojang authentication servers so the UUID that is assigned is not being verified (the mod uses this to determine quest progress)
    2. You have changed your name with Mojang which seems to break a lot of things in 1.7.10.
    The fix: For the name change, there is none, and in many cases you are now relegated to 1.8.x Minecraft from now on, for the UUID, make sure you are connecting to the authentication servers. If you have no internet, sorry, can't help, if you are using a cracked client, I have no sympathy for you.

    Q: How far away or where should I build my base?

    A: The safest place to start your own base is 1024 blocks from the starting spawn point in any direction. The quest where it randomly teleports you takes this into account. The reason for this is in the even of map fixes/content updates/ anything really that involves the starting save template, will make it so it does not overwrite anything you place or build. This applies to the overworld and Middle-Earth.

    Q: <Insert NPC Name> Is missing/dead still/etc! What do I do?

    A: As the startup screen says, some NPC’s sleep at night. Is it night time? If no, then this can sometimes happen. The NPC’s are configured to respawn after an hour, but for whatever reason that sometimes does not happen. Restore the region files from the template world (or the world download) to restore the NPC’s that are missing/dead.

    Q: OMG! My FPS is so bad!

    A: Well, since you are asking here, that means you have not read the opening screen or read any of the posts in this topic. I included information in the FPS Solutions.txt which is found in the folder that FTB installs the modpack to. If that is not enough:

    1. FastCraft by player over at the IC2 forums is a good start to add. No it is not included in the pack because player has forbidden redistribution.

    2. JVM arguments that @SatanicSanta put together

    3. Optifine even can help
    Q: Am I supposed to steal everything?

    A: That’s up to you. This is minecraft and this pack was set up to allow players total freedom unlike your traditional skyblock/HQM packs. Just ask yourself, am I a hero or a villain?

    Q: Why does the HQM book tell me I can claim reward when I cannot?

    A: That is a known bug and while they have posted about a work-around until they release a fix, I personally do not want to go back through 150 quests to change them.

    Q: Can I haz crash?

    A: Short answer, sure. Long answer, there are a lot of reasons this can happen.

    1. Make sure you have enough memory allocated for the pack. It does need more than most but I would not ever go higher than 3.5GB of memory.

    2. Also, are you using Java 7? Java 8 may work, but best results (especially if using the JVM arguments) is for Java 7, make sure you are using 64 bit java as well.

    3. If none of the above, a full crash log is necessary, put it on pastebin and post the link in the thread or no one will help you.
    Q: Can you add <insert mod name here>?

    A: Short answer, No. Long answer, still no. I spent a lot of time (this pack was built before release over the course of 6-8 months) deciding on the overall theme I was going for. Not too high-tech and mostly magical with a lot of options for building and decorating. The only exception to this was Applied Energistics, and that’s all that needs to be said for that. As of this point, the mod list is pretty well set, though I do have a few mods I am watching/waiting on, Aquatic Abyss and also looking at Adventure backpacks, Armorer’s Workshop and Cosmetic Armor.

    Q: Can you change X in the pack?

    A: Honestly, at this stage no. Most of the balance tweaks I wanted have been fleshed out with the help of my beta testers and in the early stages by the multitudes of others. I feel the configs for the most part are well-balanced and still keep to how the mod devs envisioned their mods being used while still allowing for the different style of play this pack is striving for.

    Q: I am doing <insert quest> and I can’t seem to get anywhere.

    A: Refer to the very first question I listed.

    Q: How do I transfer power, you must add ender i/o or I will never be able to use any power!

    A: Umm, no, refer to question above about adding mods. As for power transfer, I am holding out for ducts for thermal expansion, but this does not mean we have no power transmission. I will defer to @Vals NoisyToys for her explanation on her best methods.

    Q: Can I join your server?

    A: Good question, and that depends. @TheRangerX has graciously donated his time, energy and resources to make the official server possible. It is whitelisted, and if there are slots available he will add you...in the order you applied and you apply by PMing him on the FTB forums. I will say that there have been a few (though rare) occasions where I will add someone to the whitelist despite how many we currently have, but this is extremely rare and usually it is for someone I personally know.

    Q: Do I need to reset?
    A: Major version numbers (For example 2.3.x to 2.4.x) will require a reset. This is typically mentioned several times during the beta phase leading up to a recommended release.

    A: Lol, thank you, appreciate that, but I don’t do this for money or recognition. If you seriously want to donate, the official server is the best place to show your appreciation. The funds given there go completely to the operation of the server and expansion to allow more players to play.

    Q: This pack is awesome! Just shut up and take my money!

    A: Lol, thank you, appreciate that, but I don’t do this for money or recognition. If you seriously want to donate, the official server is the best place to show your appreciation. The funds given there go completely to the operation of the server and expansion to allow more players to play.

    Q: <insert random question>

    A: Please, for the love of god and all things holy and that you hold dear, at the very least read back a few pages in the topic to make sure your question has not already asked, or, I don’t know, use the topic search feature so lovingly provided by the founders of this forum to see if maybe it has already been answered. If your response to this questions is, “Too lazy to look” then everyone here is too lazy to help.
     
    Last edited: Jul 2, 2015
    KyanG, CommandoDan, Zelastra and 12 others like this.
  11. GreatOrator

    GreatOrator New Member

    Beauties of using google drive...the mod list is identical in both the client and server for 2.3.13, so if they are not correct on the launcher I will have to let watchful know so he can fix. Sounds like you have a mismatch of client and server versions though.
     
    eDilettante and Vals NoisyToys like this.
  12. Gamingjg

    Gamingjg New Member

    I will redownload but I downloaded both twice before posting. Will be a bit though, have other obligations at the moment. Thanks!
     
    Vals NoisyToys and GreatOrator like this.
  13. Matthewk1000

    Matthewk1000 New Member

    Hey I know I keep saying this but my life has gotten very busy and setting up new series before school starts too ext. But tom morning I am finaly free to record so wish me luck. :D
     
  14. Vals NoisyToys

    Vals NoisyToys New Member

    @Wiremash
    You can rename a Charm (or Enhanced for that matter) of Dislocation in an anvil to help yourself remember where they go. ;)

    (I haven't had a chance to read the rest of the thread today and won't for a couple of hours so if I'm repeating something already said, oops! :p)
     
    eDilettante and GreatOrator like this.
  15. GreatOrator

    GreatOrator New Member

    Good Luck!
     
    eDilettante likes this.
  16. Flexion

    Flexion New Member

    Hi, I just wanted to make a chunk loader but couldn't see it in NEI. I checked the modlist, but chickenchunks is installed on both server and client. And just crafting it is also no succes. Is this some sort of disabled item?
     
    GreatOrator and Vals NoisyToys like this.
  17. Vals NoisyToys

    Vals NoisyToys New Member

    There is a cheap chunk loader called a dimensional anchor that requires no fuel (my favorite), and another called (I think) personal anchor from Railcraft which requires ender pearls to run.
     
    GreatOrator and eDilettante like this.
  18. eDilettante

    eDilettante New Member

    My alternative early/mid-game method, because I'm too lazy to deal with BC pipes (and because I got a couple of reward bags containing redstone blocks) was to chain together a bunch of leadstone energy cells and use them in much the way I would usually use TE energy conduits... just think of them as really thick pipes and make sure you have the correct sides set to input/output the power from the generator(s) and to the machine(s)...
    And then when you're ready to go to the extra utilities nodes you already have a bunch of storage cells that you can upgrade fairly cheaply to hardened cells for a decent early game energy storage bank.

    Cheers,
    Andrew (aka eD ;-)
     
    Last edited: Jan 6, 2015
  19. Maffeo404

    Maffeo404 New Member

    I did something stupid and need help...I opened up the Ancient temple and read what the guy said and instead of clicking the leave conversation option, I clicked the land of fire by accident. Now I am stuck in the Nether...Anyway to get pack without losing all my stuff?
     
    GreatOrator and eDilettante like this.
  20. Wiremash

    Wiremash New Member

    Sorry for this, I can't complete the council summons quest (I have read at least 15 pages back) I am still unsure how to reconfigure the location block, there is little information on customnpcs. I have searched the whole mage tower for the location block but I still cannot complete the quest.
     
    GreatOrator and eDilettante like this.

Share This Page