[1.10.2] Sprout

Discussion in 'thephoenixlodge' started by thephoenixlodge, Dec 17, 2016.

  1. McFrugal

    McFrugal New Member

    The heart crystal shards initially seem to be useless since you can't craft them into hearts. Turns out you need to find a monastery first... could you add a tooltip onto the heart crystal to indicate it is a bought item?
     
  2. Flabort

    Flabort New Member

    Hmm. Heart crystals needing monasteries was in the 0.8.0 change log, but it is true that there is little indication in game about that until you find a monastery.
     
  3. Avalonzo

    Avalonzo New Member

    The needle and thread seems buggy as when I'm trying to make cloth to sell to the cloth/sewing lady I sometimes get 1 craft and sometimes get 3 crafts before the the needle just vanishes is that intended.
     
  4. Inaeo

    Inaeo New Member

    Is Sprout server ready? If so, are there servers of it up and going yet? My group is getting hungry for a new pack already, and I'd love to have this be next in queue. That said, they chew through packs, and I tend to play a bit slower (mostly free time variation), so having a public server in my back pocket is a strong consideration.
     
    SorceressJacklyn likes this.
  5. Avalonzo

    Avalonzo New Member

    I think I might have worked out whats happening with the needle and string if it's not intended pressing U/right clicking to see the recipe uses shows all that damage states and guessing it's choosing 1 of the damage states at random and would explain why the needle has a random amount of uses.
     
  6. DeathOfTime

    DeathOfTime New Member

    small band of hunters near spawn:
    [​IMG]
    my first base (near spawn) was eaten by a dragon:
    [​IMG]
    found a piece of redstone and a repeater near the wagon when i started up this world. a pond genned a few blocks below where the wagon was.

    seed: 7156725295573245770

    so far i haven't learned much about the pack. except for stay away from any area where i can hear wings. hoping my third attempt at a base goes better then the other two. liking the pack so far. have some problems with crashes. did notice in one log that biome tweaker was disabled. when i looked it up I found the mod it depended on wasn't installed. been having a bad year so haven't felt up to to much bug reporting. sorry about the lack of reports and logs.
     
    Last edited: Jun 26, 2017
  7. Avalonzo

    Avalonzo New Member

    The redstone/repeater is a small hiccup it's part of the customNPC's spawning mechanic i.e. the customNPC's are spawned via command blocks w/ a redstone circuit sometimes the when the npc spawns the redstone circuit breaks and on occasion you will need to repair the circuit to get the npc to spawn.

    Did the dragon suddenly spawn on your base or just landed there as if the dragon only landed there it then your base was more likely eaten via a chunk error as due to the missing portion looking like a perfect 16x16 area i.e. a chunk. Whenever I have seen that type of chuck error in other packs the missing part of the chunk usually will be spawn somewhere nearby.

    I have also seen a mass of hunters close to the spawn chunks a few times -
    [​IMG]
     
  8. DeathOfTime

    DeathOfTime New Member

    last night i played for at least a hour with no crashes. i increased the memory allotted to java (in the curse minecraft setting) to 12,288MB. it seems to have stopped crashing. i was watching memory use in game and it never allotted more then just below 8GB. The memory use mostly stayed below 5GB. It had the occasional spike above 6GB though.

    i haven't heard any dragons at my third base yet. it is a little way from spawn. on a small island just off the shore. i know there are two dragons a short distance off. so far it seems far enough away.
    i might have to figure out how to repair that circuit. just in case it turns out to be needed later.

    the dragon was eating my base. i didn't spot it until i left my base for a bit. when i came back it was down in that pit. every where it moved massive amounts of blocks would disappear, over a very short period of time. The way it appeared was why i stated the dragon ate my base. the blocks disappeared as the dragon moved towards a edge of the pit. the pit actually got pretty big. not for sure how the dragon got out. looks like it ate its way through a pirate ship near the shore. seen it hovering near another pirate ship off in the distance when i went back to spawn to recover some of my corpses. i will try and get another set of screen shots to show all the damage i think its done. i witnessed it digging out a lot of the pit. i am not certain of how much of the rest is its. i think lots of it though.

    edit:
    http://imgur.com/a/lkIHb
    yep, all that was done by the dragon. it dug all its way through that ship. i remember the area looking much different when i first was looking around to set up my base.
     
    Last edited: Jun 26, 2017
  9. Avalonzo

    Avalonzo New Member

    Hi Death of time I looked into the iceandfire config file and the dragon destroying the blocks seems to be intended -

    "dragon griefing - 2 is no griefing, 1 is breaking weak blocks, 0 is default" {
    I:dragonGriefing=1
    }

    Your going to need to alter the config to stop it from happening again.
     
  10. Avalonzo

    Avalonzo New Member

    I think the slayers guild needs to made even rarer as all 5 have spawned rather close to each other.

    [​IMG]

    Seed: -7036772778146331866
     
  11. DeathOfTime

    DeathOfTime New Member

    i know its intended. and from what i read in discord going to be left that way. i am just hoping they stick to a territory and my base isn't in it. mostly was reporting what happened thinking it was funny, frustrating, and extreme. i abandoned my second base after a dragon in the area killed me. figured it would eventually take it out if i left it there. That is why i am on my third base.

    this pack has been fun. frustrating, and fun. unusual combo. hard to get that sort of thing right.
     
  12. Avalonzo

    Avalonzo New Member

    I know exactly what you mean I've lost count of how many crashes and deaths I've had so far but keep playing as it's so much fun cough cough dark souls cough lol XD
     
    DeathOfTime likes this.
  13. DeathOfTime

    DeathOfTime New Member

    can you give it more then 8GB RAM. that seemed to have cleared the crashes up for me (i gave it at 12GB). i hear foamfix helps. it didn't work for me. the memory use was spiking fairly high. that might actually crash it if only 8GB is available. if i remember java and minecraft right.

    i haven't been able to get into darksouls. that tutorial ogre though was a funny part. didn't help my screen was to dark. i didn't see there was a way out of the room. just had trouble getting interested in the game. might later though. my interests tend to change repeatedly, over time.

    edit:
    spent a half hour trying to figure out how to kill the giant ogre. thought that that was what they meant by difficult.

    edit: forgot my mipmaps were maxed. like i usually leave them. turned them off and will try loading the game with less ram allocated. to see roughly when it becomes unstable. or just play for a ton of hours. not for sure which yet.
     
    Last edited: Jun 26, 2017
  14. Avalonzo

    Avalonzo New Member

    I already gave 12GB and have foamfix lawful installed both make it run smooth as butter. All the crashes seem to be the same - Exception ticking world - - which I would hazard a guess is the world is being generated faster than it can handle going to need to undo a level or 2 of my speed totems currently got speed 3.
     
    DeathOfTime likes this.
  15. DeathOfTime

    DeathOfTime New Member

    i just turned the akashic tomb into the astral sorcery book. when i sneak click to turn it back it open the astral book's inventory instead. not for sure of how to turn it back into the akashic tomb. likely need to check.

    the game keeps notifying me that the sound system crashed. the birds chirping cuts out about that point. the game locks up for a few seconds as well.

    running at 6GB and 0mipmaps. the game is running fine. for the most part. no full crashes. the ram flexes from 3GB up to just over five. then goes back down to 3. has yet to full out crash though.
    [​IMG]

    edit: figured out the akashic tomb. forget it was left click air.
     
  16. DeathOfTime

    DeathOfTime New Member

    disabled ambient sounds, betterfps, chunk animator, dynamic surroundings. as well as biome tweaker. since the game was just disabling it, the mod it needed to run wasn't installed. played for a few hours with my brother in multiplayer LAN. the game ran really smoothly. we barely noticed any lag when we were both exploring. no crashes of any sort. he had the game set to 7GB and 0 mipmaps. I had the game set to 12GB and 0 mipmaps.

    Will try leaving all the mods enabled on later versions. for now though this works. it changes the immersion, doesn't actually change anything else.
     
  17. Death_Rictus

    Death_Rictus New Member

    Is anyone else having a problem with some ore doublers (sag mill/extra utilties crusher) being inconsistent about what they spit out? The different machines give different results and some of them are clusters that can only be smelted in an arc furnace. I've found ways around this but it's still annoying.
     
  18. I too am wondering this. A server version would be a definite boon.
     
  19. DoomSquirter

    DoomSquirter Well-Known Member

    @thephoenixlodge, do you have a git for issues or anything yet? Just loaded pack up, turned on scavenger mode, but every time I die, it crashes.

    pertinent bits:

    Description: Unexpected error

    java.lang.IllegalArgumentException: Cannot get property PropertyBool{name=bottom, clazz=class java.lang.Boolean, values=[true, false]} as it does not exist in BlockStateContainer{block=minecraft:air, properties=[]}
    at net.minecraft.block.state.BlockStateContainer$StateImplementation.func_177229_b(BlockStateContainer.java:196)
    at rustic.common.tileentity.TileEntityCabinet.getRenderBoundingBox(TileEntityCabinet.java:52)
    at net.minecraft.client.renderer.RenderGlobal.func_180446_a(RenderGlobal.java:700)

    now, everytime I've died, it's been in a recurrent complex structure, so maybe that's causing it.

    pack seems interesting, but trying not to die is hard haha :)
     
  20. pixelzgmd

    pixelzgmd Guest

    First off - I'd just like to say I'm loving this pack so far. Having a bit of trouble with Level Up! though - Try as I might, even when I am prompted to Choose a Class, hitting the L key doesn't do anything. I've read variuos posts around the internet and just can't seem to find a solution for this. I checked the controls to see if there were any conflicts - Levels was taking the L key, so I changed it to something else, but still no joy. I checked through the config files but saw nothing there about key binding.

    Has anyone else had this problem (is it a problem? Am I just doing it wrong?) and has found a solution?
     

Share This Page