1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

[Solved!] NEI crashing with the U Key

Discussion in 'General FTB chat' started by Shevron, Mar 16, 2014.

  1. Shevron

    Shevron Well-Known Member

    Any insight appreciated. While not game breaking, it's annoying as I sometimes forget and use it.

    Running the DW20 1.0.18 pack with a couple extra mods:
    • Galacticraft
    • Archimedes Ships
    • ArmorStatusHUD
    • RotaryCraft
    • JABBA
    • NotEnoughKeys
    Every time I hit the U key in NEI to see the uses for an item, client crashes out with the following:

    http://pastebin.com/PfU8vK1D
     
  2. Vasa

    Vasa New Member

    try updating NEI , NEI plugins and NEI addons.
     
  3. Shevron

    Shevron Well-Known Member

    Checked ChickenBones' thread, and this pack seems to be running the latest version.
     
  4. SinisterBro :3

    SinisterBro :3 New Member

    What happens if you delete GalactriCraft and try it?
     
  5. Shevron

    Shevron Well-Known Member

    Still crashes.

    Gonna try a "virgin" installation of DW20, and start reintroducing addons one by one till I get it to crash with U.
     
  6. Shevron

    Shevron Well-Known Member

    Aha! It's Rotarycraft / DragonAPI.

    @Reika ... we need your rescue!
     
  7. SinisterBro :3

    SinisterBro :3 New Member

    I give him max 4 hours to respond. Reika is fast :)
     
  8. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    There is no reference to my code here, and I do not get these problems in my installation.

    <15s.
     
    Jack0928PC likes this.
  9. SinisterBro :3

    SinisterBro :3 New Member

    ......
    2fast2quick
     
  10. Shevron

    Shevron Well-Known Member

    Geez! Now that's what I call service!

    Well what I can say it, I installed the DW20 pack 1.0.18 afresh, and worked fine. Pressing U in NEI does what it's supposed to.

    After I installed RC and DragonAPI, pressing U crashes me out.

    Could probably be an NEI related issue, but knowing you monitor the forum more closely, I decided to blame you first <3
     
  11. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    Or just lucky.

    Try building it in reverse, starting with just RC and DragonAPI. At least that will narrow the mod interaction.


    RAWR
     
  12. Shevron

    Shevron Well-Known Member

    So you mean just leaving NEI and RC+DrAPI in the modpack?
     
  13. Shevron

    Shevron Well-Known Member

    Hmmmm you're right ... disabled everything except chicken-core thingy, NEI, Rotarycraft and DragonAPI, and U works just fine.

    Must be some weird mod interaction then - which is gonna be a biatch to find....

    ... especially since the new version of the launcher is taking an absolute eternity to load. Am I alone getting this?
     
  14. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    Add mods one by one. Not only should small packs be fast to load, but you will know what mod the erroring item comes from.
     
  15. Shevron

    Shevron Well-Known Member

    Yeah ... this is gonna take a while.
     
  16. ThatOneSlowking

    ThatOneSlowking New Member

    I would suspect galacticraft...
     
  17. Shevron

    Shevron Well-Known Member

    It isn't.

    As I said, installed a fresh DW20 pack, with just rotarycraft and dragonAPI added - and still crashes.

    I've now disabled literally everything, and adding mods one by one until I find the one that crashes it.
     
  18. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    He means GalacticCraft+RC as the interaction.
     
    ThatOneSlowking likes this.
  19. Shevron

    Shevron Well-Known Member

    Galacticraft isn't installed anywhere in this test and it's a new world. Still crashes!
     
  20. Shevron

    Shevron Well-Known Member

    You know what ... f*ck it I don't care. I'll live with not every using the U function.

    Enabling addons one by one is destroying my will to live and I'll soon hang myself in the mouse wire.
     

Share This Page