Pack updates and new packs

Status
Not open for further replies.

Golrith

Over-Achiever
Trusted User
Nov 11, 2012
3,837
2,137
248
Reading on the Optfine forum, it seems that the forge version currently being used is NOT the recommended version. 499 is still the recommended version (I think).
BC and Forestry have updated to the latest forge, even though it's not classed as stable yet, and so I assume that FTB has also updated accordingly.
I thought FTB policy was not to update mods if still in "beta"? Latest Forge is basically this, so should not have been updated.

I don't think Optifine is going to get updated until latest forge is recommended status.
 

shuehner

New Member
Jul 29, 2019
2
0
0
In Linux, the Dw20 pack v 5.0.1 does not seem to load at all.
All I'm getting is vanilla Minecraft, and the FML window does not pop up.
The console does not show anything interesting, just vanilla Minecraft loading.
Hi,
the following does work for me as a workaround until there is a fixed pack.
In your ftb-install folder:


Code:
cd Direwolf20/instMods
mv minecraftforge.zip MinecraftForge.zip
As it looks like the file included in the pack is all lowercase but checking the debug output of the FTB_Launcher it seems to build the classpath using MinecarftForge.zip. That doesn't matter on windows but on linux the case is important.

Note: works for me, YMMV
 

EpicEraser

New Member
Jul 29, 2019
73
0
0
Hi,
the following does work for me as a workaround until there is a fixed pack.
In your ftb-install folder:


Code:
cd Direwolf20/instMods
mv minecraftforge.zip MinecraftForge.zip
As it looks like the file included in the pack is all lowercase but checking the debug output of the FTB_Launcher it seems to build the classpath using MinecarftForge.zip. That doesn't matter on windows but on linux the case is important.

Note: works for me, YMMV
Yup, that was it.
Thanks a lot!
 

viteros

New Member
Jul 29, 2019
3
0
0
when i say yes to download the new version of the pack it goes a little and then says there is an error in the download (mac user)
 

Howard

New Member
Jul 29, 2019
1
0
0
So it seems the packs updated without giving me the choice and I did not want to update just yet is there a way to go back and downgrade? For example i want to go back to mindcrack v7

*edit*
Nevermind I figured it out as soon as the rage left my body :)
 

ShireensPlay

New Member
Jul 29, 2019
62
0
0
Optifine is not compatibile with newer versions of Forge. The Optifine mod author is working on fixing the problem. This is mostly an SSP issue though.
I thought so... FTB is gonna be so laggy now[DOUBLEPOST=1359411072][/DOUBLEPOST]
If you're going to be making these packs which update every few weeks, especially if people are playing along with direwolf on his map releases, the IDs have to match. Even a couple of mismatches is enough to screw up the world sometimes.
i totally agree, I'm following Direwolfs LP as well and all of these crashes and updates are just a pain in the butt.
 

Mrboomx

New Member
Jul 29, 2019
9
0
0
when i click launch it loads the ftb intro then my screen goes black after that i have optifine disabled and it still did the same thing
 

ShireensPlay

New Member
Jul 29, 2019
62
0
0
Did they know that Optifine wasn't compatible with Forge? If they did, why did they release the update, when we need optifine to play?
 

Endyl192

New Member
Jul 29, 2019
19
0
0
My world was also stuck on "Building world" stage. After checking out the console I found that the problem was the following:
- due to mystcraft, I already had dimension 7 allocated
- twilight forest also wanted to use dimension 7 as the dimension id for the forest

Solution:
Since my number 7 mystcraft age had instability (and so I have long thrown away any linking/descriptive book to it) I deleted the following files/folders in my save folder:
- DIM_MYST7 (folder)
- data/agedata_7.dat (file)

After that my world loaded as it should. (But I still have to check if everything else is alright, nothing is missing or messed up :D At least the world loads.)
 

Giddimani

New Member
Jul 29, 2019
148
0
0
Wow, updating the pack without Optifine is not working for me, just tried it and had 12-13 fps, with optifine I have 47 fps.

Luckily I keep a backup everytime, I think its shociking with so many gamebreaking changes and such a high risk update, the launcher would not make an automatic backup/ask if you want to make a backup before updating.
 

viteros

New Member
Jul 29, 2019
3
0
0
There is some problem with the mac version because I can't download any of the new versions... it says in the middle of the download that "error in downloading the modpack" and then I tryied erasing my files but it didn't matter the problem is still happening... PLEASE HELP!!
 

WurzleUK

New Member
Jul 29, 2019
3
0
0
My world was also stuck on "Building world" stage. After checking out the console I found that the problem was the following:
- due to mystcraft, I already had dimension 7 allocated
- twilight forest also wanted to use dimension 7 as the dimension id for the forest

Solution:
Since my number 7 mystcraft age had instability (and so I have long thrown away any linking/descriptive book to it) I deleted the following files/folders in my save folder:
- DIM_MYST7 (folder)
- data/agedata_7.dat (file)

After that my world loaded as it should. (But I still have to check if everything else is alright, nothing is missing or messed up :D At least the world loads.)
Wow thought I'd lost my world there.. Thanks alot fella :)
 

HeffronCM

New Member
Jul 29, 2019
406
0
0
Again, I really appreciate everything you all are doing, but if we're going to have updates so frequently then can we please try to be sure to get all the conflicts and ID changes stamped out? Nobody wants to have to remake their world or fix a whole server that's suddenly had a bunch of blocks explode every couple of weeks. It's really demotivating.
Could you give an example of what block IDs weren't properly brought over?
 

Lathanael

New Member
Jul 29, 2019
959
0
0
I thought so... FTB is gonna be so laggy now[DOUBLEPOST=1359411072][/DOUBLEPOST]

i totally agree, I'm following Direwolfs LP as well and all of these crashes and updates are just a pain in the butt.
1. Optifine is not in our packs, so we can't and will not test against it. Adding mods on your own will always have the risk of breaking something. Sorry it is impossible for us to test against all those cases.

2. There are no ID mismatches AFAIK, can you provide an example?

My world was also stuck on "Building world" stage. After checking out the console I found that the problem was the following:
- due to mystcraft, I already had dimension 7 allocated
- twilight forest also wanted to use dimension 7 as the dimension id for the forest

Solution:
Since my number 7 mystcraft age had instability (and so I have long thrown away any linking/descriptive book to it) I deleted the following files/folders in my save folder:
- DIM_MYST7 (folder)
- data/agedata_7.dat (file)

After that my world loaded as it should. (But I still have to check if everything else is alright, nothing is missing or messed up :D At least the world loads.)
Can you PM me with the exact error log? I'd like to get this into the known issues thread so all people can access this and might read it (it will get burried here!).
 

ShireensPlay

New Member
Jul 29, 2019
62
0
0
Wow, updating the pack without Optifine is not working for me, just tried it and had 12-13 fps, with optifine I have 47 fps.

Luckily I keep a backup everytime, I think its shociking with so many gamebreaking changes and such a high risk update, the launcher would not make an automatic backup/ask if you want to make a backup before updating.
Same, I normally play with 50fps with Optifine and now I have about 20 on short distance without it
 

Mogster

New Member
Jul 29, 2019
1
0
0
There's an alternative to deleting your DIM_MYST7 ages which is to simply change the dimension number used by Twilight Forest. Edit the "TwilightForest.cfg" file in Direwolf20\minecraft\config, scroll down to the "dimension" section and change "I:dimensionID=7" to a number Mystcraft hasn't reached yet.

I found this from a couple of threads in the tech support forum, and have just tried it successfully myself. :)
 

luke11223

New Member
Jul 29, 2019
1
0
0
HELP!!!

I'm on a Mac and I log in, and attempt to download the Mindcrack pack update, it downloads, and when finished downloading it just goes away. Nothing happens it does not install.
I'm running Mac OSX 10.8.2

Please Help.
 

Notelok

New Member
Jul 29, 2019
17
0
0
1. Optifine is not in our packs, so we can't and will not test against it. Adding mods on your own will always have the risk of breaking something. Sorry it is impossible for us to test against all those cases.

2. There are no ID mismatches AFAIK, can you provide an example?



Can you PM me with the exact error log? I'd like to get this into the known issues thread so all people can access this and might read it (it will get burried here!).
I get this when I try and load my save. http://i.imgur.com/o7FRvdU.png

I click yes and it just sits there on Loading World.

EDIT : Using DW20 v5.0.1
 
Status
Not open for further replies.