Unsupported Monster 1.6.4 Bug Reports

Status
Not open for further replies.

pigtailsboy

New Member
Jul 29, 2019
4
0
0
Mod Pack: Monster
Mod & Version: Magical Crops
What's the bug? Planted crops that are not allowed to reach full maturity that are destroyed drop seeds with alternate item IDs disallowing those seeds to be stacked with seeds that drop from tall grass and mature plants
Can it be repeated? yes
Known Fix: None but if holding the seeds with the base ID dropped seeds will add to that stack. If none are held the ID is altered preventing you from combining them with the same seed type.

If the modpack is going to be frozen with known bugs intact why bother playing that pack. At what point will a limited bug pack be available I ask not expecting an answer.

Edit:
Mod Pack: Monster
Mod & Version: Magical Crops
What's the bug? Magical Crop variant sugar cane drops a item with an altered item ID disallowing stacking with vanilla sugar cane and disallows vanilla crafting recipes for sugar cane (sugar and paper) without some kind of processing machine only found in other mods.
Can it be repeated? yes
Known Fix:

Mod Pack: Monster
Mod & Version:
What's the bug? At random points the recipe for sticks using oak wood planks is lost require the client be restarted.
Can it be repeated? When it damn well feels like it.
 
Last edited:

bounding star

New Member
Jul 29, 2019
30
0
0
Mod Pack: Monster
Mod & Version: tConstruct 1.5.3
Whats the bug? after breaking a smeltery, the smeltery is no longer a valid structure even when completely reconstructed in the same configuration that worked before.
Can it be repeated? i am not able to test this on another computer
Known Fix: no idea. reconstructed multiple times and reloged but that didnt help
 

Vauthil

New Member
Jul 29, 2019
1,491
-14
1
Mod Pack: Monster (v1.1.2)
Mod & Version: GeoStrata v23b / DragonAPI v23b
Pastebin link to crash log: http://pastebin.com/G7qLiYX1 for running from Monster. http://pastebin.com/3dPzSdEJ for a version of the crash in isolation (Forge+DragonAPI+GeoStrata only).
What's the bug: Creative Mode Inventory in SMP crashes when you attempt to search (with T). Subsequent openings of the creative inventory then also result in directly crashing. Only affects SMP, not SSP.
Can it be repeated?: Yep. As noted above, tested in isolation to confirm the interaction.
Known Fix: Don't use Creative as an op in SMP for now (I set NEI to jump me straight to Creative+ for now)? Failure appears to be with isAdmin in DragonAPI, which from checking the GitHub looks to have been tweaked with the latest updates, but I'll let the adults figure out what's going on. ;)
 

mk16

New Member
Jul 29, 2019
347
0
0
mod pack: monster 1.1.2
mod & version: zans minimap 1.6.4 and some other mods
whats the bug?: when you go to the fullscreen map with zans minimap some items on your hotbar will stick through the the map.
known fix: havent found one.
 

Xarlas

New Member
Jul 29, 2019
53
0
0
Mod Pack:Monster (1.1.2)
Mod:Could be "Lycernites Mobs" (see FIX) or Codechicken (see Error Log) or Java (see Fix)
Whats the Bug: CRASH when generating a new world with Biomes o Plenty (Closes Instantly) When Lycernites Mobs is Activated
Error Log: http://pastebin.com/YEnGQgBg

Fix: Removing/Not "Enable" the Mod "Lycernites Mobs" or removing the javaParameters
Code:
-Xms3584m -XX:PermSize=1024m -XX:NewRatio=3 -XX:SurvivorRatio=3 -XX:TargetSurvivorRatio=80 -XX:MaxTenuringThreshold=8 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:MaxGCPauseMillis=10 -XX:GCPauseIntervalMillis=50 -XX:MaxGCMinorPauseMillis=7 -XX:+ExplicitGCInvokesConcurrent -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=60 -XX:+BindGCTaskThreadsToCPUs -Xnoclassgc
(Memory in launcher on 3,75 Java7 update 51 64bit (Problem still Existing after update to update 55))
 
Last edited:

Lisimba

New Member
Jul 29, 2019
1
0
0
Mod Pack: Monster 1.1.2
Mod & Version: RotaryCraft, OpenPeripheral, ComputerCraft
Pastebin link to crash log: -
Whats the bug?
Peripheral methods for RotaryCraft blocks are missing after updating from 1.1.1. The ingame handbook shows what methods should be available, but instead I just get two other methods. For example, a lubricant hose should have getCoords, getName and getPipe - but:

lua> for i,v in ipairs(peripheral.getMethods("right")) do print(i..". "..v) end
1. listMethods
2. getAdvancedMethodsData

These seem to be default methods added by OpenPeripherals. Now, RotaryCraft implements ComputerCraft stuff itself, so maybe OpenPeripherals is somehow overwriting it?

Also, the openperipheral_docs.xml dump (from the /op_dump command) in 1.1.1 was 5226 KB, while the dump in 1.1.2 is only 102 KB. It appears to have changed format a bit but there seems a lot missing too.
Can it be repeated? Yes.
Known Fix: no idea.

EDIT: I made a regular minecraft 1.6.4 install to poke at this some more. Turns out RotaryCraft plus ComputerCraft 1.58 works, and RotaryCraft with ComputerCraft 1.63 doesn't. I think RotaryCraft isn't compatible with the new version of ComputerCraft, and therefore OpenPeripherals sees them as blocks with no lua integration and adds its own, though they don't do anything useful. This may be the case for other mods too, which would explain why there is so much less stuff in the xml dump.
 
Last edited:

ax1m

New Member
Jul 29, 2019
33
0
0
Mod Pack: Monster
Mod: Big Reactors
Bug: Yellorium ingots 3x3 crafts an IC2 Uranium Block, which in turn crafts into 9 IC2 Uranium 238. These can not be used in a Big Reactors reactor or be converted back in any way to yellorium, as they are not listed in the ore dictionary as ingotUranium.
Can it be repeated? Yes
Known fix: Either make 9 Yellorium ingots craft a Yellorium block, or add U238 to the ore dictionary as ingotUranium. Either should be fine.
 

Mikerman

New Member
Jul 29, 2019
29
0
0
:
Mod Pack:Monster (1.1.2)
Mod:Could be "Lycernites Mobs" (see FIX) or Codechicken (see Error Log) or Java (see Fix)
Whats the Bug: CRASH when generating a new world with Biomes o Plenty (Closes Instantly) When Lycernites Mobs is Activated
Error Log: http://pastebin.com/YEnGQgBg

Fix: Removing/Not "Enable" the Mod "Lycernites Mobs" or removing the javaParameters
Code:
-Xms3584m -XX:PermSize=1024m -XX:NewRatio=3 -XX:SurvivorRatio=3 -XX:TargetSurvivorRatio=80 -XX:MaxTenuringThreshold=8 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:MaxGCPauseMillis=10 -XX:GCPauseIntervalMillis=50 -XX:MaxGCMinorPauseMillis=7 -XX:+ExplicitGCInvokesConcurrent -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=60 -XX:+BindGCTaskThreadsToCPUs -Xnoclassgc
(Memory in launcher on 3,75 Java7 update 51 64bit (Problem still Existing after update to update 55))
remove the parameters You had and disable lycanites. Start the game and log in to tour server or start a new world. Confirm the world loaded properly and fully exit minecraft and launcher.

after that re-enable lycanites and place your favorite Java arguments.

your game is magically fixed (I had the exact same problem, I can confirm this works)(side note: shortly after disabled lycanites as it spawned 20 lava mobs in my vulcano base. They have like 80 health and one shot kill you when you don't have powered armor)
 

Cookied93

New Member
Jul 29, 2019
2
0
0
Mod Pack: Monster v1.1.1

Mod & Version: WR-CBE 1.4.0.7

Pastebin link to crash log: http://pastebin.com/77k5WmAG

Whats the bug?: world crash during startup, tried disabling the mod and entering the world(where it started just fine) and then enabling the mod, only to have it crash again.

Can it be repeated?: yes, every startup with the mod enabled

Known Fix: disabling the mod in the "edit mod pack"
 

ParasiticSoul

New Member
Jul 29, 2019
19
0
0
Mod Pack: Monster 1.1.1
Mod & Version: IC2 Exp. (2.0.397) Compact Windmills (1.0.3.0) Aroma1997core (1.0.1.3) Power Converters (2.4.0.pre3)
Pastebin link to log: http://pastebin.com/PgrSxFju
Whats the bug? Console is spammed with these errors this causes the server to hang every 45 - 75 seconds for about 5 - 15 seconds causing numerous player disconnections due to connection timeouts.
Can it be repeated? Yes
Known Fix: None at this point

Extra info:

Im going to put my money on a fault in IC2 EXP due to the fact that it is the common denominator between compact windmills and power converters. It was fixed in a later build for 1.7 but unless you are able to convince the mod author to port build #461 to 1.6.4 I don't know what other options there are.

http://ic2api.player.to:8080/job/IC2_experimental/461/changes
 

Vauthil

New Member
Jul 29, 2019
1,491
-14
1
A quick reminder: this is a thread for reporting mod pack bugs, not reporting what you broke when you decided to add another half dozen mods on top of it, or even one mod, and it's certainly not for yelling at mod pack compilers when you decide life is unfair because adding your favorite half dozen mods on top of the pack broke it.

Those posts have been and will continue to be deleted.
 
  • Like
Reactions: Eyamaz

mk16

New Member
Jul 29, 2019
347
0
0
cant hurt to mention but the monster/minecraft/config file has a whole bunch of config files for mods that not only aren't in monster but im not sure their in any ftb 1stparty packs. not sure if its because of they way you make the file of not but like i said, cant hurt to mention....
 

beewyka819

New Member
Jul 29, 2019
12
0
0
View attachment 10635 Mod Pack: Monster
Mod : Unknown
Pastebin : Not a crash, see image attached.
Bug : Downloading a fresh modpack install, or creating a new map on Monster: Pressing F5 to view player skin. The skin is corrupted, and hollow. This doesn't happen on vanilla, or any of the other mod packs i have tried. It only happens on Monster pack.
Repeated : every time i load or create a map in monster pack. Even happened in the previous versions of the pack.
Known fix : unkowm.
Two mods cause this, if you manually installed Optifine, make sure it's above the 1.6 version that supports the newer skin system, also, denLib causes this problem as well, and monster has denLib, which is a library for mods like QuarryPlus.
 

mk16

New Member
Jul 29, 2019
347
0
0
mod pack:monster 1.1.2
mod: unknown
bug: creepers and maybe other explosions now destroy 90% of your items on death. i have tested in 1.1.1 of the pack and in vanilla, neither of them had this problem.
can it be repeated? easily
fix: have yet to find one
 

Mikerman

New Member
Jul 29, 2019
29
0
0
mod pack:monster 1.1.2
mod: unknown
bug: creepers and maybe other explosions now destroy 90% of your items on death. i have tested in 1.1.1 of the pack and in vanilla, neither of them had this problem.
can it be repeated? easily
fix: have yet to find one
have tested this and cannot recreate with all creepers (only doom creepers from Special Mobs, wich makes me believe it's a feature of the mob)
 

Fingorn

New Member
Jul 29, 2019
5
0
1
mod pack:monster 1.1.2
mod: unknown
bug: creepers and maybe other explosions now destroy 90% of your items on death. i have tested in 1.1.1 of the pack and in vanilla, neither of them had this problem.
can it be repeated? easily
fix: have yet to find one
I have this logentry after one creeper death
openblocks.common.PlayerInventoryStore.onPlayerDeath(PlayerInventoryStore.java:156): Storing post-mortem inventory of player Fingorn into /home/ccsitipmc/ftb_monster/monster/./world1/data/inventory-Fingorn-2014-05-30_08.03.23-0.dat

Graves from openblock are disabled


Edit: Not a Bug, it is a new config-opiton in Openblocks
 
Last edited:

tmzasz

New Member
Jul 29, 2019
11
0
1
Mod Pack: Monster 1.1.1-1.1.2
Mod & Version: Mariculture missing required sub mod for books - Enchiridion
Pastebin link to log: None
Whats the bug? Mariculture needs the Enchiridion mod ( same developer ) to spawn the 5 instruction manuals for mariculture
Can it be repeated? Yes
Known Fix: Add Enchiridion-1.6.4-1.1 manualy to the pack
 
  • Like
Reactions: darkinnit

darkcamo12

New Member
Jul 29, 2019
22
0
0
Mod Pack: Monster 1.1.2
smp/ssp: smp only bug works fine in single player
Mod & Version: rotary craft
Pastebin link to log: http://pastebin.com/Ug7YL8Vx
Whats the bug? interacting with the rotarycraft CVT unit (putting belts inside) causes player to be kicked from server(may happen with other blocks but have not tested)
Can it be repeated? Yes
Known Fix: unknown
 

dyerseve

New Member
Jul 29, 2019
4
0
0
Mod Pack: Monster 1.1.1
Mod & Version: Highlands & Mystcraft (Biome Worldgen issue)
Pastebin link to log: None
Whats the bug? Server crash when entering a Mystcraft age.
Can it be repeated? Not reliably as it's random worldgen related
Known Fix: http://www.minecraftforum.net/topic/1602064-164-forge-highlands-172-pre-release-v220pre/
Highlands notes that 3 biomes cause crashes in 1.6.4 and they should be disabled. I used creeperhost's monster server install and these three were enabled, so I'd guess they're enabled by default in the server pack. Since disabling I've made 3 ages with no issues at all.
 
  • Like
Reactions: Eyamaz
Status
Not open for further replies.