1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Minecraft class problem - game won't launch.

Discussion in '[Archived] Tech Support' started by GalXiOn, Apr 1, 2013.

Thread Status:
Not open for further replies.
  1. GalXiOn

    GalXiOn New Member

    Hello,
    I just downloaded the FTB client and I wanted to try out the FTB ultimate mod pack.
    After launching the client, in the log it gets to "mc = class net.minecraft.client.Minecraft" and it just stops there and it does not launch the game.
    Nothing happens after the last line of the log.

    Log:
    AnalyticsBackgroundThread started
    FTBLaunch starting up (version 1.2.2)
    Java version: 1.7.0_17
    Java vendor: Oracle Corporation
    Java home: C:\Program Files\Java\jre7
    Java specification: Java Virtual Machine Specification version: 1.7 by Oracle Corporation
    Java vm: Java HotSpotâ„¢ Client VM version: 23.7-b01 by Oracle Corporation
    OS: x86 Windows 7 6.1
    [i18n] Checking for updates ...
    [i18n] enUS English language file loaded!
    [i18n] Added 0 enUS to options pane
    [i18n] enUS English language file loaded!
    [i18n] remoteVer = 10
    [i18n] localVer = 10
    [i18n] Files are up to date
    [i18n] Fallback enUS loaded
    Loading modpack information for modpacks.xml...
    Adding pack 1
    Adding pack 2
    Adding pack 3
    Adding pack 4
    Adding pack 5
    Adding pack 6
    Adding pack 7
    Adding pack 8
    Adding pack 9
    Adding pack 10
    Adding pack 11
    Adding pack 12
    Adding pack 13
    Adding pack 14
    Adding pack 15
    Adding pack 16
    Loading modpack information for plcbeta.xml...
    Adding pack 17
    loading map information...
    loading texture pack information...
    Adding map 1
    Adding map 2
    Adding map 3
    Adding map 4
    Adding map 5
    Adding map 6
    Adding map 7
    Adding map 8
    Adding map 9
    Adding texture pack 1
    Adding texture pack 2
    Adding texture pack 3
    Logging in...
    Login complete.
    Ultimate
    Modpack is up to date.
    dirs mk'd
    Current: 1.4.7
    Required: 1.4.7
    Setting MinMemory to 256
    Setting MaxMemory to 1024
    Loading jars...
    Loading URL: file:/C:/Users/username/Desktop/Minecraft/FTB%20Clients/Ultimate/instMods/liteloader.zip
    Loading URL: file:/C:/Users/username/Desktop/Minecraft/FTB%20Clients/Ultimate/instMods/MinecraftForge.zip
    Loading URL: file:/C:/Users/username/Desktop/Minecraft/FTB%20Clients/Ultimate/minecraft/bin/minecraft.jar
    Loading URL: file:/C:/Users/username/Desktop/Minecraft/FTB%20Clients/Ultimate/minecraft/bin/lwjgl.jar
    Loading URL: file:/C:/Users/username/Desktop/Minecraft/FTB%20Clients/Ultimate/minecraft/bin/lwjgl_util.jar
    Loading URL: file:/C:/Users/username/Desktop/Minecraft/FTB%20Clients/Ultimate/minecraft/bin/jinput.jar
    Loading natives...
    Natives loaded...
    Loading minecraft class
    mc = class net.minecraft.client.Minecraft

     
  2. Ashzification

    Ashzification New Member

    Try taking the spaces out of your FTB Clients folder.
     
  3. GalXiOn

    GalXiOn New Member

    I tried renaming the folder to "FTBClients" still its the same problem.
    Alo what the files thats supposed to be in my minecraft folder inside Ultimate?.. I only have the minecraft.jar file..
    Log:

    http://pastebin.com/MHgF1xVx

    UPDATE:
    I tried a force update and installed the modpack again (FTB ULTIMATE) and now I get this error.

    http://pastebin.com/bZJLCgFm
    (I'm getting an error saying i exceeded 10,000 words.. o_O so I had to use pastebin..)

    I think the problem is with updating the bin folder of minecraft.
    Also while updating my vanilla MC to 1.5.1 i had trouble downloading from mojang servers so i had to download every file of the bin separately.
    So if anyone can upload the bin file alone(1.4.7) it would be really helpful.

    UPDATE 2:
    If I try force updating it the mod pack (32mb for Ultimate) is downloaded within 8-10 mins and now it starts to download minecraft jar files.. and gets stuck at 2 or 3%.


    So to fix this i tried copying the minecraft jar files(lwjgl.jar,minecraft.jar,jinput.jar,lwjgl_util.jar) along with natives of a vanilla MC 1.4.7 to the Ultimate folder in FTBClients.Now when I try launching it gives the same log as in my first post ending with "mc = class net.minecraft.client.Minecraft".I'm really confused now.. o_O..
     
  4. Nerixel

    Nerixel New Member

    Actually, we prefer that you use pastebin.
     
  5. GalXiOn

    GalXiOn New Member

    Done.
    Now can you please look into it?..
     
  6. Nerixel

    Nerixel New Member

    I've got no idea about this error. When I had it, redownloading fixed it, however that doesn't seem to be working for you.
     
  7. GalXiOn

    GalXiOn New Member

    Hmm...Can you please tell me what are the contents of ftblauncher/modpack/Ultimate/ ?
    and if its not much trouble can you upload one of the modpacks alone or is there a way to download the complete modpacks manually? ( i.e ultimate .. lite.. etc..) I can put them in my FTBClients folder and check - since im having trouble updating.. it MIGHT solve the problem.
    Thanks.
     
  8. Nerixel

    Nerixel New Member

    The contents of ftb/Ultimate/minecraft should look like a standard modded .minecraft folder. It should look something like this: http://puu.sh/2sqdV

    I'm not legally allowed to upload a copy of any mod packs unless given permission by Mojang and the maker of every mod involved.
     
  9. GalXiOn

    GalXiOn New Member

    I only have bin,coremods,config,mods...>.<
    Is there ANY way i can download the full ultimate modpack folder?... I'm still stuck on the 2-% on the downloading of minecraft.jar in the process on force update and for some reason its not showing the link from which the file is being downloaded from, unlike for modpacks..where it shows the link as "http://www.creeperrepo.net/direct/FTB2/.....".

    Also do you have any idea why i am getting this error(it is after I manually downloaded the jar files of bin folder)

    http://pastebin.com/bZJLCgFm

    Thanks.
     
  10. Meldiron

    Meldiron New Member

  11. DJGamer

    DJGamer New Member

    Its happening to me too, for some reason. Also, it seems to freeze my internet.
     
  12. GalXiOn

    GalXiOn New Member

    Umm.. you can get the direct link for pretty much any modpack from the log :p.. and I tried that also but the file does not include the bin folder which has the minecraft jars - which seems to be my problem >.<
    I need a working bin folder from a fully working client. :(...

    Well I have no idea about the internet freeze thing but lets hope we get a fix for this :(...
     
  13. Meldiron

    Meldiron New Member

    Ah, my bad, i misinterpeted the part about not showing link.
    Anyway, you could try to figure out if it's caused by FTB or not by opening the vanilla minecraft launcher and check the forced update option before launching.
    If it downloads then it's likely FTB somehow, if it doesn't then it's likely something on your computer or local network.
     
  14. GalXiOn

    GalXiOn New Member

    Well I had the same problem with vanilla MC - updating to 1.5.1 took about 2 hrs lol.. the speeds were mostly <1kbps while my internet connection is 4mbps... >.< maybe my network can't connect to mojang servers properly.
    Unfortunately I haven't found any way around it.. i'm still searching for it.
     
  15. DJGamer

    DJGamer New Member

    Well, for me, vanilla minecraft updated quickly, its just the ftb pack jars that aren't downloading (the maps and texture packs download as normal).
     
  16. Ashzification

    Ashzification New Member

  17. GalXiOn

    GalXiOn New Member

    About the first link - I tried disabling the antivirus and firewall settings its still causing me the download issue.
    I have no problem downloading from creeperhost (modpacks).I'm stuck at downloading the minecraft jar files from the mojang servers so I'm searching for working bin files.
     
  18. Booker The Geek

    Booker The Geek Well-Known Member

    Really? You can get theat by coping your bin folder from your mincraft directory over to your feed the beast directory. As long as you have not updated vanilla minecraft past 1.4.7

    We can not send it to you as that would be giving you the game.[DOUBLEPOST=1365026937][/DOUBLEPOST]Follow the first seven directions under the fix one section on the link in my signature about leaking worlds.
    If that does not work, please read link in my signature about log files. :D
     
  19. Eyamaz

    Eyamaz New Member

    Go to ftblauncher/modpack/ and then simply delete the ultimate folder (copy your configs first if you have custom configs.)

    Start your ftb launcher and redownload ultimate. Should fix your problem.

    Sent from my HTC One X+ using Tapatalk 2
     
  20. GalXiOn

    GalXiOn New Member

    Ok.. I will try again!...
     
Thread Status:
Not open for further replies.

Share This Page