Unsupported Magic World 2 1.6.4 -BETA- Bug Reports

Discussion in 'Modpack Bugs' started by Eyamaz, Dec 23, 2013.

Thread Status:
Not open for further replies.
  1. Eyamaz

    Eyamaz New Member

    WARNING : This pack is a Public Beta with any luck nothing major will change in the next 3 weeks. ID's should be stable. However it is completely possible that something could go horrible wrong you may find a catastrophic bug the test team missed and you might lose a few things. Projected time to full release status - 3 weeks.


    Please note we cant fix a lot of the issues just report them here so we can fix them in future.

    Be sure to send the FTB console log not the minecraft crash report

    Please report all Launcher crashes/ failures here http://forum.feed-the-beast.com/forum/tech-support.14/

    Format:

    Mod Pack: Magic World 2
    Mod & Version:
    Pastebin link to crash log:
    Whats the bug?
    Can it be repeated?
    Known Fix:




    New rule for this thread. If you post a bug that's already known and it doesn't provide any more new useful information it will be deleted. Posts that provide no useful information may also be deleted.

    Follow the format in the first post and check to see if your bug is known before posting. If your post vanishes its already known or not a bug or didn't include enough info.

    If you post a bug or problem already mentioned here: http://forum.feed-the-beast.com/threads/important-update-news-read-before-updating-any-pack.36499/

    We will delete it. Read the warning thread before posting bug reports.


    "I has a bug"

    "xyz mod is broken"

    "it crashes" -- with no crash report

    the above do not qualify as bug reports and will be terminated on sight.


    IF playing with Railcraft or Thermal Expansion enabled manually update to Thermal Expansion 11b from here http://direct.teamcofh.com/index.php?page=downloads there is a known world corruption possibility when playing with both mods installed prior to 11b of TE.
     
    Last edited by a moderator: Dec 26, 2013
  2. netmc

    netmc New Member

    Mod Pack: Magic World 2
    Mod & Version:1.0.0
    Pastebin link to crash log:
    Whats the bug? Missing Silver and Copper
    Can it be repeated?
    Known Fix:

    As far as I can tell, silver and copper are not generated in game. According the the cofh config, it is set to spawn between y195 and y220. I believe extreme hills stop around 180, so the ores will never be generated. There isn't a big use for the ores in magic world, as I have only found them used on the thaumcraft wand caps, and then not many ingots at all is needed. Doing a bit of thaumcraft research will eliminate most of the need for the copper and silver wand caps. iron -> copper -> gold -> silver -> thaumium.
     
  3. netmc

    netmc New Member

    Mod Pack: Magic World 2
    Mod & Version: 1.0.0
    Pastebin link to crash log: http://pastebin.com/HNbF7ciz
    Whats the bug? Right-clicking the backpack of a Frienderman from Better Storage crashes Minecraft. The first time I did this, the ender backpack gui opened before the crash, the second time, it crashed with no gui.
    Can it be repeated? yes
    Known Fix: none.
     
  4. Esheon

    Esheon New Member

    Mod Pack: Magic World 2
    Mod & Version: 1.0.0
    Pastebin link to crash log: http://pastebin.com/U2eACvA2
    Whats the bug? As in the linked image, aboveground textureless blocks, always (as far as I've seen) embedded in stone. Breaking the block in creative just removes the block. Going into survival and attempting to break the block with a pick crashes the game with the above-linked crash log.
    Can it be repeated? I've seen the block in a couple of different worlds now, and I think it's related to this comment from Jadedcat on the Tech World 2 thread. At least, it seems as if there is no coal above a certain level, only these blocks. Coal only seems to appear below y=100 (or somewhere close to that).
    Known Fix: edit CoFH config files to change coal ore to ID 16 instead of ID 263, per instructions in this post.

    The image in the spoiler below comes from a Magic World 2 game (Farlanders removed, Zan's minimap added, generated with Biomes O' Plenty) with the seed "Test" (no quotes)

    [​IMG]

    EDIT: The coal thing was also mentioned in the Horizons Bug Reports thread, specifically stating coal ore above y=128 as the issue. I went back into that world and checked... No coal above y=128. The lowest borked block I found was at y=128 and the highest piece of coal ore I found was at y=125. So I guess Magic World 2 has the same config issue as Hotizens and Tech World 2.

    Another EDIT: In the same Horizons Bug Reports thread linked above, Jadedcat posted a fix that I tried in MW2. After editing WorldCustomGen.txt and CoFHWorldGeneration.cfg to change the coal ore ID, I recreated the world with the same seed and parameters. The blank spots on that wall are now coal ore.

    So, anyone running Magic World 2 should probably do this preemptively, before they generate a chunk with these blocks. In my MW2 world, I ended up in a very low-lying area and so didn't notice this until I created another world to play around in at work. Hopefully, my home world hasn't generated any of these yet.
     
    Last edited: Jan 4, 2014
  5. Fevix

    Fevix New Member

    Possibly just a glitch or a mistake on my end, but I thought I'd report this just in case.

    Mod Pack: Magic World 2
    Mod & Version: Unknown
    Pastebin link to crash log: http://pastebin.com/VpxfwPfc
    Whats the bug? Was mining redstone and the game crashed.
    Can it be repeated? Unknown
    Known Fix: Restart modpack and continue playing as normal.
     
  6. Esheon

    Esheon New Member

    Technically speaking, this is not a Magic World 2-specific bug, but Magic World 2 is the only modpack that doesn't have the fix automatically included.

    Mod Pack: Magic World 2
    Mod & Version: Thaumcraft 4 and NEI
    Pastebin link to crash log: No crash
    Whats the bug? Errors in display when certain items are highlighted while NEI's tooltips are shown
    Can it be repeated? Every time
    Known Fix: Install Waila & use those tooltips instead of NEI

    This has actually been a bug in interaction between Thaumcraft and NEI for quite some time (happened back in 1.4.7 too). Now, it's "fixable" by using Waila's tooltips instead of NEI's. I'm not really sure why MW2 is the only 1.6.4 modpack that doesn't include Waila by default (it has Evoc and JABBA, from the same dev), unless it's because the modpack doesn't need the extended machine-related tooltips.

    All of these occur while NEI's highlight tooltips are active when looking at certain Thaumcraft objects.
    1.) Looking at Greatwood Leaves turns them into Silverwood Leaves (only visually - they turn blue and the tooltip says "Silverwood Leaves", but they still drop Greatwood Saplings).
    2.) Looking at a Cinderpearl, Shimmerleaf, Silverwood Sapling, or Greatwood Sapling causes it to completely vanish.

    In the latter case, the object is technically still THERE, but it is completely invisible and has no hitbox. Breaking the block under the object will still cause it to be "harvested", dropping the appropriate item (blaze powder for cinderpearl or quicksilver for shimmerleaf, etc). Reloading the world brings the items back, but they vanish again if looked at by NEI tooltips. I have seen on reddit that there may be an issue with some Twilight Forest items as well, but I haven't seen that myself.

    After being unfixed for so long, I doubt it will be fixed in any Thaumcraft or NEI update. While it was easy for me to just copy Waila over from the DireWolf 20 folder, we all know how much difficulty some folks have with changing anything. It might be best to just include Waila in future updates of Magic World 2, unless there's some major conflict I haven't yet come across.
     
  7. Eyamaz

    Eyamaz New Member

    No. The exclusion of Waila was an oversite, not intention. It will be added when I drop an update later tonight.
     
    netmc and Esheon like this.
  8. nitronic

    nitronic New Member

    Mod Pack: Magic World 2
    Mod & Version:Blood Magic v0.6.5c
    Pastebin link to crash log: no crash
    Whats the bug? When i drop myself to half a heart with the sacrificial knife, while standing on a tier 3 alter it says that i died, however i don't go to my spawn point. there is also no death gui everything just falls out of my inventory, i stay on the alter, and my height is set to 3 blocks. Then i get kicked for "illegal stance" on single player
    Can it be repeated? yes
    Known Fix: relogging fixes height but the bug is still repeatable
     
    Last edited: Jan 7, 2014
  9. AceOfShadows

    AceOfShadows New Member

    Mod Pack: Magic World 2
    Mod & Version: Unknown
    Pastebin link to crash log: http://pastebin.com/9ebvhXWc
    Whats the bug? The game Crashes within 5 minutes of starting a world
    Can it be repeated? the Crash is imminent every time I start the game
    Known Fix: None

    I have been so very frustrated by this, I'm completely unable to play without the game crashing every 5 minutes, I tried one time to play it and I was sorting my inventory almost 2 minutes into gameplay since starting the world and it crashed then, I also have all of the previous crash reports saved into the crash report FTB folder if you need more information, I would be very grateful for any fix, I just want to play the game. also, loosing Optifine is not an option, My PC can't run the pack smoothly without it.
     
  10. netmc

    netmc New Member

    According to the crash log, chicken chunks is what crashed. If you are loading optifine, the bug report is automatically invalidated. No one will look at it further. If you are insisting with playing with optifine, you could try removing chicken chunks from the mod pack. It might let you play. Since this is MagicWorld, chunk loading isn't as big of an issue as with the more technical mods.
     
    Eyamaz likes this.
  11. AceOfShadows

    AceOfShadows New Member

    Thanks mate :D removing chicken chunks totally fixed it, it freezes sometimes but I think that's just my PC's lack of processing power XD Again, thanks :D
     
  12. DarkMinotaur

    DarkMinotaur New Member

    Mod Pack: Magic World 2
    Mod & Version: 1.6.4
    Pastebin link to crash log: http://pastebin.com/XUrLEsbm
    Whats the bug? Catastrophic crash on multiplayer server, isolating a single player from gameplay while booting most/all players on the server on every login attempt by isolated player.
    Can it be repeated? Oh yeah...
    Known Fix: Deletion of player file, server side (Temporary)

    So far, this has only occurred while fiddling with Blood Magic crafting, near a Tier 3 Altar on a Bloodwood Workbench. Basically, I've logged in, played a while, cut myself, gotten stuff, and then I (the now isolated player) is disconnected from the server and given the following message (minus quotes):

    "internal exception: java.io.ioexception bad packet id 27"

    The temporary fix occurred to us while trying an Ars Magica 2 respec fix for a similar error. This did not fix the problem. So, I simply lost my player file on server, and started over. I picked up an Arcane Compendium (unlocking Ars Magica 2), hit my Occulus, put down 3 talents, and tested out my old spellbook (which worked, and levelled me to 2). Unfortunately, the bug repeated about an hour afterward while I was trying to work some blood magic to help everybody out. Mental Note: If this happens to you, DO NOT DO BLOOD MAGIC! It may simply happen again. Correlations between the Occulus Talents, Blood Magic's Life Point pool, and the loss of my Thaumcraft research has me too paranoid to play this wonderful mod.
     
  13. WayofTime

    WayofTime New Member

    Could you tell me what, exactly, you were doing when you crashed?
     
  14. DarkMinotaur

    DarkMinotaur New Member

    Both times I crashed, I had been mass producing slates, and had taken a break to craft sigils. The crash occured during crafting in both instances. I do not know if the following are going to be helpful, but I'm hoping to give you as much accurate information as possible.

    I had crashed with an orb in the crafting field. First time was an Apprentice's Orb (T2). Second time, I was using the Magician's Orb (T3). I do not remember what item I was crafting the first time, but the second time, I was crafting the Sigil of the Phantom Bridge. I kept my items pretty minimal, as during early experimentation with Blood Magic, my fiance accidently killed me with her Sacrificial Knife, and I lost all equipped items and hotbar with the Soulbound Enchantment (Full Thaum set, 1 Diamond Pick, 1 Spellbook, with a total of about 50 levels enchanted on them). I didn't report the bug at the time, since the Server Ops are family, and they simply spawned all items back in.

    Mental Note: When doing sacrifice in multiplayer, don't go poking each other when you're already cutting yourselves up. Even if you're curious, it's bad form, and apparently, there may be a bug with loss of items that are enchanted to prevent loss of items. Ironic how it surrounds sacrifice.

    Anyway, in order to prevent the loss of items invested with experience, I made a habit doing blood magic naked with minimal hotbar items: Food, Knife, Divination Slate (sometimes), whatever slate I happened to be crafting (so I could monitor my progress), and a slowly depleting stack of stone blocks

    If it helps, or could be at all relevant, I have some miscelaneous details for you:

    I'm using a custom skin made with SkinEdit (Don't know what version). The room in which the T3 Blood Altar is located is an underground setup with a floor and ceiling of Obsidian Brick, and a floor of Bloodwood Planks. In the case of conflicting mod mechanics, The Blood Altar room also contains our Witchery Altar (Whither Skull, Chalice, and Candelabra on Altar), Kettle, Distilery, and Witch Oven. Two walls have Better Barrels with Blood Magic and Witchery items located within them. Our server is hosted by Fragnet, so I can get permission to share the IP with you from our admin, so that you might see the setup for yourself.
     
  15. DarkMinotaur

    DarkMinotaur New Member

    Oh, and one wall bears Item Frames, displaying the progress I've made through Blood Magic.

    That's all the mechanics surrounding the blood Altar area. If the entire chunk may be important, our base is tiered, and you'd have to see it for yourself to judge the importance of things.
     
  16. WayofTime

    WayofTime New Member

    The common part of this problem is that you are crafting the stuff. That, alone, should not cause the issue. However, it depends what crafting table you are using? What mod is the added crafting table from? Perhaps that table can't handle the recipes for some reason, or it's a link between my mod, that table, and the server? (All of this comes from the fact that I remember you saying you used some sort of blood work bench? I may be entirely off base here.)

    As for dying due to the Sacrificial Knife, was it the knife or the dagger? I'll test stuff with the Soul Bound enchantment, and see if I need to fire a bunch of events for that to shape up correctly.
     
  17. DarkMinotaur

    DarkMinotaur New Member

    The crafting table is made of Bloodwood, a tree found in the Nether. Bloodwood is a product of the Natura mod, which is included in Magic World 2. The crafting table has a reddish color, so it may be a different block than the normal crafting table, and you may be entirely correct.

    In the course of exploring Magic World 2, I've also used the Thaumcraft workbench to craft Blood Magic items. That one works just fine, as far as I can tell. I've only experienced issue while using the Bloodwood crafting table.
     
  18. WayofTime

    WayofTime New Member

    Yeah, try using a different crafting table from now on. If the issue persists, let me know. Are Blood Magic items the ONLY ones that are causing issues, or is it possible you haven't seen others yet?
     
  19. DarkMinotaur

    DarkMinotaur New Member

    I have had my disconnection/"bad packet id 27" error only while working on a bloodwood workbench, crafting Blood Magic items. The bug has occurred only twice, but it's big enough that I haven't really had time to see it more than that. I've had to play on other servers, or just do other things than minecraft, while waiting for my admin to delete my file, server side.

    Since the second incident, I've been staying away from blood magic, just so I could play. But, if I can help troubleshoot the issue to prevent it from happening to other people, I'll gladly jump right back in! I'll run through some other Natura crafting tables, and switch up the room's make-up as I go.

    If you've got any other ideas you'd like me to try, feel free to suggest anything.
     
  20. WayofTime

    WayofTime New Member

    I'd stick away from the Natura tables, since it seems like if it affects one it affects all of them. Just go about your regular BM business, and let me know if it happens on other crafting tables :3
     
Thread Status:
Not open for further replies.

Share This Page