Unsupported Magic World 2 1.6.4 -BETA- Bug Reports

Status
Not open for further replies.

NamretsO

New Member
Jul 29, 2019
1
0
0
Mod Pack: Magic World 2
Mod & Version: Thaumcraft 4 4.0.5b, single player world
Pastebin link to crash log: No Crash
Whats the bug?: First, anytime I glanced at a greatwood leaf, the leaf transformed into a silverwood leaf for a short second. Soon, I was unable to place any item with item Id 2404 with any damage value. These items include: silverwood saplings, greatwood saplings, shimmerleaf, cinderpearl, and ethereal bloom. When I attempt to place any of them, they flicker for a second, then disappear without refunding the item. After a re-log, all saplings that were placed re-appear. However, after the re-log one of the trees has grown, and did not generate a node inside it. From what I can tell this is a bug with the damage values of the items.
Can it be repeated? Yes, in both survival and creative worlds. I was able to replicate it 3 out of 3 times.
Known Fix: None
 

Esheon

New Member
Jul 29, 2019
145
0
1
Mod Pack: Magic World 2
Mod & Version: Thaumcraft 4 4.0.5b, single player world
Pastebin link to crash log: No Crash
Whats the bug?: First, anytime I glanced at a greatwood leaf, the leaf transformed into a silverwood leaf for a short second. Soon, I was unable to place any item with item Id 2404 with any damage value. These items include: silverwood saplings, greatwood saplings, shimmerleaf, cinderpearl, and ethereal bloom. When I attempt to place any of them, they flicker for a second, then disappear without refunding the item. After a re-log, all saplings that were placed re-appear. However, after the re-log one of the trees has grown, and did not generate a node inside it. From what I can tell this is a bug with the damage values of the items.
Can it be repeated? Yes, in both survival and creative worlds. I was able to replicate it 3 out of 3 times.
Known Fix: None
Turn off NEI's item tooltips, and use Waila instead. This is a known bug.
 

Esheon

New Member
Jul 29, 2019
145
0
1
I know how us tech folks just love those intermittent hard-to-reproduce bugs, so here you go...

Mod Pack: Magic World 2
Mod & Version: Geostrata
Pastebin link to crash log: No crash
Whats the bug? The buff from Geostrata cave crystals sometimes fails to expire
Can it be repeated? happens intermittently, very unpredictable and semi-rare
Known Fix: Relog

Occasionally the buffs from Geostrata's cave crystals will get stuck at 0 seconds remaining. When this happens, the buff itself stays applied and never expires. Usually it's just one buff that stays, but I've had several stick to me before. The most I've had at once is Regen, Haste, and Nightvision. Relogging removes the buffs. Based on the visual effects of the Nightvision buff, it's fading and immediately being reapplied... i.e. the nightvision strobes in and out.

I have no idea what causes this. It might be something entirely within Geostrata, or it could be a mod interaction thing. (I'm lazy, so I haven't tested with Geostrata and nothing else installed.) It seems more common when you're around several different crystals. It also seems to happen more while I'm collecting crystals (either by breaking or using silk touch), less when I'm leaving them be. That being said, I've had it happen with one crystal (nightvision) by itself that I did not break. AT first, I thought I was just being affected by crystals on the other side of a wall (or something similar), but I've had the buffs stay on me even after I got back to the surface, where I knew there were no crystals in range.

As for duplication, it's so random I can't really say how to duplicate the issue. Run around crystals enough and you'll eventually see it, though it might take a while. Most of the time it's so subtle I don't even notice I've still got the buffs, except for Nightvision... when that one starts strobing it is VERY noticeable.
 

netmc

New Member
Jul 29, 2019
1,512
0
0
Mod Pack: Magic World 2
Mod & Version: Thaumic Tinkerer
Pastebin link to crash log:
Whats the bug? crafting the Corporeal Attractor requires copper ingots
Can it be repeated?
Known Fix: a TT commit from 1/21 - https://github.com/Vazkii/ThaumicTinkerer/commit/7de52b3c8bb9673c3c88547b499e57d63c6f02a2

Fixed in TT 2.1-67 - set config file to:
Code:
general {
    # Set to false to disable usage of ore dictionary metals (tin and copper).
    B:oreDictMetal.enabled=false
Nevermind - Enabling this doesn't fix MW2 pack. Copper ingots are still listed as required in building the attractor.
 
Last edited:

netmc

New Member
Jul 29, 2019
1,512
0
0
I did find a way to get copper, tin, silver and lead legitly in the current MW2 pack. You can trade pecs for thaumcraft native clusters, then once you have 4 ingots, you can use magical crops to create seeds and make more. Not exactly the easiest route, but it is possible.
 

imshanedulong

New Member
Jul 29, 2019
1
0
0
Mod Pack: Magic World 2
Mod & Version: Unknown
Pastebin link to crash log: No Crash
Whats the bug?
Occasionally things catch fire. Nothing nearby that might cause this, but they just catch fire. I have no reason to think this might be a feature. I can't think of any reason, they just start catching fire. It's happened to multiple people on the server and just started happening on a teleporter far away from any other magic items. The other cases do not involve teleporters or anything else from that mod (with the exception of 1 of the 3 houses that has had this problem who uses bloodcraft).
Can it be repeated?
Not sure the circumstances, but it has happened a lot.
Known Fix: Unknown
 

Yaeger

New Member
Jul 29, 2019
121
0
0
Mod Pack : Magic World 2
Version : 1.0.1
Pastebin link : http://pastebin.com/ETRQxtjX

What's the bug? ID mismatches, when upgrading from 1.0.0 to 1.0.1.

PS : not too bothered about it, I didn't get that far playing anyway.
 
Last edited:

Davosaur

New Member
Jul 29, 2019
7
0
0
Mod Pack: Magic World 2 1.0.1
Mod & Version:
Pastebin link to crash log:
Whats the bug?
Can't use the "f" key for strafe right. I like to map my wasd keys to the home row. When I do that with this pack, all movement keys work as they should except my f key as a right strafe. I have looked for conflicts within all the mod key configs. Even if there is no other instance of the "f" key being used in all of the mods' settings, I still have this problem.
Can it be repeated?
Known Fix:
 

Davosaur

New Member
Jul 29, 2019
7
0
0
Mod Pack: Magic World 2 1.0.1
Mod & Version: Not Enough Keys?
What's the bug?:
Tried to use the "configure conflicting" button in pursuit of fixing problem I reported in the previous post. The entire launcher crashes at that point. Here's the pastebin up to the point of crash. Not sure how to get a patstebin that contains the crash info since the launcher shuts down at that point- I'm kind of new to the crash report thing, but I'd like to help the community resolve this problem if I can.
Can it be repeated?: Yes- it is a consistent crash.
 

Zaes

New Member
Jul 29, 2019
108
0
0
Mod Pack: Magic World 2 1.1.0
Mod & Version: Ars Magica 2
What's the Bug?: Sigil of Containment does not contain Sheep in it's field in my SSP world. There are no inlays, and is on flat land (no possibility of them jumping over). It is within the player-loaded chunk at all times, yet they have escaped only when I am not looking at them.
Can it be repeated?: Yes. Can provide FTB log if needed, but it does not say anything related to the Sigils or its stand.
 

Zaes

New Member
Jul 29, 2019
108
0
0
Mod Pack: Magic World 2 1.0.1
Not sure how to get a patstebin that contains the crash info since the launcher shuts down at that point- I'm kind of new to the crash report thing, but I'd like to help the community resolve this problem if I can.
Assuming that you installed FTB to a folder called "FTB", the directory for all Forge-related crashes in Magic World 2 is under "FTB\Magic_World_2\minecraft". The logs are named "ForgeModLoader-client-NUMBER_HERE.log" (or ForgeModLoader-server-NUMBER_HERE.log depending on the problem), where NUMBER_HERE is the number of logs that ForgeModLoader has saved to that directory (0 = most recent, 1 = one version older than 0, 2 = one version older than 1, etc).

Once you found the correct version of the .log file, open the [pastebin website](www.pastebin.com), create a new paste, give it a name, etc (set expiatory date to 'never'), save the paste, then edit your post and put that paste's URL in so we can look at the proper report.

Hoped this helps :D

Edit: Why don't the <a href></a> tags work?
 
Last edited:

acollins41198

New Member
Jul 29, 2019
8
0
0
Mod Pack: Magic World 2

Mod & Version: Note sure, I'm not very good at reading crash reports

Pastebin link to crash log: http://pastebin.com/ijttCpVf

Whats the bug? Randomly crashed without any message, the game just closed.

Can it be repeated? I'm not sure. Since I still don't know exactly what caused the crash I haven't been able to replicate it.

Known Fix:
 

Zaes

New Member
Jul 29, 2019
108
0
0
Mod Pack: Magic World 2

Mod & Version: Note sure, I'm not very good at reading crash reports

Pastebin link to crash log: http://pastebin.com/ijttCpVf

Whats the bug? Randomly crashed without any message, the game just closed.

Can it be repeated? I'm not sure. Since I still don't know exactly what caused the crash I haven't been able to replicate it.

Known Fix:
Seems to be a Biomes O' Plenty and Dye Trees incompatibility. Please read my post that is directly above yours to find which .log file you need to post. The one you have posted is the vanilla minecraft crash report, which does not give enough information for the mod creators to work with.
 
Last edited:

acollins41198

New Member
Jul 29, 2019
8
0
0
Seems to be a Biomes O' Plenty and Dye Trees incompatibility. Please read my post that is directly above yours to find which .log file you need to post. The one you have posted is the vanilla minecraft crash report, which does not give enough information for the mod creators to work with. Please read my previous post on how to do this.
Thanks, sorry about not posting the .log file; I'll make sure to do that from now on.

Although, it appears that I've started Magic World too many times since the crash and the .log is gone.

However, I was able to experience the crash again with a new log. I also found out that it happens within some proximity of a Rainbow Forest (Which may help considering you mentioned Dye Trees).

Same crash as a few posts up, new log: http://pastebin.com/gRRayBuB (Had to do some cutting off at the top due to pastebin size restrictions)

Also looks like the world leaks. A lot.
 

BillyOatmeal

New Member
Jul 29, 2019
3
0
0
Mod Pack: Magic Farm 2 (v2.1.2)
Mod & Version: Not sure
Pastebin link to crash log: No crash
Whats the bug? You still lose hunger while 'Well Fed' buff is on while running and jumping down a 2 high tunnel. I'm assuming that you are still losing health due to your head hitting the roof.
Can it be repeated? Yes. Just run down a 2 high tunnel with the 'Well Fed' buff on.

I'm pretty sure it's a bug because after watching Jadedcat's video about MagicFarm 2, it is stated that you should not lose hunger while you have the 'Well Fed' buff. You should be able to jump, run, etc with no loss of hunger.
 

BillyOatmeal

New Member
Jul 29, 2019
3
0
0
Mod Pack: Magic World 2 1.0.1
Mod & Version:
Pastebin link to crash log:
Whats the bug?
Can't use the "f" key for strafe right. I like to map my wasd keys to the home row. When I do that with this pack, all movement keys work as they should except my f key as a right strafe. I have looked for conflicts within all the mod key configs. Even if there is no other instance of the "f" key being used in all of the mods' settings, I still have this problem.
Can it be repeated?
Known Fix:
I do know that the F key is used by Thaumcraft, Hopefully that will help you.
 

Zaes

New Member
Jul 29, 2019
108
0
0
Mod Pack: Magic World 2 1.0.1
Mod & Version:
Pastebin link to crash log:
Whats the bug?
Can't use the "f" key for strafe right. I like to map my wasd keys to the home row. When I do that with this pack, all movement keys work as they should except my f key as a right strafe. I have looked for conflicts within all the mod key configs. Even if there is no other instance of the "f" key being used in all of the mods' settings, I still have this problem.
Can it be repeated?
Known Fix:
I do know that the F key is used by Thaumcraft, Hopefully that will help you.
Thaumcraft uses the F key to switch between Foci when you have any Thaumcraft wand equipped in your inventory. Try looking in either its config file or the controls menu in-game to change it.
 

ToastGhost

New Member
Jul 29, 2019
1
0
0
Mod Pack: Magic World 2 (v1.0.1)
Mod & Version: Don't know for sure
Pastebin link to crash log: Didn't crash
Whats the bug? A random chunk error caused a massive hole to open up in the ground that goes all the way down to the void. The hole was filled with hundreds of floating skeletons (not making this up and have pics to prove it) for a short time but despawned when i relogged. The hole shows up on the mini map as a weird glitchy blur. If i jump into it, it makes me fall forever and the only way out is to /kill myself. It's also causing an insane amount of lag throughout the entire world.
Can it be repeated? The hole remains there no matter what i do. I've tried quitting out and relogging, restarting my computer, removing chicken chunks, and reloading chunks with f3 + a but nothing works.
 

padilin

New Member
Jul 29, 2019
2
0
0
Mod Pack: Magic World 2 (V1.1.0)
Mod & Version: Magical Crops (v3.2.0beta6)
Pastebin link to crash log: didn't crash, there is a forge log but its bigger than pastebin's 500kb apparently so I'm not sure what to do with it
What is the bug? All of the food crop id's are invalid. We have a server running and noticed all seeds and crops that were food related in the magical crops mod, such as chilis, were gone. NEI ui didn't even have them either. When i booted up single player, to test a witchary potion, it gave me an error. https://www.dropbox.com/s/ddb7q9mjxo4flo6/Screenshot 2014-03-01 07.58.22.png
What else do you need to identify whats going on? And how do i share the forge log file, if it is even necessary. Thanks!
 

Eyamaz

New Member
Jul 29, 2019
2,373
0
0
Mod Pack: Magic World 2 (V1.1.0)
Mod & Version: Magical Crops (v3.2.0beta6)
Pastebin link to crash log: didn't crash, there is a forge log but its bigger than pastebin's 500kb apparently so I'm not sure what to do with it
What is the bug? All of the food crop id's are invalid. We have a server running and noticed all seeds and crops that were food related in the magical crops mod, such as chilis, were gone. NEI ui didn't even have them either. When i booted up single player, to test a witchary potion, it gave me an error. https://www.dropbox.com/s/ddb7q9mjxo4flo6/Screenshot 2014-03-01 07.58.22.png
What else do you need to identify whats going on? And how do i share the forge log file, if it is even necessary. Thanks!
Doh. I think I accidentally left them disabled :(
 
Status
Not open for further replies.