Unsupported Magic Farm 2 Version 1.1.1+ Bug Reporting Thread

Status
Not open for further replies.

mohrad

New Member
Jul 29, 2019
96
0
0
Not guaranteed. Usually prints a console message saying it failed if it did.
Is there a way to prevent "failed" gravestones from deleting the items?
It's really pissing me off. I mean I am ok if it fails and i don't have "securely" stored items, but why is it deleting all of it when fails?

Nearly always I can manage to get back to spot within 5min item despawn timer.
Now I was on the move on my 160H world and lost full inv of AE disk, backpacks and strongboxes to that thing. I died on plains to some ridicule rare monster and i saw "failed" at the log...

I really wish it wasn't deleting the items on death if fails create gravestone, its way too punishing to not even have a chance of recovery due to that.

Btw. Is there some kind of cheaty/editing way to recover my items?
I was moving whole base and it's impossible for me to NEI all of that back in :/
 

keybounce

New Member
Jul 29, 2019
1,925
0
0
Is there a way to prevent "failed" gravestones from deleting the items?
It's really pissing me off. I mean I am ok if it fails and i don't have "securely" stored items, but why is it deleting all of it when fails?
The one time I had an "unable to create grave", I had a gravestone.

I placed the gravestone on the ground where it would go (on dirt), and then broke that dirt (breaking the gravestone). All my items came out.
 

mohrad

New Member
Jul 29, 2019
96
0
0
The one time I had an "unable to create grave", I had a gravestone.

I placed the gravestone on the ground where it would go (on dirt), and then broke that dirt (breaking the gravestone). All my items came out.
I really wish it was the case.
I died. Then I saw the log "Could not create gravestone (coords)" so I turned on creative and magnet mode, then tp'd there. There was nothing.
I claim this is a design flaw or glimpsed bug.

If Gravestone fails to create (Idk the condition when it fails), it should:
- search for nearest air block and place itself there
- drop all items on the ground
I got ripped off my items like that couple of times already :c
 

Jadedcat

New Member
Jul 29, 2019
2,615
1
0
So ... you have to find a sinister node, and then you have to make a mob spawner, and you'll get LOTS and LOTS of those nastier zombies when you do?

Are you sure that's a bug, and not just "being harder"?
Pretty sure this was deliberate on Azanor's part.
 

rgk007

New Member
Jul 29, 2019
35
0
0
Is there a way to prevent "failed" gravestones from deleting the items?
It's really pissing me off. I mean I am ok if it fails and i don't have "securely" stored items, but why is it deleting all of it when fails?

Nearly always I can manage to get back to spot within 5min item despawn timer.
Now I was on the move on my 160H world and lost full inv of AE disk, backpacks and strongboxes to that thing. I died on plains to some ridicule rare monster and i saw "failed" at the log...

I really wish it wasn't deleting the items on death if fails create gravestone, its way too punishing to not even have a chance of recovery due to that.

Btw. Is there some kind of cheaty/editing way to recover my items?
I was moving whole base and it's impossible for me to NEI all of that back in :/
Use the command "/gamerule keepInventory true" (Inventory 'I' is Uppercase) so you wont lose your items on death.This is a cheat so use it until they fix the bugs.
There are lot of bugs with gravestone mod.....when i smelt villagers in TC smeltory, a lot of villager gravestones are created inside the smeltory and a lot of failed one spawns....so i turned it off in config.

They should use the openblock graves for death.....it works perfectly in direwolf20 modpack since that modpack has no gravestone mod.
 

Sideshow

New Member
Jul 29, 2019
13
0
0
Mod Pack: Magic Farm 2 (v2.1.5)
Mod & Version: Minefactory Reloaded 2.7.5-352
Pastebin link to crash log:No crash
Whats the bug: Single player world won't load
Can it be repeated: Yes
Known Fix:

When I try to load my single player world it returns me to the title screen. If I again try to load it it says "shutting down internal server" and stays there. If I click quit it also becomes unresponsive until I force the window to close. This also happened in a single player world on the Direwolf20 1.6.4 pack. In both worlds this happened after trying to log in once I'd started using multiple MFR harvesters. In both worlds they would be working fine when I logged out but upon trying to log back into the world the above problem happened. I tried deleting the Magic Farm 2 folder and re-downloading the entire pack again after backing up my save. That didn't solve the problem. I deleted the MFR jar and replaced it with the MFR jar from the Monster pack (they are currently different versions) and I was able to log into my world. The harvesters were still there and working but seemed to not recognize Pam's Harvestcraft crops and were not harvesting them. They were still harvesting regular Minecraft crops (potatoes in this case). The problem doesn't lie in the crops though as in the Direwolf20 pack save world my 8 harvesters were all harvesting vanilla Minecraft crops (carrots, wheat, nether wort, etc.).
The 2.1.6 version of Magic Farm 2 that included an update to Minefactory Reloaded (from 2.7.5-352 to 2.7.6-448) seemed to fix my problem as I'm able to log into my save once again, and the harvesters are working just fine. To test it further I replaced the old version of MFR in the Direwolf20 pack with this newer version as well and I can log into the save there that was having the same issue.

Edit: After a couple of days with everything working fine the problem has come back. Would appreciate some help on solving this issue.
 
Last edited:

GuitarMoshi

New Member
Jul 29, 2019
35
0
0
The 2.1.6 version of Magic Farm 2 that included an update to Minefactory Reloaded (from 2.7.5-352 to 2.7.6-448) seemed to fix my problem as I'm able to log into my save once again, and the harvesters are working just fine. To test it further I replaced the old version of MFR in the Direwolf20 pack with this newer version as well and I can log into the save there that was having the same issue.

Edit: After a couple of days with everything working fine the problem has come back. Would appreciate some help on solving this issue.
I was describing having a very similar issue over in the MF2 Venting thread, and I think I've found a pattern after it happened on a DW20 world tonight. A harvester tried to grab a jungle tree I had planted, and after grabbing all the leaves everything stopped. I managed to restart the world and before it could lock up again I set jungle wood to yes in the harvester, and then it chopped the jungle tree logs and everything went fine from there. My MF2 world refuses to allow me to do anything, but one of those Harvestcraft fruit trees popped up next to one of my harvesters that happens to be a jungle variety and it shows the same signs of all the leaves being gone but the logs remain, and the hanging fruit is still there too on my MF2 world. I'll post on whether I'm successful in rebooting my world on removing the jungle logs via MCEdit or not once I get a chance to try it out.
 

Sideshow

New Member
Jul 29, 2019
13
0
0
I was describing having a very similar issue over in the MF2 Venting thread, and I think I've found a pattern after it happened on a DW20 world tonight. A harvester tried to grab a jungle tree I had planted, and after grabbing all the leaves everything stopped. I managed to restart the world and before it could lock up again I set jungle wood to yes in the harvester, and then it chopped the jungle tree logs and everything went fine from there. My MF2 world refuses to allow me to do anything, but one of those Harvestcraft fruit trees popped up next to one of my harvesters that happens to be a jungle variety and it shows the same signs of all the leaves being gone but the logs remain, and the hanging fruit is still there too on my MF2 world. I'll post on whether I'm successful in rebooting my world on removing the jungle logs via MCEdit or not once I get a chance to try it out.
Thanks so much for replying! After reading what you said I got to thinking about what was near my harvesters. In both worlds I stopped being able to log in shortly after harvesters were near jungle wood. In my DW20 world one of the harvesters was collecting cocoa beans (planted on jungle wood logs of course) and in my MF2 world I had jungle wood logs as decorative trim along parts of the wall. I've never used mcedit but may have to look into it to try to salvage my saved games. Will be checking in to see if removing the jungle wood works for you.
 

GuitarMoshi

New Member
Jul 29, 2019
35
0
0
Thanks so much for replying! After reading what you said I got to thinking about what was near my harvesters. In both worlds I stopped being able to log in shortly after harvesters were near jungle wood. In my DW20 world one of the harvesters was collecting cocoa beans (planted on jungle wood logs of course) and in my MF2 world I had jungle wood logs as decorative trim along parts of the wall. I've never used mcedit but may have to look into it to try to salvage my saved games. Will be checking in to see if removing the jungle wood works for you.
Success! I'm horrible at MCEdit but I managed to get rid of the tree and everything is now working again. In the editor the leaves were there so that confirms what I was seeing... the leaves get broken and then the harvester chokes on the jungle wood. I removed the entire tree including the Harvestcraft hanging fruits and all is well again. All my harvesters now have jungle wood set to YES... :cool:
 

PhilHibbs

Forum Addict
Trusted User
Jan 15, 2013
3,174
1,128
183
Birmingham, United Kingdom
Has anyone else had a problem with Heart Cannisters not working? Last night, I noticed that my health would not regenerate over 10 hearts. I tried removing and replacing the cannisters.
 

Sideshow

New Member
Jul 29, 2019
13
0
0
Success! I'm horrible at MCEdit but I managed to get rid of the tree and everything is now working again. In the editor the leaves were there so that confirms what I was seeing... the leaves get broken and then the harvester chokes on the jungle wood. I removed the entire tree including the Harvestcraft hanging fruits and all is well again. All my harvesters now have jungle wood set to YES... :cool:
Great news! Guess I'll be giving myself a crash course in mcedit to put it to use fixing my saves as well. Nice to know that all the time invested in those two worlds isn't lost. Thanks again for your input with this issue GuitarMoshi.
 

ZtH

New Member
Jul 29, 2019
10
0
0
2.1.6 ruined both of my worlds! I have no idea why, but now my servers has about 3 tps both. I can understand my main semi-public server, but my single LP??
 

LORD_MJ

New Member
Jul 29, 2019
18
0
1
Mod Pack: Magic Farm 2 (2.1.6)
Mod & Version: Not sure
Pastebin link to crash log: N/A
Whats the bug? Horses break leads after a few seconds.
Can it be repeated? Yes
Known Fix: None
 

loboca

New Member
Jul 29, 2019
416
0
0
Mod Pack: Magic Farm 2 (2.1.6) (latest)
Mod & Version: Recipe Tweaker and..?
Pastebin link to crash log: N/A
Whats the bug? Four gravel in a crafting square does not make a piece of flint. Makes a gravel brick block (or something like that).
Can it be repeated? Yes
Known Fix: None
 

RustyTheBrave

New Member
Jul 29, 2019
1
0
0
Mod Pack: Magic Farm 2.1.6
Mod & Version: Iguana's Tweaks for Tinker's Construct
Pastebin link to crash log: N/A
Whats the bug? Right-clicking on a fence with a mattock gives it free XP without damaging the mattock.
Can it be repeated? Yes.
Known Fix:
 

snowasaurus

New Member
Jul 29, 2019
1
0
0
Mod Pack: Magic Farm 2.1.6
Mod & Version: MineFactory Reloaded 2.7.7
Pastebin link to crash log: None
Whats the bug? Can't place fertilizer (MFR or Forestry) inside the Fertilizer.
Can it be repeated? Yep. I was using 2.1.7 before, but downgraded to 2.1.6 with a clean download to test it.
Known Fix: Nope
 

Janitor

New Member
Jul 29, 2019
1
0
0
Mod Pack: Magic Farm 2.1.9
Mod & Version: IguanaTweaks-1.6.4-prog5
Pastebin link to crash log: None
Whats the bug? Can't fill clay bucket with lava or water. Right click on source blocks do noithing.
Can it be repeated? Yes.
Known Fix: None
 
Last edited:
  • Like
Reactions: OwenG
Status
Not open for further replies.