1. This section of the forums is now closed. You can post and answer support requests on the new support site here

JVM Arguments for Modded Minecraft (Updated 12/30/13)

Discussion in '[Archived] Tech Support' started by Eyamaz, Aug 13, 2013.

  1. Eyamaz

    Eyamaz New Member

    Hrm. You should be getting a lot less of that with the arguments than without. Try upgrading your java to u51.
     
    Croaganey likes this.
  2. Croaganey

    Croaganey Active Member

    That seems to have helped to lessen the messages in quick testing so far. Thank you! I'm still seeing a couple "Memory overburdened" messages, but I was able to punch several trees, cows and pigs without "Can't keep up" errors. ;)

    Extra info: u51 didn't help MultiMC v0.1.1 until I updated to v0.2
     
  3. Henry Link

    Henry Link Popular Member

    Eyamaz, I was wondering if Croaganey might be better off running a server on the same machine he is using for his SSP? His specs he listed was for a 2GHz CPU. If he was to do that would it allow his client and server to run in separate cores on the same machine?
     
  4. Eyamaz

    Eyamaz New Member

    Its always worth a shot. Propperly done, he -should- get a increase seperating them. If it's configured correctly. I've never done it at less than 3GHz though, so I can't he sure.
     
  5. Croaganey

    Croaganey Active Member

    Oof. That'd be a steep learning curve. And to add to it, I'm seeing this on my system as well as DH's Win8 system. We're both on laptops, been playing various FTB packs for a year, play offline due to limited Internet access, don't even try a LAN multiplayer together in our RV, fun as that might be.

    It sounds like you don't believe the JVM arguments are my issue, if I understand correctly?
     
  6. Eyamaz

    Eyamaz New Member

    Oh god laptop. Should have known from the M on the Gfx card :p
    No, I don't believe they are the issue at all. You have a mediocre cpu by today's standards, and on a laptop to boot.
    You may want to try disabling any and all background applications you can first. The arguments will help you, but that core speed is going to kill you with the bigger 1.6 packs :(
     
  7. Croaganey

    Croaganey Active Member

    Ouch. Sad news. Thanks for the help. At least I've ruled out JVM arguments and confirmed I'm using them correctly.

    In further testing tonight I think I have a mod interaction problem, so I'll move along out of this thread and keep working on it. Disabling ATG tonight helped on my system - 20 min play so far with no errors. Will test his tomorrow and carry on.
     
  8. Gerald Huppertz

    Gerald Huppertz New Member

    Eyamaz, I noticed your server arguments do not have ParallelGCThreads=x. Is this of no real benefit? I am looking at setting up a FTB Monster server on a dedicated PC running Ubuntu. I read (possibly incorrectly) that using JDK and adding ParallelGCThreads to the startup will allow Java to use all cores to optimise itself. Is this corrector should I leave that out and stick with your code as is? Thanks.
     
  9. Eyamaz

    Eyamaz New Member

    Java automatically sets this equal to the number of cores your computer has. It also only affects the garbage collector, not the program itself.
     
  10. jeezor

    jeezor New Member

    This is as far as the console gets before freezing up when I launch it
    Logging in...
    Login complete.
    Syncing Assets:
    The FTB Launcher has found the following Java versions installed:
    The FTB Launcher has found the following Java versions installed:
    Java Path: C:\Program Files\Java\jre7\bin\javaw.exe
    Setting MinMemory to 256
    Setting MaxMemory to 2048
    Defaulting PermSize to 256m
    Error occurred during initialization of VM
    Incompatible minimum and maximum heap sizes specified
    Picked up _JAVA_OPTIONS: -Xmx512M

    EDIT: I removed the first option and for some reason it worked.
    EDIT2: ...untill I tried to start a world

     
    Last edited: Jan 24, 2014
  11. Eyamaz

    Eyamaz New Member

    go into your windows environment variables and also check your java control panal and remove the -Xmx512M argument that is set there.
     
  12. jeezor

    jeezor New Member

    I did that and now im getting
    Code:
    Invalid initial heap size: -Xms2048m-XX:PermSize=256m

    The problem being java cant create a virtual machine

     
  13. Eyamaz

    Eyamaz New Member

    needs to be a space you have
    -Xms2048m-XX:PermSize=256m
    and need
    -Xms2048m -XX:PermSize=256m
     
  14. jeezor

    jeezor New Member

    If I werent so tired, id feel stupid. Thanks so much and have a nice night!
     
    Eyamaz likes this.
  15. zenkmander

    zenkmander New Member

    Hey Eyamaz. I'm running 4 GB from the launcher due to "HD" textures (Faithful 32x). Which of these arguments will I need to change to compensate? Would it just be -Xms4096m?
     
  16. flamedance58

    flamedance58 New Member

    Running a FTB pack that's been edited (Private Pack) that's got about 101 Mods in it, most from FTB with a few extras.

    I'm running Java 7 U45 32 & 64-Bit.
    All the setting you suggested for 2gigs+

    Operating System: Windows 7 Home Premium 64-bit
    Processor: Intel(R) Core(TM) i3 CPU 540 @ 3.07GHz (4 CPUs), ~3.1GHz
    Memory: 4096MB RAM
    Available OS Memory: 4024MB RAM
    Page File: 2948MB used, 5095MB available


    I run at 5-10 fps :(

    Suggestions on what I can to fix this? Oddly enough I only had this issue today, before I would be at 30fps.

    [Edit] Remembered how to use dxdiag!
     
  17. Eyamaz

    Eyamaz New Member

    I always recommend setting Xms and Xmx equal. So set -Xms4G -Xmx4G
     
  18. zenkmander

    zenkmander New Member

    I noticed that Xmx isn't in the FTB Launcher arguments. Is there a reason for that? And just to confirm, it would be "-Xms4G", not "-Xms4096m"?
     
  19. Eyamaz

    Eyamaz New Member

    3GB total? You can try setting Xms and Xmx both to 1024m, or 1536m.
     
  20. Eyamaz

    Eyamaz New Member

    For the FTB launcher you set the slider to 4G. For Xms, both those values are exactly the same, it doesn't matter which you use.
     

Share This Page