Unsupported Horizons : 1.6.4 Bug Reports {PUBLIC BETA}

Discussion in 'Modpack Bugs' started by Jadedcat, Dec 8, 2013.

Thread Status:
Not open for further replies.
  1. gallowglass

    gallowglass New Member

    Mod Pack: Horizons 1.0.11
    Mod & Version: DragonAPI v14 / RotaryCraft v14b
    Pastebin link to crash log: no crash log
    Whats the bug? Placing a RotaryCraft pump above a pool of Engineer's Toolbox slickwater results in an apparently infinite loop, with the message below repeated rapidly in the server log:
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:214)
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:216)
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:213)
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:213)
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:213)
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:213)
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:213)
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:213)
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:213)
    2014-03-06 19:46:01 [INFO] [STDERR] at Reika.DragonAPI.Instantiable.Data.BlockArray.recursiveAddLiquidWithBounds(BlockArray.java:213)
    Can it be repeated? Yep, every time. I used MCedit to delete the pump and everything came back smoothly. Placed a pump over slickwater, blammo. Mcedit the pump out, everything back to normal.

    Known Fix: Upgrade to a newer DragonAPI/RotaryCraft? IDK. Could someone who is running a newer Horizons build check it out. FWIW, the slick water pool is 19x19 and at least 64 blocks deep. (I was planning on pumping my slickwater into a tank with the RotaryCraft pump now that my husher maxxed out....)
     
  2. chaossdragon

    chaossdragon New Member

    Mod Pack: Horizons v2.0.2
    Mod & Version: Translocators v1.1.0.14
    Pastebin link to crash log: N/A
    Whats the bug? Hit 'C' to interface with the blue crafting grid, and attempting to craft anything causes a client crash to desktop, relog and instantly crash to desktop, repeat add nausium...
    Can it be repeated? Happened to two of my players on my server.
    Known Fix: "/tpx Player_Name Yourself" or delete player file and restore their lost items...(optional)
     
  3. Eyamaz

    Eyamaz New Member

    This should be fixed in .15 which is in 2.1.0.
     
  4. caelin

    caelin New Member

    Mod Pack: Horizons v1.0.13 -> v2.0.2
    Mod & Version: Metallurgy 3 v3.3.2.18 -> 3.3.3.1
    Pastebin link to crash log: Pbin was cranky about size so I split the log. This is our live version with config carry-over from 1.0.13 Log1of2 Log2of2
    Whats the bug? Since we upgraded to v2.0.2 we have many Black/Purple checked blocks in the world that used to be Metallurgy ores and such. I think it may have to do with this line in the HZ 2.0.0 config changes notes:
    • Shifted the IDs of all Metallurgy Machines and a few items
    I'm not sure how to start troubleshooting this for real. If I use our 1.0.13 configs we get log errors about Metallurgy items in addition to these blocks. I have tried pulling the world into a local testing server and using the stock 2.0.2 Metallurgy configs. There the item errors dissipate, but the funky blocks remain. The blocks show ID's like: tile.Ender905.10.name in the tool-tip. I have confirmed these are(were?) actual ore blocks by spinning up a backup copy of the server/world to verify.

    I've been looking for leads on how to work this problem, but the google-fu on this is apparently weak for me. I may be 'asking' the wrong questions though as I'm pretty novice on troubleshooting this kind of error.

    Can it be repeated? Yep, even tried from a backup world.
    Known Fix: None by me... but that's why I'm here. :)
     
    Last edited: Mar 9, 2014
  5. Eyamaz

    Eyamaz New Member

    I moved Horizons to 2.x.x specifically because of this and plainly stated in our news section that world's would not survive an update.
     
  6. caelin

    caelin New Member

    Jeez... I looked all over and missed it earlier, but found it after this. I took no entry in the "Important Update News Read Before Updating any Pack" as a greenlight, thus missing what you said (indeed plainly stated) in the "The slightly overdue updates." I just missed the correct bit of info by looking at what I thought was the master list of update landmines. We'll likely roll back or I may try to rejigger the IDs somehow so we can stay at 2.0.2 for the time being.

    At least we know why things are wonky. :)

    Thanks for the response Eyanmaz!
     
    Eyamaz likes this.
  7. MUSE_iC

    MUSE_iC New Member

    Mod Pack: Horizons v2.1.0

    Mod & Version: Thaumcraft 4.1.0f
    Pastebin link to crash log: None
    Whats the bug? Tempestas has the incorrect combination. The thaumonomicon list it correctly on the aspect section (aer + aqua). However when working on the research table the combination comes up as the one for Volatus (aer + ordo). This makes it impossible to make any volatus aspect since it just makes tempestas. Since this is an issue with the mod the issue is also present in Monster v1.1.0

    Can it be repeated? Yes

    Known Fix: None that I know of
     
    Eyamaz likes this.
  8. Mibudemoneyekyo

    Mibudemoneyekyo New Member

    Modpack: Horizons v2.1.0

    Mod & version: N/A

    Pastebin link to crash log: N/A

    whats the bug? Me and my friends will go into the nether, and the memory will just sky rocket. After about 5 mins being in the nether the client will just crash or freeze. Then we have to end the task to shut off minecraft. So we haven't done much with it and we believe that its a leak in the nether. We don't know if a mod is causing it, or if the code for the nether got messed up.

    Can it be repeated? yes many times it has

    Known Fix: haven't been able to fine one
     
  9. BlueDoesIt2

    BlueDoesIt2 New Member

    Mod Pack: Horizons
    Mod & Version: Archimedes Ships (Horizon 2.1.0)
    Pastebin: When it crashes it crashes everything Minecraft and launcher
    Whats the bug?: When I interact with the (Helm) of my airship my game just exits itself and the launcher before I can do anything and when I try to reconnect to the server or single-player world it logs me in and within a second it crashes all over again..

    Known Fixes: None that I know of I've been lookin' on forums for a few hours with no information
     
  10. chaossdragon

    chaossdragon New Member

    Archimedes' Ships allows the player to create custom multi-block ships that move smoothly as a unit. The heart of the mod is the Ship's Helm. All blocks touching the Ship's Helm, excepting certain naturally-occurring blocks including water and grass, will become a part of the ship when the Ship's Helm is right-clicked. This will also cause the player to mount the ship.

    source: http://ftbwiki.org/Archimedes'_Ships

    reason it was disabled...
     
    BlueDoesIt2 likes this.
  11. BlueDoesIt2

    BlueDoesIt2 New Member

    ok soo if i disable it again will it crash on startup still or will i need to start over?
     
  12. chaossdragon

    chaossdragon New Member

    In all honesty I would start over. disabling a mod after the mod in question was used to place blocks in the world could cause corruption.
    That is if you wont lose much... make a back up and try disabling and see if its ok...

    I am sorry if my previous response seemed trolly or rude. That wasn't the intention. (re-reading it myself made me cringe.)
     
  13. BlueDoesIt2

    BlueDoesIt2 New Member

    nah it was what I was looking for, an answer lol.. soo i need to just drag drop my server world out of the files and restart.. ok thanks for the help chaossdragon :)
     
  14. Pyure

    Pyure Not Totally Useless

    Kitsone, I get this error too. In the interest of establishing helpful patterns, are you by any chance growing Magical Essence crops specifically?

    Another player posted a picture featuring that particular crop, and I as well, both getting the same error.
     
  15. Kitsone

    Kitsone New Member

    I don't believe the Magical Essence crop itself was harvesting at all so I took it out of the Fan Autofarm area. The crops I had Fans harvesting were Blaze, Diamond, Iron, Gold, Emerald, Lapis, Magma, Skeleton, Nether, Dye, Wheat, Redstone, and perhaps a few others. The Rotarycraft update in Horizon's 2.1.0 fixes the issue btw though some magical crops still aren't harvested by the Fans.
     
    Pyure likes this.
  16. Wisq

    Wisq New Member

    Couple of bugs:
    Mod pack: Horizons v2.1.0

    First bug:
    Mod & Version:
    WeatherMod v1.59

    There's a "waterfall" sound when water falls a long distance and hits a solid surface at the bottom. The sound seems to be generated at the bottom where it hits; simply having water rushing by isn't noisy in itself. (This is great for e.g. Rotarycraft hydro generation; really makes it sound like it's doing something.)

    The problem is, this sound seems to be bugged. I had a village with a standard 2x2 well (Minecraft-generated) and I tried to take too much water too fast from the well. The game seemed to detect this as "falling water" now, and the bottom of the well started generating noise. Problem is, I can completely fill the well in / dig it out / let water fall down it / pick that water back up and dry it out / etc. and the sound never stops.

    I've had at least one other occasion where I've accidentally messed up water right next to my base. Since I didn't want to listen to falling water forever, and (at the time) couldn't figure out how to disable it / couldn't identify the source or fix it, my only recourse was to go back to my last hourly backup.

    I've since IDed it as the WeatherMod, just by looking through all the mod zipfiles for any relevant sounds. I expect at some point I may end up having to disable that sound via a resource pack.

    Second bug:
    Mod & Version:
    unknown :(

    At one point I noticed server lag while doing something unrelated, so I went to check my server monitoring. Sure enough, tick rate was below 20 for the first time ever, and was getting progressively worse. What's interesting was that all the lag was in dimension -1 (the nether), I was the only one online, and I wasn't in the nether at all (although we had recently left there). When I tried to go to the Nether to investigate (using Opis), the server booted me and wouldn't let me back on; my client just showed server timeouts. I killed and restarted the server, and the problem didn't come back.

    Here's the timeline:
    [​IMG]
    The blue part on the top left graph is dimension -1; yellow is the overworld. In the bottom left graph, I'm yellow.

    This is a small server, with only two players. I trust the other player, and she doesn't do anything weird (or anything at all) with automation or whatnot; this was just a routine nether resources collection run. We don't have any anchors in the Nether (or anywhere, yet) so it should have just been unloaded when we left. When I returned after the server restart, the Nether was all lag-free — the only "red zones" in Opis were what looked like beehives in the ceiling, but those were only taking a few microseconds and were not getting any worse.

    The server logs are very unhelpful in this case. It's basically just what you'd expect: A lot of "Can't keep up!" messages. No other messages whatsoever, or else I would gladly forward them along.
     
  17. racoonist

    racoonist New Member

    Mod pack: Horizons v2.1.0
    Bug: no diamonds anywhere

    i have been playing horizons for a while now, and even in test world i can't find any naturally spawning diamond ore. ANYWHERE. is this intentional or is there something wrong with my computer/code? (I do have the recommended version running) thanks for the help!
     
  18. gallowglass

    gallowglass New Member

    I am running the same version of Horizons and have diamonds. They do seem more rare, but I have found them.
     
  19. racoonist

    racoonist New Member

    Well, I can't find any at all. Trust me I've spent several hours clearing rocks in creative and managed to find nothing...
    Either way, is there a method to tone down the frequency of Tropicraft palms? They seem to be everywhere and my deserts look like forests for crying out loud...(I'm not even joking, look at the image) trtrtrtr.jpg
     
  20. gallowglass

    gallowglass New Member

    Mod Pack: Horizons 2.1.0
    Mod & Version: ??
    Pastebin link to crash log: No crash. But there is this:
    2014-03-18 23:19:05 [INFO] [Minecraft-Server] An unknown error occurred while attempting to perform this command
    2014-03-18 23:19:05 [INFO] [STDERR] java.lang.IllegalArgumentException: Comparison method violates its general contract!
    2014-03-18 23:19:05 [INFO] [STDERR] at java.util.ComparableTimSort.mergeLo(Unknown Source)
    2014-03-18 23:19:05 [INFO] [STDERR] at java.util.ComparableTimSort.mergeAt(Unknown Source)
    2014-03-18 23:19:05 [INFO] [STDERR] at java.util.ComparableTimSort.mergeForceCollapse(Unknown Source)
    2014-03-18 23:19:05 [INFO] [STDERR] at java.util.ComparableTimSort.sort(Unknown Source)
    2014-03-18 23:19:05 [INFO] [STDERR] at java.util.ComparableTimSort.sort(Unknown Source)
    2014-03-18 23:19:05 [INFO] [STDERR] at java.util.Arrays.sort(Unknown Source)
    2014-03-18 23:19:05 [INFO] [STDERR] at java.util.Collections.sort(Unknown Source)
    2014-03-18 23:19:05 [INFO] [STDERR] at net.minecraft.command.CommandHelp.func_71534_d(SourceFile:74)
    2014-03-18 23:19:05 [INFO] [STDERR] at net.minecraft.command.CommandHelp.func_71515_b(SourceFile:36)
    2014-03-18 23:19:05 [INFO] [STDERR] at net.minecraft.command.CommandHandler.func_71556_a(CommandHandler.java:88)
    2014-03-18 23:19:05 [INFO] [STDERR] at net.minecraft.server.dedicated.DedicatedServer.func_71333_ah(DedicatedServer.java:315)
    2014-03-18 23:19:05 [INFO] [STDERR] at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:277)
    2014-03-18 23:19:05 [INFO] [STDERR] at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:587)
    2014-03-18 23:19:05 [INFO] [STDERR] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:484)
    2014-03-18 23:19:05 [INFO] [STDERR] at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)
    Whats the bug? /help doesn't work. Instead of bringing up the help it just says "An unknown error occurred while attempting to perform this command"
    Can it be repeated? Yep.
    Known Fix: None.[DOUBLEPOST=1395199847][/DOUBLEPOST]Mod Pack: Horizons 2.1.0
    Mod & Version: Pam's Harvestcraft
    Pastebin link to crash log: No crash
    Whats the bug? Fruit on trees shows up as "slickwater" in WAILA
    Can it be repeated? Yep
    Known Fix: None.
     
Thread Status:
Not open for further replies.

Share This Page