Unsupported Direwolf 20: 1.6.4 {PUBLIC BETA}

Status
Not open for further replies.

MaGriffw

New Member
Jul 29, 2019
31
0
0
Hey Jaded ^..^/ Got a simple, but painful bug to report..

Mod Pack: Direwolf20
Mod & Version: v1.0.0 of course.

I'd set up a Server to run/test with a few of the local friends. Now, it's possible that I might have caused this issue just setting it up, but here's what I've seen so far.
Once and a while we'll get massive lag across the whole server. causing almost all players to crash out. a minute later, the lag drops, and we can log in again. It's a odd bit of lag, spiking in the high 200+ms range, but I'm assuming that's just beta bugs, and mob population loading across a whole map area. Otherwise, we're still seeing 40-70+ ms ticks. I might be able to trouble shoot this, but then I found the following issue.
The real issue is, although we have Opis in the list of mods, I can't seem to get a lot of the mod-based /commands to work... like for any of the mod commands. And, worse than this, I can't bring up any of the /help commands either through the Server itself, or in-game interface.
I noticed this with a ...953 version of forge before DW came out with his build as well, but I'd attributed that to my poor ability to put mods together correctly. Now I'm not so certain. Repeated it several times, and I'll update with the error msg. that appears in game when I get it loaded and up today.
So, I'm not expecting an immediate fix, but if anyone knows the issue, feel free to buzz me. Also if the high spike rates get tracked down, I'd love to know the cause. My best theory suggests Ars Magica mobs, but I haven't disabled it yet to try to prove it.

Many Thanks ahead of time,
Griff ^..^/
 

LimeZest

New Member
Jul 29, 2019
6
0
0
Hey Jaded ^..^/ Got a simple, but painful bug to report..

Mod Pack: Direwolf20
Mod & Version: v1.0.0 of course.

I'd set up a Server to run/test with a few of the local friends. Now, it's possible that I might have caused this issue just setting it up, but here's what I've seen so far.
Once and a while we'll get massive lag across the whole server. causing almost all players to crash out. a minute later, the lag drops, and we can log in again. It's a odd bit of lag, spiking in the high 200+ms range, but I'm assuming that's just beta bugs, and mob population loading across a whole map area. Otherwise, we're still seeing 40-70+ ms ticks. I might be able to trouble shoot this, but then I found the following issue.
The real issue is, although we have Opis in the list of mods, I can't seem to get a lot of the mod-based /commands to work... like for any of the mod commands. And, worse than this, I can't bring up any of the /help commands either through the Server itself, or in-game interface.
I noticed this with a ...953 version of forge before DW came out with his build as well, but I'd attributed that to my poor ability to put mods together correctly. Now I'm not so certain. Repeated it several times, and I'll update with the error msg. that appears in game when I get it loaded and up today.
So, I'm not expecting an immediate fix, but if anyone knows the issue, feel free to buzz me. Also if the high spike rates get tracked down, I'd love to know the cause. My best theory suggests Ars Magica mobs, but I haven't disabled it yet to try to prove it.

Many Thanks ahead of time,
Griff ^..^/
I'm seeing something similar to this but on single player, another person suggested it might be a memory leak.
 

convictvx

New Member
Jul 29, 2019
25
0
0
Mod Pack: Direwolf20
Mod & Version: project red exploration
Pastebin link to crash log: no crash
Whats the bug? stone sickle cant be crafted with stone, needs flint, so or the crafting recipe is wrong, or the name is wrong.

here are 2 printscreen links, 1 showing to try to craft it with cobble, other showing recipe in nei.
http://prntscr.com/2affrb (trying to craft with cobblestone)
http://prntscr.com/2afg53 (recipe showing in nei)

Can it be repeated? yes, try to craft with stone.
Known Fix: or craft with flint or make an other sickle (iron, gold, wooden, .....)
 

KuroiMitsukai

New Member
Jul 29, 2019
16
0
0
Mod Pack: Direwolf20
Mod & Version: project red exploration
Pastebin link to crash log: no crash
Whats the bug? stone sickle cant be crafted with stone, needs flint, so or the crafting recipe is wrong, or the name is wrong.

here are 2 printscreen links, 1 showing to try to craft it with cobble, other showing recipe in nei.
http://prntscr.com/2affrb (trying to craft with cobblestone)
http://prntscr.com/2afg53 (recipe showing in nei)

Can it be repeated? yes, try to craft with stone.
Known Fix: or craft with flint or make an other sickle (iron, gold, wooden, .....)
Flint is a type of stone so the name isn't actually wrong to be honest.
 

obobeyo

New Member
Jul 29, 2019
6
0
0
Mod Pack: Direwolf20
Mod & Version: server jar
Pastebin link to crash log: http://pastebin.com/JrkjQqNU read bottom up
Whats the bug?: when i upload my DW20 jar to my FTP site using filezilla the server cant launch the JAR it crashes the server every time starting it up
Can it be repeated?:yes
Known Fix: unknown
i can post screen shots if need be
thanks for reading
 

jmarler

New Member
Jul 29, 2019
39
0
0
Mod Pack: Direwolf20
Mod & Version: server jar
Pastebin link to crash log: http://pastebin.com/JrkjQqNU read bottom up
Whats the bug?: when i upload my DW20 jar to my FTP site using filezilla the server cant launch the JAR it crashes the server every time starting it up
Can it be repeated?:yes
Known Fix: unknown
i can post screen shots if need be
thanks for reading
Try putting the server .jar in the base directory of the server, above where the libraries folder is. If you can't do that, copy the libraries folder into the same folder as the .jar. The new forge requires this. I had a similar problem with MCPC+ that was easily fixed by moving the .jar.
 

dragon queen

New Member
Jul 29, 2019
3
0
0
Mod Pack: Direwolf20
Mod & Version: not sure
Pastebin link to crash log:N/A
Whats the bug? I am not 100% sure its a bug but I believe it is. I was strip mining in the overworld and I came across a large vein of glowstone. I uploaded a picture of it.
Can it be repeated?N/A
Known Fix:N/A

Apologies if this is not a config issue/bug.


god I feel stupid its one of those magic bee hives in the middle (I did dig into it but didnt find then did find it)
 

Attachments

SissyRoo

New Member
Jul 29, 2019
5
0
0
Mod Pack: Direwolf 20
Mod & Version: Portal Gun 2.0.1
Whats the bug: On a SMP server portals are not unique to the player anymore. If one person has a P-body gun for example and another has that same gun they can overwrite each others portals. Portals are supposed to be unique to the player regardless of the same gun.
Can it be repeated? Repeated with P-body, Standard, Bacon, Atlas, Potato guns.
Known Fix: None that I can find.
 

Uncast

New Member
Jul 29, 2019
1
0
0
Mod Pack: Direwolf 20
Mod & Version: N/A?
Whats the bug: can't break blocks that are breakable by hand (dirt, wood, leaves). can only be broken by the appropriate tool.
Can it be repeated? Currently having the issue. (restarted twice).
Known Fix: None that I can find.

Gettin out of adventure mode might help -_- ... FIXED
 
Last edited:
  • Like
Reactions: RestrictedDruid

Ashzification

New Member
Jul 29, 2019
7,425
1
0
  • Like
Reactions: RestrictedDruid

RestrictedDruid

New Member
Jul 29, 2019
59
0
0
Modpack: Direwolf20 1.6.4
Mod: Tinker's Construct

What's the bug? The knapsack disappears visually from the inventory interface. It is still attached and becomes visible again when you switch to the armour tab and take off/replace the knapsack. (Thought I'd lost my portal gun and then realized the knapsack tab was missing, replaced it and got my portal gun out of it *derp*).
 

prodamn

New Member
Jul 29, 2019
6
0
0
Mod Pack: Direwolf20
Mod & Version: Thaumic Tinkerer
Pastebin link to crash log: http://pastebin.com/qadqui0K
Whats the bug? rightclicking the Thaumic Rehabilitator crashes client.
Can it be repeated? I'm sure it can, try rightclicking the Thaumic Rehabilitator, i guess.
Known Fix: errr.... do... you... have one ?
 

NINJANICK153

New Member
Jul 29, 2019
1
0
0
Mod Pack: Direwolf20
Mod & Version:Launcher
Pastebin link to crash log:N/A
Whats the bug?i cant launch the game it opens, then freezes at the mojang picture, then closes console and game.
Can it be repeated?Yes everytime i launch
Known Fix:no clue
 

obobeyo

New Member
Jul 29, 2019
6
0
0
Try putting the server .jar in the base directory of the server, above where the libraries folder is. If you can't do that, copy the libraries folder into the same folder as the .jar. The new forge requires this. I had a similar problem with MCPC+ that was easily fixed by moving the .jar.
thank you so much you have no idea how frustrating this was for me
i but the libraries in the jar folder thanks!
 
  • Like
Reactions: jmarler

Goli

New Member
Jul 29, 2019
2
0
0
Mod Pack: Direwolf20
Mod & Version:Launcher / Thermal Expansion / IC2 (Direwolf20 1.0.0 _ 1.6.4 )
Pastebin link to crash log:N/A
Whats the bug? Coal Dust (IC2) and/or Pulverized Coal (TE) can not be crafted into Raw Carbon Fibre (IC2), the recipes seem to be wrong, it is listed in NEI however.
Can it be repeated? Yes.
Known Fix: nope
 

MeteorDevil

New Member
Jul 29, 2019
5
0
0
Mod Pack: Direwolf20
Mod & Version: none
Pastebin link to crash log: doesnt crash
Whats the bug? Minecraft exits after moving a few blocks for a few seconds, program automatically exits without crash log.
Can it be repeated? yes, start a new world and walk around.
Known Fix: no clue
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
Mod Pack: Direwolf20
Mod & Version: none
Pastebin link to crash log: doesnt crash
Whats the bug? Minecraft exits after moving a few blocks for a few seconds, program automatically exits without crash log.
Can it be repeated? yes, start a new world and walk around.
Known Fix: no clue
Need a console log if there is no crash log.[DOUBLEPOST=1386812874][/DOUBLEPOST]
Mod Pack: Direwolf20
Mod & Version:Launcher / Thermal Expansion / IC2 (Direwolf20 1.0.0 _ 1.6.4 )
Pastebin link to crash log:N/A
Whats the bug? Coal Dust (IC2) and/or Pulverized Coal (TE) can not be crafted into Raw Carbon Fibre (IC2), the recipes seem to be wrong, it is listed in NEI however.
Can it be repeated? Yes.
Known Fix: nope
This belongs in the modpack bug thread
 

Ryu Marksmen

New Member
Jul 29, 2019
2
0
0
If you connect a redstone energy conduit to a wooden transport pipe, it'll connect to the pipe. If you feed RF through that conduit, instant crash.

This is prolly due to the fact that conduits used to supply MJ, which could be given to wooden transport pipes before this update.
 

iPOLARB3AR

New Member
Jul 29, 2019
1
0
0
Mod Pack: Direwolf20
Mod & Version:Forestry,thermal expansion,Buildcraft
Pastebin link to crash log:
Whats the bug? forestry engines can not seem to be conected to any for of energy transport
Can it be repeated? yes
Known Fix:none that i know of
 
Status
Not open for further replies.