[1.7.10] TolkienCraft II - Adventure Awaits! - v2.9.5[QUESTS][ADVENTURE][NORMAL MODE]

GreatOrator

New Member
Jul 29, 2019
2,613
0
0
Baker's and blacksmith's quest isn't showing up for CustomNpcs. I haven't completed 'thin their numbers' yet, but I thought the baker and blacksmith quest should activate before that?
Those don't unloack until thin their numbers is completed, if quests disappear when you save and quit, that is usually because for some reason your UUID which is set by mojang has changed.
 
  • Like
Reactions: eDilettante

ZephyrWindSpirit

New Member
Jul 29, 2019
280
0
1
Those don't unloack until thin their numbers is completed, if quests disappear when you save and quit, that is usually because for some reason your UUID which is set by mojang has changed.
Funny, because until I took the hqm reward of Town Tour after I accepted Thin Their Numbers from the King (not completed it), I was able to talk to them and take the quest, and they showed up. Lucien's too.
 

BerryRJ

New Member
Jul 29, 2019
38
0
0
Here's a bug report: when I click anywhere inside the orange box, I hear a click but nothing else happens. If I click on the banner tab outside of the orange box I get the appropriate tab displayed. When I click within the blue box, I hear the click and I see the quest log tab for about a quarter of a second then right back to the inventory tab. If I hit the 'L' key I see the quest log just fine.
This is a fresh install of the 2.4.1 pack from the FTB launcher with the 2.4.0-beta template folder. No other changes or additions.
 

Attachments

Teraphina

New Member
Jul 29, 2019
102
0
0
Here's a bug report: when I click anywhere inside the orange box, I hear a click but nothing else happens. If I click on the banner tab outside of the orange box I get the appropriate tab displayed. When I click within the blue box, I hear the click and I see the quest log tab for about a quarter of a second then right back to the inventory tab. If I hit the 'L' key I see the quest log just fine.
This is a fresh install of the 2.4.1 pack from the FTB launcher with the 2.4.0-beta template folder. No other changes or additions.
that is a known issue you need to use the key bind to go into the quest menue "L" by default
 

GreatOrator

New Member
Jul 29, 2019
2,613
0
0
Thank you, yeah, that is a long term bug (the tabs used to stack on top of each other so at least the dev has improved it) and it apparently is difficult to make happene because those tabs are not any part of forge code and is custom written. Still, the report is good and I will forward over to the devs to see if they can use it to find a fix.
 

Teraphina

New Member
Jul 29, 2019
102
0
0
@GreatOrator ok so the quest system is very simular to what i used to write quests in EQ1 with teh exception i cant find where the quest looks for the item that is to be turned in, i have looked through all the quest files and the one that has teh council summons i have compared to other quests of the same type and the only difference i saw is it was missing the RepairCost: 2, line above the item name, going to try adding that line and see if it makes any difference

edit... ok that didnt change anything, the quest still isnt reconizing the "Council Summons"
 
Last edited:

GreatOrator

New Member
Jul 29, 2019
2,613
0
0
@GreatOrator ok so the quest system is very simular to what i used to write quests in EQ1 with teh exception i cant find where the quest looks for the item that is to be turned in, i have looked through all the quest files and the one that has teh council summons i have compared to other quests of the same type and the only difference i saw is it was missing the RepairCost: 2, line above the item name, going to try adding that line and see if it makes any difference

edit... ok that didnt change anything, the quest still isnt reconizing the "Council Summons"
Is on my list to check tonight. Did some quest linking fixing this morning but was short on time and could not get to this one. If i figure out what happened i will message you how to fix.
 
  • Like
Reactions: eDilettante

GreatOrator

New Member
Jul 29, 2019
2,613
0
0
Yeah, been an issue with pathing which is handled by vanilla minecraft. Not much can be done except either removing the gate and letting the chickens out or removing the golems
 
  • Like
Reactions: eDilettante

sabjoo

New Member
Jul 29, 2019
13
0
0
Okay, can someone help me to get this mod pack to work? I've been trying for at least an hour to start the pack, nothing works and all I'm get are errors. Yes I have downloaded the save and put it in its folder then click to run the save right? I get missing blocks/items and after clicking okay it freezes for an ungodly long time then crashes (I've dedicated 3.5 gb of ram). http://pastebin.com/8kyBgjYv
 

GreatOrator

New Member
Jul 29, 2019
2,613
0
0
  1. cpw.mods.fml.common.LoaderException: java.lang.OutOfMemoryError: Java heap space
Very first line in crash log...nothing to do with the modpack fortunately
 
  • Like
Reactions: eDilettante

GreatOrator

New Member
Jul 29, 2019
2,613
0
0
Okay I got it to work, turns out it uses 6gb of ram to run which is silly.
Naw doesn't need 6GB, you had it set to 1GB according to your crash log, 3-4 GB is all it needs
are the mystcraft portals working again or do they still freeze the game?
The portals were not what was freezing the game (I use mystportals in extraordinary way on the private server) it is world generation causing the freezes/crashes and they have been working on it but not yet released an update
 
  • Like
Reactions: eDilettante

birdiegirl4444

New Member
Jul 29, 2019
62
0
0
Hi GO, TheRangerX, Hey, IamMorvash and I were on the server, Morvash was playing with the tents in our base, He put a couple down and we looked at the gui and commented and so forth. I told him to put one down outside. I am sorry, but it just did not register very fast that I knew there was a bug with the tents. Anyway, he pops up top the mountain and puts a tent down and puts a chest and a sleeping bag in it and all is okay, but as soon as he put a lantern in it. He crashed. I was fine. we discuss and I remember that there was a bug with the camping mod. just didn't remember it was with .14 version. so anyway, I start to fly upwards towards where he put the tent, (next to the three silverwoods atop our base) and I cannot even get close before I crash. This has happened 2x for me, and each time he logs in, he crashes to desktop. Sounds suspiciously like my last crash incident where you had to delete the player. dat files from the server. so we are testing things out, and he is able to get into a single world no problem. so that is NOT like what I had. but since I cannot even fly towards that area, I am wondering if that chunk is corrupt. I am going to try to relog in and fly away from that chunk and I will let you know. with it being above our base, don't know if down below is corrupt also.. more in a bit.
Edit
okay, I try to relog in and crash to desk top same as morvash.
so I apologize, I should have remembered but ...I didn't.
anyway, any suggestions on what we can do or is a player.dat delete in order again.

edit
Okay, I was able to log in and by laying on my forward button I got away from the corrupt chunk. so I am in the server. talking with spyro, his suggestion is to bomb the effected chunk :) have not do that, will wait until I hear from you guys. hopefully you can delete the tent and Movash can log back in. but until then, he is not able to.


um okay, I took spyro's advice and put a quarry down and it crashed the server. sorry spyro and IamMorvash. so, GO if you are able to go in and delete that dang tent and refresh that chunk I will bow to you. otherwise, I crashed the server and I apologize
 
Last edited:

Netlook

New Member
Jul 29, 2019
2
0
0
Just downloaded and installed the 2.3.17 server and started it up with a /FML confirm
Then I download and launch the 2.3.17 client

I get this message "Mod rejections [FMLMod:InfernalMobs{1.6.0}] when I try to log on

Any quick way to get around that or is it an issue with the Client and Server I downloaded?
 

Dezil_nz

New Member
Jul 29, 2019
118
0
0
Just downloaded and installed the 2.3.17 server and started it up with a /FML confirm
Then I download and launch the 2.3.17 client

I get this message "Mod rejections [FMLMod:InfernalMobs{1.6.0}] when I try to log on

Any quick way to get around that or is it an issue with the Client and Server I downloaded?
replace the server copy of infernal mobs with the one from your client