[1.7.10] TerraFirmaPunk 2.0 - TerraFirmaCraft & SteamPunk Adventures

Discussion in 'Public Packs' started by OneWolfe, Oct 27, 2014.

  1. gamesetonline

    gamesetonline New Member

    Anyone else having issue filling up the thirst bar? I tried standing in every possible water, got annoyed, spawned in some fresh water, stood in it - nothing, so I spawned buckets with fresh water, drank it but the bar didn't refil. Am I doing something wrong? This is what I read on the official wikipage - 'The new blue bar on the bottom right indicates your thirst; jump into some fresh water whenever it starts to get low. Note: Fresh water will have cattails growing in it, salt water will have seaweed.'

    Edit: Found solution: [​IMG]
     
  2. OneWolfe

    OneWolfe New Member

    Even though he (bioxx) states in the 0.79.8 change log "You can now drink by right clicking any fresh water. Removed feet drinking." I have never gotten this to actually work. So far I have only been able to drink out of the jugs :(
     
  3. gamesetonline

    gamesetonline New Member

    Hm, I must have missed that in the changelog, been reading through it quickly as I was trying to find solution.
    Have you tried right-clicking the reed (as on picture above) ? That's the only way it works for me (haven't filled my jug yet). Really make sure you aim at the plant, not 'air', also it fills very very VERY slowly, but it does make sound, so you should hear it.
     
    OneWolfe likes this.
  4. OneWolfe

    OneWolfe New Member

    Clicking on the reed! Never would have thought of that :p
     
  5. Sev07

    Sev07 New Member


    oh, sorry ... it's hard to read changelog when only started playing
     
  6. OneWolfe

    OneWolfe New Member

    No problem, there are alot of changes that I wasnt aware of either. I just posted the quote as a reference, for myself as well :D

    I am always glad to help new players if I can.

    If you want to watch some experienced players there is a live stream going on right now on my friend's twitch page. http://www.twitch.tv/honneyplay
     
  7. OneWolfe

    OneWolfe New Member

    Over the last week I have been adding a great deal of exciting new features to this pack such as using the Ruins mod to create sites for the Twilight Forest mobs and bosses to spawn in the Overworld and I have even begun working on a series of quest lines from the Hardcore Questing Mod(HQM). TFC is a pretty tough mod and I think that having a questing journal like HQM is quite essential for new players, plus the rewards can really help out in a pinch.

    Unfortunately I am still waiting for any of my recent updates to be made available on the launcher. Hopefully the survival version will be available soon, so for now the tech mods are really only usable in creative.
     
  8. Sev07

    Sev07 New Member

    great!) Especially HQM)
     
    OneWolfe likes this.
  9. OneWolfe

    OneWolfe New Member

    I am currently looking for Beta Testers to help me finish up the details of this pack, however FTB is over a week behind on getting the updates out so if you want to help me out please feel free to send me a PM or an eMail for more details.
     
  10. OneWolfe

    OneWolfe New Member

    The Pack version has been finally updated on the FTB launcher. Version 0.0.6 is now live :D

    I am hoping to have version 0.0.8 submitted any day now.
     
  11. OneWolfe

    OneWolfe New Member

    Version 0.0.8 has been submitted and is awaiting review :)

    One of the things I have noticed while working with building and testing ruins specifically for TerraFirmaPunk is that the current TFC world generation seems a bit sparse. Quite often when I load a new map to test the ruins I find that the world is a fairly small continent with little terrain or biome diversity, and the continent is surrounded by very huge oceans. I have only run across a small few seeds that I liked but here is one that I was really impressed with. I spawned on a large island, but after a short swim south I found a massive continent that has tons of different biomes and at least one of every single ruin I have built so far can be found some where in its depths. However I do recommend loading it up in at least version 0.0.8 or higher.

    Here is the seed: -8899627288665900470

    And some screen shots I've taken while exploring:
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
  12. OneWolfe

    OneWolfe New Member

    Version 0.0.8 is now live and includes alot more Ruins to explore along with the start of the first few pages of Quests :D
     
  13. Xellik

    Xellik New Member

    Slight problem. The quests won't accept the axe nor the shovel that I made out of claystone. Other than that it's been a blast so far :)

    Edit: After looking around it seems I can't even look at the Agriculture section.. and I can see the quests in the bronze section but can't interact with them(Though I'm guessing im supposed to get through the stone age to unlock those quests) and there are a few unnamed ghost quests floating about.
     
    Last edited: Nov 10, 2014
  14. OneWolfe

    OneWolfe New Member

    I am glad your enjoying the pack so far :D

    I think what is causing the quest to fail is there are now 4 different kinds of stone axes, Igneous Intrusive and Extrusive, Sedimentary and what ever MM is. And I do not know how to make a quest like "complete one of these 4 options," yet, if it is even possible. Thank you for letting me know about this, I will definitely look into it.

    It looks like for the "right now", I am going to have to rework the stone age quests with the knowledge that most players (1 in 4 chance) will not find the right stones to craft the exact tools required, which is similar to a problem with the bronze age quests.
     
    Last edited: Nov 10, 2014
  15. OneWolfe

    OneWolfe New Member

    Yes the Bronze age quests are ment to be hidden, but I have been totally focused on world gen and the Twilight Bosses this weekend and just forgot to finish the bronze quests. I will have to rework the stone age and finish up the rest of the tier #2 and #3 quests before the next update. So it looks like next week is going to be busy for me :D
     
  16. TechDwarf

    TechDwarf New Member

    Sorry how to play your pack OneWolfe ?
     
  17. OneWolfe

    OneWolfe New Member

    Are you asking how to get it from the FTB launcher? or how any of the recipes work inside the game?

    To get the pack from FTB there is a Third Party Pack tab on the launcher. Under that tab should be an option to enter a pack code. The code that lets you DL and install my pack should be "TerraFirmaPunk"

    Please feel free to let me know if you have any other questions :D
     
  18. TechDwarf

    TechDwarf New Member

    Thank you very much
    )
     
    OneWolfe likes this.
  19. OneWolfe

    OneWolfe New Member

    >>> WARNING <<< Upgrading from 0.0.8 to 0.0.9 can Corrupt your Old Map

    When updating your old map from version 0.0.8 to 0.0.9 make sure that DragonAPI is enabled!

    As I keep adding mods and changing the layout of the pack there have been several issues of worlds getting corrupted and finding strange items on the ground after updating to a newer version of the pack. After submitting the latest version last night I stumbled across what might be causing the issues. In version 0.0.9 I disabled the DragonAPI mod for RotaryCraft since RC is also disabled for now, when I logged into my old map I found that my giant tree had changed into tons of hanging vines and the leaves were all roots. I then realized that DragonAPI must be causing the changes to block IDs and causing the world corruptions. So from now on I will have to make sure that DragonAPI is enabled in the rest of the packs.

    The reason I keep enabling and disabling DragonAPI is because I do not know whether I will be fully using RotaryCraft yet. RC recipes require a lot of Vanilla blocks to craft and I have not taken a lot of time to see which ones work and which do not, so until I am ready to tackle that big monster I just thought it good to keep it disabled for now.

    So when installing version 0.0.9 please check to see if the DragonAPI mod is enabled in the launcher before loading an old map.
     
  20. Eggyplant

    Eggyplant New Member

    Why are all the zombies infernal?





    (edit: I checked the configs for infernal mobs, were zombieTFC made to always be infernal or was that a mistake?)
     
    Last edited: Nov 16, 2014

Share This Page