[1.7.10] Automata — RPG, HQM, Reputation Systems, Custom Ore Gen, Mystcraft Ages

Discussion in 'Public Packs' started by Biochao, Nov 30, 2014.

?

Should I add a magic mod?

Poll closed Dec 19, 2014.
  1. Botania

    50.0%
  2. Blood Magic

    61.4%
  3. Forbidden Magic

    50.0%
  4. None

    9.1%
Multiple votes are allowed.
  1. Aldyn

    Aldyn New Member

    I can't load my 0.7.0 save in 0.8.5. It stops at "Attempting to load JABBA data" but javaw.exe is still using all of a CPU.
    FTB Launcher log: http://tny.cz/5a306b5e

    I've also tried disabling JABBA and reloading a copy of the world but it stops after the line above, "Queuing RetroGen for features for the chunk at [2, 1]." So, I'm guessing it's not hanging on JABBA, but whatever it does immediately after that, which is not logging any message. I've tried with Fastcraft enabled and disabled, but it makes no difference.

    I can load a new file fine, and I guess I can start over but I was expecting to be able to bring my save across.

    From the changelog above: (Mana Infused Ore is only found in the Nether as Nether Mithril Ore)
     
  2. giantsfan98

    giantsfan98 New Member

    The "List" quest in "Advanced Pipes" does not work. I have tried spawning it the page, putting something in the page, and putting the page into an Item Filter. None of that has detected the page.
     
  3. EPAstor

    EPAstor New Member

    Love the pack - but I also can't load my old (0.7) save in 0.8.5. The critical exception is here:

    Time: 12/20/14 11:42 AM
    Description: Exception in server tick loop

    java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.rangeCheck(Unknown Source)
    at java.util.ArrayList.get(Unknown Source)
    at hardcorequesting.QuestingData.loadData(QuestingData.java:607)
    at hardcorequesting.QuestingData.<init>(QuestingData.java:513)
    at hardcorequesting.QuestingData.readAllData(QuestingData.java:497)
    at hardcorequesting.QuestingData$1.read(QuestingData.java:403)
    at hardcorequesting.network.FileHelper.loadData(FileHelper.java:102)
    at hardcorequesting.QuestingData.load(QuestingData.java:432)
    at hardcorequesting.WorldEventListener.onLoad(WorldEventListener.java:23)
    at cpw.mods.fml.common.eventhandler.ASMEventHandler_590_WorldEventListener_onLoad_Load.invoke(.dynamic)
    at cpw.mods.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:54)
    at cpw.mods.fml.common.eventhandler.EventBus.post(EventBus.java:138)
    at net.minecraft.server.integrated.IntegratedServer.func_71247_a(IntegratedServer.java:73)
    at net.minecraft.server.integrated.IntegratedServer.func_71197_b(IntegratedServer.java:92)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:387)
    at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)

    I've uploaded my full FTB launcher log to pastebin at: http://pastebin.com/ih40atSU

    There seems to be some incompatibility in the HQM data? Any ideas for fixing this, or is this save unusable on the new version? (Restarting is... disappointing, but okay. I've learned a TON from this pack.)
     
  4. MadMax-X

    MadMax-X Active Member

    I had to delete the HQM quest data to load my old world into 0.8.5 without crashing. That seems to be a problem when too much changes in the quest layout I guess, I had that happen in another modpack before.
    I could add most of my quests back with /hqm edit, but some stuff is gone.
     
  5. Biochao

    Biochao New Member

    It looks like you are having the same problem where your quest data is corrupted.

    To everyone having this issue, try to copy quest data from one of the Aroma backups.

    Has anyone been able to successfully keep their quest progress when updating?

    I'll have to change that to a "NBT Independent Detection" quest in the next update.
     
  6. NunoAgapito

    NunoAgapito New Member

    The problem might be related with MFR. The new version doesnt work well with previous HQM progress.....

    Sent from my CUBOT ONE using Tapatalk
     
  7. ousire

    ousire New Member

    I just updated to the most recent version of the modpack, but I'm crashing whenever i load the game. I was getting this error in the 0.7 version and was hoping it'd be fixed, but it seems to be the exact same issue as before.

    http://pastebin.com/3kd31kCv Here is a pastebin of my console. Can anyone help me tell what's wrong with the modpack?
     
  8. Bearnado123

    Bearnado123 New Member

    The stuff from botania is called manasteel not mana infused metal search for manasteel in nei
     
  9. Xavion

    Xavion New Member

    No I had a mental lapse while reading the change log, anyway while botania has manasteel this pack makes mana pools and spreaders require mana infused metal which is gained from mithril ore in the nether.
     
  10. kleshas

    kleshas New Member

    Nope. Same thing happened to me on an update. I did get it back when copying the \minecraft\config\hqm contents from the 0.7 backup to 0.8.5. So far things look ok (except for the 2 missing reputation quests - I only have one on that page atm, the collect the butterflies one which I've completed; the previous two got 'deleted' when I was messing around with hqm edit)
     
  11. Biochao

    Biochao New Member

    If you copy the hqm configs from 0.7.0 none of the quests I added in 0.8.5 will be there. I was wondering if copying your quest progress data which is located in a backup of the world.
    i.e. \Backup-Automata - Map-v0.6-2014-12-14--14-39.zip\Automata - Map-v0.6\HardcoreQuesting\players.dat
     
  12. kleshas

    kleshas New Member

    Well that's fantastic. As I thought everything was good I overwrote my 0.7 backup; and I generally delete the aroma backups as I assume they are the same as a full folder backup done manually. (I back up to another disk, for redundancy purposes rather than relying on the aroma backup which is only a reversion purpose).
     
  13. RehabOholic

    RehabOholic New Member

    Well I updated, and since I had already added Botania, and had some things already setup the update for some reason changed ids.lol I had colorful stairs, and blocks dotted around my village from were I used the fertilizer to grow Botania flowers every were.lol It also changes my Dayblooms & Night Shades to a strange block. Oh well, A little hop in creative, and I deleted everything, and just got back a few things, and I'm golden. But I had to MCedit all the flowers that had already spawn, that are changed to stairs.
     
  14. kleshas

    kleshas New Member

    Latest patch.
    Tinker's Construct smelting copper. Draining off into block form gives a forestry copper block (1340:1), but placing that block and breaking it changes it into an apatite block (1340), which breaks down into apatite. Changing an unplaced block into ingot form stays as railcraft copper (5400:1).
    Draining out of the smeltery in ingot form is copper forestry (4282)
     
  15. Shadow-

    Shadow- New Member

    I'm having Quest problems.

    The Quest line Unfavorable Acts has opened, with the Beacon, Forest Princess and Thaumonomicon all available for completion after my first nether visit. I have done none of these quests..
     
  16. Biochao

    Biochao New Member

    The beacon quest should be fixed in the next version, it didn't have any detection task. The other quests all detect if you have had that item in your inventory. Have you had any of those items since going to the Nether?
     
  17. Shadow-

    Shadow- New Member

    Nope. I did receive a Relic Princess and Drone from a reward bag. The only books I have are 24 books from the village, 2 smelter books and the repossession day book.
     
  18. Biochao

    Biochao New Member

    That quest does detect any type of bee, which means I should probably get rid of the bee reward bag or the bee Unfavorable Act. As for the Thaumonomicon, I'm not sure how it's unlocked for you. There is a few Thaumonomicons in a village house that I didn't remove. Did you pickup one of them?
     
  19. Shadow-

    Shadow- New Member

    Looking in all my chests I didn't keep it, if I picked it up. I might have, but I don't know why I wouldn't have kept it.
     
  20. Skavies

    Skavies New Member

    if you are talking about the mana steel ingots, toss an iron ingot in a mana pool. it's not mid to late game it can be rushed very early. you only need a day bloom (more of them are faster) a mana spreader, 2 mana pools (so you can upgrade one in the other one, then reverse them) and you're golden.
     

Share This Page