[1.6.4] Stirecraft {Quests} {Tech/Magic}

Discussion in 'Public Packs' started by Raspen0, Jul 30, 2014.

  1. DoomSquirter

    DoomSquirter Well-Known Member

    another note. if you're adding opis (disabled), you should also add mobiuscore disabled since mobiuscore is a dependancy of opis.
    I've updated steve's factory manager to A83. (from a40, so yeah, huge difference in features and usability). btw, works great with witches oven.
     
  2. Matsi131313

    Matsi131313 New Member

    Does there exist a texture pack ?(sphax)
     
  3. StealthyShark

    StealthyShark Active Member

    Not as of right now :c I would love one lol
     
    Matsi131313 likes this.
  4. Raspen0

    Raspen0 Active Member

    Sorry for not replying for a while, i was busy with school and FTB didn't mail me about new replys in the thread :mad:

    I'm not going to add a lot more stuff to the 1.6 version of my pack, i'm currently focusing on the 1.7 version
    The 1.7 version is going to have custom machine recipes so you can for example build advanced Mekanism Machines while you have IC2 stuff.
    It will also have the Planned Tool Changes, by which i mean that i'm going to disable the vanilla tools and making TConstruct tools the default.
    There will also be around 6 mining levels of ores. (There are 4 levels in Vanilla Minecraft: Stone, Iron, Redstone, Obsidian).

    I'll start a Private Beta of it soon, there won't be quests in it yet though.

    I didn't know there was a new version for 1.6 :O
    I'll look into including the new version this weekend

    I thought i put Mobius Core in there
    I think i accidentally deleted it with uploading.
    I'll add it back in this weekend :D


    I am using a self patched version of Sphax for Stirecraft but i didn't release it because i didn't think people would use it.
    I'll look into uploading it to the BDCraft forums tomorrow :D
     
    Matsi131313 likes this.
  5. Matsi131313

    Matsi131313 New Member

    I am using a self patched version of Sphax for Stirecraft but i didn't release it because i didn't think people would use it.
    I'll look into uploading it to the BDCraft forums tomorrow :D[/quote]


    Cool thanks can you put the link in here when you uploaded it?
     
  6. Matsi131313

    Matsi131313 New Member

    Hey, I have another question.

    Can you tell me how to make a server with your modpack?
     
  7. Raspen0

    Raspen0 Active Member

    You can download the server files by going to the modpack in the FTB Launcher and pressing the Download Server Button
    Then extract the downloaded zip to a folder.

    To start the server, start the stirecraft .bat file on Windows or the stirecraft.sh file on Linux
     
    Matsi131313 likes this.
  8. Matsi131313

    Matsi131313 New Member

    I made that but when I am on the server and i try to see the reciepe of a item, the game says that there is no item with this ID existing
     
  9. Raspen0

    Raspen0 Active Member

    Weird, It works fine on my side
    Try redownloading the server files if that doesn't work, then try a Force Update on the client.
     
  10. Matsi131313

    Matsi131313 New Member

    Thanks for reply I will try it

    When do you think is the modpack ready on 1.7.10 ?
     
  11. Raspen0

    Raspen0 Active Member

    I don't know.

    A couple of mods need to update first, such as DartCraft, Mystcraft and Thermal Dynamics (The Thermal Expansion Ducts and Conduits)
    I also still need to add the new recipes and tool changes I've planned.
    And once that's done, i have to finish the 1.6 to 1.7 world conversion patch.

    I'll do a beta of the 1.7.10 update before i put it on the public pack.
     
  12. StealthyShark

    StealthyShark Active Member

    Um idk what happened but I think my world got corrupted... I was playing this morning just fine then I came back on to this crash error, I tried making a new world and it loads fine. If you have time can you take a look into this?

    ---- Minecraft Crash Report ----
    // Ooh. Shiny.

    Time: 9/28/14 8:21 PM
    Description: Exception in server tick loop

    java.lang.NullPointerException
    at hardcorequesting.QuestingData.<init>(QuestingData.java:514)
    at hardcorequesting.QuestingData.readAllData(QuestingData.java:473)
    at hardcorequesting.QuestingData$1.read(QuestingData.java:399)
    at hardcorequesting.network.FileHelper.loadData(FileHelper.java:102)
    at hardcorequesting.QuestingData.load(QuestingData.java:428)
    at hardcorequesting.WorldEventListener.onLoad(WorldEventListener.java:23)
    at net.minecraftforge.event.ASMEventHandler_495_WorldEventListener_onLoad_Load.invoke(.dynamic)
    at net.minecraftforge.event.ASMEventHandler.invoke(ASMEventHandler.java:39)
    at net.minecraftforge.event.EventBus.post(EventBus.java:108)
    at net.minecraft.server.integrated.IntegratedServer.func_71247_a(IntegratedServer.java:85)
    at net.minecraft.server.integrated.IntegratedServer.func_71197_b(IntegratedServer.java:107)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:445)
    at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)


    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.6.4
    Operating System: Windows 7 (amd64) version 6.1
    Java Version: 1.7.0_67, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 1286515584 bytes (1226 MB) / 2454482944 bytes (2340 MB) up to 3688366080 bytes (3517 MB)
    JVM Flags: 8 total; -Xms256M -Xmx3584M -XX:permSize=256m -XX:MaxPermSize=512M -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+CICompilerCountPerCPU -XX:+TieredCompilation
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: FML and Forge are installed
    IntCache: cache: 0, tcache: 0, allocated: 6, tallocated: 62
    FML: MCP v8.11 FML v6.4.49.965 Minecraft Forge 9.11.1.965 167 mods loaded, 167 mods active
    mcp{8.09} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available->Available->Available->Available->Available->Available->Available
    All mods are initialized and enabled no problem loading mods. I even deleted and redownloaded and tried the same world...didn't work.
    TConstruct Environment: Environment seems clean, however you are using a modpack; please report it to the pack author, not us!
    Ender-Quarry Relfection Code:: No problems here
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Player Count: 0 / 8; []
    Type: Integrated Server (map_client.txt)
    Is Modded: Definitely; Client brand changed to 'fml,forge'
     
  13. Raspen0

    Raspen0 Active Member

    Edit: I didn't see you already tried making a new world
    So it centernly is your quests progress that's corrupted,
    As i said in the original message, go into your world folder and delete the HardcoreQuesting folder in there. The world should then load fine.


    Original Message:
    It looks like the quest files are damaged, try doing a Force Update.
    If that doesn't work then your quests progress is corrupted, if that's the case then go into your world folder and delete the HardcoreQuesting folder
    The world should then load correctly
     
    Last edited: Sep 29, 2014
  14. StealthyShark

    StealthyShark Active Member

    Tried that, didn't work

    I ended up just deleting everything except the level.dat, region folder, and player.dat and all my settings were reset by my world was just fine. Not that big of a deal seeing how I've literally just been playing Vanilla so far c: . I'll just make sure to make backups everytime I'm doing a project
     
  15. Matsi131313

    Matsi131313 New Member

    It would be cool when the elevators in the new pack dont use xp:) hope you can do that:)
     
  16. Raspen0

    Raspen0 Active Member

    I thought about that but I think that a block such as the elevators should have a drawback.

    Do more people think the XP Drain should be disabled?
     
  17. Raspen0

    Raspen0 Active Member

    The Sphax's PureBDCraft Resource Pack Patch for Stirecraft is now available to download :D
    Link to page: http://bdcraft.net/community/viewtopic.php?f=10&t=3347&e=0
    64x is recommended, I couldn't even get my computer to run 128x without a lot of lag.
    I *might* add a 32x version for people with a slightly weaker PC

    Sorry i took so long, I've been busy with school.
    But i will have a week off soon so i will be able to do some work on the modpack :D
    I'm also prepearing the new update,,
    It has a newer version of Steve's Factory Manager, disabled a couple of update checkers so it doesn't spam as much in chat.
    And i've added a mod i made myself called Stirecraft Tweaks, or StireTweaks for short.
    The 1.6 version of the mod doesn't add any blocks of items but the 1.7 version will
    I plan to add blocks and items that will make other mods work together better.

    The only thing the 1.6 version does is that it will remember if you played a world on the 1.6 version of Stirecraft.
    With this i can give people who upgraded their world from 1.6 to 1.7 some rewards for doing so.
    For example some items that you can only find in new chunks so they can stay in older chunks.

    If you find any problems with the resource pack or if you crash because of my mod.
    Please tell me in the comments :)
     
  18. StealthyShark

    StealthyShark Active Member

    What happened in the new 2.9.9 update?
     
  19. Raspen0

    Raspen0 Active Member

    Here's the Changelog
    You can always press the Changelog button on the main page.
    That will bring you to the Google Drive folder with all the changelogs.[DOUBLEPOST=1414173418,1413099465][/DOUBLEPOST]



    A new Stirecraft update (2.9.10) is out.

    It doesn't change any ingame things.
    It adds the LegacyFixer mod which fixes Java 8 update 20+ compatibility
    I've also changed the launcher description link color to match the mod link colors.

    I've been busy with school, but every time I've got free time i work on the 1.7 version of Stirecraft.
    I'm going to change a lot of crafting recipes for Stirecraft so it feels a bit more custom.
    For example, I think doubling your ores is a bit too easy, you create a macerator or pulvirizer and your done.
    In Stirecraft in order to double your ores, you have to first crush it in a macerator or pulvilizer and then you get the Crushed Ore version of the ore
    You can't smelt that Crushed Ore, you first have to purify it in a Enrichment Chamber, Ore Washer or Fluid Transposer.
    You then get Purified Ore which you can smelt into the ingot or melt in a Smeltery.

    With this it feels a bit more custom and a little bit harder.

    There are also a couple of mods that haven't updated to 1.7.10 yet, such as Dartcraft.
    If those mods have not updated the time I want to release Stirecraft 1.7.10.
    Then those mods will have to be removed from the pack.

    In case of Thermal Dynamics (The Thermal Expansion Ducts and Conduits)
    It was said recently that it could take a long while before its done.
    So that mod will not be in the first versions of Stirecraft but will be added once it is updated.
    In case of people converting their 1.6 world, i'm going to try to convert the ducts and conduits into placeholder blocks that will convert back into ducts and conduits when TD is released.

    Also Ars Magica 2 was updated to 1.7.10 but the author Mithion left MC Modding and left Ars Magica in a buggy state.
    He recently said he didn't know if he was going to give the code to someone else or make it open-source.
    From what I've heard, you can't spawn any Ars Magica Bosses or use Armor Infusion.
    Without those things the mod is largely unplayable.
    So i'm still undecided if i'm going to leave it in for the building blocks.
    It all depends if the mod is going to be fixed or not.


    I'm going to work hard on the modpack to start a beta soon but it all depends how much time I have for it due to school.
     
  20. Vanjykins

    Vanjykins New Member

    Can anyone tell me what mod binds its keys to "up" and "right"? It shows no conflict in settings, but ingame it just doesn't work. :/
     

Share This Page