Closed 1.0.2: Unplayable lag spike

Discussion in 'Infinity Evolved 1.7.10' started by Funkymonkey, Feb 17, 2015.

  1. Funkymonkey

    Funkymonkey New Member

    Version:
    1.0.2

    What is the bug:
    As I play and fly arround or do anything really. Every 10-20Mins I get a lag spike that slowly lowers my fps until it's around 1. I looked at the percentage chart and it's the Tick rate that goes to 99.9% Usually at 8-12%.I do have a decent computer I can run and play most any game on High to very high. But it seams to be this modpack alone that has this error.

    Mod & Version:


    Paste.feed-the-beast.com log:


    Can it be repeated:
    - Happens on its own

    Known Fix:
    The only thing that works is completely closing the game. Just leaving the server and rejoining won't help!
     
  2. zchott

    zchott New Member

    I have the same problem
     
  3. Funkymonkey

    Funkymonkey New Member

    (I noticed this tends to happen a lot faster if I use mystcraft books)
     
  4. xBlizzDevious

    xBlizzDevious New Member

    I was witnessing the same issue on 1.0.2 as well. Just upgraded to 1.1.0 and haven't witnessed it happen again. I thought it was possibly my overclock or one of my graphics cards being unstable, but perhaps it's a known issue? I have another computer that is running the server and a friend was playing on it at the same time and his was smoother than mine - he never had this issue.

    I'm using the X79 platform (i7 3930k, three-way Crossfire 7970s) if either the chipset, CPU or GPU config are what's causing this issue - also using Java 7 U75 on 64 bit Windows 7. Anyone else got similar?

    I won't be able to give accurate results for an update as I've since (thinking it was my PC) reformatted and now using Windows 10 as well as taken out the extra GPUs so no Crossfire. Same Java version and display drivers, however.

    EDIT: Well that's been proven a little wrong. Just went to the Nether where it's been fine for about 20 minutes, I teleport back to the overworld and I'm almost immediately getting lag spikes every couple of seconds and the framerate has dropped significantly - barely playable right now.

    Is it possible FastCraft or Opis? Or would there be something else that might cause issues?
     
    Last edited: Feb 18, 2015
  5. ScottulusMaximus

    ScottulusMaximus New Member

    Is the standard memory leak from vanilla MC, get's worse the more you swap dimensions. Add in some JVM's to tweak garbage collection or schedule server restarts.

    You're only noticing on this pack because it's bigger than most
     
  6. xBlizzDevious

    xBlizzDevious New Member

    Few things to say about your post:
    1. Instead of telling us to tweak our garbage collection with JVM args (which to most people is gibberish), you could perhaps inform them of what to type in and point them to the JVM Arguments box in the launcher? To those wondering, try using something like this in FTB Launcher > Options > Advanced Options > Additional Java Parameters:
    Code:
    -XX:+UseLargePages -XX:PermSize=256M -XX:+AggressiveOpts -XX:+UseFastAccessorMethods -Xincgc -XX:MaxGCPauseMillis=10 -XX:+CMSParallelRemarkEnabled -XX:ParallelGCThreads=4
    2. This is a client side issue - nothing to do with the server. Apart from that, it's as often as once every ten to twenty minutes so restarting the server would be out of the question.

    3. How come this issue has never cropped up in ANY tech pack I've ever played before (at least not to this degree) on other versions of Minecraft and even the same one AND even with BIGGER mod packs? There's definitely something about this modpack, whether it be a particular mod or combination of mods or even possible some configuration somewhere.

    Oh, and it's not Fastcraft or Opis. Which makes me wonder what it might be.

    Note: I'm no Java expert or anything, I'm just suggesting those arguments as a possible help. They're untested and possibly could cause issues.
     
  7. ScottulusMaximus

    ScottulusMaximus New Member

    1. I haven't used JVM's on 1.7.10 so not going to pull it out my arse, others can add in info or you can google.
    2. "Tick rate that goes to 99.9%" Tick is server NOT client. A restart cures it, if you can't do that the JVM's are your only option if they work at all.
    3. 1.7.10 is more resource intensive and this is a big modpack, quite likely putting more strain on the system than any previous versions and modpacks.

    Run OPIS permanently and when it starts spiking have a look and see what's happening.

    Fastcraft only helps with the worldgen cock up Mojang left with us, will do nothing for memory leaks.

    PS: don't get snarky when you're offered advice

    PPS: it's the age transfer memory leak, plain and simple, comes from vanilla, a restart is the only known cure.
     
  8. Emby93

    Emby93 New Member

    You say it's from vanilla, but i've never had the memory leak happen in vanilla (even when leaving it open for 8+ hours when i fall asleep), on top of that, this isn't the only large 1.7.10 modpack, and i have never experienced the FPS drop like i have with this modpack.

    It's needless to say that, to an extent, vanilla minecraft is unpolished in terms up memory usage, it's age old problem were leaks, which by the way, stopped being a problem quite some time ago.

    The problem with this is that the FPS drop is inconsistent.

    I personally have never messed with JVMs, as i have no experience with them.

    But the thing with the memory leak is, if it was just a leak, it would be a STEADY decline, over time. The problem with the modpack is there is no decline, there's just a drop. 120~ FPS dropped to 5-15 just suddenly without warning. That indicates it's not a leak, it's a problem within the pack itself. Leaks do not cause a heavy drop (unless you're hardly running the game as is). On top of that, memory leaks are noticed by people who watch their memory usage (such as myself) and i can safely say that the there is no leak that is causing this problem.
     
  9. xBlizzDevious

    xBlizzDevious New Member

    I've not been running Opis all of the time so can't guarantee what's happening with server and client - however, this IS NOT server side. This was the situation:
    Two computers, two people. I ran the server on computer A as well as the client. My client lagged to crappery while my friend was happily playing away on the server without a single issue from computer B. This happened multiple times and so I moved the server from computer A to computer B so that my friend was running the server as well as his client. I was still getting the same issue, he was still playing as smooth as butter until we stopped playing.

    It's not a memory leak, either. I have 16GB assigned to Minecraft in the FTB launcher (I've got 32GB) and my total RAM usage (so not what Minecraft is using) was around 8-9GB at all times. Never above. Minecraft was usually using 4-5GB.

    I wasn't at all being snarky; I was offering a little advice to make your advice better. It may have come across snarky, but that's because you can't portray tone over text particularly easily.

    I've never had the memory leak and I've been playing and modding Minecraft since Alpha 1.2.6. I think I'd have come across this issue by now if it was "age-old" and caused by intensive modpacks. On which, 155 mods is nothing - I've ran modpacks of over 220 mods and they've worked fine.

    1. Yes.
    2. Correct.
    3. I've tried - never really noticed any difference client-side, but they often help (or hinder) server-side.
    4. Also correct. I have to say that it seems to be happening more when I teleport. But to blow that theory away, I teleported in excess of twenty times in less than five minutes and had no issues at all.


    EDIT: Perhaps the issue that the OP is having is different to that of myself and Emby93? It sounds like the end-result is the same, but maybe the cause is different?
     
  10. kylemcqueen75

    kylemcqueen75 Well-Known Member

    Jesus man, default minecraft never uses more than 500MB for me o.0

    I have had this issue before as well, it turned out to be my mistake tho. I noticed that when I set JMVs for Minecraft to use more memory I forgot to set both -Xms and -Xmx. As far as my understanding -Xmx is the max amount of memory Java will allocate and -Xms is the lowest amount. (I cannot confirm this, its just what seems to be for me). Setting only -Xms (lets say to -Xmx4G) and leaving out Xmx will cause my Minecraft to allocate all 4G to the game and cause these lag spikes. I am writing this on my phone so hopefully its not to bad lol My suggestion is to make sure you set both Xmx/Xms, Xmx being the max and Xms being the lowest. Example
    -Xmx4G -Xms512MB
     
  11. ScottulusMaximus

    ScottulusMaximus New Member

    Turn your RAM down to 3/4GB
     
  12. ScottulusMaximus

    ScottulusMaximus New Member

    @Emby93

    No, just no... There is no steady decline, RAM usage goes up and up and up and then Java says holy shit and does a massive Garbage Cleanup. That's where the lag spike comes from. The RAM usage then rises again, rinse and repeat.

    The vanilla memory leak has NOT been resolved and gets worse the more you transition across ages.

    Solutions:
    Allocate a lower amount of RAM so the GC runs more frequently with less of a lag spike and add JVM's to tweak the GC to run more often to balance out CPU load.


    MORE RAM DOES NOT EQUAL BETTER PERFORMANCE!!!!!!
     
  13. ScottulusMaximus

    ScottulusMaximus New Member

    Mods you can close this "bug" it's nothing to do with the modpack it's just bad setup...
     
  14. xBlizzDevious

    xBlizzDevious New Member

    Haha. Well when the RAM is there, application take it and use it - if set to. The FTB args for RAM usage are 512MB up to what you set (which for me is 16GB). Minecraft using 4-5GB isn't too bad as far as I can see.

    Yeah, 'cause allocating too much RAM breaks stuff! You know how many times I've heard that one? Guess what! I tried it. It doesn't fix it.

    Read. Both of us have pointed out that there's no memory leak issue here. Quite likely there is a memory leak when traversing dimensions in Minecraft, but that's NOT what's causing our issue.
    Oh, and a truthful statement from you! "More RAM does not equal better performance". Very good. (Sorry, if this didn't come across well. I'M BEING SNARKY NOW)!

    *In a piss-taking tone:* Mods, you can ban this guy for being stooooopid.


    On a serious note: does anyone (other thanScottulusMaximus) have any idea why this strange bug seems to be occurring for some people and not others? It doesn't seem to be tied to anything in particular but genuinely makes the game completely unplayable until restarted.

    EDIT: Oh, and @ScottulusMaximus the other computer here was running exactly the same args, RAM amounts and so on and never had the issue. So that kinda disproves your point entirely.
     
  15. mti_

    mti_ New Member

    Not wanting to get involved with the flame war Ill just point out that assigning large amounts of RAM is not adviced cause it actually harms performance. This has something to do with garbage collection I think.
    Also if people describe performance issues it would probably most helpful if they did some monitoring and trouble shooting of their own. Find out what Opis has to say before you try and find an answer for a frankly very generic problem.
     
  16. EndlessFields

    EndlessFields New Member

    I have had similar issues in other packs using to much RAM. Turned my max down to 4GB and no further issues. Java is weird that way. It really is the garbage collection process. Having it run more frequently is much better than infrequently in large chunks.
     
  17. xBlizzDevious

    xBlizzDevious New Member

    I'm planning on playing some later with Opis running all of the time. I'll get back to you with results.

    Question: in what was is this issue "generic"?

    That's a bit odd as I was using 4GB before - when I was getting this issue at least twice as frequently - and have since turned my RAM allowance UP to 16GB and have had the issue a lot less. Not sure why, but it's the opposite of what everyone else thinks. Also, if it's the garbage collection, how come I'm never using more than 4 or 5GB or RAM with up to 16GB set and still sometimes get the issue?
     
  18. Funkymonkey

    Funkymonkey New Member

    I'll try lowering my ram from 10-4Gbs
     
  19. mti_

    mti_ New Member

    Solving a problem as generic as "I am lagging" is a lot harder than "I use A on B and C happens".
     
  20. xBlizzDevious

    xBlizzDevious New Member

    I guess so. But if it's happening to more than one person, it's not completely random and must have some sort of cause. So - to try and diagnose - I've played the game with 3.5GB of RAM set in the launcher and with Opis running the whole time I've been playing. I've screengrabbed a few of the tabs (ones that had a lot of entries and higher tick times).
    Nothing particularly seems out of order and nothing particularly changed from when I first opened it. Though there is one thing which kinda confused me - almost all entries under client timing events seem to be "<error>". RAM use at this point is ~3.8GB.

    What I was doing:
    I was using the portal between the overworld and the Twilight Forest (a few times) and then crafted some stuff in the ME system (manual, not auto), then I went through a Nether portal, where my framerate stayed as it should UNTIL I teleported (using JourneyMap waypoints) to a stronghold quite a distance a way. As soon as I teleported, my framerate tanked. Nothing different in Opis though.

    Client-Entities.png Client-Events.png Network-Outbound.png Summary.png Tracking-Dimensions.png





    EDIT: Just opened the game up again and the lag was immediately there again. Seems odd. I changed the RAM amount from 3.5GB back to 16GB, went back in and framerate was all the way back up to where I'd expect.

    Anyone got any ideas with all of this extra information?

    EDIT 2: My hat seems to be using 1410µs to render and is the highest user by more than double. Most other entities seem to be at position 0, 0, 0. Total render time for entities is 14013µs. Assuming one frame (at 60fps) is 16000µs, JUST the entities using 14000µs makes me think it's not good. BUT - that doesn't explain why I'm getting TWO FPS. Not sure what's caused it this time as I was just wondering around my base, crafting recipes and looking at recipes in NEI.

    EDIT 3: I updated Java to V8 U31 and have since seen the bug occur in a different way. It's now behaving much more like what the OP described with the sudden lag spike every now and then until it becomes unplayable. Java 8 obviously handles the RAM a lot differently to Java 7 as this is what Windows Task Manager looks like during one of said lag spikes:
    Java 8 Lag spike of doom.png

    I can't upload a copy of the log as it is over 600MB. However, looking at the task manager, it's seems like the launcher is what's causing the issue, not the game!

    @Mods: could this be re-opened as it is definitely still an issue?
     

    Attached Files:

    Last edited: Feb 21, 2015
    Funkymonkey likes this.

Share This Page