Unsupported Unleashed 1.5.2 Bug Reporting

Discussion in 'Modpack Bugs' started by slowpoke, Oct 22, 2013.

Thread Status:
Not open for further replies.
  1. slowpoke

    slowpoke Administrator FTB Founder

    Please note we cant fix a lot of the issues just report them here so we can fix them in future.

    Be sure to send the FTB console log not the minecraft crash report

    Format:

    Mod Pack: Unleashed
    Mod & Version:
    Pastebin link to crash log:
    Whats the bug?
    Can it be repeated?
    Known Fix:


    New rule for this thread. If you post a bug that's already known and it doesn't provide any more new useful information it will be deleted. Posts that provide no useful information may also be deleted.

    Follow the format in the first post and check to see if your bug is known before posting. If your post vanishes its already known or not a bug or didn't include enough info.

    "I has a bug"

    "xyz mod is broken"

    "it crashes" -- with no crash report

    the above do not qualify as bug reports and will be terminated on sight.
     
    DwarfHunterPro likes this.
  2. oppositeZERO

    oppositeZERO New Member

    Mod Pack: Unleashed 1.1.6
    Mod & Version: Standard 1.1.6 Mods
    Pastebin link to crash log: http://pastebin.com/bJN1a9nx
    Whats the bug? Severe Server console spam upon startup (Thousands of lines of errors per second)
    Can it be repeated? Yes, simply upgrade a working in production 1.1.5 server to 1.1.6
    Known Fix: I've seen something like this a while ago when I manually tried to downgrade back to a working version of IC2, I have a feeling I was able to fix it by also downgrading some of the IC2 Addons as well.

    Edit: Downgrading IC2 to v 1.116.634 fixes the issue. Download link below.

    http://ic2api.player.to:8080/job/IC2_lf/364/artifact/packages/industrialcraft-2_1.116.364-lf.jar
     
    Geech6 likes this.
  3. Azorath

    Azorath New Member

    Mod Pack: Unleashed (1.1.3)
    Mod & Version: Thaumcraft(3.0.5h1) and NEI( either NEI addons(1.8.1.r27) or NEI plugins(1.0.9.3))
    Pastebin link to crash log: http://pastebin.com/FsAKSXid
    Whats the bug? The game crashes and the world becomes unrecoverable.
    Can it be repeated? When you have NEI highlight tips shown(option in the NEI In-game config) and look at a cinderpearl it's render goes weird and is represented as two white squares intersecting each other, if you middle click it in creative mode it crashes and the world is unrecoverable (i tried lots of things).
    Known Fix: Once you have done the bug i haven't found a way to reverse the effects, but to avoid it completely you can just make the highlight tips hidden.
     
  4. Cozza

    Cozza New Member

    Slowpoke, why aren't you carrying over the known issues lists between versions? Unless it's been fixed, it should still be a known issue.

    There was a lot of stuff in the 1.1.4 thread that was deleted so I'm no longer able to look those issues up.

    Here's some current issues that I believe are still outstanding:

    Mod Pack: Unleashed (Any Version)
    Mod & Version: Biomes O Plenty (Whatever was in Unleashed from release till present)
    Pastebin link to crash log: http://pastebin.com/WMj6uzpW (Dimension ID is not important, happens with any MYST dimension)
    Whats the bug? If a client which has BoP enabled, joins a server with BoP disabled. Upon entering a Mystcraft world the client will crash.
    Can it be repeated? Yes. Enter a MYST world while BoP is disabled on server and enabled on client.
    Known Fix: Disable BoP on the client.

    Mod Pack: Unleashed 1.1.5+
    Mod & Version: qCraft 1.0+
    Pastebin link to crash log: No Crash
    Whats the bug? qCraft does not follow the forge world structure, creating new folders in the server root instead of under the overworld folder. This starts to become more of an issue as more and more MYST worlds are created. Makes the folders a complete mess.
    Can it be repeated? Sure, just enable the mod
    Known Fix: None

    Mod Pack: Unleashed 1.1.4+
    Mod & Version: IC2 #374-#385
    Pastebin link to crash: No crash
    What's the bug? See here for a good explanation of the issue
    Can it be repeated? Yes, place an electric engine and connect it up with cable as usual. Break the engine and place it again, it will not run.
    Known fix: So far I've tested with builds #385, #374 and #364. #364 does not have the issue (However it does have the issue of mass fabs always acting like they have scrap, so it's a choice swapping one issue for another)

    Reported by RavenLyke here
    Mod Pack: Unleashed 1.1.5+
    Pastebin: http://pastebin.com/eTgy6vbj
    Id 3222 is mismatched between world and game. Seems to be an item from Tinkers Construct:
    Unsure what this will cause not updating world yet.
     
  5. Vauthil

    Vauthil New Member

    First: 1.1.4 thread isn't deleted, you can still see it in the forum, right here.

    Second: slowpoke doesn't maintain that list (he has more urgent and pressing things to occupy his time/mind), I do. Carrying stuff over that isn't fixed, first of all, requires checking to see if it is or isn't fixed. I haven't had the time/inclination this week to chase all the old issues and replicate them on 1.1.6 so a Known Issues List can be provided (and I didn't touch 1.1.5 because of the carry-over of big ticket 1.1.4 issues that 1.1.6 addresses). If people can report what's still broken from the 1.1.4 list, I will happily oblige in compiling the list with that assistance as doing it myself is a process that often takes hours, depending on how many crash bugs are lingering (I run on a toaster, crash bugs = many long restarts). My personal attention right now is tuned towards things that pay my bills, however, so my personal corroboration's going to take a while.
     
  6. slowpoke

    slowpoke Administrator FTB Founder

    Can you maybe provide a screenshot of this to validate, Dan took a look at the code and wasnt able to replicate what you were saying.
     
  7. Cozza

    Cozza New Member

    Thanks for the link, I couldn't find the thread at all.

    This is where verbose changelogs come in handy. keep a good changelog and you can easily see whats fixed. Most mod authors keep decent changelogs so even copying and pasting the fixes will suffice. Saying "updated to xxx for bugfix" tells us absolutely nothing however saying "updated to xxx version to fix known issue *insert issue here*" tells everyone that our existing issue is now resolved and you can mark it off the running bug list.

    I'm not having a go, I just find it frustrating to have to search through all the threads for existing issues. Each new thread for each version should have a running list of known issues.

    You really don't even need to replicate them with each version, if for instance IC2 has issues in 1.1.4 and you didn't change the IC2 version in 1.1.5 you can safely assume the issue still exists.

    This May be MCPC+ related Slow, I'll report back on that. If it is, i'll report it to dan directly and not via FTB.
     
  8. Geech6

    Geech6 New Member

    I can confirm this. I updated from 1.1.3 to 1.1.6, and I am running off of an existing 1.1.3 world.

    The client loads up fine, but server won't start. From what I can tell according to the log it seems to be breaking with the IC2 Energy Net and Advanced Solars.

    Just for a picture of how much this spams, I ran my sever for a minute and a half, and I had a 616,808 line log file. It came out to 64 megabytes of text...
     
  9. Ashzification

    Ashzification New Member

    When reporting bugs, make sure they occur with the standard packs.
    Do not add anything, as added stuff breaks things faster than standard stuff breaks things.
    Vauthil can confirm, it plays hell with trying to get a proper problem list.
     
    Vauthil likes this.
  10. Cozza

    Cozza New Member

    I understand this and that's why I haven't pressed the issue further. And as stated, I won't if I find it is MCPC related.
     
  11. Phoenixsong

    Phoenixsong New Member


    Adding another confirmation, same thing happens here. (Upgrading from 1.1.5 to 1.1.6)

    Two more pieces of information:
    • My server's CPU and Memory stay maxed out at 100% until I shut it down
    • After restarting several times, the server managed to start up. I logged in and found that several chunks in the middle of my base had regenerated to their originally generated state (i.e. the land before it was terraformed and built upon), which removed all of my machinery, and some other blocks were randomly changed (coal ore was embedded in one of my walls)
     
  12. the_dmx

    the_dmx New Member

    Disabling advanced solar panels allows the server to boot again.
     
  13. oppositeZERO

    oppositeZERO New Member


    After a bit of testing, downgrading IC2 to version 1.116.364-lf seems to fix the problem for me.

    I also have to ask, why have the last three updates gone out without testing? It's not that hard it took me a whole 5-10 minutes to relise the last three updates were broken. I really do expect better.
     
    AlanEsh and Geech6 like this.
  14. bloop428

    bloop428 New Member

    Removed
     
  15. AgeGee

    AgeGee New Member

    Mod & Version: Unleashed 1.1.6 Mods
    Pastebin link to crash log: http://pastebin.com/gbXxSqA1
    Whats the bug?: Server console spam upon startup
    Can it be repeated?: Yes upgrade from 1.1.5 server and world to 1.1.6 with the old world from 1.1.5
    Known Fix: N/A
     
  16. slowpoke

    slowpoke Administrator FTB Founder


    This is why we dont make these packs recommended, because there are things that are missed. Essentially this is the testing period which enables us to get input from more people than a couple of internal testers.
     
    oppositeZERO and ThePoet444 like this.
  17. Master_Wight

    Master_Wight New Member

    How do you report game-breaking bugs again? ;~; I found an xp duplication bug.. Not going to post it, of course, but yeah.. It's bad :c
     
  18. sindre1106

    sindre1106 New Member

    Mod Pack: Unleashed
    Mod & Version: 1.1.3
    Pastebin link to crash log:
    Whats the bug?: The AE system stops working once the system reaches about 1'000 melons, it wasn't always like this, it was just recently and I can't think of why. I can still access my items through the terminals, but crafting doesn't work though. It's no difference between having the melons in storage cells or barrels/chests. I hope this is already know and will be fixed as soon as possible. Thanks
    Can it be repeated?
    Known Fix: N/A
     
  19. Master_Wight

    Master_Wight New Member


    Woooow, I just updated today and the spam is /insane/!
    Also, in my Single-player world it spams the console and the lag is so intense I can't even play... In 1.1.5 it worked fine. Thank heavens I have a backup >-<
    I'd post a pastebin link, but when I try it literally says the file is too big for pastebin. That's how bad it is..
    And my minecraft is now frozen.
    Update: Now it crashed.
     
  20. Geech6

    Geech6 New Member

    From what I understand If you rollback the version of IC2 to the version in the last stable FTB Unleashed release (I would say the version of IC2 from 1.1.3) the problem should be fixed.

    EDIT: IC2 v1.116.364-lf is the build of IC2 released with FTB Unleashed 1.1.3. It is also the last stable release that I can find.
     
Thread Status:
Not open for further replies.

Share This Page