Server running advice?

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

ChemE

New Member
Jul 29, 2019
371
0
0
No, that is certainly a conspicuous omission but we've never worked out how to tell how much of the RAM we are using. There is not a display on the web client. Is that lag just from worldgen perhaps? My server is in Toronto and we get good pings from the UK and Southern US.
 
D

Daihok

Guest
ok think I got a little server going but still have trouble upping the ram. I used this video
to help with most of it but for some reason my >bat file just closes when i try and start server, this is what i have in the .bat file.
java -Xmx3024M -Xms3024M -jar forge-1.10.2-12.18.3.2281-universal.jar nogui
so not to sure what im doin wrong. If anyone has had this issue knows the answer help would be appreciated lol
 

ChemE

New Member
Jul 29, 2019
371
0
0
Does the process terminate? The nogui flag will make it look like it failed b/c there will not be any visual clue that the server is in fact running. Try omitting the nogui flag. Or leave it and fire up your launcher and try logging into a local server.
 
D

Daihok

Guest
yea i tryed without the nogui and everything it still just closes out for some reason
 
D

Daihok

Guest
Nah no crash report. Just closes out for some reason. I havent even added any mods to the server yet its just forge alone.
 

Middleclaw

Well-Known Member
Apr 12, 2014
264
181
68
Looking at the ftb ServerStart.bat file, you need to imput it something like this, but bear in mind that the XMS, XMX functions are ignored in java 8

java -server -Xms%MIN_RAM% -Xmx%MAX_RAM% -XX:permSize=%PERMGEN_SIZE% %JAVA_PARAMETERS% -jar %FORGEJAR% nogui
 
D

Daihok

Guest
well i gave up the ghost just gonna rent a server lol. Prolly be better in the long run anyhow.
 
D

Daihok

Guest
Yea i set it to true. I know i said i was gonna just rent a server but still been messing around with this trying to get it figured out.
 

mc.crab

Well-Known Member
Feb 2, 2013
1,397
116
89
Check the logs folder and post the fml-server-latest.log if it exists.
 

Drbretto

Popular Member
Mar 5, 2016
1,893
783
139
So far pretty damn happy with the server. It's only been a day, but I've really pushed it. I'm running the 3 gig plan. Even though there's only two of us, I might actually have to bump that one up to the $10 plan. The reason being that I've unlocked the view distance on the server from 10 to 32, which is massive, but necessary for my playstyle. No compromises!

The difference, I'm finding, is the customer service. It's not that anyone has been rude or anything yet, but the response time is glacial (understandable being that it was over the weekend, so no big deal) and the one guy I did talk to couldn't spell very well and didn't have the right information. Again, total pass because I was asking stuff that was very customized for my unique specifications, and their mistake was only trying to save me money (they recommended a lower tier that wouldn't even run this thing). My only advice would be to make sure you already know what you're doing before jumping in.

It was a bit laggy at first, but seemed to stable off by the end of the day. I think I had the same thing with mcpro. Can't hate this price. I'm overall pretty dang happy. The customer support for MCProHosting is really, really good, but it's not "let's pay three times as much" good. This is the way to go.
 
  • Like
Reactions: ChemE

Drbretto

Popular Member
Mar 5, 2016
1,893
783
139
Boy, I will double stress this. If you're going to go through shockbyte, the tradeoff is the customer support. I put in a ticket on Saturday and it still has not been answered, or even acknowledged. There's a button to escalate my issue to the top of the heap for an extra dollar, though!

The prices, great. The server itself, mixed so far but I can't see if that's because I don't have enough ram allocated or not because I can't see my usage. Customer support, nonexistent.

None of that overshadows the pricing, but that warning needs to be out there for new server owners. Know what you're doing. You're on your own.
 

Drbretto

Popular Member
Mar 5, 2016
1,893
783
139
OK, I'm having TPS issues and I have some theories as to why. I don't think I have any arguments set up for RAM usage or to help with garbage collection. I'm betting it's not using all the RAM I have available. But I can't for the life of me remember where I would put those arguments! Anyone wanna help a brotha out with this fading memory? lol
 

Hambeau

Over-Achiever
Jul 24, 2013
2,602
1,533
213
OK, I'm having TPS issues and I have some theories as to why. I don't think I have any arguments set up for RAM usage or to help with garbage collection. I'm betting it's not using all the RAM I have available. But I can't for the life of me remember where I would put those arguments! Anyone wanna help a brotha out with this fading memory? lol
It has nothing to do with the amount of ram you have available, but how much of the allocated ram needs to be cleared periodically by Java... This process is what we affectionately know as "Garbage Collection".

Unfortunately Minecraft, although getting better, was written in a less than optimal manner and has more GC than many programs. Anything up to about 5.5GB should clean up quickly.
 

Drbretto

Popular Member
Mar 5, 2016
1,893
783
139
Yeah, I've been researching all day and I agree. I found some parameters to add, I just can figure out 100% how to apply them. I think they go in the serverstart.bat or sh file, but I'm not sure how multicraft would even know to use that file. Though, I have an idea and I'll try it when I get home. I might be all set. I will not stop anyone who definitely knows what I'm doing from telling me, though :)

I'm really annoyed that this hosting site doesn't show your ram and CPU usage. I have to guess whether or not I am in the right package.

Edit: I'm not totally sure that's the only problem, either, though. I have one person playing right now and she's running with a view distance of 12 and I'm still occasionally getting:

01.05 15:20:31 [Server] Server thread/WARN Can't keep up! Did the system time change, or is the server overloaded? Running 2044ms behind, skipping 40 tick(s)

This comes in spikes. I'm going to try the parameters, but if that doesn't do it, it's the host. It's gotta be.
 

ChemE

New Member
Jul 29, 2019
371
0
0
Is forge/tps any help in figuring out what is causing the lag spikes?
 

Drbretto

Popular Member
Mar 5, 2016
1,893
783
139
the only command I was able to find was /cofh tps and that shows the tps for each world. The first time I ran it, it was fine. I ran it again in the middle of a spike and it was down to 5.xx TPS on the overworld.

I can't rule out a mod issue, either, but it's FTB beyond with a couple of added mods. nothing major, just a few extra blocks type stuff like one that makes chimney's that smoke when you're cooking something in a furnace, and world gen mods like BoP, RTG and recurrent complex. I can't imagine anything that'd be killing the server any.

It's entirely possible I skipped some crucial step somewhere, though.
 

Drbretto

Popular Member
Mar 5, 2016
1,893
783
139
Here's a sample I pulled from my ticket in to shockbyte:

01.05 12:30:27 [Server] Server thread/WARN Can't keep up! Did the system time change, or is the server overloaded? Running 4207ms behind, skipping 84 tick(s)
01.05 12:31:18 [Server] Server thread/WARN Tried to over-fill a container
01.05 12:32:26 [Server] Server thread/INFO Overall: 5.58 TPS/179.36MS (27%)
01.05 12:32:26 [Server] Server thread/INFO Overworld [0]: 5.58 TPS/179.12MS (27%)
01.05 12:32:26 [Server] Server thread/INFO Nether [-1]: 20.00 TPS/0.02MS (100%)
01.05 12:32:26 [Server] Server thread/INFO The End [1]: 20.00 TPS/0.01MS (100%)
01.05 12:32:26 [Server] Server thread/INFO Deep Dark [-3]: 20.00 TPS/0.05MS (100%)
01.05 12:32:26 [Server] Server thread/INFO ExtraUtils2_Quarry_Dim [-4]: 20.00 TPS/0.02MS (100%)
01.05 12:32:26 [Server] Server thread/INFO simplevoidworld [-5]: 20.00 TPS/0.02MS (100%)
01.05 12:32:26 [Server] Server thread/INFO MiningWorld [-2]: 20.00 TPS/0.01MS (100%)
01.05 12:32:51 [Server] Server thread/WARN neondancer07 moved too quickly! 3.9246456649730135,-0.5393447997685143,-9.470606215643329
01.05 12:32:57 [Server] Server thread/WARN neondancer07 moved too quickly! 5.881829645394646,-0.5393447997685143,-8.811545916128125
01.05 12:32:59 [Server] Server thread/WARN neondancer07 moved too quickly! 4.326688786357408,-0.5393447997685143,-9.255314662287901
01.05 12:33:02 [Server] Server thread/WARN neondancer07 moved too quickly!
 

Drbretto

Popular Member
Mar 5, 2016
1,893
783
139
I tried /forge tps and it looks like it's pretty much the same kind of thing. Here it is when it's not spiking, btw:

01.05 16:29:34 [Server] Server thread/INFO Dim -3 : Mean tick time: 0.077 ms. Mean TPS: 20.000 01.05 16:29:34 [Server] Server thread/INFO Dim -4 : Mean tick time: 0.020 ms. Mean TPS: 20.000 01.05 16:29:34 [Server] Server thread/INFO Dim -5 : Mean tick time: 0.020 ms. Mean TPS: 20.000 01.05 16:29:34 [Server] Server thread/INFO Dim -1 : Mean tick time: 0.018 ms. Mean TPS: 20.000 01.05 16:29:34 [Server] Server thread/INFO Dim 1 : Mean tick time: 0.016 ms. Mean TPS: 20.000 01.05 16:29:34 [Server] Server thread/INFO Dim -2 : Mean tick time: 0.019 ms. Mean TPS: 20.000 01.05 16:29:34 [Server] Server thread/INFO Dim 0 : Mean tick time: 29.299 ms. Mean TPS: 20.000 01.05 16:29:34 [Server] Server thread/INFO Overall : Mean tick time: 33.989 ms. Mean TPS: 20.000


Which all looks good to me.