Unsupported Magic Farm 2 Version 1.1.1+ Bug Reporting Thread

Status
Not open for further replies.

Jukari

New Member
Jul 29, 2019
21
0
0
Well since it appears no one has any bugs in MF except an intermittent memory leak on some systems.....
I appreciate all you do, and think you do a great job doing it. I just figured since I found the way to reproduce the leak, I should post it, so people have a solution for it. Not sure why people think problems can be fixed if no one can reproduce them.

Keep up the great work!
 

rgk007

New Member
Jul 29, 2019
35
0
0
Sounds great. Love the mod, btw. It's not a huge deal to me, just an inconvenient bug. Knowing about it helps handle it though. So now I just put the oysters in before logging off, and grab them when I get back on.
You can't do that in single player world.
 

Jukari

New Member
Jul 29, 2019
21
0
0
You can't do that in single player world.
So make another dimension, or a portal to chunks you don't plan on building in, add a chunk loader, place oysters, place sand, leave, come back in 20-30 minutes. Should be done, and your client will have rendered nothing, so no memory leak.
 

netmc

New Member
Jul 29, 2019
1,512
0
0
Mod Pack: Magic Farm 2.1.2
Mod & Version:
Pastebin link to crash log:
Whats the bug? Cannot use an iron TiCo shovel on iron gravel.
Can it be repeated?
Known Fix:
 

ChrisC

New Member
Jul 29, 2019
6
0
0
The clay bucket doesn't break when placing lava into a mariculture tank (fluid tank). Doesn't crash or anything, just figured it was a bug, not a feature. Current version is 2.1.2
 

keybounce

New Member
Jul 29, 2019
1,925
0
0
So there seems to be a leak in rendering the ME controller (confirmed) and ME drive (not confirmed ... ocean was in the background).

My repeat by: Stand in front of them. Watch tenured memory climb.

Place dirt blocks in front of them, to make a wall. Watch tenured memory stay stable.

Remove one dirt block, exposing the controller. Watch tenured memory climb.
Replace it, remove the dirt block exposing the drive.

Watch tenured climb; have someone point out that I also just exposed the ocean, and there's probably oysters down in the ocean :).

As I understand it, AE is no longer being updated for 164, so this is probably "can't fix".
 

rgk007

New Member
Jul 29, 2019
35
0
0
So there seems to be a leak in rendering the ME controller (confirmed) and ME drive (not confirmed ... ocean was in the background).

My repeat by: Stand in front of them. Watch tenured memory climb.

Place dirt blocks in front of them, to make a wall. Watch tenured memory stay stable.

Remove one dirt block, exposing the controller. Watch tenured memory climb.
Replace it, remove the dirt block exposing the drive.

Watch tenured climb; have someone point out that I also just exposed the ocean, and there's probably oysters down in the ocean :).

As I understand it, AE is no longer being updated for 164, so this is probably "can't fix".
It could be Oyesters because i think 1 out of 3 oyesters naturally generate pearls.(that's what i saw in config).

Go to Mariculture "worldgen" config and change "B:"Pearl Oyster > Generation"=true" to false.I did that and played MF2 for 6 hours straight with no memory leak issue.
 

Jadedcat

New Member
Jul 29, 2019
2,615
0
0
Duplicated both of your tests and got... nadda.. no leak .. nothing. Both of these seem to be rendr related.. which means if you are having them and I am not.. its possibly hardware related.
 

rgk007

New Member
Jul 29, 2019
35
0
0
Mod Pack: Magic Farm 2.1.2
Mod & Version:
Pastebin link to crash log:
Whats the bug? Cannot use an iron TiCo shovel on iron gravel.
Can it be repeated?
Known Fix:
You need to boost the shovel by getting enough XP just like Pickaxe,then only you can use it on iron gravel.
 

keybounce

New Member
Jul 29, 2019
1,925
0
0
Duplicated both of your tests and got... nadda.. no leak .. nothing. Both of these seem to be rendr related.. which means if you are having them and I am not.. its possibly hardware related.
Hmm ...

My testing so far: apple driver, using HD3000 graphics.

Potential to test: Apple driver with an AMD card; AMD driver with AMD card. (Not only does that thing run hot, but turning it on makes everything else run hot/more energy, and it doesn't even seem to run minecraft any faster. As far as I can tell, the only real difference is that vram goes from 384m to 1g, and minecraft with the default textures doesn't need it.)

Will give this a test, and see if it makes a difference.
Also, I'll try testing this on a superflat instead of a standard world -- that will at least eliminate the oceans and underground mobs.
 

netmc

New Member
Jul 29, 2019
1,512
0
0
You need to boost the shovel by getting enough XP just like Pickaxe,then only you can use it on iron gravel.
The boost is supposed to be for the next tier of materials. To mine tin, you need a boosted iron pick, but to mine iron, an iron pick is fine. Also, only the picks have a boosted XP. The other tools do not. My guess is that is has something to do with the vanilla iron tools being reenabled for thaumcraft. Since the vanilla tools have been nerfed so they will only function on the lowest tier of materials, I think the game is confusing an iron TiCo shovel with a vanilla iron shovel.

Edit: Just tested in world. The iron TiCo shovel can mine the exact same items as the copper shovel.
 
Last edited:

rgk007

New Member
Jul 29, 2019
35
0
0
The boost is supposed to be for the next tier of materials. To mine tin, you need a boosted iron pick, but to mine iron, an iron pick is fine. Also, only the picks have a boosted XP. The other tools do not. My guess is that is has something to do with the vanilla iron tools being reenabled for thaumcraft. Since the vanilla tools have been nerfed so they will only function on the lowest tier of materials, I think the game is confusing an iron TiCo shovel with a vanilla iron shovel.

Edit: Just tested in world. The iron TiCo shovel can mine the exact same items as the copper shovel.
I thought it was a bug at first too....then i waited for a while....after using it for too long it got boosted....after that i could mine iron....too bad we can't use mob head to boost it like pickaxe.

Edit: Make an alumite shovel....you can mine iron gravel ore without boosting.
 
Last edited:

rgk007

New Member
Jul 29, 2019
35
0
0
Mod Pack: Magic Farm 2.1.2
Mod & Version: Iguana tweaks tinker's construct
Pastebin link to crash log:
Whats the bug?
Battle axe "XP" remains at 00....not gaining any XP for killing mobs. Tested with Full iron and cobalt Axe
Can it be repeated? Yes
Known Fix:
 

rgk007

New Member
Jul 29, 2019
35
0
0
Mod Pack: Magic Farm 2.1.2
Mod & Version: Iguana tweaks tinker's construct
Pastebin link to crash log:
Whats the bug?
Thaumium Modifier exploit.I tested this with hammer only and I'm pretty sure it can be done with other tools.What i did is...i made a hammer entirely of alumite....then replaced with thaumium tough rod...now i got 1 extra modifier....then i replaced it with alumite tough rod...no change in modifier (ie the modifier added by thaumium stayed)....then i again added a thaumium tough rod....now got 2 extra modifier....etc
Can it be repeated? Yes
Known Fix:
 

ragnia1980

New Member
Jul 29, 2019
8
0
0
Mod Pack: Magic Farm 2.1.3
Mod & Version:
Pastebin link to crash log:
Whats the bug? players on my server can't craft fluix dust or ME cable with the changed recipe in 2.1.3. I have confirmed it's only on the server and not in ssp. Also tested on non MCPC+ server with same results as before, It shows the results of the crafting but when you go to pull the item out of the crafting table it doesnt work.
Can it be repeated? yep on server running 2.1.3
Known Fix:unknown
 

Jadedcat

New Member
Jul 29, 2019
2,615
0
0
Mod Pack: Magic Farm 2.1.3
Mod & Version:
Pastebin link to crash log:
Whats the bug? players on my server can't craft fluix dust or ME cable with the changed recipe in 2.1.3. I have confirmed it's only on the server and not in ssp. Also tested on non MCPC+ server with same results as before, It shows the results of the crafting but when you go to pull the item out of the crafting table it doesnt work.
Can it be repeated? yep on server running 2.1.3
Known Fix:unknown
Well... phooey. I'll play with that some more and see what I can figure out. For now I'd say remove the AE.cfg inside the minetweaker config folder.
 

AforAnonymous

New Member
Jul 29, 2019
62
0
0
Duplicated both of your tests and got... nadda.. no leak .. nothing. Both of these seem to be rendr related.. which means if you are having them and I am not.. its possibly hardware related.
Not necessarily. Could be graphics settings, both in-game and in the driver.
 

keybounce

New Member
Jul 29, 2019
1,925
0
0
Reported by my friends on skype:
Aquatic backpack fails to keep the fish alive.
> well, i would like to make it known that the aquatic backpack is not working properly
> and most of my fish just died
> It took what i gave it, and when i closed my inventory, it ejected it all
> fish in item form have a very limited lifespan out of water
 

ragnia1980

New Member
Jul 29, 2019
8
0
0
Mod Pack: Magic Farm 2.1.3
Mod & Version:Extra Utilities
Pastebin link to crash log:
Whats the bug? can't use the ender quarry because it doesnt recognize the fancy fences fence as a valid quarry boundary
Can it be repeated?
Known Fix:unknown
 
Status
Not open for further replies.