1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Launcher not working on windows 8!

Discussion in '[Archived] Tech Support' started by elites180, Jan 13, 2013.

  1. elites180

    elites180 New Member

    Hi, i recently got a new pc, and FTB worked perfectly when i first installed it, now when i open the launcher, my console gets spammed with this.
    Please help!
    HTML:
    FTBLaunch starting up (version 1.2.0) AnalyticsBackgroundThread started Java version: 1.7.0_10 Java vendor: Oracle Corporation Java home: C:\Program Files (x86)\Java\jre7 Java specification: Java Virtual Machine Specification version: 1.7 by Oracle Corporation Java vm: Java HotSpot(TM) Client VM version: 23.6-b04 by Oracle Corporation OS: x86 Windows 8 6.2 Error making tracking request: java.net.ConnectException: connect: Address is invalid on local machine, or port is not valid on remote machine connect: Address is invalid on local machine, or port is not valid on remote machine: java.net.ConnectException: connect: Address is invalid on local machine, or port is not valid on remote machine [i18n] Checking for updates ... [i18n] enUS English language file loaded! [i18n] Could not retrieve version info, skipping update.: java.net.ConnectException: connect: Address is invalid on local machine, or port is not valid on remote machine For input string: "’
     
  2. frederikam

    frederikam New Member

    I also got Windows 8, and i fixed the problem the following way:
    • Right click on the launcher file.
    • Go into properties.
    • Go into compatibility.
    • Have the launcher run in compatibility mode for Windows 7.
     
  3. Ashzification

    Ashzification New Member

    Since this is the most simple solution I've found, can I add this to my trouble shooting guide?
     
  4. elites180

    elites180 New Member

    Hrm, it still isnt working..
     
  5. frederikam

    frederikam New Member

    If it can help people then yes, but do remember to add in that if it stays in compatibility mode the game starts flickering. Only have it run in compatibility mode, when you want to download modpacks, possible also other files.
    Can you post a new log, on pastebin this time.
     
  6. Karimiri

    Karimiri New Member

    also: windows 8 is crap... true story...
     
  7. Apophis1

    Apophis1 New Member

    Worked fine in Win8 for me no issues at all, I am yet to find anything that windows 8 has problems with
     
  8. grindle2000

    grindle2000 New Member

    I personally have had no problems with running FTB in Win 8 and I actually get better stress scores across the board on windows 8 , granted only slightly better than Win 7 but still better.

    The interface was a bit clunky at first but once i got used to it seems strange to be on a win 7 machine now.
     
  9. frederikam

    frederikam New Member

    Indeed a very true story. It is less convenient.

    Edit: Removed that weird Avast! text, that was coming out of nowhere.
     
  10. mantuxas301

    mantuxas301 New Member

    for me its kaspersky thats causing the problem(also on windows 8) luckily i was able to resolve it by tweaking java settings at the firewall
     
  11. UncleSam21997

    UncleSam21997 New Member

    I also have kaspersky and windows 8 and have been trying for hours to fix it, although I have not prevailed. Can you tell me how you did this with the firewall in kaspersky?
     
  12. mantuxas301

    mantuxas301 New Member

    Ok ill try to help you. You should follow these steps: 1.Go to settings in Kaspersky 2.Select the Firewall tab and click settings. 3.Under all applications find folder Oracle America or similar. 4. Click the plus sign :p 5. you should see 5-6 applications called: Java(TM) Platform SE binary. 6. Right click on any of those and select 'application rules...' 7.Go to the 'Exclusions' tab and tick the box on 'Do not scan network traffic' 8. Repeat it on all 5-6 'Java(TM) Platform SE binary'. 9.(IMPORTANT) APPLY new firewall settings. 10. Enjoy Feed the beast and minecraft without this lame problem ;) Hope this helps, cheers.
     
  13. UncleSam21997

    UncleSam21997 New Member

    I had already done everything except the exclusion tab, this has seem to taken away a couple of lines of error code. Although, I do not have 5-6 of the java binary files. I only have one. Also the launcher is still not working.

    Here is the exact error code it gives me when I try to launch the software.

    IOException, minecraft servers might be down. Check @ help.mojang.com
    Login failed:
    connect: Address is invalid on local machine, or port is not valid on remote machine: java.net.ConnectException: connect: Address is invalid on local machine, or port is not valid on remote machine

    I also get a error saying IOException Minecraft servers might be down. Check @help.majong.com
     
  14. ChocoMocoHD

    ChocoMocoHD New Member


    I had this same problem and then got help from a FTB Admin. First close all java programs, press WINDOWS button + R and paste in this code: -Djava.net.preferIPv4Stack=true
    And you should see a black screen pop up and disappear in a millisecond and that means it worked! :D[DOUBLEPOST=1366666882][/DOUBLEPOST]
    I had this same problem and then got help from a FTB Admin. First close all java programs, press WINDOWS button + R and paste in this code: -Djava.net.preferIPv4Stack=true
    And you should see a black screen pop up and disappear in a millisecond and that means it worked! :D
     
  15. Ashzification

    Ashzification New Member

  16. Geepers1999

    Geepers1999 New Member

    I keep getting this error { Error: Could not find or load main class Java.net.preferIPv4Stack=true } please help me im launching the mindcrack pack
     
  17. Ashzification

    Ashzification New Member

    Post your own thread. Whatever issue you're having is in no way related to the one here.
    Provide the information requested here:
    http://forum.feed-the-beast.com/threads/important-info.578/
     
  18. MegaUltraNinja

    MegaUltraNinja New Member

    I keep on getting an Error whenever i try to play on any 1.6.4 packs
    2013-12-21 16:46:44 [SEVERE] [Minecraft-Client] ########## GL ERROR ##########
    2013-12-21 16:46:44 [SEVERE] [Minecraft-Client] @ Post render
    2013-12-21 16:46:44 [SEVERE] [Minecraft-Client] 1285: Out of memory
    and that's the error message that i get i don't know why it happens though i have open GL off so could you find a fix? i know that is not very much but that is the only thing i could find went wrong. http://pastebin.com/nvinqWb3 is the pastebin link to it
    edit: this doesn't happen on my horrible win 7 PC so that's why it's here
     
    Last edited: Dec 20, 2013
  19. Ashzification

    Ashzification New Member

    That paste is not valid.
     
  20. OlexaKid64

    OlexaKid64 New Member

    I have an odd question. I'm running FTB and the fix for my issue should be to run it as an administrator. However, this file does that have the option to run as an admin and doesn't even have a compatibility tab. Any ideas how to fix this? I can play multiplayer, just not singleplayer.
     

Share This Page