1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Problem I need help with my mods...

Discussion in 'General FTB chat' started by Shadrack_Orbion_777, Dec 5, 2018.

  1. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    Guys, As i've mentioned in my introduction, i'm playing minecraft 1.7.10.

    A while ago i wanted to create my own modpack, After messing around enough i managed to clear out a tolerable amount of mod conflicts. Long story short, my minecraft works at a floating line with the mods that i have and i have uploaded a picture with the list of mods.

    Now i tried adding clonecraft for minecraft 1.7.10 and this happened: Problem resulting from clonecraft.jpg List of Mods.jpg

    There are some problems with the menu of TooManyItems as when i search for specific items or go beyond the 5th slide it makes the game crash. But now i'm trying to add clonecraft and with your kind help i may be able to add other cool mods i wanted for a long time but couldn't because of my lack of skill.
     
  2. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    This is not the only mod that causes this exact same error. Originally i had planned to add Ender IO, Erebus Dimension, Thaumic Energistics and this one Clonecraft. But all of them (minus EnderIO) does the same bugged thing.
     
  3. ShneekeyTheLost

    ShneekeyTheLost Too Much Free Time

    Your problem is that some mod or another is using a 'Dummy Container', probably as a means of forcing load order, however has screwed up the code somewhere. Try updating all your mods to the latest version (for 1.7.10 of course), and try again. If that fails, then there's a mod in there somewhere being a boog, and you need to hunt it down. My personal money is on Aether2, but that's just me.
     
    Shadrack_Orbion_777 likes this.
  4. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    Thank you #ShneekyTheLost. Sorry for my bluntness but i'm quite poor when it comes to IT knowledge, even for games... What is a Dummy Container and where can that be found? Also Aether 2 was a big bothersome turf when tried to install it. Messed around with it for weeks until i managed to make it work. So you might be right. But if that is the case can't the mod be messed with in such way that it reduces a bit of its ego? As in it allows other mods to be installed?

    What i mean by that is, can i find a way to mess with its config or code so that it stops being a bug?

    It is only because despite it being a bug, it is a really awesome mod... Otherwise i wouldn't have gone through the torment of making it understand what team work means...
     
  5. ShneekeyTheLost

    ShneekeyTheLost Too Much Free Time

    Unfortunately, there isn't enough information here to go on to give you a more definitive answer. Something is making a dummy container to force loading priority, but without a full crash log, it is impossible to determine which mod (or set of mods) is being naughty. I'd give odds Aether2 is involved, simply because... well, let's just say I'm familiar with it, and leave it at that. But that doesn't necessarily mean it's the only one involved. Twilight Forest has been known to cause some pretty funny-not-funny 'issues', and there's a few mods in that list that I've honestly never seen before, which is a genuine surprise to me.

    Data, Data, Data, Mr. Watson. I cannot make bricks without clay. But if you are going to post a crash log, do yourself a favor and don't just post the raw code into the forum. Use Pastebin, which has a number of useful features besides not clogging up your post with walls of text.
     
    Shadrack_Orbion_777 likes this.
  6. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    So a while ago i posted the data log but since i uploaded a file or i shared a link it is still awaiting moderator approval. So as soon as the mods let the reply show let me know...
     
  7. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    Luv the Sherlock Holmes pun.

    There are a few conflicts and bugs in the game that makes me play the game as if i'm walking on glass shards.
    Some of them are when creating a random mystcraft dimension, there is the risk for the game to generate a buggy dimension that causes the whole save file to crack open because it makes a world with, say, an infinite ocean of taint goo liquid or liquid death from thaumcraft. Or it makes the same world with a weird liquid that is covered by an equally infinite layer of snow and as soon as i enter in such dimension i only have a few minutes to use the GET OUTTA HERE green link book.
    Another bug with mystcraft is that when i decide to enter in creative and take all the available pages for mystcraft dimension making, the mod doesn't recognize not even a fraction of the mother-load of blocks available from all of the other mods therefor i cannot create a truly crazy dimension as i like it to.

    If these problems could be solved, i would be HIGHLY grateful and would manage to make my dream modpack and share it with my friends!
    Maybe with u'r help i could also add the other dimension mod, Erebus, and enhance my experience with thaumic energistics and EnderIO.

    PLZ HELP ME MAKE MY DREAM COME TRUE! it is going to be an awesome modpack. even if it is focused around minecraft 1.7.10. There are mods for this version that never made it beyond this level of the game and are pretty cool! I also wanted to add another dimension mod that deals with a frozen version of the nether and so many plans.

    Maybe with u'r help i can actually make this happen. THANK YOU! :D:D:D:D

    I had to double repost this because it went straight into quarantine. I think it must be because of the link to pastebin. I had to wait two days for mods to review it and they still did not check it up...

    So i changed the link with the uploaded file text of the code.
     

    Attached Files:

  8. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    As an addition to this here's a looong picture of the actual crash log with all its colors marking the errors and being a tad more helpful than just a mere text file. Minecraft Chrash Log.jpg
     
  9. ShneekeyTheLost

    ShneekeyTheLost Too Much Free Time

    Ooookay... let's see if we can wrangle this rodeo...

    First off, you are using TMI instead of NEI. You should probably not do that. Dump Too Many Items, install NEI instead. Several of these mods have NEI plugins built into the mods that don't appreciate TMI.

    Second off, your Java arguments are... unique. And extremely counter-productive.
    Code:
    -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx3G -Xms3G
    That was a Java 7 argument that was a bad idea, even back in Java 7. You really shouldn't be using that 'MojanTricksIntelDriversForPerformance' thing. Especially not on an AMD setup.

    Try this instead:
    Code:
    -XX:+UseG1GC -Xmx4G -Xms4G -Dsun.rmi.dgc.server.gcInterval=2147483646 -XX:+UnlockExperimentalVMOptions -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M
    So, let's start there. Get rid of TMI and use NEI, and change your java args, and see if that works. If not, post your new crash log and we'll go from there.
     
  10. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member


    Thanks for the update bro...

    Changed the Java Argument and it works epic!

    Now the mod part... Changed for NEI for minecraft 1.7.10 the last version of the mod and dis wat happens (this is what happens) :confused:
    I mean forge doesn't even start to build the mods up. Shut! :(
    Could this have to do with the way i assembled the mods in the config files or does it have to do with the version of the NEI mod?

    Correct me if i'm wrong but shouldn't i drag the zip file of the mod in the mods folder for it to be installed? cause that's pretty much the only way i know how to add mods... and then work a bit on their configs for further cooperation...

    Uploaded a text file for the picture as well...


    Crash Report.jpg
     

    Attached Files:

  11. ShneekeyTheLost

    ShneekeyTheLost Too Much Free Time

    NEI has a dependency on Code Chicken Core...
     
  12. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    Done it...

    Added codechickencore last version for 1.7.10.
    Forge started to assemble the modpack and then...

    Minecraft Chrash Log.jpg
     

    Attached Files:

  13. ShneekeyTheLost

    ShneekeyTheLost Too Much Free Time

    Okay, it appears as though some of your mods are using a different version of the CoFH API than others. This is causing a conflict. Please update ALL your mods to latest versions thereof for 1.7.10.

    In particular, update all your Buildcraft parts, Extra Utilities, Brandon Core and Redgear Core

    Also, please don't keep posting those large images. They are only getting in the way. Just the log, thanks.
     
    Shadrack_Orbion_777 likes this.
  14. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    Hi Bro!

    Thanks to your help! I managed to get the game started and running with most of the mods that i wanted. Added something like 42 more mods all around thaumcraft, AoA, mystcraft and applied energistics mixing with thaumcraft. And with all the config done the game can get to the main menu but...

    That ominous but...

    The game log registered 10 Fatal Errors, 399 Errors and 201 Warnings... Plus the needed 789 general infos...

    Among the 10 fatals i found that most of'em are around thaumcraft and some id's but i have no clue how to work with certain id's... don't know their in game limits if they have any, cause i know there are something like 256 maximum block id slots...

    I reckon that without solving these problemz the game would still be playable like walking on glass. Or maybe it will work fine until one point that it crashes. Or i'm not even able to start a world before it crashes. i had this problem in the beginning. At this point i don't have the guts to start a world and have the main menu turn into a crash log...

    So i've uploaded the text documents... Lets get this awesome modpack running! It is going to be a masterpiece of magic and science! :D:D

    Hey, just out of curiosity ar u a youtuber?:D
     

    Attached Files:

  15. ShneekeyTheLost

    ShneekeyTheLost Too Much Free Time

    The bad errors are being caused by Thaumcraft Additions. You might want to delete the config file for Thaumcraft Additions and let it manually regenerate it, that might actually help.

    Most of the other errors are update errors with the CoFH Suite looking at a Github that hasn't been updated in years (because this is 1.7.10). Nothing to be worried about there.

    There's also some missing texture errors... those MIGHT cause a crash if you 'see' one but can't load a texture. No clue what is going on there. Might want to reinstall those mods, just to be sure.

    I am a youtuber, yes. However, I currently have several projects on my plate at this time.
     
    Shadrack_Orbion_777 likes this.
  16. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    Awesome maybe you'll feature my modpack when it is fully done!
     
  17. ShneekeyTheLost

    ShneekeyTheLost Too Much Free Time

    Probably not. Like I said, I have enough projects I'm working on at the moment.
     
    Shadrack_Orbion_777 likes this.
  18. LordPINE

    LordPINE Well-Known Member

    Missing texture errors are generally nothing to worry about, if they can't be loaded they are replaced with the beautiful black and magenta square texture. It shouldn't crash.
     
    Shadrack_Orbion_777 likes this.
  19. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    Thanks ShneekyTheLost for all u'r awesome help brother! Thanks to u'r kindness and like minded passion for this awesome game my modpack is starting to shine like a new proto-star in space! Thanks to God for sending u to help me!

    You have a new subscriber to u'r channel just because of this help!
    Thank you a thousand times bro! :);):D

    EDIT:
    uuummm yeah... can u tell me what's u'r youtube channel called?
     
  20. Shadrack_Orbion_777

    Shadrack_Orbion_777 New Member

    Thanks for the imput LordPINE.

    I need some help relating to my lag spikes.

    Now my modpack is holding 69 mods... Now they all work perfectly fine thanks to the help of shneekythelost but there's a problem. My game is SERIOUSLY lag spiking. In the beginning Mystcraft was baking a cake... (profiling) i think most of us know this problem. But now when i log on it won't go past 10fps... sometimes goes as low as 5fps... I don't know whether mystcraft finished profiling cause i spent a good two hours waiting for the spike to end but nada...

    What can i do to be able to test-play this new awesome modpack?
     

Share This Page