how could I change my menu button for the minimap to m again when it is turned off?

Discussion in 'General FTB chat' started by martin0leung, Apr 11, 2013.

  1. martin0leung

    martin0leung Member

    I accidentally changed my minimap menu button to none, how could I change it back?[DOUBLEPOST=1365686674][/DOUBLEPOST]can somebody tell me what to do? thanks!
  2. ntwitch

    ntwitch Active Member

    You didn't specify whether you were talking about Rei Minimap or VoxelMap.

    Edit minecraft/mods/rei_minimap/keyconfig.txt

    Menu Key: M
    (note the space)

    Edit minecraft/mods/VoxelMods/

    Menu Key:M
    (NOTE: no space)
  3. LittleMike

    LittleMike Active Member

    But how would you open up the minimap menu if you've done that and removed the keybinding for the menu? I think that's what OP's problem is.
  4. KirinDave

    KirinDave Over-Achiever

    Good point. Misread. My bad!

    That's what I get for reading from reading a forum on a phone in a line.
  5. LittleMike

    LittleMike Active Member

    No worries. I think ntwitch had the solution - at that point you have to just edit the config file because there's no way in game to change the keybinding.[DOUBLEPOST=1365700386][/DOUBLEPOST]Speaking of which - that may be a good idea to implement - having the mod check for a keybinding, and if none, pop up a warning that won't let them exit until they set one.
  6. martin0leung

    martin0leung Member

    thanks to you all, It helped a lot! now I can change settings on my voxelmap again![DOUBLEPOST=1365910045][/DOUBLEPOST]
    it is voxelmap, sorry if I didn't mention it!
  7. Abdiel

    Abdiel Well-Known Member

    I actually want some things I never use (sorry, exosuits) to be set to none. I don't have infinite keys on my keyboard, and some actions are so broken that they activate even when I type the hotkey in chat.
  8. guiguilyon

    guiguilyon Active Member

    The voxelmap M button conflicts with other ones. I try to set the MENU KEY setting on the numpad divide key /, but the problem is that I don't know what's the precise english denomination of this key. I tried : "/" and "DIVIDE" in the file. But it doesn't work, when the games start, the Menu Key setting is changed back to "NONE".

    How do I set it to the numpad devide key please ?
  9. Adonis0

    Adonis0 Popular Member

    Change it to a button that you can which has no conflict, go in-game and try setting it to the slash key
  10. Not_Steve

    Not_Steve Over-Achiever

    Or just change the railcraft key bind to something else iirc that's what it conflicts with
  11. guiguilyon

    guiguilyon Active Member

    Thanks guys. I went in the controls menu that displays every key bindings and checked for every alphabet letter if it was already being used. I think I went until the letter "I" whicj wasn't used by anything. But it still didn't work. I really don't know why.

    But anyway, I changed tactic and checked other bindings using the M key. And it was ideed the "Railcraft Locomotive Mode Key" that was using the M key. I changed that and then I was able to open this freacking voxelmap menu! :)

    I have to redo all this stuff at each pack update which is really annoying. So I'm gonna save my config files now. :)
  12. RealLeoe

    RealLeoe New Member

    i accidentally changed my minimap key to NONE and i quit out of minecraft. Anyone know how i can change it back? (and also im using Zan's minimap)
  13. Hambeau

    Hambeau Forum Addict

    I do all my keymap changes in the Minecraft OPTIONS menu... [ESC], then select [OPTIONS], then [Controls].

    If you want to free up keys for mods you don't use just select each key then hit [ESC] and it will be set to "none".

    I'm only familiar with FtB packs, but they usually group keystrokes by mod, alphabetically. Sometimes a mod has it's own config menu embedded but that will be indicated.

    This works for re-enabling formerly disabled keys as well.
  14. guiguilyon

    guiguilyon Active Member

    I don't use Zan's minimap anymore.
    I guess you can set it the Zan's minimap configuration file located in the "config" folder of FTB.
    Or you should be able to rebind it in the key configs in Minecraft. Be sure that the key binded to Zan's minimap is not binded to something else (it shouyld appear in red). You can unbind keys by pressing "Esc" on your keyboard.
    Maybe Zan's keybindings are not accessible by the general Minecraft keybindings. In that case maybe you can set it in the "Mods configs" menu available in FTB. It's the same as changing the config files from the config folder.

Share This Page