1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Windows .exe FTB Launcher is extremely slow

Discussion in '[Archived] Tech Support' started by Youriyo20, Jun 16, 2013.

Thread Status:
Not open for further replies.
  1. Philo

    Philo New Member

    I'm afraid I've run out of ideas.
    Please post a complete up-to-date console debug log and let's hope that someone else will be able to point out the cause for these delays.
     
  2. Eyamaz

    Eyamaz New Member

    Can you also post your system specs?
     
  3. Youriyo20

    Youriyo20 New Member

  4. Ashzification

    Ashzification New Member

    It could be because your system language is dutch. Not only does the launcher have to launch the modpack, but it has to launch based on a translation that could be causing it to hang.
     
  5. Eyamaz

    Eyamaz New Member

    We did have that issue where the Brazilian localization setup from MS completely stopped the launcher from launching.

    I don't see any other reason other than your running vista. I would upgrade to at least 7. Vista can be, wonkey...
     
    Ashzification likes this.
  6. Ashzification

    Ashzification New Member

    I wasn't going to say it :p
     
    Eyamaz and PeggleFrank like this.
  7. Youriyo20

    Youriyo20 New Member

    i know vista is kinda wierd and dumb but its the house computer so i have to talk to my parents before upgrading.

    but i will try changing my pc's language and try it then.
     
  8. Philo

    Philo New Member

    Hmm. My system language is German, and I never had a problem with it.
    I don't think the launcher installs a localized version depending on the system language. It cares more about the language settings you select ingame.
    On top of that, localization in FTB is not really a big deal, compared to games like Fallout 4 or Skyrim, for instance. And those games launch fast.
    But even if FTB localized according to system settings, and if there were a problem with some languages, wouldn't one expect this to be an issue only once, on the first launch, not every time?
    So I'm sceptic.

    Edit:
    Started writing before Eyamaz had posted. So I guess there may be issues due to system language setups after all...
     
  9. Ashzification

    Ashzification New Member

    It's just a theory, since there really are no others to present.


    I just launched my ultimate pack. JSTR texture pack. One update behind on Java (since I just got prompted for it today). Languages set to English, only other program open/running is Chrome. Nothing significant changed (if I recall).
    Kept launcher as "top" program (didn't tab out) and it loaded in about a minute.

    The only other reasoning I can come up with for his taking so long is vista.
     
  10. Philo

    Philo New Member

    Yet both Vista and Dutch are permanent system characteristics which the computer already had when it still worked fine and FTB launched within a minute.
    Imo, both fail to explain the sudden change that occurred almost over night.
     
  11. Ashzification

    Ashzification New Member

    Only other thing:
    He's lying and something else updated.
    I'm saying, he's telling us the truth, nothing has been changed, and these are reasons why it could have suddenly become slow.

    Or, his computer is shitting the bed and there's nothing we can do to help.
     
  12. Philo

    Philo New Member

    "House computer" - wouldn't that mean it's potentially used by several people in the family, so someone else could actually have caused changes to the system that Youriyo20 is unaware of?
     
  13. Youriyo20

    Youriyo20 New Member

    I'm the only one with the knowledge to change something in the computer no one else even comes in the computer settings and i know it almost cant be the language maybe vista though but if it is vista then ftb should had that loading time in the beginning when i started playing ftb.
     
  14. Ashzification

    Ashzification New Member

    Changes also include software updates, driver updates, etc.

    Edit: and I know that programs don't just start lagging for no reason at all. Something is causing it, we just need to figure out what.
     
  15. Youriyo20

    Youriyo20 New Member

    Its kinda weird that this has happened, and also the computer is at my room my mom and dad occasionally check the email and play a game that's all they do.
     
  16. Eyamaz

    Eyamaz New Member

    I had several issues for the short time I ran vista, quite like this. I had games that ran fine then suddenly ran like crap. No updates on anything in between. Vista, imho, is the worst os Microsoft ever made. I had to do complete reinstalls to fix anything.

    I think it's because it was the first implementation of both aero and their hardedged permissions system.
     
  17. Youriyo20

    Youriyo20 New Member

    yea i know i'm running vista and had to defrag and do complete re installs of everything like 3 times.



    EDIT:

    well i'm hoping someone finds a solution or stumble on one by accident i really wanna play ftb againXD
     
  18. Philo

    Philo New Member

    The posted log gives us a detailed account of a 13 minute launch process. I studied it again and found three suspicious locations:
    1. Lines #66 ff. where the launcher seems to re-download and re-install the modpack; this takes roughly one minute.
      Code:
      [12:44:23] [INFO] LaunchFrame.initializeMods:868: Ultimate
      [12:44:23] [INFO] ModManager$ModManagerWorker.downloadModPack:112: Downloading Mod Pack
      [12:44:23] [INFO] DownloadUtils.getCreeperhostLink:68: http://www.creeperrepo.net/direct/FTB2/5916e24959237c9cfee78cc9531a1334/modpacks%5EUltimate5E1_1_2%5EUltimate.zip
      [12:44:31] [INFO] DownloadUtils.getCreeperhostLink:68: http://www.creeperrepo.net/direct/FTB2/5916e24959237c9cfee78cc9531a1334/modpacks%5EUltimate%5E1_1_2%5EFTB_temp.gif
      [12:44:31] [INFO] DownloadUtils.isValid:236: Local: 7EE06EEA285629C5C9EB46AFFDFFBDA5
      [12:44:31] [INFO] DownloadUtils.isValid:237: Remote: 7EE06EEA285629C5C9EB46AFFDFFBDA5
      [12:44:51] [INFO] LaunchFrame.installMods:718: dirs mk'd
      [12:44:58] [INFO] GameUpdateWorker.loadJarURLs:75: Loading Jar URLs
      [12:44:58] [INFO] GameUpdateWorker.doInBackground:60: Downloading Jars
      [12:45:26] [INFO] GameUpdateWorker.doInBackground:66: Extracting Files
      [12:45:26] [INFO] LaunchFrame$14.done:625: Game update complete 
    2. Line #731 f. where the launcher takes a minute to get over the fact that MFR compats are not needed:
      Code:
      2013-06-20 12:50:52 [WARNING] [ForgeModLoader] Sufficient Biomes missing - MFR Sufficient Biomes Compat not loading
      2013-06-20 12:51:50 [INFO] [STDOUT] Fluid registration: Molten White Dye
    3. Line #781 f. where the launcher stalls for almost 3 minutes:
      Code:
      2013-06-20 12:52:58 [INFO] [STDOUT] Fluid registration: ice
      2013-06-20 12:55:44 [INFO] [Forestry] Skipping CraftGuide integration.
    Delays #2 and #3 are not really accounted for, nor are the remaining 8 minutes. Everything seems to simply take so much longer than normally as though the computer were running with hand brakes put on ... or without most of its cores.

    Speaking of which, Youriyo20, could you just check that? Start the launcher, then your task manager, right-click on "javaw.exe", select "Set affinity" (bottom option) and see if all available CPUs have a checkmark. If not so, set it please.
     
  19. Ashzification

    Ashzification New Member

    Point number 1 can usually be fixed by changing the location you're downloading from.
     
  20. Youriyo20

    Youriyo20 New Member

    Oke Philo i checked and they already have a checkmark.
     
Thread Status:
Not open for further replies.

Share This Page