FTB Infinity Release

Jackcat136

New Member
Jul 29, 2019
193
0
0
So I'm happily trying to play Infinity, and I'm not able to play... Whenever it gets to around the Mojang screen of launching, it will crash, and I can't play, this is happening on all versions, and I was planning on having a nice little session tonight. Anybody know whats going on here?
 

buggirlexpres

Relatable Gamer
Trusted User
Retired Staff
Nov 24, 2012
3,940
7,373
663
6 Feet Under
twitter.com
So I'm happily trying to play Infinity, and I'm not able to play... Whenever it gets to around the Mojang screen of launching, it will crash, and I can't play, this is happening on all versions, and I was planning on having a nice little session tonight. Anybody know whats going on here?
We would if you gave a crash report.
 
  • Like
Reactions: Hambeau

DoctorOr

New Member
Jul 29, 2019
1,735
0
0
The Runic Dungeon Biome id conflicts with the BoP Outback (both are ID 78)

Ran into this in the overworld after disabling Twilight Forest and regenerating my world.

This is Infinity 1.3.2 (and config file is unchanged in 1.3.4, same conflict)
 
  • Like
Reactions: RedBoss

Hambeau

Over-Achiever
Jul 24, 2013
2,602
1,533
213
Has anyone else noticed EnderIO Alloy Smelteries disappearing when picked up with a Yeta Wrech? I just lost 3 that way, 2 with an active Electromagnet and one without.
Are you sure they're lost? try looking at another inventory then back in yours... There's was a similar video refresh bug when pulling items out of a smeltery table.

The two may or may not be related.
 

PhilHibbs

Forum Addict
Trusted User
Jan 15, 2013
3,174
1,128
183
Birmingham, United Kingdom
Are you sure they're lost? try looking at another inventory then back in yours... There's was a similar video refresh bug when pulling items out of a smeltery table.

The two may or may not be related.
Totally disappeared - I went to my AE system each time and requested replacements. They never turned up, I've played a fair bit since then. I'll do some testing in a creative world with a variety of machines.
 

PhilHibbs

Forum Addict
Trusted User
Jan 15, 2013
3,174
1,128
183
Birmingham, United Kingdom
Has anyone else noticed EnderIO Alloy Smelteries disappearing when picked up with a Yeta Wrech? I just lost 3 that way, 2 with an active Electromagnet and one without.
Okay this is really, really weird. I just found them in my cobblestone chest! It's a wooden chest that is fed by two EU transfer nodes with... er... world interaction upgrades... ok, that's how it's happening. They're acting like some kind of item vacuum, I didn't expect that! Well, I needed to expand my cobblegen anyway so this is a good time to move it a good distance away from where I'm expanding my processing basement. *Edit* Or, I just add filters to them for cobblestone only!
 
Last edited:

Hambeau

Over-Achiever
Jul 24, 2013
2,602
1,533
213
Can anyone tell me if it's recommended now to update to 1.2.1? And maybe post some Patch Notes? Pls? :)
The patch notes should be in the second section of the main forum, under the "Modpacks" thread. usually new "betas" go recommended a week or so after they are put up, if no big bugs are found.

[Edit] Infinity Recommended is 1.2.1... currently the beta is 1.3.4
The selection tab for each pack tells you the recommended version.
 
Last edited:

NJM1564

New Member
Jul 29, 2019
2,348
0
0
Okay this is really, really weird. I just found them in my cobblestone chest! It's a wooden chest that is fed by two EU transfer nodes with... er... world interaction upgrades... ok, that's how it's happening. They're acting like some kind of item vacuum, I didn't expect that! Well, I needed to expand my cobblegen anyway so this is a good time to move it a good distance away from where I'm expanding my processing basement. *Edit* Or, I just add filters to them for cobblestone only!
Oh yah they do that now. I had a simaler thing happen to me. You should know that the vacuum effect is extremely directionalized. So it'll only pull in the direction it's facing. And the effect expands based on the number of world interaction upgrades. So it can work over 64 blocks.
 

WauloK

New Member
Jul 29, 2019
47
0
0
Now it's Logistics Pipes' turn to crash the server: (1.3.4)

Details:
Name: logisticspipes.pipes.basic.LogisticsTileGenericPipe // logisticspipes.pipes.basic.LogisticsTileGenericPipe
Block type: ID #2339 (tile.null // logisticspipes.pipes.basic.LogisticsBlockGenericPipe)
Block data value: 0 / 0x0 / 0b0000
Block location: World: (-1412,71,-447), Chunk: (at 12,4,1 in -89,-28; contains blocks -1424,0,-448 to -1409,255,-433), Region: (-3,-1; contains chunks -96,-32 to -65,-1, blocks -1536,0,-512 to -1025,255,-1)
Actual block type: ID #2339 (tile.null // logisticspipes.pipes.basic.LogisticsBlockGenericPipe)
Actual block data value: 0 / 0x0 / 0b0000
LP-Version: 0.8.3.113:false
Pipe: logisticspipes.pipes.PipeItemsProviderLogistics
Transport: logisticspipes.transport.PipeTransportLogistics
Router: ServerRouter: {ID: 18, UUID: 84053f3f-f818-4a8e-bc92-1f0fd2b69c40, AT: (0, -1412, 71, -447), Version: 1), Destroied: false}
stillNeedReplace: false
Stacktrace:
at net.minecraft.world.World.func_72939_s(World.java:2491)
at net.minecraft.world.WorldServer.func_72939_s(WorldServer.java:669)
 
Last edited:

Ddash

New Member
Jul 29, 2019
1
0
0
Works great, but something I have came across is really bugging me and my friends. Recently we have been playing and all our stuff has reset like all our stuff in inventory and all our achievements, it's like we're freshly joining the server but we have our houses and stuff still and the chests there, I could just place my stuff in chests upon leaving the game but wouldn't like more of a hassle, hope there's a fix to prevent us from losing all our stuff and achievements upon leaving the game.
 

Max_Matti

New Member
Jul 29, 2019
1
0
0
Hi, got a crash to report:

Log:
Client: http://pastebin.com/kVCkfaHn (had to cut it at the top because it's too long for pastebin and the website you're using for your "upload log" button is down).
http://paste.feed-the-beast.com/view/2c38a3cd
Server: unfortunately I don't know how to copy+paste from screens that are openened in ssh, but the log looked fine to me. ('Connection reset by peer' looks the same as if I were to pull out my ethernet cable).

Upgraded from FTB 1.1.0 (with dynmap in the mods folder) to 1.4.0 (without dynmap, wanted to install that later), playing on Server, old FTB Server zip is from:
http://www.creeperrepo.net/FTB2/modpacks^FTBInfinity^1_1_0^FTBInfinityServer.zip
(downloaded directly from your website a few days/weeks ago)
new FTB zip (on Server) is from:
http://www.creeperrepo.net/FTB2/modpacks^FTBInfinity^1_4_0^FTBInfinityServer.zip
(changed the URL to 1.4.0 manually because the link is not up to date, both downloaded with wget)
The client executables are what I got from the FTB Launcher.

This happened:
After upgrading I tried to access a few chests, for some chests everything went fine (as expected) but for 2 of my chests the client crashed everytime I tried to open them. The server is still running.
As I went through the crash log I found out that the problem was caused in the ItemRenderer.
Because I couldn't find any info about what Item caused the crash I restarted the client and broke the chest, as expected the client crashed again, this is the error log you see.
As I looked through the crash log again I found out that the entity (droppen item) responsible for the crash seems to be an Iron Spike from Extra Utilities with the ID 500874. Edit1: nevermind the ID, seems to be the 500874th entity on the server or sth, thought that was the Item ID.

The client is Linux Mint with Awesome WM on an asus z97-p, an intel i5-4460 processor, a Geforce 750ti and 16 GB RAM.
The server is a virtual machine with 2 cores and 4 GB RAM on a rented (dedicated) server. The OS is Debian 7.8 and java is jre1.8.0_40, the runscript provided in the zip is run in a screen (so I can disconnect from ssh without killing java).

I have a backup of my world file, so I'm fine that way but we already made quite a bit progress on that server, so a way to remove that item (and maybe other items, that are causing crashes) would be nice.
I also thought about downgrading back to 1.1.0 again and then destroying the "bad" items (Iron Spikes are not really valuable) but I think that there may be more "bad" items and switching between the two versions multiple times to detect and filter out the "bad" items would be a bit too circumstancial with my setup.

Edit2: when searching for Iron Spikes in NEI, they have the fire texture and when clicking on that icon, the game also crashes.
 
Last edited: